Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old 25 Apr 2017, 15:14
bfdzio bfdzio is offline
 
Join Date: Oct 2007
Anyone know how to fix this error? Race condition

Ok so last night I got reports from users with 1 particular thread causing problems giving them a 500 error. I checked the logs and this is what I got:

[Tue Apr 25 08:05:30.088781 2017] [core:error] [pid 27436:tid 139842581161728] [client 198.47.254.41:59955] Caught race condition abuser. attacker: 500, victim: 99 open file owner: 99, open file: /home/nciu/public_html/forum/clientscript/vbulletin_css/style00032l/dbtech_thanks.css, referer:
Now, I have tried all the maintaince stuff and also turned off storing stylesheets as files. Not sure what else to do? It seems to be an issue with permissions but it all goes back to the css files. I have made sure the permissions are good on all of them but also have turned off storing as files and still get the same result.

Any ideas?
Reply With Quote
  #2  
Old 25 Apr 2017, 15:24
Dave Dave is offline
 
Join Date: Jun 2010
Did you only change the chmod permission or also the chown permission? In this case I'm pretty sure it's the chown permission you have to change.
Reply With Quote
  #3  
Old 25 Apr 2017, 18:02
bfdzio bfdzio is offline
 
Join Date: Oct 2007
Originally Posted by Dave View Post
Did you only change the chmod permission or also the chown permission? In this case I'm pretty sure it's the chown permission you have to change.
Just now changed CHOWN to the account I host that site on and still having the issue. Blah. Some were set to nobody for the owners.

Any other clue by chance? Weird this only didn't start til yesterday as well. Nothing had changed.
Reply With Quote
  #4  
Old 25 Apr 2017, 19:18
Dave Dave is offline
 
Join Date: Jun 2010
Did you execute chown recursively in the root folder of the website?
Reply With Quote
  #5  
Old 25 Apr 2017, 19:40
bfdzio bfdzio is offline
 
Join Date: Oct 2007
Originally Posted by Dave View Post
Did you execute chown recursively in the root folder of the website?
Naw just the folder....good point. Seems obvious I should have done that. I'll do that in a bit.

--------------- Added 25 Apr 2017 at 21:47 ---------------

Welp, I killed my site doing that. BRB now.

--------------- Added 25 Apr 2017 at 21:58 ---------------

NVM, fixed it. I accidentally changed the public_html permissions at the same time. Still can't access that one thread though :-/
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 06:09.

Layout Options | Width: Wide Color: