Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #106  
Old 05 Nov 2012, 22:19
TheSupportForum TheSupportForum is offline
 
Join Date: Jan 2007
Originally Posted by John Lester View Post
Ok so I sorta started working on this again, and I can't figure out what's wrong here. I'm trying to copy the rows from subscribethread to unsub_subscribethread *yes it does exist*. Yes the option is selected in the ACP. The mod runs but doesn't spit out ANY errors, it also doesn't copy the rows

This is the select query I'm using


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

This is the code inside of the function

for example where is


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

If I run this query in phpmyadmin it works ...


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

you havent registered the variable


$unsubscribe

here is an example of how to do so

$templater = vB_Template::create('unsubscribe');
$templater->register('$unsubscribe', $unsubscribe);
$template_hook[forumhome_wgo_pos2] .= $templater->render();

you will then need to call $unsubscribe in a template which will display the content from the query remembering to change the $template_hook

you will then need to place {vb:raw unsubscribe}
in template unsubscribe

as long as you place the correct hook location with the correct template hook the query will show in the hook location you selected
__________________
http://www.multihunters.co.uk - all your coding needs

Last edited by TheSupportForum; 05 Nov 2012 at 22:24.
Reply With Quote
  #107  
Old 06 Nov 2012, 07:46
John Lester's Avatar
John Lester John Lester is offline
 
Join Date: Nov 2004
Oh great now I'm even more confused ... this mod uses misc.php?do=unsubscribe as the url. In the mod a basic template is "built" and all of the other code executes fine (so far). I have a few more select queries structured like the one I posted earlier ... they seem to work just fine.

So now I'm wondering ... is the mod even executing those select queries? If it's working as is now (aside from the code in question) do I still need to tie it into a hook?

Keep in mind I'm a complete novice at this, all I'm doing is added options to an existing mod (that was marked as reusable and updated for 4.x by kh99).

Just for shits n giggles I'm going to attach what I have so far, if someone would be kind enough to look at it and tell me if there's a better way to go about doing this I might as well find out now and switch gears
Attached Files
File Type: xml product-advanced_unsubscribe_link_1.0.xml (31.9 KB, 1 views)
Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Administrative and Maintenance Tools Email Rules - Require that users' email addresses match a regular expression Analogpoint vBulletin 3.8 Add-ons 15 03 May 2013 13:26



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 15:52.

Layout Options | Width: Wide Color: