Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Multiple account login detector (AE Detector) Details »
Multiple account login detector (AE Detector)
Mod Version: 1.03, by MPDev (Member) MPDev is offline
Developer Last Online: Dec 2016 I like it Show Printable Version Email this Page

vB Version: 3.7.1 Rating: (94 votes - 4.84 average) Installs: 1444
Released: 23 Jun 2008 Last Update: Never Downloads: 5730
Not Supported Uses Plugins Re-usable Code Translations  

Mod of the Month winner!
Top 10 most installed mods for vB3.6!

Same plug-in found here:

http://www.vbulletin.org/forum/showthread.php?t=125871


There are no differences as this plug-in works with the 3.5, 3.6 or 3.7 releases of vBulletin.


If you are like me and migrated from .threads, a common modification was an "AE detector", a simple mod that saved a cookie of a history of ids logged into on your site. If someone logged into more than one account, you got a PM letting you know that your site was being accessed from multiple accounts.

Over the years this was very helpful in identifying users who were posting under multiple accounts (alter-egos!) and users who would return after being banned.

You might be wondering why I don't use the vbcookie call - well, thats because on logout all vB cookies are cleared, so we need to store a cookie that is not effected by the login/logout process.

New Installation
1. Add New Product with attached XML
2. Go to vBulletin Options -> AE Multiple Login Detection Settings and set your specific settings.

Time to install: Easy - 2 minutes.

Upgrade
If you installed this as a Plug-in manually, you can delete that plugin and install this Product, just make sure to go into the Options and set them accordingly.

I hope you find this useful and will click INSTALL if you use it; should it prove useful to enough people I can look at making this installation more automated without the need for edits and an Admin Options page.

To upgrade you will want to reimport this XML file and edit your options accordingly.

1.0.3
-----
. Added a check to ensure that users weren't deleted when reporting violations
. added htmlspecialchars_uni call to username

Note: I am unable to get the call to construct_phrase with $vbphrase['multiplelogin_alert'] to work reliably, as such the $message variable is still set manually inside the plug-in and not via the phrase. If anyone has an idea of why this might not always work, I'm all ears.

1.0.2
-----
. Updated to include exclusion groups, users
. Changed so PM is sent by ae sender id

1.0.1
-----
. Released as a Product (thank you PHPGeek2k3 for your help)
. Added option to post to a forum versus send a PM (or both)
. All settings moved into Admin Option

1.0.0
-----
Initial release.

Download Now

Only licensed members can download files, Click Here for more information.

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Administrative and Maintenance Tools Multiple account login detector (AE Detector) MPDev vBulletin 3.6 Add-ons 598 25 Nov 2013 03:28
Multiple account login detector (AE Detector) MPDev vBulletin 3.5 Add-ons 482 09 Jun 2012 15:26

  #331  
Old 23 Sep 2011, 06:32
Joe Blow Joe Blow is offline
 
Join Date: Aug 2004
Great mod, but I really wish it had an option to add a post to an existing thread rather than starting a new thread for each alert.
Reply With Quote
  #332  
Old 26 Sep 2011, 18:49
PimvanJ PimvanJ is offline
 
Join Date: Jan 2006
Real name: Pim
Install on 4,1,6 no problem.
Working!
Reply With Quote
  #333  
Old 27 Sep 2011, 03:05
AusPhotography's Avatar
AusPhotography AusPhotography is offline
 
Join Date: Nov 2007
Real name: Rick-owner, Kym-admin
It would be even better if it used Evercookie

Kym
__________________
www.AusPhotography.net.au a.k.a. AP is a photography forum where members share their photography, photo editing skills and techniques. We run regular photographic competitions; Rick (site owner) and Kym (site tech) using this account
*** Home of the AP fully comprehensive vb4 photographic competition management solution ***
Reply With Quote
  #334  
Old 27 Sep 2011, 17:17
lycheepassion lycheepassion is offline
 
Join Date: Aug 2009
how do you usue this>
Reply With Quote
  #335  
Old 11 Oct 2011, 14:09
Jaydee 2 Jaydee 2 is offline
 
Join Date: Oct 2008
Real name: Jörg
Thanks a lot, seems to work well enough in 3.8.7

To translate the thread-text into german (or other) language, it could necessary to change it directly in the plugin instead of phrase (or you better change both of them).
And i would advise to create a special "bot-user" (e.g. "Multi-Account Detector") for posting alert-threads and pm's.
Reply With Quote
  #336  
Old 11 Oct 2011, 14:35
bryanb's Avatar
bryanb bryanb is offline
 
Join Date: Oct 2003
It works in 4.1.7!
__________________
"Master of my domain"
Reply With Quote
  #337  
Old 17 Oct 2011, 22:38
Moshe1010 Moshe1010 is offline
 
Join Date: Oct 2008
Worked great for 2 years and just stopped working for no reason (no upgrade or changes were done in the past few months, and it stopped from working couple of weeks ago). I'm on VB 3.8.6
Reply With Quote
  #338  
Old 28 Dec 2011, 09:25
kralksk kralksk is offline
 
Join Date: Mar 2009
Originally Posted by Sonic625 View Post
Got a problem and has been happening for awhile just never looked into it....
I have it set to create a new thread when someone tripes it and that works perfectly, however say I wanted to search the forum for a username... that is where I have the problem, when I search for a username it shows no results. I can do this with any name (I copied and pasted names from the post to make sure I had it correctly) and it never finds a result.
vB 3.8.4 and has happened since 3.7
how to solve ?
Reply With Quote
  #339  
Old 11 Jan 2012, 02:04
too_cool_3's Avatar
too_cool_3 too_cool_3 is offline
 
Join Date: Sep 2007
Real name: Marc
This working for anyone on 4.1.8 or above?
__________________
TBMOTORING - Thunder Bay Automotive Enthusiast Club
http://tbmotoring.com
Reply With Quote
  #340  
Old 11 Jan 2012, 03:58
Videx's Avatar
Videx Videx is offline
 
Join Date: Feb 2007
Originally Posted by too_cool_3 View Post
This working for anyone on 4.1.8 or above?
Yes, I just got a hit from last night. 4.1.8

Be aware this is a really tough one to test.
Reply With Quote
  #341  
Old 11 Jan 2012, 23:36
AusPhotography's Avatar
AusPhotography AusPhotography is offline
 
Join Date: Nov 2007
Real name: Rick-owner, Kym-admin
Yes, works well on 4.1.8.

As for testing you need two regular user accounts, clear cache, login using 1st account, then logout and login using the 2nd account (in the same browser), that should trip the detector.
__________________
www.AusPhotography.net.au a.k.a. AP is a photography forum where members share their photography, photo editing skills and techniques. We run regular photographic competitions; Rick (site owner) and Kym (site tech) using this account
*** Home of the AP fully comprehensive vb4 photographic competition management solution ***
Reply With Quote
  #342  
Old 05 Feb 2012, 09:35
gamaken gamaken is offline
 
Join Date: Aug 2010
Has anyone ever noticed if you run an IP address search on your admin account (the account you have set to report the Alternate accounts), the names and IP addresses of every AE Detector reported member shows up as your's? I thought it was strange. Anyone know why that happens?
Reply With Quote
  #343  
Old 05 Feb 2012, 18:11
Alan_SP's Avatar
Alan_SP Alan_SP is offline
 
Join Date: Nov 2009
Yes, because you're the one that reports it.

You need to understand that IP address you get are those used when you made posts. And here we have posts made by user you decided to use to report about clone. This user's IP address is same as clone's as this mod is programmed in this fashion. It could be programmed to use some fixed IP address or some random IP address.

Anyway, on my forum I have special account created for this purpose only, to report MA.
Reply With Quote
  #344  
Old 09 Feb 2012, 13:31
RedPoint RedPoint is offline
 
Join Date: Oct 2007
Run this addon with vers 4.1.10 ?
Reply With Quote
  #345  
Old 09 Feb 2012, 22:22
charalampos's Avatar
charalampos charalampos is offline
 
Join Date: Dec 2008


installed thanks !

Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 20:33.

Layout Options | Width: Wide Color: