Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
VSa - Advanced Forum Statistics (AJAX) Details »
VSa - Advanced Forum Statistics (AJAX)
Mod Version: 7.1, by Valter (Coder) Valter is offline
Developer Last Online: May 2014 I like it Show Printable Version Email this Page

vB Version: 4.x.x Rating: (237 votes - 4.74 average) Installs: 2505
Released: 14 Feb 2010 Last Update: 02 Aug 2012 Downloads: 19757
Not Supported DB Changes Uses Plugins Auto-Template  

Info:
AJAX Forum Statistics:
-Latest Posts
-Latest Forum News
-Most Viewed Threads
-Hottest Threads
-Most Popular Forums
-Latest Classified Ads
-Latest Blog Entries
-Latest Group Posts
-Newest Members
-Top Posters
-Top Thread Starters
-Top Referrers
-Top Reputations
-Top Thanked
-Top Infractions
-Profile Visits
-Latest Social Groups
-Latest Donations

You can turn on/off individual stats, count data from last x days for some of them if you wish, trim titles/usernames to save page space, make several other functionality/make-up customizations... See screenshots.


You can have Main Stats box shown on several pages...
It's shown by default on forumhome (to disable it set "Main Top Stats box on ForumHome" to "None")
To activate another location:
a) add THIS_SCRIPT name to "Stats on pages" field in product options
b) add template name to "Stats in templates" field in product options
c) add "{vb:raw vsatopstats}" to the template you added Stats to


Notes:
-To set options go to: vBulletin Options > VSa - Advanced Forum Statistics
-"Top Thanked" requires Abe1's "Post Thanks" or Scandal's "Thumbs Up?" products to work
-"Latest Donations" requires "VSa - PayPal Donate" hack to work
-To move Top Stats box somewhere else on forumhome: 1.-Set placement setting to "None" 2.-Add "index" to "Stats on pages" setting 3.-Add "FORUMHOME" to "Stats in templates" setting 4.-Add "{vb:raw vsatopstats}" wherever you wish in FORUMHOME template.
-If Top Stats box is messed up because of long usernames or thread/forum titles be noted that you can trim them in ACP options.
-When forum/thread titles or usernames are trimmed, mouse-over will show you full version.


Installation:
-Import XML file (as product) through AdminCP: Plugin System > Manage Products > [Add/Import Product]


Versions:
v1.0 - Jun 12. 2006.
-First release
v6.6.1 - May 14. 2009.
-Latest vB 3.x version
v7.0 - Feb 14. 2010.
-First vB4 release
-Fixed some previous version bugs, optimized code
v7.0.1 - Feb 16. 2010.
-Fixed: Newpost/lastpost linking in 'Latest Posts'
-Fixed: Errors with PHP 5.3
-Fixed: AFS table messed up in footer
-Fixed: Several style errors, including XHTML incompatibilities
-New: Auto-insert on forumhome location - Below Forums
v7.0.2 - Feb 22. 2010.
-Fixed: Several style issues for unregistered users
-Fixed: 'Latest Donations' issues
-Fixed: Import error on some configs
-Fixed: Minor bugs
v7.0.3 - Apr 12. 2010.
-Fixed security bug (user able to set number of results manually)
v7.0.4 - Jan 14. 2012.
-Fixed: Status icons must be GIFs
-Fixed: Status icon overlay problems in Chrome and Safari
-Fixed: Drop-down menu items invisible until highlighted
-Fixed: Last unread post links not compatible with vBSEO
-Fixed: Search Member's posts shows results as threads
-Added: Rich thread prefix support
-Improved: CSS compatibility
-Minor bugs fixed
v7.0.5 - Jan 15. 2012.
-Links in Latest Posts are now fully SEO compatible
-New option: Automatically disable auto-refresh if server load is higher than X
v7.0.6 - Jan 17. 2012.
-Fixed: Prefixes linked in some thread stats
v7.0.7 - Jan 22. 2012.
-New: Show Stats in selected forum only
-Fixed: Some style issues
-Improved: Product menu style
-Improved: Menu disappears on click
-Changed background color variable: 'editor_background' used for better compatibility with custom styles
v7.0.8 - May 27. 2012.
-Fixed: QL Enable Stats link in vB 4.2
v7.0.9 - Jul 07. 2012.
-Fixed: Hide on misc.php requests not related to Stats
v7.1 - Avg 02. 2012.
-New: Top Thanked now works with "Thumbs Up?" system by Scandal
-Note: Above still works with "Post Thanks" system by Abe

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	stats1.jpg
Views:	21052
Size:	178.7 KB
ID:	112315   Click image for larger version

Name:	stats2.jpg
Views:	14826
Size:	153.8 KB
ID:	112316   Click image for larger version

Name:	menu.jpg
Views:	9592
Size:	65.4 KB
ID:	112317   Click image for larger version

Name:	more.jpg
Views:	10585
Size:	73.7 KB
ID:	112318  

Click image for larger version

Name:	acp1.jpg
Views:	7268
Size:	109.4 KB
ID:	112319   Click image for larger version

Name:	acp2.jpg
Views:	6005
Size:	117.0 KB
ID:	112320  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Statistics Modifications Cyb - Advanced Forum Statistics Valter vBulletin 3.8 Add-ons 1230 31 Aug 2019 17:31
Statistics Modifications Cyb - Advanced Forum Statistics Valter vBulletin 3.7 Add-ons 651 02 Sep 2013 13:25
Statistics Modifications Cyb - Advanced Forum Statistics Valter vBulletin 3.6 Add-ons 1599 15 Feb 2013 03:33
Cyb - Advanced Forum Statistics Valter vBulletin 3.5 Add-ons 116 16 May 2010 03:57

  #1306  
Old 10 Dec 2015, 11:08
Milobil Milobil is offline
 
Join Date: Jun 2012
Thanks it works
Reply With Quote
  #1307  
Old 10 Dec 2015, 13:14
Ende1 Ende1 is offline
 
Join Date: Dec 2015
MarkFL, can you help me with my question? I've tried everything, but nothing seems to work
Reply With Quote
  #1308  
Old 10 Dec 2015, 17:32
MarkFL's Avatar
MarkFL MarkFL is offline
 
Join Date: Feb 2014
Real name: Mark
Originally Posted by Ende1 View Post
MarkFL, can you help me with my question? I've tried everything, but nothing seems to work
If I understand the issue you posted in another thread, you have found that a user who has been put into the "global ignore" list has none of their posts show up in the stats produced by this product, thereby potentially tipping them off that something isn't normal about their account.

I can't promise anything, but I will investigate this in the near future and see if I can find a fix.
Reply With Quote
  #1309  
Old 15 Dec 2015, 01:09
Ende1 Ende1 is offline
 
Join Date: Dec 2015
Originally Posted by MarkFL View Post
If I understand the issue you posted in another thread, you have found that a user who has been put into the "global ignore" list has none of their posts show up in the stats produced by this product, thereby potentially tipping them off that something isn't normal about their account.

I can't promise anything, but I will investigate this in the near future and see if I can find a fix.
Exactly. Thanks for your help.
Reply With Quote
  #1310  
Old 17 Dec 2015, 22:12
Ende1 Ende1 is offline
 
Join Date: Dec 2015
Did you have any time to make some progress?
Reply With Quote
  #1311  
Old 18 Dec 2015, 00:10
MarkFL's Avatar
MarkFL MarkFL is offline
 
Join Date: Feb 2014
Real name: Mark
Originally Posted by Ende1 View Post
Did you have any time to make some progress?
Not yet, but once I know anything I will let you know.
__________________
Former vBulletin.org Staff Member



Support for my products (as well as updates/new product publishing) has been moved to MHB - vBulletin Products and TAZ - Add-ons
Reply With Quote
  #1312  
Old 09 Jan 2016, 08:49
Ende1 Ende1 is offline
 
Join Date: Dec 2015
Did you try it out bro?
Reply With Quote
  #1313  
Old 12 Jan 2016, 16:48
Ende1 Ende1 is offline
 
Join Date: Dec 2015
Is no one else having this issue?
Reply With Quote
  #1314  
Old 17 Jan 2016, 09:11
Ende1 Ende1 is offline
 
Join Date: Dec 2015
Can I contact Valter himself to ask him about this? Is he still a developer?
Reply With Quote
  #1315  
Old 22 Jan 2016, 08:59
postcd postcd is offline
 
Join Date: Feb 2012
Originally Posted by booble View Post
on remote server Chat Box & Advance Forum Statistics Not Loading On Logging on firefox, I have press ctrl+f5

It says "Loading..." eternally
I have this issue too. On refresh its ok, but when i open forum homepage in new tab, it fails this way. Used both Firefox and Chrome.

When i open page via web proxy like anonymouse.org, the "Loading..." issue is not there.

The other vB forum that is using this plugin do not have this issue.

Also im logged out of that forum frequenly, that is another issue, might be related.l

Last edited by postcd; 22 Jan 2016 at 09:16.
Reply With Quote
  #1316  
Old 28 Mar 2016, 21:51
ggrimes620 ggrimes620 is offline
 
Join Date: Feb 2013
Originally Posted by pbnjj11 View Post
How do you change the background color of the stats???? I see that you added the feature but I'm a bit lost on how to do this...sorry.
Originally Posted by Valter View Post
In your style change stylevar editor_background.
57 pages in and I find what I'm looking for.
Reply With Quote
  #1317  
Old 06 May 2016, 18:55
ArcadeSyndicate's Avatar
ArcadeSyndicate ArcadeSyndicate is offline
 
Join Date: Oct 2008
seems there is a conflict with the latest firefox update. see the missing thread icons on the left?
Attached Images
File Type: png firefoxold.png (115.2 KB, 27 views)
File Type: png firefoxnew.png (108.7 KB, 28 views)
__________________
Reply With Quote
  #1318  
Old 06 May 2016, 22:58
djbaxter djbaxter is offline
 
Join Date: Aug 2006
Location: Ottawa, Canada
Originally Posted by ArcadeSyndicate View Post
seems there is a conflict with the latest firefox update. see the missing thread icons on the left?
I'm using the latest Firefox update and the icons are not missing for me.

Check for a conflict from another plugin, or a corrupted browser cache (flush it).
Reply With Quote
  #1319  
Old 08 May 2016, 15:57
jimnyc jimnyc is offline
 
Join Date: Aug 2003
Originally Posted by ArcadeSyndicate View Post
seems there is a conflict with the latest firefox update. see the missing thread icons on the left?
I also have this issue. Using FF 46.0.1

Something must have changed that affects the alignment. In mine, those folders are gone too. But if I run my mouse over it, copy those thread listings, and then paste it into a post - those folders are actually there. Not sure what's happening, but I have the same thing as you, and it didn't happen until the same day as you, right after I received the update.

I'll try disabling and reenabling various addons I have and see if I can figure it out.
Reply With Quote
  #1320  
Old 08 May 2016, 17:48
djbaxter djbaxter is offline
 
Join Date: Aug 2006
Location: Ottawa, Canada
Originally Posted by ArcadeSyndicate View Post
seems there is a conflict with the latest firefox update. see the missing thread icons on the left?
Originally Posted by djbaxter View Post
I'm using the latest Firefox update and the icons are not missing for me.

Check for a conflict from another plugin, or a corrupted browser cache (flush it).
Originally Posted by jimnyc View Post
I also have this issue. Using FF 46.0.1

Something must have changed that affects the alignment. In mine, those folders are gone too. But if I run my mouse over it, copy those thread listings, and then paste it into a post - those folders are actually there. Not sure what's happening, but I have the same thing as you, and it didn't happen until the same day as you, right after I received the update.

I'll try disabling and reenabling various addons I have and see if I can figure it out.
Apologies. My version of Firefox updated to 46.0.1 overnight and sure enough those icons are gone for me now too...
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 17:29.

Layout Options | Width: Wide Color: