Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old 24 Mar 2012, 08:55
sacobra sacobra is offline
 
Join Date: Mar 2010
Thumbs down global_bootstrap_init_start code causing 301 redirects

I have got this the following code in global_bootstrap_init_start hook for Janrain plugin.


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

However this code is causing a 301 redirect when accessing the home page (content.php).

When accessing the URL http://<domain-name>/ it is redirecting to http://<domain-name>/?engage_callback=0&add_engage_identifier=0

Would anyone know how to fix this?Regards
Reply With Quote
  #2  
Old 24 Mar 2012, 16:12
Lynne's Avatar
Lynne Lynne is offline
 
Join Date: Sep 2004
Real name: Lynne
I just added that plugin to my site and I am not getting that result at all. I would guess it is another plugin you have, or other code you have added, that is actually causing this to happen.
__________________
Former vBulletin.org Staff Member

Try a search before posting for help. Many users won't, and don't, help if the question has been answered several times before.
W3Schools -
Online vBulletin Manual
If I post some CSS and don't say where it goes, put it in the additional.css template.
I will NOT help via PM (you will be directed to post in the forums for help.)
Reply With Quote
  #3  
Old 25 Mar 2012, 04:15
sacobra sacobra is offline
 
Join Date: Mar 2010
The mod does not work as is. And developer has stopped supporting. So I have customised it to work for my site.

I tested & figured out that whatever I add in the global_bootstrap_init_start get appended in the home page URL.
For e.g:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Leads to URL being /?engage_callback&add_engage_identified=0

If I change it to

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

The URL becomes /?testing=0
That is if I change the get variable to something that I'm not using in the rest of the code.

I have checked if the php variable $engage_callback has any effect. But it does not. I can change the php variable to whatever I want and there is no change in the the behaviours.

What I see in the Page Source is that the javascript code embedded in it is

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

instead of

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

How does the
Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

results in the RELPATH variable being filled?

--------------- Added 25 Mar 2012 at 04:31 ---------------

And I tried disabling a few plugins that I have to isolate the problem and it doesn't seem to be due to any of them.
Reply With Quote
  #4  
Old 28 Mar 2012, 02:03
sacobra sacobra is offline
 
Join Date: Mar 2010
I moved the code & database to another server and this issue is NOT present. It seems that the some server configuration is to blame for this.

Do anyone know what config in an Apache server can cause this kind of behavior?

Regards

--------------- Added 28 Mar 2012 at 02:35 ---------------

I've isolated the problem.

It is caused when Mod-rewrite friendly URL is turned on. When I change that setting to Basic / Advanced, there is no issue.

Any idea on what could be causing this with mod-rewrite friendly URL?

Regards
Reply With Quote
  #5  
Old 28 Mar 2012, 16:24
Lynne's Avatar
Lynne Lynne is offline
 
Join Date: Sep 2004
Real name: Lynne
Perhaps the .htaccess is causing the issue? You may want to look at that.
__________________
Former vBulletin.org Staff Member

Try a search before posting for help. Many users won't, and don't, help if the question has been answered several times before.
W3Schools -
Online vBulletin Manual
If I post some CSS and don't say where it goes, put it in the additional.css template.
I will NOT help via PM (you will be directed to post in the forums for help.)
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 12:59.

Layout Options | Width: Wide Color: