Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Last post on forum home, working version Details »
Last post on forum home, working version
Mod Version: 1.00, by Scott MacVicar (Member) Scott MacVicar is offline
Developer Last Online: Mar 2016 I like it Show Printable Version Email this Page

This modification is in the archives.
vB Version: 2.2.x Rating: (0 vote - 0 average) Installs: 85
Released: 21 Sep 2001 Last Update: Never Downloads: 10
Not Supported  

I had tried a version suggested by someone else instead of my own and well, all it did was send the load average up by about 10 times what it was.

This version inserts the last title into the forum database when it is updating the last post name and time. There is no difference in loading time as everything is called normally by vBulletin.

This works on 2.0.x and 2.2.x

Updated at 11:34 GMT on 28th September 2002

Thanks to floren for the latest update.

Download Now

Only licensed members can download files, Click Here for more information.

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Forum Home Enhancements Most active user Last X (last day/last week/last month/ever) Fully controlled Omranic vBulletin 3.6 Add-ons 70 03 Nov 2011 17:05

  #181  
Old 06 May 2002, 08:46
Bald Bouncer's Avatar
Bald Bouncer Bald Bouncer is offline
 
Join Date: Oct 2001
edited

Last edited by Bald Bouncer; 06 May 2002 at 08:55.
Reply With Quote
  #182  
Old 07 May 2002, 14:24
kms's Avatar
kms kms is offline
 
Join Date: Mar 2002
Originally posted by PPN
send the functions.php to [email protected] and I'll look it over
hiya PPN, any luck m8 ?

TIA
__________________
Regards

KMS

PCLincs
Reply With Quote
  #183  
Old 07 May 2002, 15:19
mashby's Avatar
mashby mashby is offline
 
Join Date: Jan 2002
Real name: Michael Ashby
A rather lengthy hack, but it installed just as described and works like a charm. Thanks for making such a great hack!
Reply With Quote
  #184  
Old 07 May 2002, 15:21
mashby's Avatar
mashby mashby is offline
 
Join Date: Jan 2002
Real name: Michael Ashby
I noticed that the thread title for items in "private" forums don't show up on the home page. Is that intentional?
Reply With Quote
  #185  
Old 18 May 2002, 06:22
Boofo's Avatar
Boofo Boofo is offline
 
Join Date: Mar 2002
Real name: Rob
Forums update counters

I just installed this hack and when I tried to update the forum counters, I got this error. Can you tell me what it means and what I need to do, please?

Database error in vBulletin Control Panel 2.2.5:

Invalid SQL: SELECT * FROM thread WHERE forumid='1' AND lastposter='Boofo's Babe' AND lastpost='1021587428'
mysql error: You have an error in your SQL syntax near 's Babe' AND lastpost='1021587428'' at line 1

mysql error number: 1064

Date: Saturday 18th of May 2002 07:10:17 AM
Script: http://www.bearfacts2.com/forum/forum/admin/misc.php
Referer: http://www.bearfacts2.com/forum/admi...action=chooser
Reply With Quote
  #186  
Old 18 May 2002, 09:04
Boofo's Avatar
Boofo Boofo is offline
 
Join Date: Mar 2002
Real name: Rob
Found the problem...

It seems that SQL doesn't like user names with apostrophies in them. "Boofo's Babe" was reading as "s Babe" and the DB didn't like that. I went ahead and posted in the forums and re-ran the update counters and it went off without a hitch with me as the last poster. Is there any way around this so users can use apostrohies in their names if they like?

BTW: Great hack, PPN! (as usual)
Reply With Quote
  #187  
Old 18 May 2002, 18:27
Jen's Avatar
Jen Jen is offline
 
Join Date: Apr 2002
I have one quick question that doesn't seem to have been covered yet..

I want to guarantee that the user ALWAYS goes to the thread shown as the last post, but if you load up the index, wait for a few more posts to be made and then click the thread link it goes to the newest thread, NOT the one listed as last post.

This is confusing my users to no end (if they'd only click a little faster it wouldn't be a problem ).

Is there any way to set the goto link to go to the thread listed as the last post even if there have been new posts made since?
Reply With Quote
  #188  
Old 20 May 2002, 01:18
Franki Franki is offline
 
Join Date: Mar 2002
I installed this hack and works fine BUT not with polls. I posted a new thread with poll and it didn't appear as a new post in the forum home page. Why is that?
Reply With Quote
  #189  
Old 20 May 2002, 01:24
Boofo's Avatar
Boofo Boofo is offline
 
Join Date: Mar 2002
Real name: Rob
It works here

It works with polls here fine. I am running version 2.2.5, what are you running?
Reply With Quote
  #190  
Old 01 Jun 2002, 01:02
Frank-kun Frank-kun is offline
 
Join Date: Nov 2001
Hmm..looks like I have a problem...

Had this hack since 2.2.0 and it's worked like a charm ever since - just did the Beyond Compare thing and it worked fine. But I updated to 2.2.6 today and it's having a problem. It works fine on a new reply or new thread, but won't work on moving or deleting threads or posts. It just puts it as before, with just name and date.

I tried installing from scratch, doing the update forums info thing again, still no dice.

Curiously enough it does seem to be leaving a space for the last title on forum home, it's just that it's blanked.

Could someone give some insight or perhaps point me to the file that deals with the move/delete to try and fix this?
Reply With Quote
  #191  
Old 01 Jun 2002, 14:57
Frank-kun Frank-kun is offline
 
Join Date: Nov 2001
Hey, how about that, I solved my own problem

I believe that in 2.2.6, the file to update forum post counts and lastposters was changed, so that the "title" is not part of the SELECT statement that is called in order to get the lastposts info. Because of this, $lasttitle is set to blank because according to the code, it tries to set itself using the "title" variable.

As a quick fix, you can simply have the SELECT statement call the title column again. So if you have this hack installed, your code should look like this:

in admin/functions.php:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Just replace it with:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

...and you should have no problems with moving/deleting with PPN's Last Title hack.

Now, I don't know if the "title" was taken out of the code for some reason to fix a bug, but if it was, perhaps a better fix that preserves the bugfix might be more useful. But this one's a quick fix.

Thanks again PPN for a great hack.
Reply With Quote
  #192  
Old 01 Jun 2002, 15:01
Boofo's Avatar
Boofo Boofo is offline
 
Join Date: Mar 2002
Real name: Rob
Do you...

Do you need to chnage it to this for 2.2.5 too or just 2.2.6?
Reply With Quote
  #193  
Old 01 Jun 2002, 19:55
Frank-kun Frank-kun is offline
 
Join Date: Nov 2001
Re: Do you...

Originally posted by Boofo
Do you need to chnage it to this for 2.2.5 too or just 2.2.6?
Probably just for 2.2.6. If you're working ok with the hack and you have 2.2.5 you should probably just leave it be. But if you're having problems when you move or delete posts, then you should probably try to apply the change.
Reply With Quote
  #194  
Old 01 Jun 2002, 20:33
Boofo's Avatar
Boofo Boofo is offline
 
Join Date: Mar 2002
Real name: Rob
Re: Re: Do you...

Would it mess anything up to just go ahead and add it to avoid any problmes that could arise? I mean, if it won't hurt anything then it might be a good idea to go ahead and update it.

Originally posted by Frank-kun


Probably just for 2.2.6. If you're working ok with the hack and you have 2.2.5 you should probably just leave it be. But if you're having problems when you move or delete posts, then you should probably try to apply the change.
Reply With Quote
  #195  
Old 03 Jul 2002, 09:55
alanvo alanvo is offline
 
Join Date: Feb 2002
it screws up my tables, why is that, can anybody please help me...

http://www.demsang.net/forums
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 07:59.

Layout Options | Width: Wide Color: