Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old 01 Mar 2011, 22:49
wpeloquin wpeloquin is offline
 
Join Date: May 2006
Question uploading images in a plugin.

I am trying to put in an upload picture function on a plugin i am working on, but i cannot get the plugin to work properly. I am obviously doing something wrong, and I am sure it is probably something simple that i am overlooking. The goal is to store the picture name (default.jpg, name.gif, etc) in the database field, and upload the file to $imagedir. The image could then be shown using something like <img src="{vb:raw imagedir}{vb:raw picture variable}" />

This is what i currently have:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Reply With Quote
  #2  
Old 01 Mar 2011, 23:06
Lynne's Avatar
Lynne Lynne is offline
 
Join Date: Sep 2004
Real name: Lynne
And what is the result of what you have - can we have a link/example? And what template are you editing (and where)? And what hook location are you using?
__________________
Former vBulletin.org Staff Member

Try a search before posting for help. Many users won't, and don't, help if the question has been answered several times before.
W3Schools -
Online vBulletin Manual
If I post some CSS and don't say where it goes, put it in the additional.css template.
I will NOT help via PM (you will be directed to post in the forums for help.)
Reply With Quote
  #3  
Old 02 Mar 2011, 19:52
wpeloquin wpeloquin is offline
 
Join Date: May 2006
the template i am using is a custom added template (roster_add) using a custom php file (roster.php).

I attached a picture showing the base element of the form. Every aspect of the entire form works properly, minus the picture uploading. When i select a picture and submit, Array gets stored in the database field for the picture instead of the picture name.

the result, in a "view character" screen, shows the broken image alt text (character name). if you try to view picture, it returns an invalid link, "demoforums/images/roster/Array". So the code is pulling the correct data from the database for viewing, but the data is being stored wrong. "Array" is being stored instead of "picturename.png", and the file is not being uploaded at all to the directory.

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 23:12.

Layout Options | Width: Wide Color: