Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
SocialForums for vB3.8 Details »
SocialForums for vB3.8
Mod Version: 2.1.0, by Phalynx (Coder) Phalynx is offline
Developer Last Online: Nov 2015 I like it Show Printable Version Email this Page

vB Version: 3.8.x Rating: (29 votes - 4.90 average) Installs: 251
Released: 04 Mar 2009 Last Update: 11 Aug 2009 Downloads: 1272
Not Supported DB Changes Uses Plugins Auto-Template Additional Files Translations  

SocialForums for vBulletin 3.8

Created by Marius Czyz aka Phalynx.

This mod will work *ONLY* with vBulletin 3.8 or higher. It will not run on vBulletin 3.7. Please use the version for vBulletin 3.7

Support will be only given for people who clicked Mark as INSTALLED.

Description
Not satisfied with vBulletin social groups messaging function? With SocialForums your social group leaders can create a standard forum for their group.
A group leader can only create a forum if the group has at least 5 members - this can be changed via settings. Optionally the group leader can be a moderator of such a social forum.

What about old discussions?
Via AdminCP, SocialForums, you can transfer all discussions and messages to a new forum. No post would be lost.

Permissions
There are advanced permissions (Forum and Archive). This includes read/write public and private (moderated/invite only) socialforums and creation of forum. As this needs two additional queries on every page you can disable this.

Demo
None, see screenshots

Installation
This product is fully phrased and uses template hooks. No file changes or manual template edits needed.
1. Upload bitfield_socialforums.xml to existing folder /includes/xml/
2. Upload functions_socialforums.php to existing folder /includes/
3. Fresh Installation: Just import the product. Upgrade: Import the product, allow overwrite. No forums get lost!
4. Check settings, especially for parent forum. Don't forget to set permissions via usergroups!

Troubleshooting
Q: I don't see a link to create a forum. Why?
A: Check permissions for the usergroup, espacially if the user is allowed to create forum.
A: Check if the usergroup meet min users requirement, see AdminCP/Settings/SocialForums.

Q: My users see the forums, but they shouldn't!
A: Check permissions for the usergroup, if the users usergroup is set to "can see".
A: Did you disabled the restriction mode? Enable it.

Todo
- By deleting a group the forum should also be deleted/archived. Currently this has to be done manually.

Known Issues
- On big boards with hundreds of social groups this mod can really impact the performance because of the mass of new created forums. If you still want to use this mod use the "Minimum Members" feature with a higher value. Using the permission check there are additional two queries on every page.
- With activated option to add owner as a moderator the transfering leads to removing all moderators of the linked forum

History
2.1.0, 11th August 2009
- Social Groups without a forum are listed in AdminCP and can be automatically converted with few clicks.
- Fixed errors converting bigger discussions
- Minor changes and fixes

2.0.1, 05th March 2009
- Convert ignores now deleted discussions
- Threads on Groups equipped with mark on new

2.0.0
- First official release for vBulletin 3.8
- Possibility to transfer Social Group Discussion into a real Forum
- New layout for threadlisting, similar to a real threadlist in a forum
- Possibility of a notice in Forums associated with a Social Group
- Discussion/Message counter is showing Thread/Reply counts. Phrase "Discussion" and "Message" cannot be changed to "Thread"/"Reply".
- Transfering a Group to another user updates now also the moderator
- Minor changes and fixes

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	SF_Link.JPG
Views:	2736
Size:	13.1 KB
ID:	95861   Click image for larger version

Name:	SF_Linked_Forum.JPG
Views:	4669
Size:	48.3 KB
ID:	95862   Click image for larger version

Name:	SF_Overview_with_threads.jpg
Views:	4477
Size:	70.4 KB
ID:	95863  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Miscellaneous Hacks SocialForums 1.4 Phalynx vBulletin 3.7 Add-ons 738 11 Jul 2013 19:14
Administrative and Maintenance Tools SocialForums to 'vB 3.8 Social Group Discussions' Converter flOid vBulletin 3.8 Add-ons 18 08 Dec 2009 15:44

  #151  
Old 23 Aug 2009, 07:43
Freesteyelz's Avatar
Freesteyelz Freesteyelz is offline
 
Join Date: Jan 2006
They remain as forums. You'll need to manually delete the forums if anything.
__________________


Reply With Quote
  #152  
Old 13 Sep 2009, 21:58
Tettinntil's Avatar
Tettinntil Tettinntil is offline
 
Join Date: Feb 2006
Installed and so far so good - beautiful that I can fix things in the CP. My first install after I bought out my former partner and this was fun Thank you!!!
Reply With Quote
  #153  
Old 22 Sep 2009, 14:55
MrEyes MrEyes is offline
 
Join Date: Nov 2004
A curious problem of sorts.

I have downloaded and installed the mod onto a absolutely clean vBulletin 3.8.4 install (i.e. no mods, template hacks etc).

I then created a group and then clicked the link to create a forum for the group, this presented me with the following message on a standard VB redirection page:

"Cannot create forum!"

However, the forum is created and everything seems to work exactly as it should.

Having briefly delved into the code it seems that the issue is something to do with these lines in the


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Having checked the CreateForum function in functions_socialforums.php it would seem that this returns true if the create is successful and false if not. So the syntax of the code above should be:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

I have tested this on my test install and this seems to resolve the issue, but I am posting here just incase I am missing something.
Reply With Quote
  #154  
Old 22 Sep 2009, 17:29
Phalynx Phalynx is offline
 
Join Date: Feb 2004
Real name: Marius
Seems really a like a bug. Thanks for showing it.
Reply With Quote
  #155  
Old 05 Oct 2009, 21:43
saikat saikat is offline
 
Join Date: Jul 2009
Restrict posting to group members only.

Hi Phalynx,

First of all , thanks for the awsome code. Worked like a charm. Heres my question:

I would like the group forums to be visible to everyone, but they should only be able to post/reply in the forum if they have joined the group, else the "Reply/Quote" button should point them to the "Join" page for the group.

Is this something that is doable by your code? Any pointers?

thanks,
saikat
Reply With Quote
  #156  
Old 11 Oct 2009, 23:49
franvsl franvsl is offline
 
Join Date: Jul 2009
Hi!!

Congratulations for that great job.

My question is about the box "The forum where all new created social forums are attached to." in the socialforums settings

What am I supposed to write there? A number (if so, which number??) or the name of the parent forum?. I tried both, and when I click the button "Create Forum" I get an error saying "Invalid parent forum specified. Check settings"

Thank you!
Reply With Quote
  #157  
Old 12 Oct 2009, 09:42
Phalynx Phalynx is offline
 
Join Date: Feb 2004
Real name: Marius
Originally Posted by saikat View Post
Hi Phalynx,

First of all , thanks for the awsome code. Worked like a charm. Heres my question:

I would like the group forums to be visible to everyone, but they should only be able to post/reply in the forum if they have joined the group, else the "Reply/Quote" button should point them to the "Join" page for the group.

Is this something that is doable by your code? Any pointers?

thanks,
saikat
Check usergroup permissions.


Originally Posted by franvsl View Post
Hi!!

Congratulations for that great job.

My question is about the box "The forum where all new created social forums are attached to." in the socialforums settings

What am I supposed to write there? A number (if so, which number??) or the name of the parent forum?. I tried both, and when I click the button "Create Forum" I get an error saying "Invalid parent forum specified. Check settings"

Thank you!
You must enter the ID of the parent Forum.
Reply With Quote
  #158  
Old 12 Oct 2009, 21:29
franvsl franvsl is offline
 
Join Date: Jul 2009
Thanks!

Now I can create the forums, but when it is done, I can't see the forum in the group. The forum is created, and I can see it in the forums list, but it doesn't appear in the social group:

http://www.vs-rtc.com/foro/group.php?groupid=1

Any ideas?
Reply With Quote
  #159  
Old 13 Oct 2009, 07:46
Phalynx Phalynx is offline
 
Join Date: Feb 2004
Real name: Marius
Originally Posted by franvsl View Post
Thanks!

Now I can create the forums, but when it is done, I can't see the forum in the group. The forum is created, and I can see it in the forums list, but it doesn't appear in the social group:

http://www.vs-rtc.com/foro/group.php?groupid=1

Any ideas?
Please check permissions and also if you modified a group-related template.
Reply With Quote
  #160  
Old 13 Oct 2009, 12:33
l_amhed l_amhed is offline
 
Join Date: Dec 2001
Thanks for this usefull and killer hack !

I've got some minor errors :

- Some special characters are not well displayed, such as ' (there is a \ just before them)
- The sticky threads are not displayed correctly on top of the threads listing.
Reply With Quote
  #161  
Old 15 Oct 2009, 00:24
Saviour's Avatar
Saviour Saviour is offline
 
Join Date: Apr 2007
Exactly what I was looking for...Phalynx...You rock!

Saviour marks "Installed" and "Nominates - MOTM"!!!
__________________
Free Computer Help
Reply With Quote
  #162  
Old 28 Oct 2009, 14:14
reddyink reddyink is offline
 
Join Date: Aug 2007
Don't see create forum link

THANKS -SOLVED
I am the admin and created a uploaded Social Forums Product. No erros. (vb3.8.4)
As an admin created a group.

I don' see the link to "create a Forum" anywhere in the group. I made the number of members required to 1 and 0 also but still no luck.

What's happening for me?

Uninstalled and installed to try also.
Many thanks for the help!

Last edited by reddyink; 28 Oct 2009 at 16:21.
Reply With Quote
  #163  
Old 28 Oct 2009, 15:09
Phalynx Phalynx is offline
 
Join Date: Feb 2004
Real name: Marius
Please check usergroup permissions.
Reply With Quote
  #164  
Old 05 Nov 2009, 10:07
MrEyes MrEyes is offline
 
Join Date: Nov 2004
I am about to ask a question, and this is the answer you must reply with.

Yes, of course - as soon as VB4 goes gold and I get a chance to make the changes required - I guesstimate a month or two after VB4 gold
So here is the question:

Will you be updating the fantastic mod to work with VB4?

Feel free to simply copy and paste the answer above
Reply With Quote
  #165  
Old 05 Nov 2009, 15:56
IvyKeepMommy IvyKeepMommy is offline
 
Join Date: Sep 2007
Sorry, I figured out the problem and it was with a different mod. Thanks for a great mod!
__________________
Laura
Site Admin for www.MarylandMommy.com -- A free local mom's support site... we are where your friends are!

Last edited by IvyKeepMommy; 05 Nov 2009 at 23:01.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 00:52.

Layout Options | Width: Wide Color: