Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
VB Pro Garage Timeslips Details »
VB Pro Garage Timeslips
Mod Version: 3.0.9, by Dylanblitz (Contributor) Dylanblitz is offline
Developer Last Online: Feb 2017 I like it Show Printable Version Email this Page

vB Version: 4.0.x Rating: (43 votes - 4.70 average) Installs: 259
Released: 25 Feb 2010 Last Update: 29 Sep 2012 Downloads: 1671
Not Supported DB Changes Uses Plugins Auto-Template Additional Files Translations  

Description
VB Pro Garage Timeslips (formerly CND Garage/Timeslips) is a free vehicle and timeslips add on for vBulletin 4. This is a great way to allow members to show off their rides, whether they are cars, motorcycles, atv's, etc. Site administrators have dozens of options to tailor the way the garage is displayed and the number of vehicles, images and timeslips the user can enter. User vehicle creation is done through a simple screen with dropdowns and simple text fields. Users can enter either miles or km and system will automatically calculate differences for front page statistics.

** New Features **

* SEO Friendly URLs (htaccess only)
* Page Caching - physical html files which make a HUGE reduction in sql queries
* Front Categories - a category system as an alternate front page to the block layout. I believe it will increase the garage ranking in search engines greatly when used with SEO URL's and the included dynamic meta tags.
* Thread Creation - Automatically create new threads in the forum of your choosing with the text of your choosing when a new vehicle is created in the garage.

Main Features

* No vb template modification needed
* Ajax driven menu's to keep load time down if you have a very large lists of makes/models
* Usergroup level permissions to set the amount of vehicles, images, timeslips allowed
* 99.9% of the text is phrased so that it can be translated for multinational sites
* On the fly image/text watermarking ability to make sure images are tied to your site
* Lytebox image presentation

Installation
Instructions, tips and more are now in the included chm file. If you have problems with the chm I have the document published at:
http://www.vbprogarage.com/forums/docs/html_vb4_ts_300/

The quick and dirty install:
1) Upload all files in the upload folder
2) Import vb_pro_garage.xml into Product Manager
3) Import vb_pro_garage_language_english.xml into Languages & Phrases
4) If you want all makes and models I've collected, import vb_pro_garage_vehicles^^new_install_only.xml into Product Manager

Post Installation
So you don't have to find it in the instructions. After install, there is a button up top in the navbar. This button by default is admin only. This is so you can configure and test without having to close the garage. When you are ready to deploy to the community:
ACP->Settings->Options->Garage General Settings - Set Garage Menu Button to Enabled.

The garage is developed on vb 4.0.7 and tested back to 4.0.0. The garage will run on PHP 5.x+ compiled with GD/GD2 and MySQL 5.x+

Additional options for the garage like adding featured businesses that support your site, fuel tracking, dyno charts, modifications and lots more are included in the commercial version.

Many thanks to Coroner for his stylebridge which led me on a path that saved me hours and hours of template editing

There are a few bugs that you might run into on this version. Instead of working on correcting them in the files and working on getting a new package up here, I'm working on the next version and including the posts that fix the errors here.

Change Log:
v3.0.9 - 09/29/2012
-----------------------------
Fixed sql injection problem
Replaced depreciated split function usage
Fixed sql error on image comments
Fixed Make/Model count on front page resetting to 1
Fixed extra unlabeled field on vehicle create/edit (Timeslips only)
Fixed postbit dropdown showing character code
Fixed tables incorrectly set with TYPE instead of ENGINE
Added navigation manager links to product xml

v3.0.8 - 12/9/2010
-----------------------------
Fixed missing vehicle comment code

v3.0.7 - 12/1/2010
-----------------------------
Fixed error with non existant garage_special_track table

v3.0.6 - 11/21/2010
-----------------------------
Fixed who's online error
Fixed map infowindow colors

v3.0.5 - 11/15/2010
-----------------------------
Fixed error with member profile vehicle block
Fixed member tab url path
Fixed error on vehicle map with apostrophes in title

v3.0.4a - 11/12/2010
-----------------------------
Corrected package error

v3.0.4 - 11/11/2010
-----------------------------
Fixed error with front blocks
Fixed style error with vB4.0.8 changes

v3.0.3 - 11/2/2010
-----------------------------
Fixed duplicate countries
Fixed vehicle view slideshow image size
Fixed username browse error
Fixed geocode error on missing zip
Fixed postbit error with vehicles that have a apostrophe in the name

v3.0.2 - 10/25/2010
-----------------------------
Fixed missing add vehicle button on member profile
Added bbcode capabilities to welcome box on garage front page
Moved vehicle count to db table to ease db queries
Added notification scheduled task to send message to new users about adding a garage entry
Added default clear image for watermark
Fixed code to disregard watermark option if image is missing
Fixed search username error
Updated obsolete data queries
Added SEO Friendly URLS
Added page caching capabilities
Fixed sql error with moving vehicle class and color to new selection on deletion in ACP
Added function to replace non english characters with english characters in ajax selection lists
Added image comments
Added notification for image and vehicle comments
Added option to add page title
Added zip code to vehicle and googlemap
Added ability to disable and ability to hide info for googlemap

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	01_front_cat.png
Views:	4129
Size:	133.0 KB
ID:	123185   Click image for larger version

Name:	01_front.jpg
Views:	2313
Size:	63.1 KB
ID:	123186   Click image for larger version

Name:	02_ajax_image_data.png
Views:	1798
Size:	62.1 KB
ID:	123187   Click image for larger version

Name:	02a_browse.jpg
Views:	1937
Size:	86.8 KB
ID:	123188  

Click image for larger version

Name:	03_add_vehicle.jpg
Views:	1126
Size:	94.5 KB
ID:	123189   Click image for larger version

Name:	04_view_vehicle.jpg
Views:	1430
Size:	89.1 KB
ID:	123190   Click image for larger version

Name:	05_add_timeslip.png
Views:	905
Size:	24.6 KB
ID:	123191   Click image for larger version

Name:	06_view_timeslip.png
Views:	787
Size:	18.3 KB
ID:	123192  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Add-On Releases CND Garage - Timeslips Dylanblitz vBulletin 3.8 Add-ons 227 24 May 2015 22:29

  #871  
Old 12 Apr 2012, 02:56
cdoyle cdoyle is offline
 
Join Date: Oct 2004
I found one little bug with the approvals of trims.
When it sends me the PM, with the link to the approval.

The link takes me to
http://www.caraudiocentral.net/forum...proval.php?do=

But it should be
http://www.caraudiocentral.net/forum...al.php?do=trim

Chris
Reply With Quote
  #872  
Old 12 Apr 2012, 18:27
gpinjason's Avatar
gpinjason gpinjason is offline
 
Join Date: Feb 2012
Originally Posted by cdoyle View Post
I found one little bug with the approvals of trims.
When it sends me the PM, with the link to the approval.

The link takes me to
http://www.caraudiocentral.net/forum...proval.php?do=

But it should be
http://www.caraudiocentral.net/forum...al.php?do=trim

Chris
I get the same thing
Reply With Quote
  #873  
Old 14 May 2012, 14:54
Jonm Jonm is offline
 
Join Date: May 2011
I keep getting this error message when trying to add a photo?

Filename.jpg - Error: Image could not be moved.

anyone any ideas?
Reply With Quote
  #874  
Old 30 May 2012, 20:42
gpinjason's Avatar
gpinjason gpinjason is offline
 
Join Date: Feb 2012
Navigation Tab is gone with 4.2.0.. any fix for this yet?
Reply With Quote
  #875  
Old 30 May 2012, 20:57
upperme upperme is offline
 
Join Date: Feb 2011
Yep, same here. I'd be interested to know when this is fixed as well.

Thanks,

Jim

Originally Posted by gpinjason View Post
Navigation Tab is gone with 4.2.0.. any fix for this yet?
Reply With Quote
  #876  
Old 31 May 2012, 03:01
cdoyle cdoyle is offline
 
Join Date: Oct 2004
I just added the tab manually in the navigation manager.
Reply With Quote
  #877  
Old 31 May 2012, 04:49
Dylanblitz Dylanblitz is offline
 
Join Date: Oct 2005
Originally Posted by Jonm View Post
I keep getting this error message when trying to add a photo?

anyone any ideas?
The error you are getting means that php doesn't have the permissions to move the file from the tmp folder to the users image directory. When a user uploads a picture it will try to create the subfolders if the user hasn't uploaded one before and move the image to it. What permissions are set on the images/garage/attach folder?


Originally Posted by gpinjason View Post
Navigation Tab is gone with 4.2.0.. any fix for this yet?
First you have to disable to old navigation
ACP->Plugins & Products->Plugin Manager
Find Garage Menu Button and uncheck the box then Save

Now to create the new one
ACP->Plugins & Products->Add New Plugin
Product: VP Pro Garage
Hook Location: navigation_tab_complete
Title: Garage Menu Button 4.2
Execution Order: 5
Plugin PHP Code: Copy and paste the contents of the attached text file into that box.
Plugin is Active: Yes

That should give you the navigation back. Let me know if you have any problems.

Or you could create them manually
Attached Files
File Type: txt garage_nav42_lite.txt (2.4 KB, 23 views)
__________________
VB Pro Garage with Timeslips
Reply With Quote
  #878  
Old 01 Jun 2012, 02:18
Front Range 4x4 Front Range 4x4 is offline
 
Join Date: Jan 2009
Real name: Chris
Thanks Dylan, pretty nice mod!

After numerous attempts I have it installed on my 4x4 site ( (vBulletin 4.1.12 Patch Level 1) I've styled the thumbnails on my site in both the Albums and the "New Album Picture Forum Home" mod using the same code. I'd like to do the same to the Garage and wonder if anyone can give me any tips on where I would edit this? Below is the look I'm shooting for both in the garage and in the Forumhome images.

TIA!
Attached Images
File Type: jpg screenshot_101.jpg (209.2 KB, 16 views)
Reply With Quote
  #879  
Old 03 Jun 2012, 12:16
Dylanblitz Dylanblitz is offline
 
Join Date: Oct 2005
Originally Posted by Front Range 4x4 View Post
Thanks Dylan, pretty nice mod!

After numerous attempts I have it installed on my 4x4 site ( (vBulletin 4.1.12 Patch Level 1) I've styled the thumbnails on my site in both the Albums and the "New Album Picture Forum Home" mod using the same code. I'd like to do the same to the Garage and wonder if anyone can give me any tips on where I would edit this? Below is the look I'm shooting for both in the garage and in the Forumhome images.

TIA!
I'm not quite sure what you are trying to do?
__________________
VB Pro Garage with Timeslips
Reply With Quote
  #880  
Old 04 Jun 2012, 00:45
Mr_Running Mr_Running is offline
 
Join Date: May 2010
Frame around the photos <--
Reply With Quote
  #881  
Old 04 Jun 2012, 02:16
Front Range 4x4 Front Range 4x4 is offline
 
Join Date: Jan 2009
Real name: Chris
Originally Posted by Dylanblitz View Post
I'm not quite sure what you are trying to do?
Put the white frame around the pics.

Originally Posted by Mr_Running View Post
Thanks Mr_Running, that's my post on how to do it in the albums. I was having trouble doing it for the garage files, must have been a brain-dead moment. Here's my garage.
Attached Images
File Type: jpg screenshot_103.jpg (112.0 KB, 11 views)
Reply With Quote
  #882  
Old 04 Jun 2012, 12:00
Mr_Running Mr_Running is offline
 
Join Date: May 2010
Looks like it's figured out?
Reply With Quote
  #883  
Old 07 Jun 2012, 10:27
bosken bosken is offline
 
Join Date: Jan 2011
Originally Posted by Dylanblitz View Post
The error you are getting means that php doesn't have the permissions to move the file from the tmp folder to the users image directory. When a user uploads a picture it will try to create the subfolders if the user hasn't uploaded one before and move the image to it. What permissions are set on the images/garage/attach folder?



First you have to disable to old navigation
ACP->Plugins & Products->Plugin Manager
Find Garage Menu Button and uncheck the box then Save

Now to create the new one
ACP->Plugins & Products->Add New Plugin
Product: VP Pro Garage
Hook Location: navigation_tab_complete
Title: Garage Menu Button 4.2
Execution Order: 5
Plugin PHP Code: Copy and paste the contents of the attached text file into that box.
Plugin is Active: Yes

That should give you the navigation back. Let me know if you have any problems.

Or you could create them manually
Tried this, got the tab back but wont take me to the garage, just stays on forum tab.
If I hoover the mouse pointer over the Garage tab the URL just point to main forum main URL, if i manually write http://myfoum/garage.php all works

When adding the tab i new VB nav manager, tab works, but all submenus are gone.

Last edited by bosken; 07 Jun 2012 at 11:50.
Reply With Quote
  #884  
Old 07 Jun 2012, 11:17
bosken bosken is offline
 
Join Date: Jan 2011
Here is how the tab looks like in VB Nav manager. This brings me the tab but submenus are gone.
What am I missing or doing wrong?




Last edited by bosken; 07 Jun 2012 at 11:29.
Reply With Quote
  #885  
Old 07 Jun 2012, 12:20
bosken bosken is offline
 
Join Date: Jan 2011
Originally Posted by Dylanblitz View Post
First you have to disable to old navigation
ACP->Plugins & Products->Plugin Manager
Find Garage Menu Button and uncheck the box then Save
I can only make following settings on this. Enabled or Admin only. no disable.

Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 02:29.

Layout Options | Width: Wide Color: