Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Lightweight Style Options for "Lightweight Style" Details »
Lightweight Style Options for "Lightweight Style"
Mod Version: 1.0.0, by dartho (Coder/Designer) dartho is offline
Developer Last Online: Feb 2021 I like it Show Printable Version Email this Page

vB Version: 4.0.6 Rating: (31 votes - 4.90 average) Installs: 439
Released: 26 Aug 2010 Last Update: Never Downloads: 2184
Supported DB Changes Uses Plugins Auto-Template  

Firstly - this is only of use if you have installed the Lightweight Style

Secondly - make sure you read the notes if you use the Mobile Style and the Mobile Style Options addon.

OK, now that the formalities are over, this is an add-on to the Lightweight Style It allows you to customise a few common parts of the style without needing to edit templates.

It also adds in options to disable some products when the Lightweight style is being used and optionally adds "Posted by Mobile Device" type text into posts created using the mobile style.

* Optionally adds links to default style (in footer or header)
* Optionally add 'Posted Via Mobile' message to new posts/threads (message can be customised)
* Optionally display "What's Going On" box in forum home
* Optionally display Style Chooser in footer
* Set 'Home' link URL (rather than editing templates)
* Can optionally hide mobile style from Style Chooser

Version Control:
1.0.0 - 26 AUG 2010 - Initial Release

Notes:
If you have installed "Mobile Style Options" (vb4) and make use of the 'Posted via Mobile Device' option, uninstalling Mobile Style Options will remove all records of posts made using the Mobile Style. The posts will of course remain, just the message will be gone. If this is not an issue for you - uninstall it BEFORE installing this addon. If you wish to keep those records, rather than uninstall it, disable it OR edit the product via Product Manager and remove all the uninstall code, save and then uninstall (this last option is the cleanest)

Running them both is OK, but you will need to disable the "Add Posted By Mobile Message to Post" plugin on the Mobile Style Options product. Uninstalling one of them will affect the other and cause errors as they share database columns. If you uninstall one without making the uninstall code changes, you shjould uninstall both and then re-install the one you are staying with.

Download Now

Only licensed members can download files, Click Here for more information.

Addons

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Forum Style Lightweight Style for Small Screen Devices (cell phone, iphone, mobile, android) dartho vBulletin 4.x Styles 1147 26 Feb 2020 21:00
Add-On Releases Extend and Customise "Mobile" Style Options dartho vBulletin 3.7 Add-ons 193 09 Jun 2010 16:03
Add-On Releases Fast and Lightweight AJAX Musicbox for vBulletin 3.6.x silveryhat vBulletin 3.6 Add-ons 19 05 Dec 2009 05:52

  #121  
Old 18 May 2011, 11:14
dartho dartho is offline
 
Join Date: Sep 2005
Chances are when you installed (or when you first attemnpted to uninstall) this you had a timeout or errors which caused the tables to not be created, and now when trying to drop teh tables it can't as they aren't there.

What you can do is go into the product manager and edit this product and delete teh contents of teh Uninstall Code. Then when you uninstall it will remove everything except the database columns which aren't actually there anyway.
Reply With Quote
  #122  
Old 18 May 2011, 12:15
charlesr charlesr is offline
 
Join Date: Aug 2009
Great. All sorted. Much appreciated.
Reply With Quote
  #123  
Old 12 Jun 2011, 19:44
Filgga's Avatar
Filgga Filgga is offline
 
Join Date: Jul 2007
Sad,

This' causing database errors on vB 4.1.4

Had to disable
__________________
I'm back, hell was full

Last edited by Filgga; 14 Jun 2011 at 00:17.
Reply With Quote
  #124  
Old 13 Jun 2011, 00:32
dartho dartho is offline
 
Join Date: Sep 2005
Sad, people report errors but provide no further information which may help to resolve them.

Don't forget to click the "Mark as Uninstalled" link
Reply With Quote
  #125  
Old 13 Jun 2011, 22:01
Filgga's Avatar
Filgga Filgga is offline
 
Join Date: Jul 2007
Originally Posted by dartho View Post
Sad, people report errors but provide no further information which may help to resolve them.

Don't forget to click the "Mark as Uninstalled" link
This made my day...

It's like this:

Users cannot swicth to the PC version of the site. Tried all efforts but in vain.

I did not UnInstall, simply disabled, waiting for ur input. I meant, disabled in my previous msg.

I sent you a PM, please see what you can do. I doubt it's only me.
__________________
I'm back, hell was full

Last edited by Filgga; 14 Jun 2011 at 00:16.
Reply With Quote
  #126  
Old 14 Jun 2011, 00:11
dartho dartho is offline
 
Join Date: Sep 2005
Thanks for the PM, Filgga - but you still haven't told me anything! I need error messages at least to find out where you are having a problem. What is the full database error message?
Reply With Quote
  #127  
Old 14 Jun 2011, 00:22
Filgga's Avatar
Filgga Filgga is offline
 
Join Date: Jul 2007
Originally Posted by dartho View Post
Thanks for the PM, Filgga - but you still haven't told me anything! I need error messages at least to find out where you are having a problem. What is the full database error message?
The database error was being caused by this:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

as the new vB 4.1.4 tells me do not recognize 'UA' field in MySQL (sorry I did not copy the error).

I enabled the mod, disabled only that, the errors are gone (i did an edit above).

Still, users cannot switch between themes (to default theme).

U can visit my site (on my signature) via mobile and then via PC and see the difference.

This' after upgrading to vB 4.1.4; everything was OK before upgrading.

Looks like you're now upgrading http://vbdev.org/forum.php please test this and you'll see what we're facing
__________________
I'm back, hell was full

Last edited by Filgga; 14 Jun 2011 at 00:31.
Reply With Quote
  #128  
Old 14 Jun 2011, 02:39
dartho dartho is offline
 
Join Date: Sep 2005
I upgraded to 4.1.4 on my test site and I get no errors and also have no issues switching styles.
Reply With Quote
  #129  
Old 01 Jul 2011, 02:37
cnrr cnrr is offline
 
Join Date: Feb 2011
how can i disable share browser details from guests? (via mobile text's descripton)
Attached Images
File Type: png viamobil.png (24.4 KB, 17 views)
Reply With Quote
  #130  
Old 01 Jul 2011, 02:58
dartho dartho is offline
 
Join Date: Sep 2005
Edit the posted_by_mobile_device template and change the title in the anchor to something other than {vb:raw post_ua}
Reply With Quote
  #131  
Old 01 Jul 2011, 03:01
dartho dartho is offline
 
Join Date: Sep 2005
Sorry - saw you only want to do this for guests.

Change
{vb:raw post_ua}
to
<vb:if condition="$show['member']">{vb:raw post_ua}</vb:if>

in that same template and then there will be no tool tip for guests
Reply With Quote
  #132  
Old 03 Jul 2011, 08:56
thenashy thenashy is offline
 
Join Date: Jun 2011
I have installed this, and have it all working. However, when viewing the mobile theme, when users click "Desktop" to go back to the default style, there is no style n umber displayed.

How does this noob fix that?
Reply With Quote
  #133  
Old 11 Jul 2011, 19:42
cnrr cnrr is offline
 
Join Date: Feb 2011
Originally Posted by dartho View Post
Sorry - saw you only want to do this for guests.

Change
{vb:raw post_ua}
to
<vb:if condition="$show['member']">{vb:raw post_ua}</vb:if>

in that same template and then there will be no tool tip for guests
thank you dartho for code. i'm setting for only administrator.

<vb:if condition="$bbuserinfo[usergroupid] == 6">{vb:raw post_ua}</vb:if>
Reply With Quote
  #134  
Old 13 Jul 2011, 16:23
Shevko's Avatar
Shevko Shevko is offline
 
Join Date: Sep 2007
Real name: Seyfi D.
Hi i use vb 4.1.4 and this theme.. there is a problem.. when opera mini users use your theme, theme auto change to default theme.. and this always to be.. what can i do?
Reply With Quote
  #135  
Old 16 Jul 2011, 12:04
Taurus1's Avatar
Taurus1 Taurus1 is offline
 
Join Date: Dec 2009
When I choose not to show the "What's going on" section it still shows though. Any ideas on that? Thank you very much!
__________________
For custom designed Windows 7 Visual Styles/Themes, please visit CreativX!
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 04:34.

Layout Options | Width: Wide Color: