Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
DownloadsII Details »
DownloadsII
Mod Version: 5.1.2, by RS_Jelle (Coder) RS_Jelle is offline
Developer Last Online: May 2016 I like it Show Printable Version Email this Page

vB Version: 3.8.x Rating: (208 votes - 4.80 average) Installs: 2108
Released: 02 Jul 2006 Last Update: 25 Apr 2010 Downloads: 16070
Not Supported DB Changes Uses Plugins Auto-Template Additional Files  

There's a vB4 version of this mod available: http://www.vbulletin.org/forum/showthread.php?t=231427

DownloadsII

DownloadsII is a download database that integrates into vBulletin. It allows you to upload files, add images to them, create categories, link to external files - and more. It is very flexible and has many options.

Because a lot of people keep on asking this:
This mod works with any version of vBulletin 3.7.x and 3.8.x!

It's also coded 100% XHTML 1.0 Transitional valid, just like vBulletin itself.



Instructions & Support

You can find an installation manual in the zip package (Readme-Install.txt).

We try to answer most questions asked in this thread. Please don't send any pm's if we don't ask for them, as we said we try to give a high level of support in this thread. Don't forget to click the install link, so you will receive important update notifications.

Screenshots & Live demo

At the bottom of this post, you can find 6 screenshots of the front-end and back-end (AdminCP part) of the DownloadsII software. You can see the newest version in action at the Minatica.be Downloads (Dutch).

Changelog (version 5.1.2)

Jelle
  • Backported CSRF security fix from the vB 4 release
  • Added permission check for Update Counters
  • Fixed PHP warnings when running PHP 5.3
  • Removed the imagecreatefrombmp() function. It doesn't exist.
  • Added permission check for rating submissions
You can find all the changelogs of this and older versions here.

Help!!! I can't upload large files??

This is probably the second most asked question. Have a look at this post for the solution.

It doesn't work with GARS?!

If you also use the latest version of GARS, you will get the "Fields marked in RED must be filled in!" error when uploading a file. I provided a fix here on the GARS forums.

Addons

We are offering 3 addons for this mod at the moment (have a look at the bottom of this post for them). DownloadsII contains 5 hook locations for the vBulletin plugin systems, so you can add extra functionality without file edits.

Do you want to help expanding DownloadsII (if you are a coder)? Check out this post!

Notes
  • ecDownloads Buddy is NOT compatible with this version. If you are using the Buddy, you should UNINSTALL it before installing DownloadsII ver 5.x.x. The Buddy's features are now integrated into DownloadsII.
  • DownloadsII is a direct derivative work from Ron1n's ecDownloads.

Download Now

Only licensed members can download files, Click Here for more information.

Addons

Supporters / CoAuthors

Screenshots

Click image for larger version

Name:	ecDownloadsII-5.0.1-add-file.gif
Views:	14209
Size:	97.8 KB
ID:	51206   Click image for larger version

Name:	ecDownloadsII-5.0.1-admin-edit-category.gif
Views:	9174
Size:	18.7 KB
ID:	51207   Click image for larger version

Name:	ecDownloadsII-5.0.1-admin-navigation.gif
Views:	5171
Size:	4.6 KB
ID:	51208   Click image for larger version

Name:	ecDownloadsII-5.0.1-category.gif
Views:	18848
Size:	86.8 KB
ID:	51209  

Click image for larger version

Name:	ecDownloadsII-5.0.1-file.gif
Views:	30714
Size:	108.2 KB
ID:	51210   Click image for larger version

Name:	ecDownloadsII-5.0.1-main.gif
Views:	14749
Size:	64.3 KB
ID:	51211  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Add-On Releases DownloadsII ver 5.0 vbAdvanced Add-On CyberRanger vBulletin 3.6 Add-ons 159 01 Jul 2011 18:15

  #4141  
Old 25 Apr 2010, 17:22
KenDude KenDude is offline
 
Join Date: Jul 2006
Originally Posted by RS_Jelle View Post
DownloadsII 5.1.2 is an immediate security release fixing a severe CSRF security issue. Abusing this issue can lead to the unwanted removal of files, images and comments. So I recommend to update your site as soon as possible.

Next to that some other issues were fixed like PHP warnings when you are running PHP 5.3.

DownloadsII 5.1.2 Changelog

Jelle
  • Backported CSRF security fix from the vB 4 release
  • Added permission check for Update Counters
  • Fixed PHP warnings when running PHP 5.3
  • Removed the imagecreatefrombmp() function. It doesn't exist.
  • Added permission check for rating submissions
I'm assuming that on 3.8.x this still works fine with Downloads II Create Thread and Downloads II Upload Rules add-ons?
Reply With Quote
  #4142  
Old 25 Apr 2010, 17:36
Megatr0n Megatr0n is offline
 
Join Date: Jul 2007
Jelle, can you confirm which files we have to upload or is it all?

I've made some changes to the hack that's why by editing some of the files.
Reply With Quote
  #4143  
Old 25 Apr 2010, 19:42
RS_Jelle's Avatar
RS_Jelle RS_Jelle is offline
 
Join Date: Jul 2005
Originally Posted by KenDude View Post
I'm assuming that on 3.8.x this still works fine with Downloads II Create Thread and Downloads II Upload Rules add-ons?
Normally they should. Though the rules add-on isn't an official one.

Originally Posted by Megatr0n View Post
Jelle, can you confirm which files we have to upload or is it all?

I've made some changes to the hack that's why by editing some of the files.
Search for "actionhash" in downloads.php and the product XML for the CSRF changes, which are the biggest deal. I suggest you to use a diff compare tool (like WinMerge), so you can compare the code of both versions easily.
__________________
Now released: DownloadsII 6.0.9 (for vB 4.x) and 5.1.2 (for vB 3.7.x and 3.8.x)
Minatica.be - Belgian/Dutch computer and technology site
Reply With Quote
  #4144  
Old 25 Apr 2010, 23:42
dr.tawy dr.tawy is offline
 
Join Date: Feb 2010
is there any way to override server side parameters with the stupid rule of maximum 2mb

i tried several times to edit .htaccess

i even talked to the hosting company said" we are offering hosting services not file uploading one so rules are not to be changed"

Any help ?
Reply With Quote
  #4145  
Old 26 Apr 2010, 00:02
Black Tiger's Avatar
Black Tiger Black Tiger is offline
 
Join Date: Apr 2004
Maybe you should search this tread a bit next time. This question and kindlike already passed numerous times. A mistake that newbies often make. But people don't like to answer the same thing over and over again.

If it does not work with a .htaccess file, try it with a php.ini file with the correct settings in your public_html directory.
If that does not work, you have to ask your hoster and it seems your hoster does not want to cooperate, in that case it's end of story, or change hosting company ofcourse.
__________________
Greetings, Black Tiger
Reply With Quote
  #4146  
Old 26 Apr 2010, 01:29
brettxw brettxw is offline
 
Join Date: Feb 2009
If we are upgrading and I upload the new files, will I lose all my settings for my current download section? And have to re add everything?
Reply With Quote
  #4147  
Old 26 Apr 2010, 03:35
Nadeemjp Nadeemjp is offline
 
Join Date: Aug 2008
Real name: Nadeem Qadir
hello RS
as soon as i upgraded, the following error is occurring:

Warning: fetch_template() calls should be replaced by the vB_Template class. Template name: downloads_navbar_button in [path]/includes/functions.php on line 3957

any cluie how to remove it?
__________________
Family Bunker
Reply With Quote
  #4148  
Old 26 Apr 2010, 11:35
Black Tiger's Avatar
Black Tiger Black Tiger is offline
 
Join Date: Apr 2004
@brettxw: No ofcourse not, assuming you wil do the right procedure when uploading.
Upload all files to their correct contents, overwriting the old ones.
The import the product and set "overwrite" to "yes". Then all will be upgraded fine and your settings will not be changed.
__________________
Greetings, Black Tiger
Reply With Quote
  #4149  
Old 26 Apr 2010, 12:54
dr.tawy dr.tawy is offline
 
Join Date: Feb 2010
Originally Posted by Black Tiger View Post
Maybe you should search this tread a bit next time. This question and kindlike already passed numerous times. A mistake that newbies often make. But people don't like to answer the same thing over and over again.

If it does not work with a .htaccess file, try it with a php.ini file with the correct settings in your public_html directory.
If that does not work, you have to ask your hoster and it seems your hoster does not want to cooperate, in that case it's end of story, or change hosting company ofcourse.

and maybe you should actually read my post next time

if you have read it you would have understood that i already did all of these options even talked to the hosting company
Reply With Quote
  #4150  
Old 26 Apr 2010, 20:57
Black Tiger's Avatar
Black Tiger Black Tiger is offline
 
Join Date: Apr 2004
and maybe you should actually read my post next time
Maybe you should actually read your own post again. You did not mention you already searched this thread. And if you did, you should have found the answer because it is in there several times.

Don't be annoyed, but try to learn (also about what the meaning of smileys is). If I wanted to make a snear at you, I would not have also answered your question like I did.
__________________
Greetings, Black Tiger
Reply With Quote
  #4151  
Old 26 Apr 2010, 21:48
Black Tiger's Avatar
Black Tiger Black Tiger is offline
 
Join Date: Apr 2004
Originally Posted by dr.tawy
are you following ?
I am, but you aren't. I answered your question already in my first reply.
__________________
Greetings, Black Tiger
Reply With Quote
  #4152  
Old 27 Apr 2010, 09:02
Nadeemjp Nadeemjp is offline
 
Join Date: Aug 2008
Real name: Nadeem Qadir
Originally Posted by Nadeemjp View Post
hello RS
as soon as i upgraded, the following error is occurring:

Warning: fetch_template() calls should be replaced by the vB_Template class. Template name: downloads_navbar_button in [path]/includes/functions.php on line 3957

any cluie how to remove it?
actually, how stupid of me, i accidentally installed this version parallel to my vb4 version. now my site and admincp access is denied:d
i am sorry for this clumsyness, but could someone help me out please?
__________________
Family Bunker
Reply With Quote
  #4153  
Old 27 Apr 2010, 09:35
WEBDosser's Avatar
WEBDosser WEBDosser is offline
 
Join Date: Oct 2001
disable the plugin system
Reply With Quote
  #4154  
Old 28 Apr 2010, 05:26
Nadeemjp Nadeemjp is offline
 
Join Date: Aug 2008
Real name: Nadeem Qadir
thanks, yeah i did that and the problem is solved
__________________
Family Bunker
Reply With Quote
  #4155  
Old 28 Apr 2010, 18:06
TheInsaneManiac TheInsaneManiac is offline
 
Join Date: Feb 2008
Why does it always say:
Downloads: 4294967295

I don't have that many downloads.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 03:36.

Layout Options | Width: Wide Color: