Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
NNTP Gateway (Usenet/Newsgroups) Details »
NNTP Gateway (Usenet/Newsgroups)
Mod Version: 1.00, by Gilby (Member) Gilby is offline
Developer Last Online: Apr 2013 I like it Show Printable Version Email this Page

This modification is in the archives.
vB Version: 2.2.x Rating: (4 votes - 4.75 average) Installs: 71
Released: 20 Feb 2002 Last Update: Never Downloads: 18
Not Supported  

This hack provides a gateway to any NNTP newsgroup such as those from Usenet and other newsgroup servers. Selected newsgroups are imported from your news server and post on the forum are sent out to the newsgroup. This hack was greatly inspired by fastforward's usenet gateway hack. This one is a complete rewrite of that hack written in PHP and works with vB 2.2.2.

Installation:
Installation is pretty simple. No modifications to the vB php files are needed and it simply consists of dropping in the files to your forums directory, running the SQL modifications, and modifying the newsgroup settings for your desired newsgroups. For the complete installation details, read the readme.txt file.

Here are some of the features:
  • Real cool vbcode to text conversion!
  • All posts are inserted, even if parent thread cannot be found for replies
  • Guests posts also get sent to the newsgroup.
  • Importing of attachments from the newsgroup
  • Poll info sent to newsgroup
  • Attachment link sent to newsgroup
  • Supports unlimited newsgroups and servers.
  • email notification of new replies, just like regular forum posts
  • Can import HTML messages and convert to limited vb code.

For control panel integration, please check out GameCrash's Graphical Interface addition.

What's not in it that was in fastforward's usenet gateway hack:
  • No control panel integration at the moment. (Available separately)
  • Does not support separate footers
  • Does not allow custom email address to be used via the users option
  • No spam control or string replacement support.
  • No purging or autoexpire.

There is still lots that I'd like to add to it, but this is competely functional for basic newsgroup gateway support. It is most likely not free of bugs. If you have questions, suggestions or annoyances, please post in this thread.

vb3 support
lierduh modified this to provide support for the beta versions of vb3. When the release candidates of vb3 come out, I plan to add support for vb3 and add other features to this hack. If you have suggestions for new features, let me know.

E-mail gateway support
New in this version, you can now gateway with an email list. This will fetch emails from a POP email account and send via php's mail function to the mailing list's email address. To set up the list, in the newsgroup field, enter in the email address to send outgoing posts to. In the server field, enter in the pop3 server, and in the username and password fields enter in, you guessed it, the username and password to your pop account. Note: the email gateway capabilities has not been fully tested, so it might not work with your POP server. Also, it does not work in combo with a news<->forum gateway in the same forum (you can use either kind though in differnet forums within your forums).

Download Now

Only licensed members can download files, Click Here for more information.

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
NNTP Gateway for Usenet ( Newsgroups ), Mailing Lists lierduh vBulletin 3.5 Add-ons 734 04 Feb 2013 06:06
NNTP Gateway for Usenet ( Newsgroups ), Mailing Lists lierduh vBulletin 3.0 Full Releases 1005 04 Nov 2008 19:09

  #136  
Old 27 Feb 2002, 12:59
Gilby Gilby is offline
 
Join Date: Nov 2001
Originally posted by lifesourcerec
Ok. And one more thing. How do I get the posts to show up in a forum? I used different forumid numbers and nothing showed up. But it did list everything in stats (total posts, top poster, etc.). How do you determine the forum if you have sub-forums?
Just go into the forum you want to use for the newsgroup and in the URL, it'll have something like "forumid=3" and this corresponds to forum 3, so put 3 in the forumid column in the database.
Reply With Quote
  #137  
Old 27 Feb 2002, 13:35
ART's Avatar
ART ART is offline
 
Join Date: Feb 2002
thanx Gilby for the work!
all went smooth
__________________
What's brewing in Poland? Find out on Browar.biz (in Polish)
Reply With Quote
  #138  
Old 27 Feb 2002, 14:07
The Realist's Avatar
The Realist The Realist is offline
 
Join Date: Oct 2001
Real name: Brian
On running the gateway file the following eror is showing, any clues to solving this:

1 group(s) gatewayed.
Could not connect to NNTP-serverLogging in to news.demon.net, group alt.binaries.satellite-tv,alt.dss
Not connectedNot connected
Reply With Quote
  #139  
Old 27 Feb 2002, 15:04
annams annams is offline
 
Join Date: Dec 2001
Originally posted by Gilby


Whereever you find:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Replace it with:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

I'll have that change in the next release.
Thanks for the help. That fixed it.

I have one more minor issue:

I have posted few test messages to the test newsgroup at webdiscuss. My message got transmitted properly, but I see the following lines below my actual message:

===
--
Srinivas Annam - Moderator

'$2' ($1)
===

What is the $2 and $1? Is it somehow trying to put my signature on to the usenet? If so, how do I disable it?

Also, transmitting Moderator to the USENET newsgroup is not a good idea in my opinion.

I appreciate very much for this hack!

- Srinivas
Reply With Quote
  #140  
Old 27 Feb 2002, 15:33
annams annams is offline
 
Join Date: Dec 2001
I have done a bit more testing. Looks like it is not the signatures which is the problem (since quotes is also giving the same issue). It appears like another issue with older PHP.

Could you please take a look at this thread and offer me a fix please:

http://www.unicyclist.com/forums/sho...threadid=16654

PS: Thank you for putting up with my old version of php. I don't have much choice in the PHP version, my ISP (pair.com) does not easily upgrade it. (they go through rigorous evaluation/testing process before upgrading).
Reply With Quote
  #141  
Old 27 Feb 2002, 21:39
Gilby Gilby is offline
 
Join Date: Nov 2001
Originally posted by The Realist
On running the gateway file the following eror is showing, any clues to solving this:

1 group(s) gatewayed.
Could not connect to NNTP-serverLogging in to news.demon.net, group alt.binaries.satellite-tv,alt.dss
Not connectedNot connected
The server is probably non-existent. Make sure you have the settings in the database correct for that server.
Reply With Quote
  #142  
Old 27 Feb 2002, 22:02
Gilby Gilby is offline
 
Join Date: Nov 2001
Originally posted by annams
What is the $2 and $1? Is it somehow trying to put my signature on to the usenet? If so, how do I disable it?
It's the use of the preg_replace function that is not compatible with older version of php. The newer versions support using $1 for the first match, but in older version, it uses \\1 for the same thing. Newer versions of course are backwards compatible, so I have changed it to the old way so it works for everyone. Try out the gateway.php I attached and let me know if that works for you. If it does, I'll release this version.


Also, transmitting Moderator to the USENET newsgroup is not a good idea in my opinion.
That's just the 'title' that is being put in the signature. If there is no custom title, it is not put in there. Does vB use the cutom title field to define "moderator"? If it does, I suppose I'll make it an otpion to disable that in a future release.
Attached Files
File Type: php gateway.php (21.2 KB, 18 views)
Reply With Quote
  #143  
Old 28 Feb 2002, 01:59
annams annams is offline
 
Join Date: Dec 2001
Originally posted by Gilby


That's just the 'title' that is being put in the signature. If there is no custom title, it is not put in there. Does vB use the cutom title field to define "moderator"? If it does, I suppose I'll make it an otpion to disable that in a future release.
Gateway.php works great, thank you!

I have the control panel and the database the title moderator is not part of custom titles. Moderator is defined is stored under usertitle field in usergroup table. I would really appreciate if that can be removed (or atleast as an option).

Btw, Tinyurl is a great idea!

Once again thanks for this hack, this is like dream come true!!!
Reply With Quote
  #144  
Old 28 Feb 2002, 02:49
Gilby Gilby is offline
 
Join Date: Nov 2001
Originally posted by annams
I have the control panel and the database the title moderator is not part of custom titles. Moderator is defined is stored under usertitle field in usergroup table. I would really appreciate if that can be removed (or atleast as an option).
I just tried it out on my test forums and when i made a moderator, it changed the usertitle, but left the customtitle set to 0. The user title is only output in the signature if the customtitle is set to 1, as is most likely the case for you. If you set customtitle to 0, then everything should be normal for you.
Reply With Quote
  #145  
Old 28 Feb 2002, 13:43
annams annams is offline
 
Join Date: Dec 2001
Originally posted by Gilby


I just tried it out on my test forums and when i made a moderator, it changed the usertitle, but left the customtitle set to 0. The user title is only output in the signature if the customtitle is set to 1, as is most likely the case for you. If you set customtitle to 0, then everything should be normal for you.
Oops, my mistake! I somehow had customtitle set for my user id. Thanks.
Reply With Quote
  #146  
Old 01 Mar 2002, 09:07
saab340 saab340 is offline
 
Join Date: Dec 2001
Works

I finally got it working

My database grew from 13 megs to 300 megs.

Now is there a command, I can run, to reduce that.

Most of the posts has replies in it. ie

>>
>>>
>>>
>>

So if I want to remove lines like those,...

what is the command to do so?

Thanks
Reply With Quote
  #147  
Old 01 Mar 2002, 14:02
mood mood is offline
 
Join Date: Feb 2002
Hi All!

Just tried the gateway on my test forum and mySQL reports:
--------
Database error in vBulletin 2.2.2:

Invalid SQL: UPDATE forum SET replycount=replycount+1,threadcount=threadcount+1,lastpost='1014616161',lastpost er='john' WHERE forumid IN ()
mysql error: You have an error in your SQL syntax near ')' at line 1

mysql error number: 1064
-------

any ideas?

Mood
Reply With Quote
  #148  
Old 01 Mar 2002, 14:17
mood mood is offline
 
Join Date: Feb 2002
Found my problem.

my test forum is forum ID 3 in the control VB panel yet if I point the URL to forum 3 I get nothing. The test forum showss up with ID 7.
Why ? Pls point me how I can set the forum IDs to the right number...

Thanks
Mood
Reply With Quote
  #149  
Old 01 Mar 2002, 17:32
lifesourcerec's Avatar
lifesourcerec lifesourcerec is offline
 
Join Date: Jan 2002
I have a minor problem

I get this:

6 group(s) gatewayed.
Logging in to news.tn.comcast.giganews.com, group rec.collecting.cards.discuss
Logging in to news.tn.comcast.giganews.com, group rec.collecting.sport.baseball
Logging in to news.tn.comcast.giganews.com, group rec.collecting.sport.basketball
Logging in to news.tn.comcast.giganews.com, group rec.collecting.sport.football
Logging in to news.tn.comcast.giganews.com, group rec.collecting.sport.hockey

No errors, but it's not getting the messages from them.
Reply With Quote
  #150  
Old 01 Mar 2002, 19:37
lifesourcerec's Avatar
lifesourcerec lifesourcerec is offline
 
Join Date: Jan 2002
Originally posted by Gilby
I just uploaded a new version. Same functionality, but it should eliminate most the errors people have had. You can find that in the first post in this thread.

If you've already installed the hack, make sure you run the SQL a few posts back as that will make a huge difference for when your tables get filled with a lot of posts. In one case it brought the query speed from around 30 seconds to a fraction of a second.

If you want a gauge of how long things are taking, you can rin the script like: http://www.yourserver.com/gateway.php?showqueries=1 and it'll print out all the SQL queries as well as the start and finish time of the queries.
After running that, I only get 1 error:

Warning: Cannot add header information - headers already sent by (output started at /forums/global.php:120) in /forums/gateway.php on line 428

6 group(s) gatewayed.
Logging in to news.tn.comcast.giganews.com, group rec.collecting.cards.discuss
Query: SELECT post.postid,post.username,post.userid,post.dateline,post.attachmentid,post.paget ext,post.showsignature,post.ipaddress,thread.pollid,thread.title,post.threadid,t hread.forumid FROM thread,post WHERE post.isusenetpost=0 AND thread.threadid=post.threadid AND post.dateline=thread.dateline AND post.userid=thread.postuserid AND (thread.forumid=26)
Time before: 0.45870900154114
Time after: 0.45999503135681
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 21:49.

Layout Options | Width: Wide Color: