Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
NNTP Gateway for Usenet ( Newsgroups ), Mailing Lists Details »
NNTP Gateway for Usenet ( Newsgroups ), Mailing Lists
Mod Version: 2.3.2, by lierduh (Member) lierduh is offline
Developer Last Online: Jul 2012 I like it Show Printable Version Email this Page

This modification is in the archives.
vB Version: 3.0.5 Rating: (10 votes - 4.80 average) Installs: 186
Released: 15 May 2004 Last Update: 28 Feb 2005 Downloads: 268
Not Supported DB Changes  

The latest version: V2.3.2 (31 Oct 2004)

What is it?

This hack provides a gateway from vBulletin forums to the USENET. It allows forum members to read newsgroup messages as well as to send posts to the newsgroups. In a nutshell, it turns vBulletin forums into a basic function news reader.

For an added bonus, this package also supports mailing list archive and forum to mailing list gateway. The software retrieves messages from a pop3 account and import them into the forums threaded. It also allows a forums user to send messages to the mailing list by the forum posting interface.

Why?

The gateway will be appreciated by forum members who do not know how to set up a news reader, or people who do not have port 119 open in their network. A forum interface to read and post news are often considered to be better than a news reader.

The gateway adds more contents to your forums and allows the members to interact with wider audience. It is common to see new users signing up to use this feature.

History

This hack is basically a hacked vB2 NNTP gateway written by Gilby to work with vB3. The original hack can be found here:

http://www.vbulletin.org/forum/showt...7&page=1&pp=15


Features

Some of the features and improvement include:
  • Handles both newsgroup posts and mailing lists.
  • Handles MIME encoded messages and attachment.
  • Handles UUEncoded messages.
  • Two Admin Control Panels for all settings.
  • Automated installation.
  • Correct thread implementation. All imported messages and posts sent to newsgroups will be threaded correctly according to References and Message-ID headers.
  • Optional setting to thread by subject for mailing lists that strip references header.
  • Supports TABLE_PREFIX.
  • Imported messages will be searchable just like normal forum posts.
  • Similar threads are built when the messages are imported if the system setting is on.
  • Multiple attachments importing.
  • Save attachment to database or file according to vB setting.
  • Thumbnail created while importing image files.
  • Multiple attachment post to newsgroup is also supported.
  • Selectable X-No-Archive header honouring system.
  • Light on system resources.
  • Global Killfile to filter out unwanted messages. Killfiles can have OR and AND effectiveness.
  • Strip footer by setting for incoming messages. Strips out repeated message footers.
  • Built options to disable signatures and footers for out going messages.

Future development
  • AdminCP interfaces. (completed)
  • Installation/upgrade script. (completed, coded into AdminCP)
  • Traditional "> " lead posting interface.

What do you need and do not need?

You do not need to edit vB php files if you use two bookmarks
You need to edit one vB php file to insert two lines of code if you want direct click links within AdminCP.
No need to run SQL.

Installation

Basically the AdminCP interfaces take care of installation as well as upgrade in the background. Back up your database first. The scripts can modify your database without alerting you!

Please follow the instructions in the readme.txt file for more details.

Support

Please post your support questions to this thread. Please check the FAQ in the third post within this thread first.

================== UPDATES ======================
Jul 31 2004 (release version 2.2.0)
  • Provided option of not importing attachments
  • Provided option of pause between messages
  • Provided option of not sending messages to USENET
  • Provided mechanism to skip importing a message if it was crashed on it
  • Provided "Default Footer" option
  • Provided strip_footer function for mailing lists
    (written originally by KevinM)
  • Provided Killfile functions with Header/Body/AND/OR settings
  • Provided ability to thread messages by subject for mailing lists
  • Provided ability to use a single POP3 account for different mailing lists
    (use prefix)
  • Merged KevinM's attachment routine, save thumbnail to hard drive
    as vB3.0.3
  • Official support to have the script run by Scheduled Tasks
  • Many bug fixes

Please note, when you manually run the script, you must turn on the debug mode. Otherwise nothing will be displayed on the screen.

To run as debug mode: http://forums.yourdomain.com/gateway.php?debug=1

25 Oct 2004
  • Provided the option of sending posts using the real email address
  • Provided the option of sending posts using a fixed email address for
    each group.
  • Posts are now held back if they are in the moderating queue
  • Scheduled task log is now working
  • Provided the option of sending the debug messages to the vB3 cron log
  • Bug fixes

31 Oct 2004

Fixed bugs running the gateway by the vB3 Scheduled Tasks

1 March 2004

Uploaded the new zip file. It contains one or two bug fixes.

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	nntp_groups1.jpg
Views:	1826
Size:	34.3 KB
ID:	18668   Click image for larger version

Name:	nntp_settings.jpg
Views:	1414
Size:	65.7 KB
ID:	18674   Click image for larger version

Name:	nntp_settings1.jpg
Views:	1151
Size:	48.6 KB
ID:	18675   Click image for larger version

Name:	nntp_groups.jpg
Views:	1814
Size:	53.2 KB
ID:	18680  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
NNTP Gateway for Usenet ( Newsgroups ), Mailing Lists lierduh vBulletin 3.5 Add-ons 734 04 Feb 2013 06:06
NNTP Gateway (Usenet/Newsgroups) Gilby vBulletin 2.x Full Releases 987 16 Jul 2005 00:01

  #751  
Old 23 Jan 2005, 22:01
cyc cyc is offline
 
Join Date: Nov 2002
Hi

I have noticed if we get the error "Could not connect to NNTP-server" the script still tries to post to the newsgroup. Would it be possible to edit the script so it doesnt try to post if it doesnt get a successful connection to the news server?

cheers
Reply With Quote
  #752  
Old 24 Jan 2005, 16:46
Izze_de Izze_de is offline
 
Join Date: Jan 2005
hi,

i have the problem that i set up one newsgroup in one forum for testing.

it works fine now it dont stop importing the news.
first i set the newgroup to inactive.
then i deleted the group.
then i delted the cronjob in crontab.

nothing works it is still importing like hell.
and it has still the same time. this time is hours ago.
looks like a nevernding poll of the gateway.php because the time didnt change. it is still the time when i started this the first time.

what can i do to stop this ?

thx

EDIT

all right, it seems that i found how to stop it.

i restarted apache2 webserver and now it stopped.

strange... :ermm:

Last edited by Izze_de; 24 Jan 2005 at 17:49.
Reply With Quote
  #753  
Old 24 Jan 2005, 19:05
Izze_de Izze_de is offline
 
Join Date: Jan 2005
Originally Posted by journey
I have the script up and running on a new vB3.03 install. It seems as though when I d/l posts/threads (from usenet) that my overall post/thread count statistics increment at a 2:1 ratio (the main forums view stats to the right of the individual forums seem normal though). ie, if I were to have downloaded 10k posts my overall post stats would read 20k. Why would posts / threads be double counted in the overall stats (but not on the individual stats)?

This happened both when I initially downloaded threads as well as everytime I d/l additonal posts when the cron job runs.

oh yeah, and non-usenet forums that are strictly local do correctly update the overall and forum specific post/thread count at a 1:1 ratio.

irate:
exactly same problem for me.
all newsgroups are counted double.
normal forum threads just once.

and this is a clear, just one testpost, user- and hackfree (except this one) forum.
brand new installed.
Reply With Quote
  #754  
Old 25 Jan 2005, 09:42
Marv Marv is offline
 
Join Date: Jun 2002
excluding usenet-posts from "getnew"

Is there another way to exclude the usenet-posts from getnew instead of changing the getnew-param to

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

? We were informed by some users that they´ve encountered errorscausetheir browsers can´t handle the long version where everysingleforum-id is listed :ermm:

We import about 50 newsgroups in our forums and I would like tohavethem excluded like
Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

but the string"...&exclude=120-140" won´t work. Anyone who couldshow me a quick´ndirty workaround ?

Any help appreciated.

Last edited by Marv; 26 Jan 2005 at 08:41.
Reply With Quote
  #755  
Old 26 Jan 2005, 22:07
ART's Avatar
ART ART is offline
 
Join Date: Feb 2002
I've been using the Usenet gateway on my vb2 forums - last sunday I did an update to vb306 at last. now i wanted to update the gateway hack too - and now I have a question - can I use this hack on existing usenet-forums within my site? Will the new hack recognize the posts and threads that are already stored on my usenet-forums and won't try to resend it to usenet groups?
__________________
What's brewing in Poland? Find out on Browar.biz (in Polish)
Reply With Quote
  #756  
Old 27 Jan 2005, 15:06
Bro_Joey_Gowdy's Avatar
Bro_Joey_Gowdy Bro_Joey_Gowdy is offline
 
Join Date: May 2002
Real name: Joey Paul Gowdy
I was curious as to how many different usenet newsgroup providers there were and how much they cost, so, Ive started a thread in the lounge entitled :

"What "Usenet" newsgroup provider do you use ?"

http://www.vbulletin.org/forum/showthread.php?t=75232

It would have been nice to have seen this question / link in the F.A.Q. post of this thread.
Reply With Quote
  #757  
Old 29 Jan 2005, 12:38
lierduh lierduh is offline
 
Join Date: Jan 2003
Originally Posted by ART
I've been using the Usenet gateway on my vb2 forums - last sunday I did an update to vb306 at last. now i wanted to update the gateway hack too - and now I have a question - can I use this hack on existing usenet-forums within my site? Will the new hack recognize the posts and threads that are already stored on my usenet-forums and won't try to resend it to usenet groups?
You should be able to upgrade from v2 version automatically by opening up the two control panel pages once.

No the posts already exported will not be exported again.
Reply With Quote
  #758  
Old 29 Jan 2005, 12:41
lierduh lierduh is offline
 
Join Date: Jan 2003
Originally Posted by Bro_Joey_Gowdy
I was curious as to how many different usenet newsgroup providers there were and how much they cost, so, Ive started a thread in the lounge entitled :

"What "Usenet" newsgroup provider do you use ?"

http://www.vbulletin.org/forum/showthread.php?t=75232

It would have been nice to have seen this question / link in the F.A.Q. post of this thread.
Will include the link in the FAQ post. Perhaps you need to make it more clear about the usage of newsgroup provider, ie. using it with a forum gateway and link back to this thread. So that people know it is not just for private access.
Reply With Quote
  #759  
Old 29 Jan 2005, 12:51
lierduh lierduh is offline
 
Join Date: Jan 2003
If you have many newsgroup forums. You can put all your local forums under one main forum. Then you can use the main forum id in the URL just as we have done for the NNTP forums.

/search.php?do=getnew&forumid=1
(1 is the main forum id for all your local forums)

Originally Posted by Marv
Is there another way to exclude the usenet-posts from getnew instead of changing the getnew-param to

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

? We were informed by some users that they´ve encountered errorscausetheir browsers can´t handle the long version where everysingleforum-id is listed :ermm:

We import about 50 newsgroups in our forums and I would like tohavethem excluded like
Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

but the string"...&exclude=120-140" won´t work. Anyone who couldshow me a quick´ndirty workaround ?

Any help appreciated.
Reply With Quote
  #760  
Old 05 Feb 2005, 09:40
infiniterb infiniterb is offline
 
Join Date: Apr 2003
lierduh,

I'm still having my issue that I posted above. I can get posts to show up on my forums, and I can successfully post. I am using the Scheduled Tasks in vb and it works fine. However, all is working fine for only the first forum in the list. I'm currently using the following groups in this order:

24hoursupport.helpdesk
alt.privacy.spyware
microsoft.public.security
microsoft.public.windows.inetexplorer.ie6.browser
microsoft.public.windowsxp.basics
microsoft.public.windowsxp.general
microsoft.public.windowsxp.help_and_support
microsoft.public.windowsxp.security_admin

All groups are enabled, and are using a personal newshosting.com account I have set up with posting access. When gateway.php runs via the scheduled tasks, it hits the first group on the list, and updates it with the new posts from the NG. I have gateway.php set to hit the groups listed above every 15 min (I've played with different times, and nothing seems to work).

Any idea why only the first group in my list will update? I've even set the first group to disabled, which allows the 2nd group to update just fine and allow posting, however the 3rd group on down are not updated. It'd be a real pain to have to enable/disable groups manually.
Reply With Quote
  #761  
Old 05 Feb 2005, 22:35
lierduh lierduh is offline
 
Join Date: Jan 2003
Have you ruled out the server only lets you access one group at a time?



Originally Posted by infiniterb
lierduh,

I'm still having my issue that I posted above. I can get posts to show up on my forums, and I can successfully post. I am using the Scheduled Tasks in vb and it works fine. However, all is working fine for only the first forum in the list. I'm currently using the following groups in this order:

24hoursupport.helpdesk
alt.privacy.spyware
microsoft.public.security
microsoft.public.windows.inetexplorer.ie6.browser
microsoft.public.windowsxp.basics
microsoft.public.windowsxp.general
microsoft.public.windowsxp.help_and_support
microsoft.public.windowsxp.security_admin

All groups are enabled, and are using a personal newshosting.com account I have set up with posting access. When gateway.php runs via the scheduled tasks, it hits the first group on the list, and updates it with the new posts from the NG. I have gateway.php set to hit the groups listed above every 15 min (I've played with different times, and nothing seems to work).

Any idea why only the first group in my list will update? I've even set the first group to disabled, which allows the 2nd group to update just fine and allow posting, however the 3rd group on down are not updated. It'd be a real pain to have to enable/disable groups manually.
Reply With Quote
  #762  
Old 05 Feb 2005, 22:48
infiniterb infiniterb is offline
 
Join Date: Apr 2003
I have not. I was wondering if anyone else had similar issues, or if this were something you had come across.
Reply With Quote
  #763  
Old 06 Feb 2005, 05:05
recumbent615 recumbent615 is offline
 
Join Date: Apr 2002
Great Mod - Love it

I have recently installed this mod on my upgraded VB V3.0.6 . I had been using the same mod on my old VB 2.x install. I use it as a Mailing list gateway and it is much improved over the older VB2 version.

I have noticed that it does not seem to do the right thing when it reads a message that is a reply ( to the mailing list ) to an exsisting thread that does not contain a References header. I had read in some posts that others had seen this issue last year, and I believe that KevinM had a patch. My question is, did that not work? is that why it was not incorproated into the latest released version?

I just did not want to apply a mod to the mod if it does not work?

Thanks for any feed back on this issue.

Kevin B
Reply With Quote
  #764  
Old 06 Feb 2005, 15:47
ART's Avatar
ART ART is offline
 
Join Date: Feb 2002
Originally Posted by lierduh
You should be able to upgrade from v2 version automatically by opening up the two control panel pages once.

No the posts already exported will not be exported again.
Thanks lierduh, in the meantime I did the update - and all went smoothly

and thanks for the work - the new gateway runs perfect for me!
__________________
What's brewing in Poland? Find out on Browar.biz (in Polish)
Reply With Quote
  #765  
Old 08 Feb 2005, 01:23
recumbent615 recumbent615 is offline
 
Join Date: Apr 2002
Originally Posted by recumbent615
I have recently installed this mod on my upgraded VB V3.0.6 . I had been using the same mod on my old VB 2.x install. I use it as a Mailing list gateway and it is much improved over the older VB2 version.

I have noticed that it does not seem to do the right thing when it reads a message that is a reply ( to the mailing list ) to an exsisting thread that does not contain a References header. I had read in some posts that others had seen this issue last year, and I believe that KevinM had a patch. My question is, did that not work? is that why it was not incorproated into the latest released version?

I just did not want to apply a mod to the mod if it does not work?

Thanks for any feed back on this issue.

Kevin B

Here is an example of the problem: See the attached Image Issue.gif

and the headers from the Second line of that Image that did not get threaded correctly


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Note that the Subject is RE: but there is not References Tag in the header. I thought that this hack would first look for the Reference line in the header and if it could not fine one it would then try to match on Subject ( after removing the RE: )

Is it possible that there is a setting that I have missed or need to add to get this MOD to thread both ways ?

Thanks

Kevin
Attached Images
File Type: gif Issue.gif (12.7 KB, 26 views)
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 20:09.

Layout Options | Width: Wide Color: