Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old 14 Mar 2016, 17:35
r5mjh r5mjh is offline
 
Join Date: Dec 2015
problem with albumpictures after upgade to 423

ok all, just about to upgrade our main site to 423, anyways dave (top man) done loads of work all working great btw, but when playing around with a old problem i noticed there was a big issue

whilst upgrading the dev site i found the upgrade was failing alot in the early part of moving the albumpictures from the database see the thread i posted here

https://www.vbulletin.org/forum/showthread.php?t=322090

anyways looks like now loads of the albumpicture are not working, i ran the query that dave supplied to stop the attachments being deleted and did it straight after upgrade, but only just found this issue, is this another 423 bug?? are the pictures in the albumpictures to big so it crashs whilst upgrading, if i could find the set albumpictures i can test but as you know theres a massive load of directorys in attachments

any help is greatly received, would 422 be better??

mick

--------------- Added 14 Mar 2016 at 21:11 ---------------

getting this error while trying to move pictures from db to file system

[Mon Mar 14 20:02:15 2016] [warn] [client 81] mod_fcgid: read data timeout in 45 seconds, referer: http://dev.*****.org/boards/install/upgrade.php
[Mon Mar 14 20:02:15 2016] [error] [client 81] Premature end of script headers: upgrade.php, referer: http://dev.*****.org/boards/install/upgrade.php
Reply With Quote
  #2  
Old 14 Mar 2016, 21:17
squidsk's Avatar
squidsk squidsk is offline
 
Join Date: Nov 2010
That query must be run before upgrading to 4.2.3 or you'll lose attachments. Running it after the upgrade does nothing. The query, if it's the one I'm thinking of from Paul M, prevents attachments being deleted it doesn't restore already deleted attachments.
Reply With Quote
  #3  
Old 15 Mar 2016, 09:57
r5mjh r5mjh is offline
 
Join Date: Dec 2015
this is the server error i get whilst im upgrading its when the upgrade is trying to move the picture in the database step 89 in 4.0.0 alpha 1

its when its moving them to the attachments file system, it keeps stopping and im getting theses server log errors im stuffed if i cant upgrade without the upgrade crashing all the time aand refreshing browser works but pictures are lost even though in the vb upgrade i get no errors
Reply With Quote
  #4  
Old 15 Mar 2016, 13:33
squidsk's Avatar
squidsk squidsk is offline
 
Join Date: Nov 2010
The error your getting is that the action is running into the maximum time allowed for a page to load. You need to increase that in your php.ini and then restart Apache to do the upgrade.
Reply With Quote
  #5  
Old 15 Mar 2016, 14:21
r5mjh r5mjh is offline
 
Join Date: Dec 2015
thanx boss spoke to hosts and thats exactly what they did it seems to be working now ill check back with update

--------------- Added 15 Mar 2016 at 23:07 ---------------

ok seems like the upgrade now works with no errors on log, but ive now got another problem

basically some of the files that were in the pictures table that get moved while upgrading are not displaying on the forum, i ftp searched 1 attachment and it wasnt present

im not sure why im just running all rebuilders would that help??

im at a lose really ive gone through all this hassle and now get this major issue, anyone had the same issue

i really need help to try and find out why there not being displayed

thnx in advance

Last edited by r5mjh; 15 Mar 2016 at 23:40.
Reply With Quote
  #6  
Old 16 Mar 2016, 20:34
r5mjh r5mjh is offline
 
Join Date: Dec 2015
done another upgrade today some albumpictures are missing i moved to file system before in 371 and they worked fine they have disappeared after upgrade im at a lose now

any ideas anyone
Reply With Quote
  #7  
Old 18 Mar 2016, 15:39
r5mjh r5mjh is offline
 
Join Date: Dec 2015
dave has sorted a former upgrade or server moved has caused a corrupted table so he removed 2 lines of code from a file and hey presto

well done dave
Reply With Quote
  #8  
Old 19 Mar 2016, 16:40
Manoel Júnior's Avatar
Manoel Júnior Manoel Júnior is offline
 
Join Date: Feb 2009
Real name: Manoel Júnior
This happened to me, I had more than 3GB photos and lost ALL. So vBulletin is going from bad to worse.
Reply With Quote
  #9  
Old 22 Mar 2016, 23:36
Mark.B Mark.B is offline
 
Join Date: Feb 2004
http://www.vbulletin.org/forum/showt...66#post2567866
__________________
MARK.B (Member of the vB Support Team)
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 04:55.

Layout Options | Width: Wide Color: