Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
8WayRun.Com - Media Library Details »
8WayRun.Com - Media Library
Mod Version: 4.1.7, by Jaxel (Coder) Jaxel is offline
Developer Last Online: Sep 2013 I like it Show Printable Version Email this Page

This modification is currently quarantined.
vB Version: 4.0.x Rating: (131 votes - 4.73 average) Installs: 915
Released: 17 Apr 2010 Last Update: 27 Oct 2010 Downloads: 7899
Not Supported DB Changes Uses Plugins Auto-Template Additional Files Translations External Content  

Don't forget to click INSTALL!
I'm an unemployed computer programmer... if you appreciate the work I have done on this mod, please don't hesitate in offering me a donation by clicking the "Support Developer" link to the right of this text. A donation of $50 or more automatically gives you the right to remove the copyright footer for this modification from a single forum.

This is a new modification, spawning from the old VB 3.x Video Directory modifications.
For all intents and purposes, both my old Video Directory Remixed mod, and Survivor's original Video Directory mod have been discontinued. Neither of us are maintaining these older versions, they will not receive any future updates and we will not be providing any support. This version has a new name because it has been completely rewritten from scratch and is not being built on Survivor's old code. Because of this, if you are upgrading to this new version, from the old version, be sure to read this entire post in order to understand the upgrade process.

What is this mod?
Simply put, this mod is a directory for media. It supports URL inputs, in order to extract meta data and directorize media into a simple and easy to understand library. Users can add their favorite media from a select few online distribution centers (such as Youtube or Vimeo) and categorize and tag them as they see fit. This mod offers rudimentary support for the hosting of local media. An administrator can upload a media to the /customVID/ (default) directory; then add the media to the library using the URL code of "local:filename". Media hosted locally will be displayed using JWPlayer, but will not provide meta data, so that kind of information will need to be entered manually.

Demo:
http://www.8wayrun.com/media.php

Features:
  • Integrated directly into the vBulletin user database and product manager.
  • Fully phrased and built on tempaltes for easy re-skinning and styling.
  • Simple to use administration features and usergroup permission settings.
  • Landing page with the most recent, most popular and highest rated media.
  • Ability to add media into a single category, while adding multiple tags.
  • Ability to browse media through categories, tags, and user contributions.
  • Summary tag cloud with a link to the entire list of tags in the system.
  • Comment and rating system based on AJAX including graceful degredation.
  • Individual RSS Feeds for newest videos, categories, tags and user media.
  • Search function for titles and descriptions.
Installation:
If you are upgrading from before version 1.1, please install that version first.
  1. Upload all the files in the "upload" directory of the attached zip file to your forum root.
  2. CHMOD the /customVID/thumbs/ directory to full read/write/execute 777 permissions.
  3. CHMOD the /customVID/sitemap/ directory to full read/write/execute 777 permissions.
  4. Import the product file called "product-medialibrary.xml" in the Product Manager of vBulletin.
  5. Set your usergroup permissions and media library settings in your administration control panel.
  6. OPTIONAL: Enable the "Generate XML Media Sitemap" scheduled task in your administration control panel.

    NOTES: Make sure you decide what you wish to use for your thumbnail quality setting. By default, thumbnails are saved at 50% quality. At 50%, thumbnails will only be 2kb in size, but at the expense of quality. At 100%, thumbnails will be about 15kb in size, but will have the highest quality. I recommend setting it to 80%, which would leave thumbnails at 5kb in size with still excellent quality.

    Every time you change your thumbnail quality setting, you will need to run the "Rebuild Media Thumbnails" to see any changes.
Upgrading from VDR:
  1. The "video*" tables from your previous installation of VDR need to exist in your database.
  2. Enable the "media ADMIN import" plugin in the plugin manager of your control panel.
  3. Run the "Import Media from VDR" process in your update counters menu in maintenance.
  4. Disable the "media ADMIN import" plugin in the plugin manager of your control panel.
  5. Run the "Rebuild Media Thumbnails" process in your update counters menu in maintenance.
  6. You may now uninstall VDR once you confirm everything has been imported as intended.

    NOTES: You will mostly likely get at least one error while rebuilding media thumbnails...

    When you get an error, click the details link for that media. If the media displays some sort of error such as "This video has been removed" or "This video no longer exist", then that means that media is gone and you'll be unable to generate a thumbnail for that particular media. Use the available options on that media's detail page to DELETE it from your library. Then go back to your browser window which is rebuilding thumbnails and click the "retry from this position" link.

    If you got an error for a media, but after clicking the details link you can find no obvious error with the video; then the error could have just been a simple syn/ack failure. Just click the "retry from this position" link and the system will try to rebuild that thumbnail again.
Known Bugs:
There is a conflict with this modification and some of Valter's VSA modifications that will prevent navbar permissions from being handled correctly. I don't know exactly who's fault it is; but I'm pretty sure there are no errors in my code that would be causing this problem. There is a work around for this however.

Admin Control Panel > Plugins & Products > Plugin Manager > "media NAVTAB"

Find the code:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Replace with:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	product-screenshot1.jpg
Views:	10618
Size:	89.6 KB
ID:	116041   Click image for larger version

Name:	product-screenshot2.jpg
Views:	5287
Size:	91.5 KB
ID:	116042   Click image for larger version

Name:	product-screenshot3.jpg
Views:	4545
Size:	81.3 KB
ID:	116043   Click image for larger version

Name:	product-screenshot4.jpg
Views:	7474
Size:	82.6 KB
ID:	116044  

Click image for larger version

Name:	product-screenshot5.jpg
Views:	5370
Size:	87.1 KB
ID:	116045   Click image for larger version

Name:	product-screenshot6.jpg
Views:	3939
Size:	113.6 KB
ID:	116046   Click image for larger version

Name:	product-screenshot7.jpg
Views:	4054
Size:	103.7 KB
ID:	116047   Click image for larger version

Name:	product-screenshot8.jpg
Views:	3415
Size:	107.9 KB
ID:	116048  

Show Your Support

  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Add-On Releases Digital Sith's AMEs - ADULT Media Definitions Digital Sith vBulletin 3.6 Add-ons 66 08 Sep 2015 23:44
Mini Mods 8WayRun.Com - Random Header Jaxel vBulletin 4.x Add-ons 47 11 Jan 2013 23:26
Add-On Releases Media Block for DnP Instant! Musicbox - Display the fun media list anywhere ! silveryhat vBulletin 3.8 Add-ons 2 19 Jan 2011 14:12
Add-On Releases DJ's AME (Auto Media Embedding) XML Media Definitions (Third Time's the Charm) Digital Jedi Modification Graveyard 828 10 Mar 2010 06:45

  #1681  
Old 02 Nov 2010, 15:13
LichtMann's Avatar
LichtMann LichtMann is offline
 
Join Date: Jan 2009
Hi Jaxel

Thank you for the great mod. I'v been using it for a while.

Btw, I am trying to setup the RSS Feed, but when I try to fetch the content, it shows nothing, like there'd be no content at all.

http://www.gamersco.com/media.php?do=rss

That is the RSS URL. I've tried some permissions, but finally the feed is not showing the content. Do you know what could be the reason?

Thank you for your attention.
Reply With Quote
  #1682  
Old 02 Nov 2010, 15:21
Jaxel Jaxel is offline
 
Join Date: Sep 2005
Feed works fine for me... what browser are you using?

Chrome does not have a built in RSS feed reader... You can install it here:
https://chrome.google.com/extensions...bbbdekmmmcbfjd
Reply With Quote
  #1683  
Old 02 Nov 2010, 15:35
Xeyn Xeyn is offline
 
Join Date: Jun 2009
all the vids i want to add from youtube come up with...when i try to add:

Syndication of this video was restricted by its owner
Reply With Quote
  #1684  
Old 02 Nov 2010, 15:41
LichtMann's Avatar
LichtMann LichtMann is offline
 
Join Date: Jan 2009
Originally Posted by Jaxel View Post
Feed works fine for me... what browser are you using?

Chrome does not have a built in RSS feed reader... You can install it here:
https://chrome.google.com/extensions...bbbdekmmmcbfjd
Well, it works like a charm now, I dont know why. Thank you for the answer!
Reply With Quote
  #1685  
Old 02 Nov 2010, 18:04
LichtMann's Avatar
LichtMann LichtMann is offline
 
Join Date: Jan 2009
Well, and this another thing.

I am changing some things inside the mod, in order to enable the Like Button from Facebook.

As well, it's necessary to add some tags in the HTML code. Actually it is taking the generic information of vb, but no the specific for each video. For that reason the Like button doesn't work well.

For example


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

So I tracked it, and it comes from $vbulletin->options['description'] in the functions_facebook.php file from vbulletin.

Do you have any suggestion of a plugin that can fill the variables needed by facebook? (meta property="og:description", meta property="og:url", meta property="og:type")

Thank you.
Reply With Quote
  #1686  
Old 03 Nov 2010, 01:30
Arved Yagami Arved Yagami is offline
 
Join Date: Jan 2004
Can anyone help? I'm still getting this error


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Reply With Quote
  #1687  
Old 03 Nov 2010, 02:02
Jaxel Jaxel is offline
 
Join Date: Sep 2005
Originally Posted by VBUsers View Post
the nav link is showing up all broken and incorrect on my forum

http://www.hydrocanna.com/forum.php

can you tell me how to fix that?
This is due to the edits on your skin...

Originally Posted by danyol1706 View Post
Hi,

After the recent update, I'm getting a "page not found" error after clicking on a video in my media gallery. Did I break the links? If so, how can I fix this?
Turn off SEO slugs

Originally Posted by Xeyn View Post
all the vids i want to add from youtube come up with...when i try to add:

Syndication of this video was restricted by its owner
Don't complain to me... complain to its owner.

Originally Posted by LichtMann View Post
Well, it works like a charm now, I dont know why. Thank you for the answer!
Its because the feed isn't generated until after a while...

Originally Posted by Arved Yagami View Post
Can anyone help? I'm still getting this error


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.
Please read the install instructions.
Reply With Quote
  #1688  
Old 03 Nov 2010, 17:39
Dangerboy's Avatar
Dangerboy Dangerboy is offline
 
Join Date: Oct 2008
Real name: Robert Segal
Hi Jaxel,

Is megavideo thumbnails working for you? I did some testing with adding new megavideo items and it worked fine. I though I fixed the issue so I tried building the thumbnails in the update counter section and the new entries are now just black thumbnails too. I've played around with the permissions for the thumbs directory as well in the "customVID" folder but no luck. Any ideas would be greatly appreciated.
Reply With Quote
  #1689  
Old 04 Nov 2010, 11:44
stwan stwan is offline
 
Join Date: Feb 2009
Bugs in 4.1.7 (vbulletin 4.0.8):
Untitled-1.jpg
Untitled-2.jpg

And please make Words => in the phrase:
Untitled-3.jpg
media.php
Untitled-4.jpg
media.php?do=admin_tags
Reply With Quote
  #1690  
Old 04 Nov 2010, 12:09
staffurdu staffurdu is offline
 
Join Date: Jun 2010
I need a little help if you could spare some time.

I saw a site installed MediaLibrary at forums and they were showing latest media additions in a widget at home page and the thing is that it wasnt just showing names but also thumbnails.

I have searched a lot because I didnt wanted to disturb you but I havent found such mod or addon.

Can you please send me link to such mod or guide me how this can be done..
Reply With Quote
  #1691  
Old 04 Nov 2010, 13:58
stwan stwan is offline
 
Join Date: Feb 2009
staffurdu, http://www.vbulletin.org/forum/showthread.php?t=244058 this?
Reply With Quote
  #1692  
Old 04 Nov 2010, 14:23
staffurdu staffurdu is offline
 
Join Date: Jun 2010
Originally Posted by stwan View Post
Yes exactly. Thanks a lot.
Reply With Quote
  #1693  
Old 05 Nov 2010, 15:50
EquinoxWorld EquinoxWorld is offline
 
Join Date: Nov 2009
Originally Posted by Dangerboy View Post
Hi Jaxel,

Is megavideo thumbnails working for you? I did some testing with adding new megavideo items and it worked fine. I though I fixed the issue so I tried building the thumbnails in the update counter section and the new entries are now just black thumbnails too. I've played around with the permissions for the thumbs directory as well in the "customVID" folder but no luck. Any ideas would be greatly appreciated.
Megavideo thumbnails not working for us either, at least the new releases anyway. I uploaded an old megavideo URL today and it created the thumbnail just fine but newly uploaded videos to megavideo URL has been not creating thumnail at all. This has been going on for a few days now. Any ideas anyone?

EDITED: I may add when I ran the rebuild thumbnail process same thing happen as you Dangerboy , the thumbnail just became black. And for some reason it took a while to rebuild about 10 of them. I don't believe it is a permissions issue or anything from the script end, sometimes megavideo changes their API so we might have to change the megavideo.xml if someone knows how to update that it would be extremely helpful.

Last edited by EquinoxWorld; 05 Nov 2010 at 16:09.
Reply With Quote
  #1694  
Old 05 Nov 2010, 16:49
Jaxel Jaxel is offline
 
Join Date: Sep 2005
Originally Posted by EquinoxWorld View Post
Megavideo thumbnails not working for us either, at least the new releases anyway. I uploaded an old megavideo URL today and it created the thumbnail just fine but newly uploaded videos to megavideo URL has been not creating thumnail at all. This has been going on for a few days now. Any ideas anyone?

EDITED: I may add when I ran the rebuild thumbnail process same thing happen as you Dangerboy , the thumbnail just became black. And for some reason it took a while to rebuild about 10 of them. I don't believe it is a permissions issue or anything from the script end, sometimes megavideo changes their API so we might have to change the megavideo.xml if someone knows how to update that it would be extremely helpful.
MegaVideo changes their API CONSTANTLY... I've had to update the importer for them about 7 times now...
Reply With Quote
  #1695  
Old 05 Nov 2010, 17:15
EquinoxWorld EquinoxWorld is offline
 
Join Date: Nov 2009
Originally Posted by Jaxel View Post
MegaVideo changes their API CONSTANTLY... I've had to update the importer for them about 7 times now...
Hello Jaxel,

Thank for your response. Is it maybe possible for us to get a tut of some sorts so we can change the importer ourselves or is it too complicated? I am more or less familiar with the API but have very little experience with the importers. Either way it would be very helpful to all members who use this mod and I am sure less of a burden for you . Thanks again for your quick reply though. I hope we can get this updated at some point, Megavideo represents about 50% of our imports. Any help with this would be as always very much appreciated.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 22:36.

Layout Options | Width: Wide Color: