Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
AME3 - Auto Media Embeding and Video Extender Details »
AME3 - Auto Media Embeding and Video Extender
Mod Version: 3.0.1, by The Geek (Coder) The Geek is offline
Developer Last Online: Jan 2019 I like it Show Printable Version Email this Page

vB Version: 4.0.0 Rating: (97 votes - 4.72 average) Installs: 1363
Released: 21 Dec 2009 Last Update: 17 Jan 2010 Downloads: 10308
Not Supported DB Changes Uses Plugins Additional Files External Content  

From the makers of Smooth and Jazz comes the singing sensation my mom has been waiting months for:

AME3. Bigger. Badder. Bestest.

NOTE ABOUT vB4.0.3: ------------------------------------------------------------

vBulletin 4.0.3 has changed the way video codes are handled and in the process, inadvertently broke AME3. I have submitted a bug report and believe that the issue will be quickly resolved. There is a manual fix you can apply for 4.0.3 here in the interim.
-----------------------------------------------------------------------------------------------

AME3 is the sequel to the multi award winning AME 1x and AME 2x systems. AME3. This time, its different.
AME3 does 3 things:
  • It allows users to simply paste URLs into their message without having to use the video bbcode or video popup box.
  • It allows you to add, edit and customise the video definitions that ship with vB4
  • It allows you to import community created definitions to extend the system in ways you otherwise couldn't.
Now you can use AME anywhere you can use video bbcode: posts, blogs, visitor messages, the CMS, etc...

Note that I am releasing this early for beta testing and general feedback. There is currently a bug in RC2, RC4 and 4.0.0 that will prevent AME from working however there is a workaround posted below.

I have written a pretty comprehensive readme and attached it seperatly to this post. I suspect both this post and the readme will get updated as AME3 becomes finalised.

Download Now

Only licensed members can download files, Click Here for more information.

Addons

Screenshots

Click image for larger version

Name:	wysiwyg.jpg
Views:	11590
Size:	179.5 KB
ID:	107851   Click image for larger version

Name:	postbit.jpg
Views:	9309
Size:	159.5 KB
ID:	107852  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Add-On Releases Digital Sith's AMEs - ADULT Media Definitions Digital Sith vBulletin 3.6 Add-ons 66 08 Sep 2015 22:44
Add-On Releases DJ's AME (Auto Media Embedding) XML Media Definitions (Third Time's the Charm) Digital Jedi Modification Graveyard 828 10 Mar 2010 05:45

  #1081  
Old 15 Apr 2011, 22:49
testbot testbot is offline
 
Join Date: Feb 2009
i mean if someone posts the url from youtube instead of the new share link. like this...

http://www.youtube.com/watch?v=cgkj3...rec_grec_index

will it still embed that?

i'm having some slight problems and don't have time to trouble shoot so if someone already has it sorted that would be cool. the .be links work fine for me. thx for that.
Reply With Quote
  #1082  
Old 15 Apr 2011, 23:39
Alan_SP's Avatar
Alan_SP Alan_SP is offline
 
Join Date: Nov 2009
New and old youtube links have different tagoption (for differentiating between new and old youtube links (old is youtube, new is youtuben, at least I just added n at the end of old youtube tagoption, you don't have to)), also regex is different.

If you have problems with old youtube links, the problem is in settings for old one. Post them here, maybe we can see where exactly problem is?
Reply With Quote
  #1083  
Old 15 Apr 2011, 23:53
testbot testbot is offline
 
Join Date: Feb 2009
^ i'm aware of the difference between the new tags. i had my own embed/object code that i used that isn't working anymore. if you're doing HD videos then maybe you can show me what you're using for the old urls. thanks for your assistance.

my standard youtube url (old version):
regex:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Reply With Quote
  #1084  
Old 16 Apr 2011, 11:39
0verl0rd 0verl0rd is offline
 
Join Date: Oct 2010
Any fix on this? I can't get it to work even with dailymotion...
Reply With Quote
  #1085  
Old 16 Apr 2011, 16:02
testbot testbot is offline
 
Join Date: Feb 2009
Originally Posted by 0verl0rd View Post
Any fix on this? I can't get it to work even with dailymotion...
did you try this:

Originally Posted by testbot View Post
Editing core files is the incorrect way to do things. They did add the hook so the following will fix the issue.

1. AdminCP>Plugins & Producs>Plugin Manager>Add New
2.
Product: AME3
Hook: data_parse_bbcode_video (not data_preparse_bbcode_video_start)
Title: AME - Parse bbcode video
Execution Order: 1
Plugin Code:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

3. Plugin is active 'Yes'
4. Save


If you have cache enabled you might have to clear that.
Reply With Quote
  #1086  
Old 17 Apr 2011, 02:35
Alan_SP's Avatar
Alan_SP Alan_SP is offline
 
Join Date: Nov 2009
Originally Posted by testbot View Post
i had my own embed/object code that i used that isn't working anymore. if you're doing HD videos then maybe you can show me what you're using for the old urls. thanks for your assistance.
For old YT videos I use exactly same code, as new YT address just redirects you to old YT address. Copy embed code from new to old (of course, modify width and height to your liking) and that should work without problems. At least it does for me. Actually, I copied code from old for new ones. And I found code here, I don't remember in what exact post, sorry. Credits for this embed code isn't mine.
Reply With Quote
  #1087  
Old 17 Apr 2011, 03:07
testbot testbot is offline
 
Join Date: Feb 2009
turns it the video i was using to test it was jacked up. :lol:
Reply With Quote
  #1088  
Old 19 Apr 2011, 07:11
wat3v3r wat3v3r is offline
 
Join Date: Jun 2008
We been recently testing vb4 for a possible upgrade int he near future (still on vb3 for now) But i see megavideo tags no longer work?

Any method to get them working again ? We only use youtube and Mv tags on our board. Got youtube to work but stuck on Mv. Any help?
Reply With Quote
  #1089  
Old 24 Apr 2011, 21:29
mdreamer's Avatar
mdreamer mdreamer is offline
 
Join Date: Aug 2008
Hi,

Just installed it. works great.
I have just one problem.. on some videos am am getting:
"This video contains content from SME. It is restricted from playback on certain sites.
Watch on YouTube"

I Didn't had it on AME 2.5... What's wrong?
Reply With Quote
  #1090  
Old 25 Apr 2011, 22:22
Phaedrus Phaedrus is offline
 
Join Date: Aug 2006
Originally Posted by mdreamer View Post
Hi,

Just installed it. works great.
I have just one problem.. on some videos am am getting:
"This video contains content from SME. It is restricted from playback on certain sites.
Watch on YouTube"

I Didn't had it on AME 2.5... What's wrong?
those are ones that youtube will not allow to play through imbedding. That isn't from the mod.
Reply With Quote
  #1091  
Old 27 Apr 2011, 12:17
Iguana Goddess's Avatar
Iguana Goddess Iguana Goddess is offline
 
Join Date: Sep 2009
Real name: Jennifer
I have noticed that youtube is including a . in some of the video urls which causes embedding with this mod to not work.
__________________
www.rejecthaven.com
Reply With Quote
  #1092  
Old 27 Apr 2011, 14:30
yin9 yin9 is offline
 
Join Date: Dec 2010
Someone has Megavideo definition for VB4?

Thanks in advance.
Reply With Quote
  #1093  
Old 29 Apr 2011, 00:08
Phaedrus Phaedrus is offline
 
Join Date: Aug 2006
Originally Posted by Iguana Goddess View Post
I have noticed that youtube is including a . in some of the video urls which causes embedding with this mod to not work.
This post should help you.

Originally Posted by Alan_SP View Post
For new youtube code (youtu.be one, if there is new one, please give link for us to see):

Go to AdminCP, AME CP, choose Add New.

For Provider: YouTube New (or whatever you like as a name for it)
Tagoption: youtuben (this can be anything you like, but unique, I just added n to stress it's new youtube tag)
URL: http://youtu.be
Regex URL: http:\/\/youtu\.be\/([a-z0-9-_]+) (this must looks like this, I used old original youtube regex to construct this one based on new youtube links)
Regex Scrape: leave empty
Embed:
Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Here I'm using code for HD video. It's the same as for old YouTube videos, because links just get redirected to old site (new links a just much simpler on us users). You can change width and height of video. Also you can disable HD if you want it.

Priority: 0
Reply With Quote
  #1094  
Old 05 May 2011, 05:30
0verl0rd 0verl0rd is offline
 
Join Date: Oct 2010
Unhappy

Originally Posted by testbot View Post
did you try this:
Tried but still not working..

it does wrap the youtube url in

but it does not show the player



BTW, was anybody able to make it work for 'quickreply' with out the advance reply?

In quickreply i think the text/links are not parsed into AME3 automatically.

Also,

What is the difference between the two YT URL?

http://www.youtube.com/watch?v=YdLvHkzCZJo <--- this is parsed with AME3 automatically.

http://www.youtube.com/watch?v=-aOLWOwF-es <--- this is not parsed with AME3 automatically.


Lastly,

Does anybody share their ame.xml that is working on VB 4.1.3 ?

Thanks a lot!

Last edited by 0verl0rd; 05 May 2011 at 08:12.
Reply With Quote
  #1095  
Old 16 May 2011, 06:00
steveyos666 steveyos666 is offline
 
Join Date: Jul 2008
Originally Posted by Alan_SP View Post
For new youtube code (youtu.be one, if there is new one, please give link for us to see):

Go to AdminCP, AME CP, choose Add New.

For Provider: YouTube New (or whatever you like as a name for it)
Tagoption: youtuben (this can be anything you like, but unique, I just added n to stress it's new youtube tag)
URL: http://youtu.be
Regex URL: http:\/\/youtu\.be\/([a-z0-9-_]+) (this must looks like this, I used old original youtube regex to construct this one based on new youtube links)
Regex Scrape: leave empty
Embed:
Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Here I'm using code for HD video. It's the same as for old YouTube videos, because links just get redirected to old site (new links a just much simpler on us users). You can change width and height of video. Also you can disable HD if you want it.

Priority: 0

This didn't do anything for me, regular youtube and youtu.be links both just showing up as links


There's a lot of pages to go through, am I supposed to somehow disable vb4's new horrible terrible built-in video tag?





EDIT WAIT: the above coupled with testbot's code worked fine, someone add both steps to the mod's original post man I hate how we gotta go through 70 pages of stuff to get mods working properly on this damn site thanks for the text though guys I love this thing, loved vb3 more though hate vb4 with a passion

Last edited by steveyos666; 16 May 2011 at 06:16.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 23:47.

Layout Options | Width: Wide Color: