Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
  #1  
Old 13 Mar 2005, 03:50
coRtALoS's Avatar
coRtALoS coRtALoS is offline
 
Join Date: Apr 2003
Location: Northeastern U.S.
Real name: Sean Daniels
Looks like I've got a new bug for you...

I searched these forums for it and didn't find any previous problems similar to this.

My forum has well over 100,000 members, and for some reason the modifications I had to make in the showthread.php made my members with userid over 100000 show up as guests on the postbit.

Upon uploading a backup of my original showthread.php file, it fixed the problem on it's own.

Help would be appreciated.
Reply With Quote
Comments
  #2  
Old 13 Mar 2005, 11:10
Revan's Avatar
Revan Revan is offline
 
Join Date: Jan 2004
Real name: Fillip
The only thing I can think of is that you can try to run the DB Fix, in case some missing userids are lurking there.
If this doesn't solve your problem, then Im afraid you have to wait until the 2nd ETA in my sig is done, because this version will not require actually modifying any code, just adding.
Reply With Quote
  #3  
Old 13 Mar 2005, 14:20
coRtALoS's Avatar
coRtALoS coRtALoS is offline
 
Join Date: Apr 2003
Location: Northeastern U.S.
Real name: Sean Daniels
Well it's something new with your recent updates. I ran one of your previous releases of the RPG system just fine (I think it was 2.9 or something).

I'd just really hate to have to wait that long without it.

----Edit----

Another problem I didn't mention earlier was rpg_install.php got this error upon running the installer.
Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

I wasn't aware rpg_class was supposed to be present...

Last edited by coRtALoS; 14 Mar 2005 at 01:07. Reason: Automerged Doublepost
Reply With Quote
  #4  
Old 14 Mar 2005, 08:50
Revan's Avatar
Revan Revan is offline
 
Join Date: Jan 2004
Real name: Fillip
The table rpg_class was created during install, so if you deleted it then you just screwed yourself out of this hack working XD
Try manually readding any tables you have dropped, then uninstalling, then reinstalling.
I see no reason why members over 100,000 should show up as guests...
Reply With Quote
  #5  
Old 15 Mar 2005, 06:25
coRtALoS's Avatar
coRtALoS coRtALoS is offline
 
Join Date: Apr 2003
Location: Northeastern U.S.
Real name: Sean Daniels
While I was doing this, I never completely installed the hack either. I happened to see what had happened after doing newthread.php, newreply.php, showthread.php, and showpost.php during a short break, and tried fixing it before continuing on.

Also, could you please just copy me the list of all the fields for the rpg_class table? I copied the classes over from the rpg_classm table on my older version of the RPG, but not sure if you made any modifications to that.
Reply With Quote
  #6  
Old 15 Mar 2005, 07:10
Revan's Avatar
Revan Revan is offline
 
Join Date: Jan 2004
Real name: Fillip
I did, but you can just pick it out from the /install/rpg_mysql-schema.php
In v3 I merged the classm and classf tables
Reply With Quote
  #7  
Old 15 Mar 2005, 20:32
coRtALoS's Avatar
coRtALoS coRtALoS is offline
 
Join Date: Apr 2003
Location: Northeastern U.S.
Real name: Sean Daniels
I'm thinking now maybe it's something to do with this person's userid (107752)? I haven't seen this happen to anyone else now that I've had a chance to look around.

Attached are screenshots of before and after I upload the modified showthread.php doing only the modifications you call for in your .txt file. Also, here is a link to that thread if you'd like to see for yourself.
http://www.battleforums.com/showthread.php?t=90789

I've manually added, updated, and verified all of my tables... any ideas?

I suppose if this doesn't happen on a large-scale, I could always merge his posts into a new useraccount and see if it happens again.
Attached Images
File Type: jpg userid107752guest.jpg (28.5 KB, 12 views)
File Type: jpg userid107752registered.jpg (82.8 KB, 17 views)

Last edited by coRtALoS; 15 Mar 2005 at 20:35.
Reply With Quote
  #8  
Old 15 Mar 2005, 21:20
Revan's Avatar
Revan Revan is offline
 
Join Date: Jan 2004
Real name: Fillip
You have to check if this is happening to users newer than his userID.
I have a somewhat similar problem on my live board actually, it absolutely REFUSES to fetch the RPG Name of newer members.
Actually, now that I went to check this out for myself, this problem seems to have gone away on its own...
*ahem* anyways
You could do that userid check (with a modded showthread obviously), then if it does not happen, verify this by posting some with a temp account you create, and if this still is not slammed by the problem, merge the two into the new userid.
Hassle, but stuff like this is impossible to detect and remotely fix
Reply With Quote
  #9  
Old 15 Mar 2005, 21:50
coRtALoS's Avatar
coRtALoS coRtALoS is offline
 
Join Date: Apr 2003
Location: Northeastern U.S.
Real name: Sean Daniels
Yeah, not happening to new registrations. Thanks for the help so far Revan. I'm going to try finishing this install up and see what happens. Wish I could give you an e-blowjob to thank you for the support so far.

I'll be sure to pis- let you know if I have any more problems.

Some beautiful modifications I see you've made since the last version though!
Reply With Quote
  #10  
Old 15 Mar 2005, 22:30
Revan's Avatar
Revan Revan is offline
 
Join Date: Jan 2004
Real name: Fillip
Originally Posted by coRtALoS
Wish I could give you an e-blowjob to thank you for the support so far.
Since I don't know if your a girl or not, I would be willing to settle for some cash via paypal j\k

Originally Posted by coRtALoS
Some beautiful modifications I see you've made since the last version though!
Thanks
I know the templates still look like something the cat killed and dragged home through the mud, but I just recently learned how to do templates the vBised way, so for the next update after Final, I will have the templates fixed up

//peace
Reply With Quote
  #11  
Old 16 Mar 2005, 04:18
coRtALoS's Avatar
coRtALoS coRtALoS is offline
 
Join Date: Apr 2003
Location: Northeastern U.S.
Real name: Sean Daniels
I think this is the last error I'm going to get. Everything else is working smoothly.
Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Where line 590 has
Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

It prevents any threads from displaying. Something going on with showthread.php

What would happen if we just left my original file intact and didn't fix this problem? Is it just going to stop something from showing up? Or actually going to affect RPGers?

---EDIT---

Ah ++++. This affects stats from showing up on the postbit, doesn't it?

Lastly, I keep seeing these tables for 'monsters'. I assume this is something that you're still working on?

Last edited by coRtALoS; 16 Mar 2005 at 04:41.
Reply With Quote
  #12  
Old 16 Mar 2005, 07:29
Revan's Avatar
Revan Revan is offline
 
Join Date: Jan 2004
Real name: Fillip
To answer the easiest question first, yes I am working on the Monster Arena.
It is currently 25% complete, with 1/3 files done.
It will also be the first part of the RPG IH that will have 100% vBised templates to work on all styles/browsers [/showoff]

As for the pow() error: Wtbf
Are you sure you didn't piss about with the query in showthread.php?
The error is derived from this line in /includes/functions_showthread.php:
Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Where $post['xp'] seems to be undefined.
Reply With Quote
  #13  
Old 27 Mar 2005, 06:02
coRtALoS's Avatar
coRtALoS coRtALoS is offline
 
Join Date: Apr 2003
Location: Northeastern U.S.
Real name: Sean Daniels
Any way to 'define' it manually? I realize remote troubleshooting can be a pain in the ass, but I've messed around with this so much trying to get it to work.

Any possible things I should try looking for to help fix this? What files specifically could be altered that would be causing this error?
Reply With Quote
  #14  
Old 27 Mar 2005, 12:00
Revan's Avatar
Revan Revan is offline
 
Join Date: Jan 2004
Real name: Fillip
The only thing I can say is that it appears like you don't have the "xp" column in your `user`. Because the $posts query does fetch everything from the user table.
Alternatively you can try adding this before the "user.ma AS uma": user.xp AS xp
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 20:55.

Layout Options | Width: Wide Color: