Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
DJ's AME :: The Ultimate Automatic Media Embedder :: 2.5.7 Details »
DJ's AME :: The Ultimate Automatic Media Embedder :: 2.5.7
Mod Version: 2.5.7, by Digital Jedi (Coder/Designer) Digital Jedi is offline
Developer Last Online: Aug 2018 I like it Show Printable Version Email this Page

vB Version: 3.8.x Rating: (9 votes - 5.00 average) Installs: 93
Released: 15 Oct 2013 Last Update: 18 Oct 2013 Downloads: 655
Not Supported DB Changes Uses Plugins Auto-Template Additional Files Translations External Content  

From the team who brought you the blockbuster film "Yahtzee!", comes the next major motion picture about incredibly bad and arbitrary puns:

AME 2.5.7: Electric Boogaloo


AME automatically embeds media in posts without the need for pesky BBCode cluttering up your editor toolbar. It's also lightweight, and saves resources that BBCode would ordinarily consume. Your users don't even have to know you have AME installed. If they share a link from YouTube, Dailymotion, Amazon, Metacafe or Vimeo, AME automatically embeds the content for them. No special code to learn. No instructions for newbies to understand.

In addition, AME allows you to create, import and export support for individual websites in the form of media definitions. These XML files expand your AME to support a limitless number of websites from around the net and let you share them with the community. We currently have around 200 media definitions collected at this repository thread. If you want additional support for website not listed, please ask for it there. Odds are, we might already have one. (TIP: Be sure to check the Add-Ons section below for stuff you might miss out on, otherwise.)




CREDITS

This modification was originally built by The Geek, who is no longer coding for vBulletin. We miss him. But he gave permission for someone to continue to build upon his work. All I've done is modify the code a little to support additional functionality and to provide a place to continue to support the product. The product didn't need too much tweaking, but I did manage to add some new features I think you will enjoy, which I'll lay out in the feature list below.



RECOMMENDATIONS

It is HIGHLY recommended that you read the READ ME.html file included in the ZIP file before you upgrade or install. You don't want to be blind-sided, now do you?




NEW INSTALLATIONS
  1. Download and Unzip the contents of the ZIP file.
    .
  2. Upload the contents of the "UPLOAD to Forum Root" folder to your forum's root directory. (This is the directory where your vBulletin is physically installed.) Also, if you've renamed your Admin CP folder, be sure to move the admincp folder's contents to your renamed directory.
    .
  3. CHMOD your amecache folder to 777.
    .
  4. Go to your Admin CP Plugins & Products Manage Products Add/Import Products and import the product-djs_AME-2.5.7.xml file.
    .
  5. Your Admin CP should automatically refresh and you should now see the AME CP somewhere below your vBulletin Options menu.



TO UPGRADE

If you are upgrading from AME 2.5.6.
  1. Delete custom definitions specifically for Amazon, Dailymotion, Metacafe, Vimeo and YouTube. (Key names: amazon, dailymotion, metacafe, vimeo and youtube) Theses five definitions are now hard coded into the product and will be updated along with the product if need be. You can back these up if you need to, but keep in mind if you use any custom defs for these sites, they will be duplicated every time you upgrade AME. So don't ask my why your videos are doubled up, or I'll throw rocks at you.
    .
  2. Upload the contents of the "UPLOAD to Forum Root" folder to your forum's root directory, overwriting previous versions of the files.
    .
  3. Ensure that your amecache directory is still CHMOD'd to 777.
    .
  4. Import the product-djs_AME-2.5.7.xml file into your Product Manager, making sure to set the option to Allow Overwrite to Yes.
    .
  5. If you are using the file cache, it is strongly recommended that you re-sync your cache using the Tools menu.



WHAT ELSE?

The following five posts will include:
  • Additional Screenshots
  • Full Features List
  • FAQ
  • Resources to develop your own custom definitions
  • AME History/Changelog

Download Now

Only licensed members can download files, Click Here for more information.

Addons

Supporters / CoAuthors

Screenshots

Click image for larger version

Name:	screen-demo-1.png
Views:	418
Size:	48.8 KB
ID:	146824   Click image for larger version

Name:	screen-demo-2.png
Views:	391
Size:	367.6 KB
ID:	146825  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Major Additions Ultimate Media Gallery LITE Coroner vBulletin 3.8 Add-ons 452 01 Mar 2012 22:01
Major Additions Ultimate Media Gallery LITE Coroner vBulletin 3.7 Add-ons 109 08 Apr 2010 16:18

  #61  
Old 23 Oct 2013, 04:27
the Sandman's Avatar
the Sandman the Sandman is offline
 
Join Date: Aug 2003
OK - [OzzModz] Global Admin / Mod Notes In ACP / MODCP installed without difficulty.
__________________
The Admin Zone Forums Discussions & Articles for Forum Administrators

Interviews: Kier Scott Jerry Mike Sullivan Andreas Steve Machol Wayne Luke Jake Bunce Floris Logician Xenon Erwin Brad
Reply With Quote
  #62  
Old 23 Oct 2013, 04:28
ozzy47's Avatar
ozzy47 ozzy47 is offline
 
Join Date: Aug 2009
Real name: Chris
Ok then that narrows it down a bit, since you were sucessfull with that, then it it a issue with the xml, either in it's self, or something going on when you download / upload it. DJ may be able to find out what is going on.
__________________
You can get access to my 180 mods for vB 3.6 - 4.x at The Admin Zone as well as the professional support you are used to. New vBulletin Spider Definitions, vBulletin Spiders List Hits 1000 Spiders! ​ OzzModz down. Site has had a data breach, checking how the intrusion happened. Change your PW if you use the same one on my site and others.
Reply With Quote
  #63  
Old 23 Oct 2013, 05:36
Digital Jedi's Avatar
Digital Jedi Digital Jedi is offline
 
Join Date: Oct 2006
Real name: Mark Daniel Martinez
I won't get to check until sometime tomorrow, but if you wouldn't mind attaching the XML file you downloaded to a post, I can take a look at it and see if it's maybe being corrupted during download.
__________________
Reply With Quote
  #64  
Old 23 Oct 2013, 13:14
the Sandman's Avatar
the Sandman the Sandman is offline
 
Join Date: Aug 2003
Attached!
Attached Files
File Type: xml product-djs_AME-2.5.7.xml (152.3 KB, 5 views)
__________________
The Admin Zone Forums Discussions & Articles for Forum Administrators

Interviews: Kier Scott Jerry Mike Sullivan Andreas Steve Machol Wayne Luke Jake Bunce Floris Logician Xenon Erwin Brad
Reply With Quote
  #65  
Old 23 Oct 2013, 21:13
Digital Jedi's Avatar
Digital Jedi Digital Jedi is offline
 
Join Date: Oct 2006
Real name: Mark Daniel Martinez
Originally Posted by the Sandman View Post
Attached!
I did a comparison in Notepad++, and the content isn't being corrupted in any way. You're getting the XML intact.

This is not my area of expertise, so I might be blowing smoke here, but there's a couple of things I know of that you can check. Keep in mind, this particular error message is notoriously vague, so it's tough to know exactly what's causing it. But we can try, at least.

Reupload all your AME files to their proper location, if you haven't already and see if a file upload got corrupted, rather than the XML.

Check your phpinfo, and see if upload_tmp_dir is set. I've read, here on the forums actually, that it can cause file processing problems. However, I can verify that it is NOT set in either of my installations.

Check to see if libXML is enabled. Again, I would think if other modifications are installing just fine, the it would have to be. But we're just checking for now.


The only other two times I've seen this error related to vBulletin 3 is with large RSS feeds, and with Photopost not installing because the files were in the wrong location. Even my searches turn up the same two issues again and again. As it seems neither of these, on the surface, seem related I can only assume it's a server configuration. The change in the admincp folder shouldn't matter, though.

Also, and this is totally a hail mary, you can also try this one. I removed some whitespaces in the XML where my username appears and one I noticed at the end of the document.
Attached Files
File Type: xml product-djs_AME-2.5.70.xml (152.0 KB, 2 views)
__________________
Reply With Quote
  #66  
Old 24 Oct 2013, 00:40
the Sandman's Avatar
the Sandman the Sandman is offline
 
Join Date: Aug 2003
No luck with the new xml file.

I've uploaded and unzipped the package twice.

upload_tmp_dir no value no value

libxml
libXML support active
libXML Version 2.9.0
libXML streams enabled
__________________
The Admin Zone Forums Discussions & Articles for Forum Administrators

Interviews: Kier Scott Jerry Mike Sullivan Andreas Steve Machol Wayne Luke Jake Bunce Floris Logician Xenon Erwin Brad
Reply With Quote
  #67  
Old 24 Oct 2013, 09:26
Digital Jedi's Avatar
Digital Jedi Digital Jedi is offline
 
Join Date: Oct 2006
Real name: Mark Daniel Martinez
Originally Posted by the Sandman View Post
No luck with the new xml file.

I've uploaded and unzipped the package twice.

upload_tmp_dir no value no value

libxml
libXML support active
libXML Version 2.9.0
libXML streams enabled
I've tried digging a little deeper into vB.org tonight regarding this error, and other than the two unlikely issues I mentioned before, it looks like it's server issue. The error is very vague, which is why there's very little specific information about it online, or even here on the forums. The few people that have mentioned a similar error while importing a product, seldom got replies or got back to the thread with an update. But I think we've ruled out just about everything else other than a server problem. Truthfully, I don't think upload_tmp_dir is the problem, since I'm seeing it run on my live site and my demo with no value. It must be a something that your host can track down. I wish I could offer more specifics, or even a resource to look over. But the error is just that vague and not well documented.
__________________
Reply With Quote
  #68  
Old 19 Nov 2013, 16:53
rrhill rrhill is offline
 
Join Date: Jul 2012
Styles trouble

Would really like to get this AME software running on my forum. But when I install the software, my themes (from vbstyles.com) no longer display the layout correct. It looks as an HTML page missing it's .css file. (see attached image error1)

Even when I disable the AME, there remain layout issues. Only after removing the product, the layout is okay again. (see attached image #2)

I'm pretty new to vBulletin and have to study it's layout features yet. Any hints that could help me see the light? I need your help.

Kind regards,
Robert van den Heuvel,
Amsterdam
Attached Images
File Type: gif error1.gif (18.5 KB, 11 views)
File Type: gif error2.gif (18.2 KB, 11 views)
Reply With Quote
  #69  
Old 19 Nov 2013, 16:56
Max Taxable's Avatar
Max Taxable Max Taxable is offline
 
Join Date: Feb 2011
Originally Posted by rrhill View Post
Would really like to get this AME software running on my forum. But when I install the software, my themes (from vbstyles.com) no longer display the layout correct. It looks as an HTML page missing it's .css file. (see attached image error1)

Even when I disable the AME, there remain layout issues. Only after removing the product, the layout is okay again. (see attached image #2)

I'm pretty new to vBulletin (4.2) and have to study it's layout features yet. Any hints that could help me see the light? I need your help.

Kind regards,
Robert van den Heuvel,
Amsterdam
You understand this modification is for vB 3.8.X, correct?

Version 4.2 already embeds media, it's native to the version.
Reply With Quote
  #70  
Old 19 Nov 2013, 17:02
Gadget_Guy Gadget_Guy is offline
 
Join Date: Jun 2010
I get this all the time with adding plugins.

Install the plugin

(The styles will go all wonky for the forum)

Then, pick any plugin at random, disable, then re-enable it

Presto... forum goes back to looking normal.


I have no idea why.... but this has become my go-to fix for when this happens.

Drove me crazy for months trying to figure this out...


D.
Reply With Quote
  #71  
Old 19 Nov 2013, 18:42
rrhill rrhill is offline
 
Join Date: Jul 2012
Originally Posted by Max Taxable View Post
You understand this modification is for vB 3.8.X, correct?

Version 4.2 already embeds media, it's native to the version.
Thank you for your response. Started a vBulletin board three weeks ago. No, I was not aware this was a modification for 3.8.X only.

What I wanted to do is embed more video's than just youtube alone. Next I found "Digital Sith's AMEs - ADULT Media Definitions" at: http://www.vbulletin.org/forum/showt...ight=xtube.com

The AME seemed exactly the plug in I was looking for. Do you have any hints where I should start to learn more for playing other media definitions in v4.2?
Reply With Quote
  #72  
Old 19 Nov 2013, 18:43
rrhill rrhill is offline
 
Join Date: Jul 2012
Originally Posted by Gadget_Guy View Post
I get this all the time with adding plugins.

Install the plugin

(The styles will go all wonky for the forum)

Then, pick any plugin at random, disable, then re-enable it

Presto... forum goes back to looking normal.


I have no idea why.... but this has become my go-to fix for when this happens.

Drove me crazy for months trying to figure this out...


D.
Thank you for sharing this info... never would have guessed this : -)
Reply With Quote
  #73  
Old 19 Nov 2013, 18:58
Max Taxable's Avatar
Max Taxable Max Taxable is offline
 
Join Date: Feb 2011
Originally Posted by rrhill View Post
Thank you for your response. Started a vBulletin board three weeks ago. No, I was not aware this was a modification for 3.8.X only.

What I wanted to do is embed more video's than just youtube alone. Next I found "Digital Sith's AMEs - ADULT Media Definitions" at: http://www.vbulletin.org/forum/showt...ight=xtube.com

The AME seemed exactly the plug in I was looking for. Do you have any hints where I should start to learn more for playing other media definitions in v4.2?
I don't know for a fact this won't work in version 4. It might well, since there is no version of this FOR version 4.

The native vB 4 media embedding supports more than just YouTube videos. Which might also be why there is no version of this Mod, for vB4.

I like, don't think you need it and stuff.
Reply With Quote
  #74  
Old 19 Nov 2013, 19:08
Digital Jedi's Avatar
Digital Jedi Digital Jedi is offline
 
Join Date: Oct 2006
Real name: Mark Daniel Martinez
It shouldn't work for verson 4 at all. However, there is The Geek's version for vB 4, but it requires some patching at the moment to make work with different vB 4 versions. I'm working on my own forked version of that (just like I did with this one) for AME 3, where you won't need some patching. Unfortunately, I'm limited by the fact I don't have access to a 4.2 board. (I have 4.0.) So I'm a bit reluctant to release a full version not knowing if it will even function properly.

In addition, AME 3 definitions are unique to AME 3, as AME 2.5 definitions are to AME 2.5. They're not compatible and will have to be updated. I DID release a Beta set of definitions for AME 3, and so far, no one has said there are a lot of problems. I'll release one more set for AME as a Beta, and the go live if no one continues to have any problems. DS has said he'll probably do an AME 3 set of his Adult definitions, but, well, if you think I'm slow....
__________________
Reply With Quote
  #75  
Old 19 Nov 2013, 19:15
Digital Jedi's Avatar
Digital Jedi Digital Jedi is offline
 
Join Date: Oct 2006
Real name: Mark Daniel Martinez
Originally Posted by Max Taxable View Post
I don't know for a fact this won't work in version 4. It might well, since there is no version of this FOR version 4.

The native vB 4 media embedding supports more than just YouTube videos. Which might also be why there is no version of this Mod, for vB4.

I like, don't think you need it and stuff.
The Geek did build one, but it's lesser known. He built AME 3 on vB4's native ability. The thing with vB4 is it embedded, but it didn't autoembed. And you couldn't create and share definitions with the community in the form of exportable XML files, so AME 3 brought that to vB4. Which is why the definitions aren't compatible, because the AME 3 used the existing infrastructure, whereas AME 1-2.5 were entirely The Geek's codebase.
__________________
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 10:34.

Layout Options | Width: Wide Color: