Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
VBulletin-Wordpress Bridge for 3.64 Details »
VBulletin-Wordpress Bridge for 3.64
Mod Version: 1.00, by imranbaig (Member) imranbaig is offline
Developer Last Online: Aug 2013 I like it Show Printable Version Email this Page

This modification is in the archives.
vB Version: 3.6.4 Rating: (1 vote - 5.00 average) Installs: 20
Released: 03 Dec 2006 Last Update: 22 Dec 2006 Downloads: 285
Not Supported DB Changes Additional Files  

I wanted to start a site with WP the best blogging software and VB the Best forum software.
After searching at vb.org, I found a bridge which was for vb 3.0. and WP 2.0, I just edited carefully the newer version files, with permission from author Here, I'm releasing this bridge:

Note:
  • This hack will only work if your WordPress and vBulletin tables are in a single database.
  • This hack has only been tested on adding entries directly from the admin panel. It has not been tested on xmlrpc clients.
  • Use at your own risk. I will not be held liable for any loss of data nor problems that you might encounter on your site during the whole process of the mod.Backup your files and database(s) before proceeding.

WP Settings:
If you want to do file edits your self then go here

Download the attached files, and you need to edit only the following files, not all.
Edit:wp-rss2.php

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Save file.

EDIT file:vb3-settings.php

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Save file.
Now upload all files.
Note: I have edited, files for default wp-theme, if you want you can just upload comments.php to any other template it does not matter much if you are bridging it., but do the following changes to single.php only if you are using a different template then default one.

EDIT: file single.php:
Look for:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Replace it with:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Make sure you have your forum path correct there.
Now Upload all files to your wp root

vBulletin Settings:

The RSS feed will not work if you haven't activated RSS External synidcation on your forum. To do this, on your forums admincp, go to vBulletin Options->External Data Provider and check 'Yes' on Enable RSS Syncidcation.

DB Settings:
Run this query:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Upload postfeed.php to your forum root included in the attachment.
Demo here:
DEMO
Please forgive me if there are any errors or anything left out in package
I'll try and support as much as I can. But cannot guarantee it

EDIT: Upload the new Attached postfeed.php, this was the culprit which was giving errors. This should fix everything.

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	comments-front-page.jpg
Views:	1558
Size:	31.2 KB
ID:	57112   Click image for larger version

Name:	Post_comment_forum.jpg
Views:	1353
Size:	31.4 KB
ID:	57113  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
vBulletin-WordPress Bridge rsuplido vBulletin 3.0 Full Releases 201 27 Oct 2008 20:23

  #31  
Old 04 Dec 2006, 20:04
imranbaig imranbaig is offline
 
Join Date: Sep 2005
Real name: Imran
Originally Posted by category View Post
should i try your new attachment because the last one didn't work?
It is working, probably needs some work on ur template files. I'll look into your site later when I find some time if u haven't changed psw?
Reply With Quote
  #32  
Old 04 Dec 2006, 20:07
category category is offline
 
Join Date: Jul 2005
Originally Posted by imranbaig View Post
It is working, probably needs some work on ur template files. I'll look into your site later when I find some time if u haven't changed psw?

same password i not gonna update with the new update dont want to mess up what you fixed.
Reply With Quote
  #33  
Old 05 Dec 2006, 00:06
Ntfu2 Ntfu2 is offline
 
Join Date: Feb 2006
This doesnt work at all on WP 2.0.5 and 3.6.4
Reply With Quote
  #34  
Old 05 Dec 2006, 07:39
imranbaig imranbaig is offline
 
Join Date: Sep 2005
Real name: Imran
Originally Posted by Ntfu2 View Post
This doesnt work at all on WP 2.0.5 and 3.6.4
lol, what do you mean?? Look at the demo, and try to use your brain while installing.
Reply With Quote
  #35  
Old 06 Dec 2006, 00:17
Ntfu2 Ntfu2 is offline
 
Join Date: Feb 2006
i used my brain. vBulletin are in the same database

I changed all the instances of vb_threadid to vB3_threadid to match my forums prefix

Edited the SQL query to match my prefix

edited all paths that needed edited to point to my forums instead of the other one

Edited the settings file to desired settings

uploaded all files to desired locations.

and when Posting from Wordpress after hitting save, or save and continue editing it only goes to a blank page. The post is created for wordpress, but not for vBulletin and users can not leave comments.

Hopefully that constitutes as using my brain. But while we are talking about brain activity, maybe you can tell us what version of wordpress the included files are from

Last edited by Ntfu2; 06 Dec 2006 at 00:31.
Reply With Quote
  #36  
Old 06 Dec 2006, 21:45
imranbaig imranbaig is offline
 
Join Date: Sep 2005
Real name: Imran
Originally Posted by Ntfu2 View Post
i used my brain. vBulletin are in the same database

I changed all the instances of vb_threadid to vB3_threadid to match my forums prefix

Edited the SQL query to match my prefix

edited all paths that needed edited to point to my forums instead of the other one

Edited the settings file to desired settings

uploaded all files to desired locations.

and when Posting from Wordpress after hitting save, or save and continue editing it only goes to a blank page. The post is created for wordpress, but not for vBulletin and users can not leave comments.

Hopefully that constitutes as using my brain. But while we are talking about brain activity, maybe you can tell us what version of wordpress the included files are from
You used your brain:P, files that are included are of wp 2.05 as I mentioned in the thread starter it is for wp 2.05 and vb 3.64.
Please pm me your ftp, I'll have a check? If you can or what is the error and site url would really help.
Reply With Quote
  #37  
Old 06 Dec 2006, 21:51
category category is offline
 
Join Date: Jul 2005
Originally Posted by imranbaig View Post
You used your brain:P, files that are included are of wp 2.05 as I mentioned in the thread starter it is for wp 2.05 and vb 3.64.
Please pm me your ftp, I'll have a check? If you can or what is the error and site url would really help.


hey you didnt fix my problem?
Reply With Quote
  #38  
Old 07 Dec 2006, 08:17
imranbaig imranbaig is offline
 
Join Date: Sep 2005
Real name: Imran
Originally Posted by category View Post
hey you didnt fix my problem?
Past couple of days been very hectic, hangon I will try to get some time out for you. . Working on a big video site template hope to finish it by today.
Reply With Quote
  #39  
Old 09 Dec 2006, 19:12
imranbaig imranbaig is offline
 
Join Date: Sep 2005
Real name: Imran
Originally Posted by abcdefgary View Post
Is there any way to overcome this problem? I really would like to use this mod, but my tables are in separate databases. Is there any way to combine the two?
You can easily combine, these two db's, right now I'm working on one huge SE marketing project plus 5 big templates, making me really short on time, I will try and help you all when I get some breather
Reply With Quote
  #40  
Old 09 Dec 2006, 21:33
BobbyBig BobbyBig is offline
 
Join Date: Mar 2006
How about telling the visitor for what this hack is...
Reply With Quote
  #41  
Old 14 Dec 2006, 15:09
Jafo232 Jafo232 is offline
 
Join Date: May 2004
Umm, ok, I think I am reading the directions properly...

Anyway, created a forum, put its id in the vb3-settings.php file.

Enabled RSS syndication as directed. Uploaded the files to their proper places...

Post a new entry in wp, get a blank page and no post to the forum..

Whats up?
__________________
Become a Lampwright today at www.lampwrights.com!
Reply With Quote
  #42  
Old 14 Dec 2006, 15:12
wolfyman's Avatar
wolfyman wolfyman is offline
 
Join Date: Apr 2005
Real name: James
Originally Posted by Jafo232 View Post
Umm, ok, I think I am reading the directions properly...

Anyway, created a forum, put its id in the vb3-settings.php file.

Enabled RSS syndication as directed. Uploaded the files to their proper places...

Post a new entry in wp, get a blank page and no post to the forum..

Whats up?

same here.
__________________
see sig.
Reply With Quote
  #43  
Old 14 Dec 2006, 19:38
Jafo232 Jafo232 is offline
 
Join Date: May 2004
Forget it, I created my own hack that is a WordPress plugin (No VB mods). You can find it here:

http://www.vbulletin.org/forum/showthread.php?t=133997
__________________
Become a Lampwright today at www.lampwrights.com!
Reply With Quote
  #44  
Old 14 Dec 2006, 19:55
wolfyman's Avatar
wolfyman wolfyman is offline
 
Join Date: Apr 2005
Real name: James
Originally Posted by Jafo232 View Post
Forget it, I created my own hack that is a WordPress plugin (No VB mods). You can find it here:

http://www.vbulletin.org/forum/showthread.php?t=133997
bwaaaaaahahahha.

/me uninstalls, jumps ship, and hopes for better with Jafo's hack
__________________
see sig.
Reply With Quote
  #45  
Old 15 Dec 2006, 19:58
graysqwrl graysqwrl is offline
 
Join Date: Dec 2006
I though t I was going crazy.

I'm glad other people are having the same "no thread" problem that I have.

My comments always appear "off" when viewing the blog. However, the admin page shows them as on. This was a brand new install so there's nothing that could be getting in the way.

If anyone has a fix lemme know, otherwise I'm going to give the wp plugin a try
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 17:40.

Layout Options | Width: Wide Color: