Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Thread Thumbnails Details »
Thread Thumbnails
Mod Version: 2.20, by Null Parameter (Member) Null Parameter is offline
Developer Last Online: Apr 2014 I like it Show Printable Version Email this Page

vB Version: 3.8.x Rating: (31 votes - 4.45 average) Installs: 258
Released: 28 May 2009 Last Update: 09 Apr 2010 Downloads: 2043
Not Supported DB Changes Uses Plugins Auto-Template Re-usable Code Translations  

Thread Thumbnails
--------------------------------------
Created By: Null Parameter

This mod is officially tested with 3.8.1, but has been reported to work with many other versions.

Please leave any comments, suggestions or bugs.

Description

This mod allows a user, when creating or editing a thread, to specify a Thumbnail image to be used for display next to the thread in the Thread Listing.

With this mod you can define a set of forums that have thumbnails enabled, then in those forums whenever a user creates or edits their thread they can change their thumbnail, based on the method that you choose to allow.

This image is then shown in the Forum Display, in place of the Thread Icon.
The image also appears in Search & Tag Search, and I can add it to the regular Search if somebody requests it. And possibly have options for displaying in each area.

Forum Display:
Attachment 105596

Search:
Attachment 105597

ACP Options:
Attachment 105595

Installation

Install the Product XML File. That's it!

All Template Edits Are Now Automatic.

If you are Upgrading from the older version, see directions in the README file on how to undo the template edits.

Demo

Possible Future Features (With Request)
  • Additional column instead of replacing Thread Icon
  • Displaying Thumbnail within thread
  • Edit thumbnail through Thread Edit
  • Thumbnail Preview in Edit Window
Fixes
  • Version 2.2
    • Fix Attachment + Default Thumbnail Option Combo
  • Version 2.1
    • Fix DB Error when using First Attachment option
    • Fix issue with New threads not saving thumbnail
  • Version 2
    • Added Features:
      • Automatic Template Edits
      • Thumbnails in Search
      • Thumbnails from First Image/First Attachment
      • Thumbnails on Sticky Threads
    • Fixes:
      • Miscellaneous Fixes

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	ACP Options.jpg
Views:	2540
Size:	120.3 KB
ID:	105595   Click image for larger version

Name:	Forum.jpg
Views:	4784
Size:	81.0 KB
ID:	105596   Click image for larger version

Name:	Search.jpg
Views:	2620
Size:	77.3 KB
ID:	105597  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
  #31  
Old 29 May 2009, 10:09
Sofia Sofia is offline
 
Join Date: Oct 2006
Real name: Sofia
Very good work. Thank you
Reply With Quote
  #32  
Old 29 May 2009, 12:03
marshal_ramdev marshal_ramdev is offline
 
Join Date: Mar 2009
Real name: Marshal
thank you
Reply With Quote
  #33  
Old 30 May 2009, 03:47
aztecboi2003 aztecboi2003 is offline
 
Join Date: Apr 2007
Installed. How do I make the thumbs be 150x150? I had a user try it out and it's 150x225.
Reply With Quote
  #34  
Old 30 May 2009, 04:04
Null Parameter's Avatar
Null Parameter Null Parameter is offline
 
Join Date: Jun 2008
Originally Posted by aztecboi2003 View Post
Installed. How do I make the thumbs be 150x150? I had a user try it out and it's 150x225.
I don't have a max height defined right now, only width. So that just means that the width is scaled down to 150, and the height is just scaled accordingly.

I'll add a height restriction to this list of additional features.
Reply With Quote
  #35  
Old 30 May 2009, 04:11
aztecboi2003 aztecboi2003 is offline
 
Join Date: Apr 2007
Originally Posted by Null Parameter View Post
I don't have a max height defined right now, only width. So that just means that the width is scaled down to 150, and the height is just scaled accordingly.

I'll add a height restriction to this list of additional features.
Ok cool, I just installed this and it's great. Keep up the good work.
Reply With Quote
  #36  
Old 30 May 2009, 11:45
WebCraker WebCraker is offline
 
Join Date: Jan 2006
Real name: M Ibrahim
Thank you
awsome add-on

And i get it translated into arabic language for arabic froums
تم تعريب الهاك وهذا هو الرابط
http://www.support-ar.com/vb/showthread.php?t=23758

Last edited by WebCraker; 30 May 2009 at 15:13.
Reply With Quote
  #37  
Old 30 May 2009, 16:08
Etab Etab is offline
 
Join Date: Jan 2007
Originally Posted by Null Parameter View Post
Interesting idea! I'll look into it.
That would be fantastic! Thanks, Null Parameter.
Reply With Quote
  #38  
Old 30 May 2009, 17:43
Null Parameter's Avatar
Null Parameter Null Parameter is offline
 
Join Date: Jun 2008
Originally Posted by WebCraker View Post
Thank you
awsome add-on

And i get it translated into arabic language for arabic froums
تم تعريب الهاك وهذا هو الرابط
http://www.support-ar.com/vb/showthread.php?t=23758
Looks good. I'll probably make it work with phrases in the next version as well, so the strings aren't coded in, so that should make translation substitution easier in the future.


Thanks again everybody for all of the great comments. I'll be working on the new version this weekend most likely!
Reply With Quote
  #39  
Old 31 May 2009, 01:33
dancue dancue is offline
 
Join Date: Feb 2008
I would love for this to search the thread for a thumbnail or url to a picture if user has not already uploaded one.

Last edited by dancue; 31 May 2009 at 01:38.
Reply With Quote
  #40  
Old 31 May 2009, 01:47
Null Parameter's Avatar
Null Parameter Null Parameter is offline
 
Join Date: Jun 2008
Originally Posted by dancue View Post
I would love for this to search the thread for a thumbnail or url to a picture if user has not already uploaded one.
So if the URL doesn't specify a Thumbnail URL then automatically use the first one in their post? Interesting idea as well.

It's amazing what people can come up with that I never would have thought of.

And back on the thought of adding this to the RSS2 Feed, I actually have another mod I wrote (not posted, yet) that creates a Media RSS Feed using the thumbnail, which also allows your website to be enabled for cooliris. Think that is sufficient, or do you think I should still try to inject it into the RSS2 feed?
Reply With Quote
  #41  
Old 31 May 2009, 02:20
dancue dancue is offline
 
Join Date: Feb 2008
Can you make it where the author of the thread is directed to edit thread when he clicks on the "no thumbnail" image?
Reply With Quote
  #42  
Old 31 May 2009, 02:21
dancue dancue is offline
 
Join Date: Feb 2008
Originally Posted by Null Parameter View Post
So if the URL doesn't specify a Thumbnail URL then automatically use the first one in their post? Interesting idea as well.

It's amazing what people can come up with that I never would have thought of.

And back on the thought of adding this to the RSS2 Feed, I actually have another mod I wrote (not posted, yet) that creates a Media RSS Feed using the thumbnail, which also allows your website to be enabled for cooliris. Think that is sufficient, or do you think I should still try to inject it into the RSS2 feed?
Or 1st attached thumbnail...

That feature is one that is offered in the mod "Article Forums".

And I love it!!
Reply With Quote
  #43  
Old 01 Jun 2009, 01:20
kalisekj kalisekj is offline
 
Join Date: Dec 2006
I made all the edits and made the no thumbnail image and put it on the server, but now all the threads show the no thumbnail image, I go into thread and on first post I put the url IE: http://i44.tinypic.com/293zoz6.jpg and I save, but I still get the No thumbnail image , i edit again and it has nothing in the url field. So it appears the system is not saving the url I give it. Help Please!
Reply With Quote
  #44  
Old 01 Jun 2009, 01:22
kalisekj kalisekj is offline
 
Join Date: Dec 2006
BTW I am at 3.8.2
Reply With Quote
  #45  
Old 01 Jun 2009, 01:23
aztecboi2003 aztecboi2003 is offline
 
Join Date: Apr 2007
Originally Posted by kalisekj View Post
I made all the edits and made the no thumbnail image and put it on the server, but now all the threads show the no thumbnail image, I go into thread and on first post I put the url IE: http://i44.tinypic.com/293zoz6.jpg and I save, but I still get the No thumbnail image , i edit again and it has nothing in the url field. So it appears the system is not saving the url I give it. Help Please!
Did you try removing the no thumbnail image? And then seeing if that would work? I'm using it without the thumbnail image and it works fine. I'm on 3.8.2 also.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 10:52.

Layout Options | Width: Wide Color: