Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
PNG Editor Buttons Details »
PNG Editor Buttons
Mod Version: 1.00, by Wayne Luke (Administrator) Wayne Luke is offline
Developer Last Online: Oct 2020 I like it Show Printable Version Email this Page

This modification is in the archives.
vB Version: 3.7.2 Rating: (28 votes - 4.64 average) Installs: 319
Released: 20 Dec 2007 Last Update: 29 Aug 2008 Downloads: 4115
Not Supported Template Edits Re-usable Code Translations  

As another step forward in usability, here is another simple template edit that uses the FAMFAMFAM Silk Icons for your editor buttons. These icons are in PNG format with alpha transparency so should look good on any background except pure black. Black doesn't work since most of the icons contain a lot of black.


If you have a lot of Internet Explorer 6 users, then you will need to install the following addon as well:
PNG Transparency for Internet Explorer - This will enable Internet Explorer 5.5 and 6.0 to utilize PNG Transparency through DirectX filters. This is not needed for Internet Explorer 7 or higher.



Features
  • PNG icons for Standard and WYSIWYG Editors
  • Cut, Copy and Paste enabled in Editor
  • Extra icons included for additional common BBCodes including superscript, subscript, audio, video, and horizontal rules.
Installation
  1. Upload all images to yourforumpath/images/editor
  2. Merge the style.xml file into each style you want to apply the changes to. This will only work on styles with unedited editor templates. If your editor templates are modified then you will need to revert them to apply this change. To do this follow the steps below.
Merging Styles
  1. Go to Styles & Templates -> Download / UploadStyles.
  2. In the Upload form, browse to the editor_png.xml file
  3. For the Merge Into Style choose the style that these changes should be applied on.
  4. Tell the system to ignore the version number (just in case).
  5. Click Import.
  6. Repeat for each additional style.
The FAMFAMFAM Silk icons are licensed under a Creative Commons Attribution 2.5 License.
Note:
If you install this template modification after upgrading to 3.7.0 RC4 or later, you will need to manually add the security token notification to the three templates. This line of code needs to be added:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

If this is installed before you upgrade to RC4 then vBulletin will automatically add these lines during the upgrade process.

Update:
Updated to 3.7.3 with all code changes between Beta 2 and 3.7.3 applied.

Support:
For support with this template modification, please visit www.rabidbadger.net and post your issues in the Project Tools tracker. Registration is required. All registrations are moderated. To get access as soon as possible, use the same username that you use on this site.

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	editor_toolbar.gif
Views:	12394
Size:	8.5 KB
ID:	73486  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
New Editor Buttons vmacedonia Miscellaneous Images 64 19 Dec 2010 16:51
New Posting Features dark_vb_v2 Editor Buttons! bitdefuser Miscellaneous Images 18 05 Oct 2010 03:01
Mini Mods Editor Buttons newliner itsid vBulletin 3.6 Add-ons 31 11 Oct 2009 18:12

  #106  
Old 24 May 2008, 16:01
Dragon Company's Avatar
Dragon Company Dragon Company is offline
 
Join Date: Dec 2004
Very nice
__________________
Forum SIG - THE french community about Geographic Information System
Reply With Quote
  #107  
Old 24 May 2008, 19:34
trackpads's Avatar
trackpads trackpads is offline
 
Join Date: Aug 2003
Real name: Jason
Originally Posted by BarcaMaroc View Post
showthread_quickreply




Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.
Thanks!
Reply With Quote
  #108  
Old 24 May 2008, 23:33
Rocc Rocc is offline
 
Join Date: Mar 2008
I installed this and it shows the images just fine but when i tryed to edit a post none of the buttons on the editor work same with quick reply ?

i reverted the templates and yet it still dosen't work this is with 3.7.0 with default skin
Reply With Quote
  #109  
Old 25 May 2008, 23:28
Silvio's Avatar
Silvio Silvio is offline
 
Join Date: Nov 2005
Real name: Andrea
Originally Posted by GrendelKhan{TSU View Post
hmm... seems to be a conflict with Princetons' smilies below edit hack.
ie: png editor button disappear when using it. at least for me

http://www.vbulletin.org/forum/showthread.php?t=178327

ideas?
yes happen same thing to me and my templates are updated.

disabling princeton's smilies below hack then this one will work like a charm
enabling princeton's smilies below hack then will perfectly work on quick replies panes but will not with the main full editor

Pls Wayne can you help on this matter?

regards

ciao
Reply With Quote
  #110  
Old 27 May 2008, 16:30
peterpigman peterpigman is offline
 
Join Date: May 2006
I have the Show Smilies in Quickreply added which stops working when you add this also.
__________________
Uncover Reality
Reply With Quote
  #111  
Old 28 May 2008, 01:32
Dr. Bantham's Avatar
Dr. Bantham Dr. Bantham is offline
 
Join Date: Feb 2007
This appears to have messed up Highslide image functionality within PhotoPlog for me. I imported the XML file into two styles out of several and now those two styles no longer show the thumb images within Photoplog or posts. How do I reverse this?

UPDATE
The issue was with the Replacement Variable that changed "photoplog" to "Gallery". This really messed up Photoplog. Why was there even a reference to Photoplog? Are there any other areas that I need to be concerned with?
__________________
THOMAS LIGOTTI ONLINE
A Shining Brainless Beacon Of Elegant Mutations And Cunning Annihilations

Last edited by Dr. Bantham; 28 May 2008 at 01:42.
Reply With Quote
  #112  
Old 28 May 2008, 16:23
mikkitine's Avatar
mikkitine mikkitine is offline
 
Join Date: Oct 2007
Was running this successfully on 3.7.0 yesterday. Installed vBSEO 3.2.0 RC5 and then it failed to show the png icons in quick edit and new thread/post reply. On showthread_quickreply the png icons show but on the color selector instead of the colour of choice being displayed in a little bar under the palette icon, I get the address of my forum in text(which pushes all the icons to the right of it further out). Upgraded to 3.7.1 soon after and the issues are the same.

Anybody else with similar problems or solutions?
Reply With Quote
  #113  
Old 29 May 2008, 12:11
sebil's Avatar
sebil sebil is offline
 
Join Date: Feb 2008
how can uninstall this...........
great cod
Reply With Quote
  #114  
Old 29 May 2008, 19:26
BoYagoob BoYagoob is offline
 
Join Date: Feb 2005
Great .. & installed ..
Reply With Quote
  #115  
Old 31 May 2008, 09:45
Mr. Hoddz Mr. Hoddz is offline
 
Join Date: Aug 2007
Real name: Ben
/me marks as installed.

Got to say this is possibly the best graphics set on here for the editor. Love it!! Thanks for sharing.
Reply With Quote
  #116  
Old 31 May 2008, 09:47
Mr. Hoddz Mr. Hoddz is offline
 
Join Date: Aug 2007
Real name: Ben
Originally Posted by Dr. Bantham View Post
This appears to have messed up Highslide image functionality within PhotoPlog for me. I imported the XML file into two styles out of several and now those two styles no longer show the thumb images within Photoplog or posts. How do I reverse this?

UPDATE
The issue was with the Replacement Variable that changed "photoplog" to "Gallery". This really messed up Photoplog. Why was there even a reference to Photoplog? Are there any other areas that I need to be concerned with?
Yeah I've got the same thing. I think I'm gonna look through the .xml file and see what I can find. Hopefully it is something in there.
Reply With Quote
  #117  
Old 31 May 2008, 09:49
Mr. Hoddz Mr. Hoddz is offline
 
Join Date: Aug 2007
Real name: Ben
For some reason, lines 4-6 of the .xml file have these contents...


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

That is the only section that a search pulled up the word "Gallery".



The whole thing that has changed is a phrase has changed the word "photoplog" to "Gallery" (case sensitive) and this is what is causing the problem. Can't see anything that would cause it, but maybe Wayne will look into it and see what's wrong.
Reply With Quote
  #118  
Old 31 May 2008, 18:04
dannykilla's Avatar
dannykilla dannykilla is offline
 
Join Date: Jun 2007
Real name: Danny
can anyone post a update for the template "postbit_quickedit" as I am still getting the please revert templates notice on ACP home, when I click the link to view the templates that need reverting I have this information

Default Template Updated in vBulletin 3.7.0 Beta 5 by Jelsoft
Your Custom Template Last Edited in vBulletin 3.6.8 by Koleckai
Reply With Quote
  #119  
Old 05 Jun 2008, 05:50
tafreeh's Avatar
tafreeh tafreeh is offline
 
Join Date: May 2008
Location: Canada
Real name: DON
okay here is the thing...

after installing this hack, i m getting security tokken missing error.. while my userz trying to create new thread or reply to a post...

i try to fix it but i can not even find this code

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


niether this one

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.



plus editior toolbar on and off, showthread and quick reply templates are showing under templates out of date

PLease help me out
Reply With Quote
  #120  
Old 07 Jun 2008, 22:43
Cs.Net Cs.Net is offline
 
Join Date: Dec 2007
thank you nice
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 04:20.

Layout Options | Width: Wide Color: