Register Members List Search Today's Posts Mark Forums Read

Reply
 
Article Options
  #76  
Old 03 Nov 2011, 05:39
bipro bipro is offline
 
Join Date: Oct 2011
how to add CKEditor to my custom php page without using TemplateEngine of vbb. Thanks
Reply With Quote
  #77  
Old 05 Nov 2011, 20:45
Cadellin's Avatar
Cadellin Cadellin is offline
 
Join Date: Jan 2009
I've come back to this to update my product from the old WYSIWYG to CKEditor and after following the instructions here I'm just getting an empty box - no editor, text area or buttons.

Could anyone offer any advice what could be going wrong or even offer a clean working version I could try? I'm running the latest 4.1.7 PL2.

A full new article would definitely be worthwhile if someone in the know could spare the time as the old one is now so outdated it's just confusing.

Thanks
Reply With Quote
  #78  
Old 10 Jan 2012, 13:46
Hippy's Avatar
Hippy Hippy is offline
 
Join Date: Dec 2001
yes could some one explain how to add this new vb editor .. it would be great appreciated
Reply With Quote
  #79  
Old 18 Jan 2012, 01:52
Mythotical Mythotical is offline
 
Join Date: Jun 2004
I will be testing this on 4.1 platform tonight or tomorrow. First my homework for class then coding. :P
Reply With Quote
  #80  
Old 18 Jan 2012, 19:11
Cadellin's Avatar
Cadellin Cadellin is offline
 
Join Date: Jan 2009
Originally Posted by Steve M View Post
I will be testing this on 4.1 platform tonight or tomorrow. First my homework for class then coding. :P
If you get it working I don't suppose you could write up an improved article? It would be great to be able to update my mods to use WYSIWYG once again.
Reply With Quote
  #81  
Old 19 Jan 2012, 04:54
Mythotical Mythotical is offline
 
Join Date: Jun 2004
Originally Posted by Cadellin View Post
If you get it working I don't suppose you could write up an improved article? It would be great to be able to update my mods to use WYSIWYG once again.
Sure will, guaranteed. I'm about to test it now that I'm out of classes until Friday.

--------------- Added 19 Jan 2012 at 14:52 ---------------

So far I have ran into a couple of issues. I will have things ironed out later today and then I'll update my article.
Reply With Quote
  #82  
Old 19 Jan 2012, 18:13
Cadellin's Avatar
Cadellin Cadellin is offline
 
Join Date: Jan 2009
I can't tell you how happy that makes me

Cheeky I know but could you cover how to load contents into the editor at startup? I.e. Using it to edit something rather than create afresh.

It's something I never managed to find an explanation of how to do in vB-Editor and my own attempts ended in failure. - Thanks!
Reply With Quote
  #83  
Old 19 Jan 2012, 21:19
Hippy's Avatar
Hippy Hippy is offline
 
Join Date: Dec 2001
thanks steve_m
Reply With Quote
  #84  
Old 19 Jan 2012, 22:18
Mythotical Mythotical is offline
 
Join Date: Jun 2004
Originally Posted by Cadellin View Post
I can't tell you how happy that makes me

Cheeky I know but could you cover how to load contents into the editor at startup? I.e. Using it to edit something rather than create afresh.

It's something I never managed to find an explanation of how to do in vB-Editor and my own attempts ended in failure. - Thanks!
I will try to include that.

Originally Posted by Hippy View Post
thanks steve_m
No problem

--------------- Added 20 Jan 2012 at 01:53 ---------------

I have updated the article. I am now testing on the latest release of vBulletin.
Reply With Quote
  #85  
Old 21 Jan 2012, 19:25
Cadellin's Avatar
Cadellin Cadellin is offline
 
Join Date: Jan 2009
Thanks Steve

Could you clarify by what you mean by "Make sure you have this code in the area where your template containing the editor is to be called" as my editor isn't loading - the smilies etc.. are but there is just a blank space where the editor should be.

Thanks


EDIT: Fixed


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

must be below


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

The example template I originally used to base all my files off has them the other way around so I suspect I won't be the only one.

EDIT2:

Steve could you also advise about parsing the output of the new WYSIWYG? The old one had a special function I seem to remember but I can't find it.

Last edited by Cadellin; 21 Jan 2012 at 20:50.
Reply With Quote
  #86  
Old 21 Jan 2012, 20:53
Mythotical Mythotical is offline
 
Join Date: Jun 2004
Originally Posted by Cadellin View Post
Thanks Steve

Could you clarify by what you mean by "Make sure you have this code in the area where your template containing the editor is to be called" as my editor isn't loading - the smilies etc.. are but there is just a blank space where the editor should be.

Thanks


EDIT: Fixed


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

must be below


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

The example template I originally used to base all my files off has them the other way around so I suspect I won't be the only one.

EDIT2:

Steve could you also advise about parsing the output of the new WYSIWYG? The old one had a special function I seem to remember but I can't find it.
Make sure you installed the provided plugin. Then you $messagearea where you want it to appear.

If nothing else zip up your files and templates in a file and I'll have a look at it.
Reply With Quote
  #87  
Old 21 Jan 2012, 21:01
Cadellin's Avatar
Cadellin Cadellin is offline
 
Join Date: Jan 2009
Thanks Steve - switching around the special templates and includes fixed the issue. My issue now is cleaning up the output from the editor for MYSQL and then parsing it again for display.
Reply With Quote
  #88  
Old 21 Jan 2012, 21:37
Mythotical Mythotical is offline
 
Join Date: Jun 2004
Originally Posted by Cadellin View Post
Thanks Steve - switching around the special templates and includes fixed the issue. My issue now is cleaning up the output from the editor for MYSQL and then parsing it again for display.
Like I said, I'm willing to look over your code for you if you wish. Just let me know.
Reply With Quote
  #89  
Old 22 Jan 2012, 00:28
Cadellin's Avatar
Cadellin Cadellin is offline
 
Join Date: Jan 2009
Thanks for the offer Steve but I've now got everything working satisfactorily including editing which is a bonus.
Reply With Quote
  #90  
Old 22 Jan 2012, 00:33
Mythotical Mythotical is offline
 
Join Date: Jun 2004
Originally Posted by Cadellin View Post
Thanks for the offer Steve but I've now got everything working satisfactorily including editing which is a bonus.
Great to hear. Good luck.
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Article Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 21:00.

Layout Options | Width: Wide Color: