Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #16  
Old 28 Oct 2013, 22:56
JacquiiDesigns's Avatar
JacquiiDesigns JacquiiDesigns is offline
 
Join Date: Dec 2008
Location: Tennessee
Real name: Jacquii Cooke
Originally Posted by oldengine View Post
I've been a vBulletin owner/admin since 2004.

My current vBulletin stats are Threads: 116,039, Posts: 924,708, Members: 65,814

I am running: vBulletin 3.8.7 Patch Level 3

Now that vBulletin has fractured into three different followings, 3,4 and 5, what the hell do I do? Has anyone made sense of this random senseless drift in a marketing scheme? I have purchased ALL upgrades to vBulletin so that's not the problem. Which one is working at the top shelf quality that used to be vBulletin? Where do I go from here? My long term philosophy has been, "if it ain't broke, don't fix it!"
Looking for "compelling" reasons to upgrade? Take vBulletin.org for instance - Still running vB 3.7.x --- As are a myriad of other IB-owned forums, the majority (if not all) of them are running vB 3. See the IB Automotive properties at http://www.internetbrands.com/our-brands/automotive/ as an example.

If IB itself is refusing to upgrade their online properties to any of the 'latest greatest' versions of vBulletin (vB4-vB5) -- Why should you?

You likely shouldn't

J.
__________________
Call For Submissions. Come share your poetry & writing at JPiC Forum.
JPiC Forum For Writers | Celebrating Diversity With The Typed Word
Reply With Quote
  #17  
Old 28 Oct 2013, 23:42
TheLastSuperman's Avatar
TheLastSuperman TheLastSuperman is offline
 
Join Date: Sep 2008
Real name: Michael Miller Jr
Originally Posted by Paul M View Post
4.2.2 does not require php 5.4
Originally Posted by Amaury View Post
Correct.

It just adds support for PHP 5.4.
Odd because 4.2.2 seems to have issues unless you make a few changes (how time is set on the server and a few other changes, most fixes show if you search for the errors on google ) to run it on php5.3 so imo if you want to run 4.2.2 then upgrade your php to 5.4 i.e. required in a sense.

__________________
Daddy Does Dios and Figs!
https://www.linkedin.com/in/thelastsuperman

Search - Use the search feature to find similar issues/answers.
Information - Include screenshots, copy/pasted error codes, url etc.
Fixed - Please return to your thread/post and let us know how it was fixed!
Thanks - For participating! Click the "Like" on a post if someone helped you!

Last edited by TheLastSuperman; 29 Oct 2013 at 00:37.
Reply With Quote
  #18  
Old 30 Oct 2013, 16:18
oldengine oldengine is offline
 
Join Date: Mar 2004
My sincere thanks for all of the posts here. I am still running vBulletin 3.8.7 Patch Level 3+.

Last edited by oldengine; 23 Aug 2014 at 02:30.
Reply With Quote
  #19  
Old 31 Oct 2013, 22:12
skol skol is offline
 
Join Date: Oct 2008
Originally Posted by TheLastSuperman View Post
Odd because 4.2.2 seems to have issues unless you make a few changes (how time is set on the server and a few other changes, most fixes show if you search for the errors on google ) to run it on php5.3 so imo if you want to run 4.2.2 then upgrade your php to 5.4 i.e. required in a sense.

It's php specific,not just 5.3 or 5.4..What runs on 5.3.27 won't run on 5.3.17 and vice versa..So upgrading to 5.4 won't solve all the problems.
Reply With Quote
  #20  
Old 01 Nov 2013, 20:20
tryckjävel's Avatar
tryckjävel tryckjävel is offline
 
Join Date: Mar 2004
Real name: Dana
I think a big portion of why certain large sites aren't upgrading is because of the amount of work it would take to completely redo everything. At least thats what my dilemma is.

I'm currently on 3.8.7pl3, 45,000 members and 4.6mil posts… I need a better search, i need a CMS, and i need to take advantage of the latest functionality for "big board" database handling. But I'm not convinced vb4 or vb5 is the answer. I've owned vb4 since it came out, tried to upgrade to it and backed out cause i just wasn't ready to build all new templates and designs.
__________________
www.turbobricks.com - the volvo performance community
Reply With Quote
  #21  
Old 01 Nov 2013, 22:12
TheLastSuperman's Avatar
TheLastSuperman TheLastSuperman is offline
 
Join Date: Sep 2008
Real name: Michael Miller Jr
Originally Posted by skol View Post
It's php specific,not just 5.3 or 5.4..What runs on 5.3.27 won't run on 5.3.17 and vice versa..So upgrading to 5.4 won't solve all the problems.
Yes I know as in old mods etc that use deprecated values etc and yes someone was upgraded to 4.2.2 and to php5.4 then had to move them back to 5.3.27 I believe and it worked fine (yeah 4.2.2 on 5.3.27 but then on another 4.2.2 site it would not function properly on 5.3.27 but it was new the owner said forget it Mike just install me 4.2.1 so he could get going with the site as it was brand new but not everyone can simply do that i.e. if their forum has been long standing and has thousands of threads and posts etc) long story short every site there's been an issue on was custom regarding modifications/plugins so in essence unless you do a test server/site (most host will accommodate that request for free if you call and explain what is going on to them, if not perhaps a nominal fee and you will more than likely need to edit your hosts file to view the new site on the different server IP) then you just don't know and that compatibility tab in the admincp does not work all the time, it's a band-aid per say you should do as the hint suggest and sort the issues properly.

I'm not recommending 4.2.2 at all now, same as vB5.x I suggest 4.2.1 but that's because of the mod issues as some owners simply don't want to deal with all that, had them tell me that on the phone despite me telling them 4.2.2 and 5.4 will ensure their site runs smoother for longer (if no issues).
__________________
Daddy Does Dios and Figs!
https://www.linkedin.com/in/thelastsuperman

Search - Use the search feature to find similar issues/answers.
Information - Include screenshots, copy/pasted error codes, url etc.
Fixed - Please return to your thread/post and let us know how it was fixed!
Thanks - For participating! Click the "Like" on a post if someone helped you!

Last edited by TheLastSuperman; 01 Nov 2013 at 22:59.
Reply With Quote
  #22  
Old 02 Nov 2013, 00:25
skol skol is offline
 
Join Date: Oct 2008
Thats good advice,but it's not only down to mods/plugins.Vb is also different on specific php versions,but we cant go constantly testing php versions with the vb version or the mod/plugin.So we really need to see some more system requirements being more specific as to the version of 5.3 or 5.4.
Reply With Quote
  #23  
Old 02 Nov 2013, 00:49
nhawk nhawk is offline
 
Join Date: Jan 2011
LOL, just to add to the confusion...

4.2.2 is running fine on PHP 5.3.10 for me.
Reply With Quote
  #24  
Old 15 Oct 2014, 18:14
oldengine oldengine is offline
 
Join Date: Mar 2004
Now on vBulletin 3.8.9 Beta 2, but still looking.

Threads: 127,761, Posts: 1,041,312, Members: 74,459
Reply With Quote
  #25  
Old 15 Oct 2014, 18:31
Max Taxable's Avatar
Max Taxable Max Taxable is offline
 
Join Date: Feb 2011
Originally Posted by oldengine View Post
Now on vBulletin 3.8.9 Beta 2, but still looking.

Threads: 127,761, Posts: 1,041,312, Members: 74,459
If it ain't broke, don't fix it.
Reply With Quote
  #26  
Old 15 Oct 2014, 19:46
Yoshiburger Yoshiburger is offline
 
Join Date: Oct 2014
vB5.1 is broken, do NOT use it under any circumstances on a site you care about.
Reply With Quote
  #27  
Old 21 Oct 2014, 16:08
oldengine oldengine is offline
 
Join Date: Mar 2004
I suppose it could be considered broke in that I'm finding mods for version 4 that I cannot run on version 3.

If I update to 4, what exact version should I be targeting toward for starters?

Looks like Paul says: 4.2.1 or 4.2.2
Reply With Quote
  #28  
Old 21 Oct 2014, 16:54
Brandon Sheley's Avatar
Brandon Sheley Brandon Sheley is offline
 
Join Date: Mar 2005
Real name: Brandon
My suggestion is to stay far far away from vbulletin 5. It's nowhere near ready for prime time.
vBulletin 5 is broke in the fact that most of the site does not work and your members will hate you for "upgrading" to it.
__________________

Email me for website help: brandon[at]sheley[dot]org
Reply With Quote
  #29  
Old 21 Oct 2014, 18:05
Paul M's Avatar
Paul M Paul M is offline
 
Join Date: Sep 2004
Real name: Paul M
Originally Posted by oldengine View Post
I suppose it could be considered broke in that I'm finding mods for version 4 that I cannot run on version 3.

If I update to 4, what exact version should I be targeting toward for starters?

Looks like Paul says: 4.2.1 or 4.2.2
4.2.3 (wait for Beta 3 now, its due out soon).

For vB3, 3.8.9 (again, Beta 3 due in a week or two).
__________________
Former vBulletin.org Staff Member


Cable Forum
Please do not PM me about custom work - I no longer undertake any.
Note: I will not answer support questions via e-mail or PM - please use the relevant thread or forum.
Reply With Quote
  #30  
Old 21 Oct 2014, 18:29
Max Taxable's Avatar
Max Taxable Max Taxable is offline
 
Join Date: Feb 2011
Originally Posted by oldengine View Post
I suppose it could be considered broke in that I'm finding mods for version 4 that I cannot run on version 3.
You should list them. BoP5 has a huge list of v3 mods that work in v4, and otherwise. The two platforms are not so dissimilar that v4 mods cannot be also coded/ported to v3.

That's not a definition of "broken" by the way. You'll see "broken" and alot of misery and heartbreak - and loss of a ton of regular users - on a botched or glitchy "upgrade."

I've seen this happen even with a smooth "upgrade."

What's the compelling reason to "upgrade?"
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 22:03.

Layout Options | Width: Wide Color: