Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Digital Point Spy Details »
Digital Point Spy
Mod Version: 1.11, by digitalpoint (Coder) digitalpoint is offline
Developer Last Online: May 2016 I like it Show Printable Version Email this Page

vB Version: 4.x.x Rating: (35 votes - 4.69 average) Installs: 403
Released: 27 May 2010 Last Update: 10 Sep 2012 Downloads: 1960
Not Supported DB Changes Uses Plugins Auto-Template Additional Files  

About
This is a Digg-style spy for seeing what's going on in your forum in realtime.

This is something I originally made about 4 years ago. Now that I rewrote it for vBulletin 4 (it also now uses the bundled YUI for animation), I decided to also wrap it up as a product package and release it for the world to use.

Installation
  • Put the spy.php file in your forum folder.
  • Put the digitalpoint_spy.js file in your clientscript folder.
  • Install the product-digitalpoint_spy.xml product under AdminCP -> Plugins & Products -> Manage Products -> Add/Import Product
You can see a live version in action here:
http://forums.digitalpoint.com/spy.php


1.1.0 Update
  • Moved JavaScript to external file (works around template parsing bug with early versions of vBulletin 4.0.x).
  • XML generation is done with vBulletin's XML Builder class (let it deal with weird characters).
  • Switched JavaScript library to from YUI to jQuery (for an end user, it means better animations).
  • Changed do=xml to do=feed (works around servers that are overly protective and think they are trying to be hacked and blocking the request).

Download Now

Only licensed members can download files, Click Here for more information.

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
  #211  
Old 14 Dec 2010, 08:35
digitalpoint's Avatar
digitalpoint digitalpoint is offline
 
Join Date: Mar 2004
Real name: Shawn
Yep, works fine with 4.1.x
Reply With Quote
  #212  
Old 14 Dec 2010, 19:25
MonsterDK MonsterDK is offline
 
Join Date: Nov 2002
Digital Point.... my host fixed the problem. They had to change a setting on their security that was blocking something.
Works great now.

So for those of you that can't get this to work. You have the templates, you have the database table.. still does not work? Contact your host and ask them to look at it. Refer to the advice that digital point gave me on the previous page.

Thanks for your help digital point!!
Reply With Quote
  #213  
Old 14 Dec 2010, 19:27
MonsterDK MonsterDK is offline
 
Join Date: Nov 2002
QUESTION:
Is there a way to remove the link on the community drop down menu?
I'd rather just use the link to access it.
Reply With Quote
  #214  
Old 14 Dec 2010, 19:55
digitalpoint's Avatar
digitalpoint digitalpoint is offline
 
Join Date: Mar 2004
Real name: Shawn
You can disable the "Add Spy Link To Navigation" plug-in for the spy.
Reply With Quote
  #215  
Old 15 Dec 2010, 17:39
res6cue res6cue is offline
 
Join Date: Nov 2010
Nice mod!

One issue found and fixed, figured I'd pass it along so you can update the php file. After trying out the 'Only Include Subscribed Forums' function, I received a database error email advising me that 'subscribeforum' was not a valid table. Naturally this is true, because I use the vb_ prefix in my database. So I changed line 80 in the php file to include the table_prefix, and it works fine now.

In spy.php change line 80 from:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

To:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Reply With Quote
  #216  
Old 19 Dec 2010, 03:36
OziloZ's Avatar
OziloZ OziloZ is offline
 
Join Date: Jun 2006
i have problems with turkish characters

It says "unknown" at thread/post section when somebody creates a new thread or post a message.

Is this compatible with vb 4.1.0 PL2?
Reply With Quote
  #217  
Old 10 Jan 2011, 17:53
OldSchoolDSL OldSchoolDSL is offline
 
Join Date: Oct 2010
Real name: Adam H.
Originally Posted by res6cue View Post
Nice mod!

One issue found and fixed, figured I'd pass it along so you can update the php file. After trying out the 'Only Include Subscribed Forums' function, I received a database error email advising me that 'subscribeforum' was not a valid table. Naturally this is true, because I use the vb_ prefix in my database. So I changed line 80 in the php file to include the table_prefix, and it works fine now.

In spy.php change line 80 from:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

To:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.
This surely does help. Thank you.

Installed and working

4.1 PL2
Reply With Quote
  #218  
Old 11 Jan 2011, 20:06
res6cue res6cue is offline
 
Join Date: Nov 2010
Ok I found a rather odd issue that hopefully can be resolved:

From time to time, nothing populates on the page for logged in users. However if you log out and check the page as a guest, it populates! I've tried a ton of things to get it to work, including disabling all other mods, to no avail. The digitalpoint_spy table has all the entries in it (as evidenced by the page populating for guests), but it just refuses to populate for logged in users from time to time. The 'Only Include Subscribed Forums' option makes no difference, either it works or it doesn't regardless.

Is there anything that could be causing this behavior? It's driving me nuts, because I really want to keep this mod around, it's extremely handy and our users love it...when it works!
Reply With Quote
  #219  
Old 12 Jan 2011, 04:28
beatyourtruck's Avatar
beatyourtruck beatyourtruck is offline
 
Join Date: Jul 2005
Originally Posted by digitalpoint View Post
You can disable the "Add Spy Link To Navigation" plug-in for the spy.
Can you explain this a little more? what file to edit? Thanks! GREAT mod....my moderators love it to watch over the herd LOL
__________________
Beat Your Truck - RC web site and vB4 forum
Reply With Quote
  #220  
Old 12 Jan 2011, 11:19
res6cue res6cue is offline
 
Join Date: Nov 2010
Originally Posted by beatyourtruck View Post
Can you explain this a little more? what file to edit? Thanks! GREAT mod....my moderators love it to watch over the herd LOL
The easiest way to disable the link from showing on the navbar is to go to the Plugin Manager in the AdminCP, find Product : Digital Point Spy, uncheck the Active box for Add Spy Link To Navigation, then save active status. No need to edit any files.
Reply With Quote
  #221  
Old 12 Jan 2011, 20:32
digitalpoint's Avatar
digitalpoint digitalpoint is offline
 
Join Date: Mar 2004
Real name: Shawn
Originally Posted by res6cue View Post
Ok I found a rather odd issue that hopefully can be resolved:

From time to time, nothing populates on the page for logged in users. However if you log out and check the page as a guest, it populates! I've tried a ton of things to get it to work, including disabling all other mods, to no avail. The digitalpoint_spy table has all the entries in it (as evidenced by the page populating for guests), but it just refuses to populate for logged in users from time to time. The 'Only Include Subscribed Forums' option makes no difference, either it works or it doesn't regardless.

Is there anything that could be causing this behavior? It's driving me nuts, because I really want to keep this mod around, it's extremely handy and our users love it...when it works!
Are you getting any JavaScript or XML errors on the page when it doesn't show the feed?
Reply With Quote
  #222  
Old 12 Jan 2011, 22:47
Da-Vinci Da-Vinci is offline
 
Join Date: Mar 2010
Hi DP, great mod, installed and working 100% on 4.1.0 PL2, the only question I have is, are there any options in the Admin CP?

I saw very early on in the thread that somebody mentioned they have there's set to populate the last 10 entries from a historical record, yet I just can't find any options to alter anything anywhere in the ACP.

My forum is fairly busy but has peak times so at certain times of the day it's busier than others, I'd like it to load the last 10 Posts or Threads when the page is opened, obviously if the forum is experiencing lots of Posts/Threads these records would quickly move to the bottom of the page, otherwise they will sit there and show the last 10 entries.

Thanks in advance, installed and rated 5.
Reply With Quote
  #223  
Old 12 Jan 2011, 23:17
digitalpoint's Avatar
digitalpoint digitalpoint is offline
 
Join Date: Mar 2004
Real name: Shawn
As long as you've had posts within the last hour, it should fully populate on the initial page with the 25 last events...
Reply With Quote
  #224  
Old 12 Jan 2011, 23:28
res6cue res6cue is offline
 
Join Date: Nov 2010
Originally Posted by digitalpoint View Post
Are you getting any JavaScript or XML errors on the page when it doesn't show the feed?
Nope, the page itself loads fine, it just never populates. Checked in Firefox, Chrome and IE, same results for each. What's odd is that it populates for Guests as well as Users Pending Moderation, but not for Registered Users or any other "full access" accounts. Well, not consistently at least, sometimes it will and sometimes it won't. I just checked it as I was typing this and it wouldn't populate when I was logged in (either under my admin account or my test Registered Users account), however as soon as I logged out it started to populate.
Reply With Quote
  #225  
Old 13 Jan 2011, 00:01
Da-Vinci Da-Vinci is offline
 
Join Date: Mar 2010
Originally Posted by digitalpoint View Post
As long as you've had posts within the last hour, it should fully populate on the initial page with the 25 last events...
Yes I can see more posts now, it must of been because I had only just installed it and was only getting 4 results now, I'm nearer to 25, great hack thanks very much for the share.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 09:51.

Layout Options | Width: Wide Color: