Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Attached Image Watermarking PLUS Guest Viewing of Thumbnails Details »
Attached Image Watermarking PLUS Guest Viewing of Thumbnails
Mod Version: 1.00, by ConqSoft (Member) ConqSoft is offline
Developer Last Online: Mar 2012 I like it Show Printable Version Email this Page

This modification is in the archives.
vB Version: 3.6.8 Rating: (18 votes - 5.00 average) Installs: 208
Released: 12 Mar 2007 Last Update: 13 Mar 2007 Downloads: 1617
Not Supported Uses Plugins Additional Files  

I had been looking for these two options for quite a while, and was finally able to hire Brian (of vBadvanced) to write them for me. Since a lot of people have been looking for this, I have decided (with Brian's permission) to release this as a free, unsupported, modification.

This modification will allow you to specify a watermark image that will be overlayed over any attached JPG or PNG file on your site in real time, as the image is displayed. NO PERMANENT CHANGES ARE MADE TO ANY OF YOUR ATTACHMENTS. You can also exclude specific forums and usergroups from seeing the watermark.

As an added bonus, he included the ability to allow guests to see attached image thumbnails, while still requiring them to register to see the full size attachments. (Make sure you have your Unregistered / Not Logged In usergroup set to NOT have access to download attachments.)

PLEASE CLICK INSTALL so that maybe Jelsoft will include these as built-in features in a future version.

Notes/Troubleshooting:
  • Your server needs to have GD2 installed.
  • Attachments must be stored in the file system. Database storage of file attachments will not work.
  • Make sure you use the full PHYSICAL path to your watermark image.
  • Make sure you have a low number in the width/height setting. (I use 200, since my watermark image is 150 pixels wide.)
  • If you have previously viewed the attached image, your browser may cache it, so you will need to clear your browser cache or force a hard refresh (CTRL-F5) while viewing the image to get the new watermarked version.


Well, on to the modification:

=============================================
STEP 1:
Since the resulting file contains too much vBulletin code, I am unable to include it with this modification. So, the first step is to copy vBulletin's attachment.php to a file named attachment_watermark.php. Then, edit attachment_watermark.php, making the following changes.

=============================================
STEP 2:
You need to delete a LOT of lines from the top of the file. Find this line...

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

...and delete everything ABOVE it other than the <?php line at the top of the file.

Your attachment_watermark.php file should begin with this code when you've completed this step:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


=============================================
STEP 3:
Find this line of code:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

REPLACE with this code:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


=============================================
STEP 4:
Find these lines of code:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Add this code BELOW the lines referenced above:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


=============================================
STEP 5:
Find this line of code:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

REPLACE with this code:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


=============================================
STEP 6:
Find this line of code:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

REPLACE with this code:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

=============================================
STEP 7:
Find this line of code:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

REPLACE with this code:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


=============================================
STEP 8:
Save and upload attachment_watermark.php to your forum root directory.


=============================================
STEP 9:
Install the product-attach_watermark.xml Product via the vBulletin AdminCP Product Manager.


=============================================
STEP 10:
Configure the options at AdminCP -> vBulletin Options -> Attachment Watermarks. All fields should be self-explanatory.

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	attachment_watermark.gif
Views:	2453
Size:	77.0 KB
ID:	61784   Click image for larger version

Name:	mountairy_102205%20247.jpg
Views:	3087
Size:	63.4 KB
ID:	61785  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Add image fade effect to attached thumbnails Ntfu2 vBulletin 3.5 Template Modifications 19 27 Aug 2007 05:54

  #46  
Old 17 Mar 2007, 14:38
ConqSoft's Avatar
ConqSoft ConqSoft is offline
 
Join Date: Jul 2003
Not without some additional hacking/mods....
__________________
My Blog
GPS Discussion Forum

** Please do not contact me privately for help. Thanks. **

Last edited by ConqSoft; 18 Mar 2007 at 01:45.
Reply With Quote
  #47  
Old 19 Mar 2007, 12:13
Pottsy Pottsy is offline
 
Join Date: Sep 2006
Thanks - was just checking I understood it correctly.

One more thing - when the watermark is displayed (I'm using a transparent png) the overall quality of the displayed jpg goes down quite significantly. Is there any way around this?
Reply With Quote
  #48  
Old 19 Mar 2007, 13:51
voter's Avatar
voter voter is offline
 
Join Date: Dec 2006
Originally Posted by benjaminkramer View Post
yes I did
here is my attachment_watermark.php
I tested your attachment, works without problems.

Check if you really change your Attachment Storage Type into Filesystem

And the path to watermark image is correct in AdminCP -> vBulletin Options -> Attachment Watermarks
__________________
viparmenia.com
viparmenia.com
viparmenia.com
Reply With Quote
  #49  
Old 19 Mar 2007, 15:50
voter's Avatar
voter voter is offline
 
Join Date: Dec 2006
How about pictures putted via [ IMG ][ /IMG ] tags? Is there any way to put a watermark on them,too?
__________________
viparmenia.com
viparmenia.com
viparmenia.com
Reply With Quote
  #50  
Old 19 Mar 2007, 15:55
ConqSoft's Avatar
ConqSoft ConqSoft is offline
 
Join Date: Jul 2003
Originally Posted by voter View Post
How about pictures putted via [ IMG ][ /IMG ] tags? Is there any way to put a watermark on them,too?
No, this works for attached images only. If the images are on other servers you don't have any control over them, so you can't.

( Plus, they aren't on your server anyway, so you don't really have the right to watermark them. )
__________________
My Blog
GPS Discussion Forum

** Please do not contact me privately for help. Thanks. **
Reply With Quote
  #51  
Old 19 Mar 2007, 17:00
daddygrim's Avatar
daddygrim daddygrim is offline
 
Join Date: Mar 2006
Real name: MrGrim
any luck??????
Reply With Quote
  #52  
Old 19 Mar 2007, 17:01
ConqSoft's Avatar
ConqSoft ConqSoft is offline
 
Join Date: Jul 2003
Any luck with what?
__________________
My Blog
GPS Discussion Forum

** Please do not contact me privately for help. Thanks. **
Reply With Quote
  #53  
Old 22 Mar 2007, 12:38
voter's Avatar
voter voter is offline
 
Join Date: Dec 2006
There is a conflict with Attachments in Private Messages
http://www.vbulletin.org/forum/showt...83#post1209483
__________________
viparmenia.com
viparmenia.com
viparmenia.com
Reply With Quote
  #54  
Old 22 Mar 2007, 12:42
voter's Avatar
voter voter is offline
 
Join Date: Dec 2006
Originally Posted by ConqSoft View Post
No, this works for attached images only. If the images are on other servers you don't have any control over them, so you can't.

( Plus, they aren't on your server anyway, so you don't really have the right to watermark them. )
Sure for copyright one have no right to put his watermark on pictures from other servers, but I was thinking to put on images in [ img ] tags something like "Originaly on (URL)" and as URL to use the original path to image - so that people differ which pictures are from local forum and which not.
__________________
viparmenia.com
viparmenia.com
viparmenia.com
Reply With Quote
  #55  
Old 23 Mar 2007, 01:10
bacanze bacanze is offline
 
Join Date: Mar 2007
Great idea, I will give it a go tomorrow, anyone got an example?
Reply With Quote
  #56  
Old 24 Mar 2007, 17:35
phill2003 phill2003 is offline
 
Join Date: Apr 2003
good stuff, Installed thanks very much.
Reply With Quote
  #57  
Old 25 Mar 2007, 00:55
casidom casidom is offline
 
Join Date: Jul 2005
Thumbs up

ConqSoft!

Why don't you attach your attachment_watermark.php file and share it with us? That would be great. I followed all your steps, but it seems like not working at all. My attachment thumb nails did not show up.

And some more question for you, what is "The full physical path to the image you wish to use for your watermark."? Where do I find it? Does it look like "/var/www/vhosts/...../images/watermark.png"?

Thank you.
Reply With Quote
  #58  
Old 25 Mar 2007, 01:08
ConqSoft's Avatar
ConqSoft ConqSoft is offline
 
Join Date: Jul 2003
As I noted on the hack at the top, I can*t attach the file because it contains too much vBulletin code.

Yes, that would be the full physical path.
__________________
My Blog
GPS Discussion Forum

** Please do not contact me privately for help. Thanks. **
Reply With Quote
  #59  
Old 25 Mar 2007, 01:08
milsirhc's Avatar
milsirhc milsirhc is offline
 
Join Date: Jan 2007
Yup! If you can kindly attached the attachment_watermark.php, that would be fantasticcccc!!
Reply With Quote
  #60  
Old 25 Mar 2007, 02:35
casidom casidom is offline
 
Join Date: Jul 2005
Dear ConqSoft!

First of all I'd like to thank you for your quickly answer my question. Second of all, I'd like you to complete your steps in your first post because when I read all messeges in this thread, you and people have changed a lot of stuff in it. Like in secod page you said re-do step 5 and 6, I did and it still doesn't work. So, can you please post your final steps so we can follow it and make it work.

Thank you for you help.

By the way, your websites are really impresive!
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 07:39.

Layout Options | Width: Wide Color: