Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old 07 Jul 2014, 22:48
NarutoFTW NarutoFTW is offline
 
Join Date: Dec 2009
Login issue without www. included

My issue: I'm logged into my forum and my account stays logged in if I include www. in the front of the domain nanme.
However, If I take off www. and just write mydomain.com. I get logged out or just not logged in at all. However I am still logged in if I add www. in the right of the domain again.
Reply With Quote
  #2  
Old 07 Jul 2014, 22:54
ForceHSS's Avatar
ForceHSS ForceHSS is offline
 
Join Date: Apr 2008
What do you have it set to in the url settings and you can add a htaccess file to stop uses using what you don't want them too
Reply With Quote
  #3  
Old 07 Jul 2014, 22:57
NarutoFTW NarutoFTW is offline
 
Join Date: Dec 2009
You mean these settings? http://prntscr.com/40fi0u

and here's my htaccess file

RewriteEngine On

# If you are having problem with "None Could Be Negotiated" errors in Apache, uncomment this to turn off MultiViews
# Options -MultiViews

RewriteCond %{REQUEST_URI} !(admincp/|dbseocp/|modcp/|cron|mobiquo|forumrunner|api\.php|reviewpost/|classifieds/|photopost/)
RewriteRule ^((archive/)?(.*\.php(/.*)?))$ dbseo.php [L,QSA]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !/(admincp|dbseocp|modcp|clientscript|cpstyles|images|reviewpost|classifieds|photo post)/
RewriteRule ^(.+)$ dbseo.php [L,QSA]
Reply With Quote
  #4  
Old 08 Jul 2014, 00:00
Zachery's Avatar
Zachery Zachery is offline
 
Join Date: Jul 2002
Real name: Zachery Woods
Don't allow people to login to the site without the www, redirect them to the proper url.
__________________
Looking for ImpEx?
Reply With Quote
  #5  
Old 08 Jul 2014, 00:06
ForceHSS's Avatar
ForceHSS ForceHSS is offline
 
Join Date: Apr 2008
Originally Posted by NarutoFTW View Post
You mean these settings? http://prntscr.com/40fi0u

and here's my htaccess file

RewriteEngine On

# If you are having problem with "None Could Be Negotiated" errors in Apache, uncomment this to turn off MultiViews
# Options -MultiViews

RewriteCond %{REQUEST_URI} !(admincp/|dbseocp/|modcp/|cron|mobiquo|forumrunner|api\.php|reviewpost/|classifieds/|photopost/)
RewriteRule ^((archive/)?(.*\.php(/.*)?))$ dbseo.php [L,QSA]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !/(admincp|dbseocp|modcp|clientscript|cpstyles|images|reviewpost|classifieds|photo post)/
RewriteRule ^(.+)$ dbseo.php [L,QSA]
Site Name / URL / Contact Details these settings also under
RewriteEngine on put
RewriteEngine on
RewriteCond %{HTTP_HOST} ^yoursite.com [NC]
RewriteRule ^(.*)$ http://www.yoursite.com/$1 [R=301,L]
Reply With Quote
  #6  
Old 08 Jul 2014, 01:33
NarutoFTW NarutoFTW is offline
 
Join Date: Dec 2009
Originally Posted by ForceHSS View Post
Site Name / URL / Contact Details these settings also under
RewriteEngine on put
RewriteEngine on
RewriteCond %{HTTP_HOST} ^yoursite.com [NC]
RewriteRule ^(.*)$ http://www.yoursite.com/$1 [R=301,L]
Thank you sir
Reply With Quote
  #7  
Old 08 Jul 2014, 01:53
ForceHSS's Avatar
ForceHSS ForceHSS is offline
 
Join Date: Apr 2008
Happy to help
Reply With Quote
  #8  
Old 09 Jul 2014, 08:28
josh_krz josh_krz is offline
 
Join Date: Feb 2012
Real name: Josh Krzyworaczka
I am having the same issue however the solution above redirects to the public_html folder like so:

www.site.com/public_html

The .htaccess file is located outside the web directory.

EDIT: I have fixed this by using the following code. I assume it works with SSL too.


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


Last edited by josh_krz; 09 Jul 2014 at 09:27.
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 12:00.

Layout Options | Width: Wide Color: