Register Members List Search Today's Posts Mark Forums Read

Reply
 
Article Options
Fixed Main Table Width
amjadz4
Join Date: Aug 2007
Posts: 245

by amjadz4 amjadz4 is offline 30 Dec 2009

Okay so some themes come only with one width i.e 100% which fills up the screen. Like me, many want to match their website and want the width of the main table to be fixed. So how to adjust the width of the CMS, Blog and Forum all together?

vBulletin 3 had an easy way to do it, under Main CSS of the template. But in vB 4 its a bit different. Follow these steps to adjust the width of your vbulletin.

1. Log into AdminCP
2. Navigate to Styles & Templates > Your style > StyleVars
3. In the search field type in doc_width (under Common).
4. Now set the Units and Size as per your requirement, and Save. (default: auto)

That's it!

Now if at all for some reason your theme is not center aligned after adjusting the width do this:
  • Type doc_margin in the search field.
  • Set Left & Right to auto
Now you have your CMS, Blog and Forum center aligned to the width of your choice!

# Additional tip from anthony parsons:
Originally Posted by anthony parsons View Post
And don't forget to untick the "Use top margin for all sides" box, otherwise it will force left alignment.

Last edited by amjadz4; 01 Jan 2010 at 12:39..
Views: 5342
Reply With Quote
Comments
  #2  
Old 01 Jan 2010, 10:10
anthony parsons anthony parsons is offline
 
Join Date: Apr 2005
And don't forget to untick the "Use top margin for all sides" box, otherwise it will force left alignment.
Reply With Quote
  #3  
Old 30 Mar 2010, 06:14
sk8ordie778 sk8ordie778 is offline
 
Join Date: Mar 2010
This works perfect but for some reason my CMS is staying 100% forum and blog are fixed though. Any ideas?
Reply With Quote
  #4  
Old 30 Mar 2010, 08:30
amjadz4's Avatar
amjadz4 amjadz4 is offline
 
Join Date: Aug 2007
Originally Posted by sk8ordie778 View Post
This works perfect but for some reason my CMS is staying 100% forum and blog are fixed though. Any ideas?
Try changing values of doc_maxwidth & doc_minwidth.
Reply With Quote
  #5  
Old 30 Mar 2010, 09:13
sk8ordie778 sk8ordie778 is offline
 
Join Date: Mar 2010
Thanks for the reply.

I tried putting them on auto, and different pixel ranges still didn't work. What's weird is my title image I have set doesn't work for the CMS but works in my forum and blog. Does that give you any other clues?

Here's the site if you wanna take a look. http://skatecolony.com/forums/
Reply With Quote
  #6  
Old 30 Mar 2010, 11:28
amjadz4's Avatar
amjadz4 amjadz4 is offline
 
Join Date: Aug 2007
Originally Posted by sk8ordie778 View Post
Thanks for the reply.

I tried putting them on auto, and different pixel ranges still didn't work. What's weird is my title image I have set doesn't work for the CMS but works in my forum and blog. Does that give you any other clues?

Here's the site if you wanna take a look. http://skatecolony.com/forums/
The site shows 100% width. What unit are you using? Try making 900 px for doc_width and doc_maxWidth.
Reply With Quote
  #7  
Old 30 Mar 2010, 17:40
sk8ordie778 sk8ordie778 is offline
 
Join Date: Mar 2010
Ya I tried 900 px for both doc_width and doc_maxWidth. Still no change for the Home. I also tried creating a brand new style, put in my title image and changed the doc_width and doc_maxWidth to 900 and still home is at 100% in this new style.

Ok I just had a thought. When I opened up a new browser and I was not logged in to the site. The site shows me the default style layout which I think is what you saw. When I look at the site only the Home page is 100% forum/blog are at 1000px like I want.
I don't have default layout check marked and I have it set as the third style ID. Is there some option that could be hanging up the site to display the default layout and not my custom one?

I also just noticed when I open up another browser FF or IE and I go to my site my custom style does not show. But it displays fine in crome (the browser I've been doing testing in) this is probably because of cookie settings im assuming. I have my custom style checked under the style manager so shouldn't that be the default layout visitors see?

Last edited by sk8ordie778; 30 Mar 2010 at 18:00.
Reply With Quote
  #8  
Old 30 Mar 2010, 18:04
amjadz4's Avatar
amjadz4 amjadz4 is offline
 
Join Date: Aug 2007
Originally Posted by sk8ordie778 View Post
Ya I tried 900 px for both doc_width and doc_maxWidth. Still no change for the Home. I also tried creating a brand new style, put in my title image and changed the doc_width and doc_maxWidth to 900 and still home is at 100% in this new style.

Ok I just had a thought. When I opened up a new browser and I was not logged in to the site. The site shows me the default style layout which I think is what you saw. When I look at the site only the Home page is 100% forum/blog are at 1000px like I want.
I don't have default layout check marked and I have it set as the third style ID. Is there some option that could be hanging up the site to display the default layout and not my custom one?

I also just noticed when I open up another browser FF or IE and I go to my site my custom style does not show. But it displays fine in crome (the browser I've been doing testing in) this is probably because of cookie settings im assuming. I have my custom style checked under the style manager so shouldn't that be the default layout visitors see?
Okay I do not have a big screen on my laptop (14") .. so I could not make it out. Anyways, tell you what, if you really want to fix the issue, you can contact me via PM with your admin details, because I need to look into the settings and theme stylevars etc to find the problem. Can't really say what could be wrong from here!

Regards.
Reply With Quote
  #9  
Old 30 Mar 2010, 18:42
sk8ordie778 sk8ordie778 is offline
 
Join Date: Mar 2010
PM sent thanks for the help I really appreciate it.
Reply With Quote
Reply

Similar Article
Article Author Type Replies Last Post
End-User Options vB 4 - Fixed Main Table Width amjadz4 vBulletin 4.x Template Modifications 33 21 Nov 2013 15:19



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Article Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 17:19.

Layout Options | Width: Wide Color: