Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old 10 Aug 2011, 01:52
iDHKHCM iDHKHCM is offline
 
Join Date: Aug 2011
Arrow Any Help is appreciated

[CENTER]hey everyone. thanks for taking time out to read (admins/mods if this is the wrong section, i apologize didn't know where else to post, feel free to move thread)

okay so my site got hacked yesturday ect ect. restored it

on a new database. i changed all the config.php info to reflect this.
i double, tripled checked it.

i get the database error
when i right click and view page source
this is what i get as the error

Database error in vBulletin 4.0.3:

Invalid SQL:

SELECT
userfield.*, usertextfield.*, user.*, UNIX_TIMESTAMP(passworddate) AS passworddate, user.languageid AS saved_languageid,
IF(displaygroupid=0, user.usergroupid, displaygroupid) AS displaygroupid,
language.phrasegroup_global AS phrasegroup_global,
language.phrasegroup_holiday AS phrasegroup_holiday,
language.phrasegroupinfo AS lang_phrasegroupinfo,
language.options AS lang_options,
language.languagecode AS lang_code,
language.charset AS lang_charset,
language.locale AS lang_locale,
language.imagesoverride AS lang_imagesoverride,
language.dateoverride AS lang_dateoverride,
language.timeoverride AS lang_timeoverride,
language.registereddateoverride AS lang_registereddateoverride,
language.calformat1override AS lang_calformat1override,
language.calformat2override AS lang_calformat2override,
language.logdateoverride AS lang_logdateoverride,
language.decimalsep AS lang_decimalsep,
language.thousandsep AS lang_thousandsep
, (user.credits) AS vbcredits_1, user.credits AS vbcreditsb_1
FROM user AS user
LEFT JOIN userfield AS userfield ON (user.userid = userfield.userid)
LEFT JOIN usertextfield AS usertextfield ON (usertextfield.userid = user.userid) LEFT JOIN language AS language ON (language.languageid = IF(user.languageid = 0, 1, user.languageid))

WHERE user.userid = 1;

MySQL Error : Unknown column 'language.phrasegroupinfo' in 'field list'
Error Number : 1054


....................................................


any suggestions? ideas? for a fix?

timing isn't important, as anyone would i want my site up as fast as possible of course but i do understand that i have no idea what to do, so i need help. so take your time i will be here ready to read and listen.
again thanks for reading.

www.highclassmods.com

is the site i have a lockdown of the site as of now
but if u would like to see the error yourself feel free to ask.
i will give user and pass to get threw the protection

Thanks[/LEFT]

Last edited by iDHKHCM; 10 Aug 2011 at 05:11.
Reply With Quote
  #2  
Old 10 Aug 2011, 02:10
Disasterpiece's Avatar
Disasterpiece Disasterpiece is offline
 
Join Date: Apr 2007
for starters, you could change your text layout back to left-align, reading this all centered is a pain.

The database error looks like parts of the database structure are missing.

Did you restore an old backup from a different vbulletin version?
You could try to uncomment the line: (remove the //)

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

in your config.php file located in /includes/config.php
and see if this helps, but judging from the error, this doesn't seem like a plugin issue, rather than a malformed database structure.

Could you give details what you did exactly to roll back your forum to an older revision?
Reply With Quote
  #3  
Old 10 Aug 2011, 04:42
Lynne's Avatar
Lynne Lynne is offline
 
Join Date: Sep 2004
Real name: Lynne
Don't center your post text - it makes it hard to read stuff.

That error is because you are using files that are a different version from your database. If you downloaded 4.1.5 files, and are using a 4.0.3 database, then you need to run the upgrade.php scripts.
__________________
Former vBulletin.org Staff Member

Try a search before posting for help. Many users won't, and don't, help if the question has been answered several times before.
W3Schools -
Online vBulletin Manual
If I post some CSS and don't say where it goes, put it in the additional.css template.
I will NOT help via PM (you will be directed to post in the forums for help.)
Reply With Quote
  #4  
Old 10 Aug 2011, 05:12
Boofo's Avatar
Boofo Boofo is offline
 
Join Date: Mar 2002
Real name: Rob
I got that same error when I upgraded from 4.1.3 PL3 to 4.1.5 PL1. It didn't show on the screen during the upgrade process, but it sent the email. Haven't seen it since, though.
Reply With Quote
  #5  
Old 10 Aug 2011, 05:18
iDHKHCM iDHKHCM is offline
 
Join Date: Aug 2011
Originally Posted by Disasterpiece View Post
for starters, you could change your text layout back to left-align, reading this all centered is a pain.

The database error looks like parts of the database structure are missing.

Did you restore an old backup from a different vbulletin version?
You could try to uncomment the line: (remove the //)

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

in your config.php file located in /includes/config.php
and see if this helps, but judging from the error, this doesn't seem like a plugin issue, rather than a malformed database structure.

Could you give details what you did exactly to roll back your forum to an older revision?
kk centered is off, i was trying to make it easier to read lol i guess i was way off.


okay so here it is

i was on 4.0.3 vb we got hacked. restored the site, then updated to latest version of vb.

i was putting on some password protection on directories threw cpanal (like admincp ect)

when i notice the forums were missing the background. Buttons (images) from threads were missing. I immediately took off all the password protection (thinking it had something to do with it)

it didnt, problem was still their.. so i went to restore. (usually hosting provider does this for me) i read i had to delete my database then restore my back up... so i deleted my main database n went to restore it. deleted it in mysql but it still showed up in phpadmin.

so i created a brand new database. restored the back up sql onto that. change the config.php to the new database, user, n pass ect.

n now the error

sorry for writing so much just didnt want to leave anything out. that was pretty much 9 hours today all in one page lol.

so what do you think?

--------------- Added 10 Aug 2011 at 05:21 ---------------

Originally Posted by Lynne View Post
Don't center your post text - it makes it hard to read stuff.

That error is because you are using files that are a different version from your database. If you downloaded 4.1.5 files, and are using a 4.0.3 database, then you need to run the upgrade.php scripts.
centered is off, love all your work by the way! and i will run the upgrade.php and get back to you guys thanks for everything its 4 am here off to bed but will do in the morning. also would i just ftp the 4.1.5 install folder? or all of the 4.1.5 patch level 1 files back into the ftp?

--------------- Added 10 Aug 2011 at 20:45 ---------------

Originally Posted by Lynne View Post
Don't center your post text - it makes it hard to read stuff.

That error is because you are using files that are a different version from your database. If you downloaded 4.1.5 files, and are using a 4.0.3 database, then you need to run the upgrade.php scripts.
the upgrade worked great everything was fine.

admincp works great.

but the physical website gets this error



Warning: Invalid argument supplied for foreach() in [path]/includes/block/threads.php on line 221

Warning: Invalid argument supplied for foreach() in [path]/includes/block/newposts.php on line 195

disable the plugins threw config still error so safe to say its not a plugin

any ideas? i reuploaded threads.php and newposts.php but same error

Last edited by iDHKHCM; 10 Aug 2011 at 21:33.
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 12:24.

Layout Options | Width: Wide Color: