Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Picture and Album Gallery Details »
Picture and Album Gallery
Mod Version: 1.09, by HCGB (Coder) HCGB is offline
Developer Last Online: Oct 2012 I like it Show Printable Version Email this Page

vB Version: 4.1.0 Rating: (162 votes - 4.85 average) Installs: 1360
Released: 10 Mar 2010 Last Update: 12 Jan 2011 Downloads: 7802
Not Supported Uses Plugins Auto-Template Additional Files Re-usable Code Translations  

Picture and Album Gallery for vB4


This is a simple mod written out of frustration with the lack of such a basic feature in vb4 (and vb3, etc....)

Features:
Adds a Gallery drop-down menu to the nav bar OR to the navtab which allows browsing AND searching of all pictures and albums on your site.

The search function searches the album title, album description, picture caption AND username.

Note: If guest permission AdminCP->Usergroups->UserGroup Manager->Unregistered/Not Logged In->Can View Albums is "yes" then they will be able to browse album and picture thumbnails - they may NOT be able to view the full-size pictures. To hide the gallery menu from guest see Settings below.

The gallery and menu is phrased.

Tested with Vbulletin 4.0.2/3 (note: earlier versions have not been tested and are not supported) AND vBadvanced 4 beta1.

Settings:
None are needed - it does what it says on the tin .

AdminCP->Options->User Profile:Album Options "Pictures Per Page" and "Albums Per Page" control the number of thumbnails displayed per page in each gallery type.

If you get images overlapping the borders then you have inconsistent thumbnail sizes - you need to:
AdminCP->Maintenance->Update Counters->Rebuild Attachment Thumbnails

If you want to hide the Gallery menu from guests then edit the Gallery navbar (or navtab) popup menu plugin and change $allowguests = from true to false

Installation
  1. Unzip the download package and copy the contents of the UPLOAD folder into your forum folder.
  2. Go to the VB AdminCP->Plugins & Products click "Manage Products". The click "Add/ImportProduct" at the bottom of the page.
  3. Click "Browse" button and point to the product-gallery-(etc).XML file included in this ZIP package.
  4. Click "Import"
  5. Once the gallery import is complete, click "Add/Import Product" again and select EITHER product_gallery_navtab-xxx.xml OR product_gallery_navbar-xxx.xml depending on where you want the gallery menu to appear (navbar or navtab).
... all done

Updates

To update from an older version you MUST uninstall the product (admincp->manage products: delete Picture and Album Gallery). Then re-install as above.

v1.08
tested on vb4.0.3
v1.07
Fixed navtab menu - picture and album URLS swapped

Converted navtab/bar into products to make installation easier.
v1.06
Due to popular demand added navtab drop down menu (with help from
TimberFloorAu )
Cleaned up code and templates
v1.05
Phrased menu items - upgrade is not required unless you use other languages.

v1.04b
fixed database connection issue

deleted unused template from product xml
v1.03b
Changed permissions to allow guests to view thumbnail galleries

Added phrasing for main gallery code.
Removed navbar template - replaced by plug-in code
Changed album display template from albumbit to album_latestbit (it works better!)
Various template mods to clean up display
v1.02b
Wasn't remembering search query between pages.


This is my first "proper" product so comment/criticism/etc is welcome

John

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	albs.jpg
Views:	20167
Size:	86.0 KB
ID:	113797  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Social Group and Album Enhancements Album Picture Clicks to Next Picture in Album Abe1 vBulletin 3.7 Template Modifications 24 15 Mar 2011 04:45

  #781  
Old 16 Jan 2014, 12:37
giorgioarmani giorgioarmani is offline
 
Join Date: Dec 2006
Can we show the latest photos on the homepage?

How can I translate this?
Reply With Quote
  #782  
Old 16 Jan 2014, 13:03
Videx's Avatar
Videx Videx is offline
 
Join Date: Feb 2007
Originally Posted by ringnews24 View Post
Anyone?????

I have no gallery anyone help?
I guess not. The mod is not only marked as "not supported" but the coder clearly hasn't been around since October 2012.

Originally Posted by giorgioarmani View Post
How can I translate this?
I'm not sure, but generally VB translations are done in Phrases.

Originally Posted by giorgioarmani View Post
Can we show the latest photos on the homepage?

How can I translate this?
Yes, but I don't think it does this by default, so you may have to search this thread for the solution.
Reply With Quote
  #783  
Old 16 Jan 2014, 17:28
giorgioarmani giorgioarmani is offline
 
Join Date: Dec 2006
Thanks @Videx

Are there any alternatives that can show photo albums on the homepage?
Reply With Quote
  #784  
Old 16 Jan 2014, 17:38
Videx's Avatar
Videx Videx is offline
 
Join Date: Feb 2007
Originally Posted by giorgioarmani View Post
Thanks @Videx

Are there any alternatives that can show photo albums on the homepage?
This one has always worked for me so I'm the wrong person to ask. I am unaware of another solution.
Reply With Quote
  #785  
Old 16 Jan 2014, 18:34
giorgioarmani giorgioarmani is offline
 
Join Date: Dec 2006
And how did you get the gallery to show on the homepage?
Reply With Quote
  #786  
Old 16 Jan 2014, 20:04
Videx's Avatar
Videx Videx is offline
 
Join Date: Feb 2007
Heck if I remember - it's been years. Like I said, you're going to have to look for it.
Reply With Quote
  #787  
Old 16 Jan 2014, 20:07
RichieBoy67's Avatar
RichieBoy67 RichieBoy67 is offline
 
Join Date: Apr 2004
Real name: Richie
Yeah, There is a mod. I have it on one of my sites as well. I will see if I can find it for you if not found before I get to it.

#Update - That was easier than I thought. Here you go


http://www.vbulletin.org/forum/showthread.php?t=228618
__________________

Let us take care of your forum, seo, seo reports, maintenance, what ever you need.

Reply With Quote
  #788  
Old 16 Jan 2014, 20:23
giorgioarmani giorgioarmani is offline
 
Join Date: Dec 2006
Originally Posted by RichieBoy67 View Post
Yeah, There is a mod. I have it on one of my sites as well. I will see if I can find it for you if not found before I get to it.

#Update - That was easier than I thought. Here you go


http://www.vbulletin.org/forum/showthread.php?t=228618
That's a good start!

Problem is that show in the "What's Going On" section and I have that disabled.

Any ideas how to move it to the top?
Reply With Quote
  #789  
Old 17 Mar 2014, 20:43
s_cocis s_cocis is offline
 
Join Date: Nov 2011
Hello, the addons is compatible with 4.2.2 ?
Reply With Quote
  #790  
Old 30 Mar 2014, 15:38
BarelyHangingOn BarelyHangingOn is offline
 
Join Date: Feb 2003
This mod has screwed up the colours on my navbar.

Like others it made the links in the dropdowns white on white.

I changed the navbar template and changed it to black which fixed the problem.

Now on the main page the titles as well have change from white to black even though in the navbar template I have it set to white.

Prior to upgading to 4.2.2 the text was white on the main page and the links in the drop down menu were black on white.

Does anybody have a fix for this?
Attached Images
File Type: jpg navbar.JPG (10.9 KB, 14 views)
Reply With Quote
  #791  
Old 31 Mar 2014, 06:45
RichieBoy67's Avatar
RichieBoy67 RichieBoy67 is offline
 
Join Date: Apr 2004
Real name: Richie
I just realized my album images are not showing up in Internet Explorer. I am not sure if this mod is the cause. Can someone else with the latest Vb4 check and see if you are seeing the images in IE?

Thanks,
Rich
__________________

Let us take care of your forum, seo, seo reports, maintenance, what ever you need.

Reply With Quote
  #792  
Old 31 Mar 2014, 13:40
Videx's Avatar
Videx Videx is offline
 
Join Date: Feb 2007
Originally Posted by RichieBoy67 View Post
I just realized my album images are not showing up in Internet Explorer. I am not sure if this mod is the cause. Can someone else with the latest Vb4 check and see if you are seeing the images in IE?

Thanks,
Rich
Not sure which site you want us to look at; the one in your sig doesn't seem to be a forum. FWIW, this all seems to work on our forum (Shannondale.org) in IE.
Reply With Quote
  #793  
Old 31 Mar 2014, 15:36
RichieBoy67's Avatar
RichieBoy67 RichieBoy67 is offline
 
Join Date: Apr 2004
Real name: Richie
Originally Posted by Videx View Post
Not sure which site you want us to look at; the one in your sig doesn't seem to be a forum. FWIW, this all seems to work on our forum (Shannondale.org) in IE.
Thanks,

I actually meant I wanted you to see if it was working for you guys on your sites.

My site is musclemecca.com if you want to check
__________________

Let us take care of your forum, seo, seo reports, maintenance, what ever you need.

Reply With Quote
  #794  
Old 31 Mar 2014, 16:00
RichieBoy67's Avatar
RichieBoy67 RichieBoy67 is offline
 
Join Date: Apr 2004
Real name: Richie
## I tried a few simple things to fix this but nothing has worked yet.

I tried uninstalling this plug, deleting the files and reinstalling. I also tried a standard style.

All the other images on the site work fine in ie. It is just the albums.
__________________

Let us take care of your forum, seo, seo reports, maintenance, what ever you need.


Last edited by RichieBoy67; 31 Mar 2014 at 17:00.
Reply With Quote
  #795  
Old 31 Mar 2014, 20:23
Videx's Avatar
Videx Videx is offline
 
Join Date: Feb 2007
Originally Posted by RichieBoy67 View Post
Thanks,

I actually meant I wanted you to see if it was working for you guys on your sites.

My site is musclemecca.com if you want to check
Confirmed here too. Okay in Chrome, but in IE 11 there are X's in place of the images. You don't have something odd like vbseo installed? Anyway, I guess you've already tried at least disabling all your other mods?
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 15:43.

Layout Options | Width: Wide Color: