Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
VSa - Advanced Forum Statistics (AJAX) Details »
VSa - Advanced Forum Statistics (AJAX)
Mod Version: 7.1, by Valter (Coder) Valter is offline
Developer Last Online: May 2014 I like it Show Printable Version Email this Page

vB Version: 4.x.x Rating: (238 votes - 4.74 average) Installs: 2508
Released: 14 Feb 2010 Last Update: 02 Aug 2012 Downloads: 19887
Not Supported DB Changes Uses Plugins Auto-Template  

Info:
AJAX Forum Statistics:
-Latest Posts
-Latest Forum News
-Most Viewed Threads
-Hottest Threads
-Most Popular Forums
-Latest Classified Ads
-Latest Blog Entries
-Latest Group Posts
-Newest Members
-Top Posters
-Top Thread Starters
-Top Referrers
-Top Reputations
-Top Thanked
-Top Infractions
-Profile Visits
-Latest Social Groups
-Latest Donations

You can turn on/off individual stats, count data from last x days for some of them if you wish, trim titles/usernames to save page space, make several other functionality/make-up customizations... See screenshots.


You can have Main Stats box shown on several pages...
It's shown by default on forumhome (to disable it set "Main Top Stats box on ForumHome" to "None")
To activate another location:
a) add THIS_SCRIPT name to "Stats on pages" field in product options
b) add template name to "Stats in templates" field in product options
c) add "{vb:raw vsatopstats}" to the template you added Stats to


Notes:
-To set options go to: vBulletin Options > VSa - Advanced Forum Statistics
-"Top Thanked" requires Abe1's "Post Thanks" or Scandal's "Thumbs Up?" products to work
-"Latest Donations" requires "VSa - PayPal Donate" hack to work
-To move Top Stats box somewhere else on forumhome: 1.-Set placement setting to "None" 2.-Add "index" to "Stats on pages" setting 3.-Add "FORUMHOME" to "Stats in templates" setting 4.-Add "{vb:raw vsatopstats}" wherever you wish in FORUMHOME template.
-If Top Stats box is messed up because of long usernames or thread/forum titles be noted that you can trim them in ACP options.
-When forum/thread titles or usernames are trimmed, mouse-over will show you full version.


Installation:
-Import XML file (as product) through AdminCP: Plugin System > Manage Products > [Add/Import Product]


Versions:
v1.0 - Jun 12. 2006.
-First release
v6.6.1 - May 14. 2009.
-Latest vB 3.x version
v7.0 - Feb 14. 2010.
-First vB4 release
-Fixed some previous version bugs, optimized code
v7.0.1 - Feb 16. 2010.
-Fixed: Newpost/lastpost linking in 'Latest Posts'
-Fixed: Errors with PHP 5.3
-Fixed: AFS table messed up in footer
-Fixed: Several style errors, including XHTML incompatibilities
-New: Auto-insert on forumhome location - Below Forums
v7.0.2 - Feb 22. 2010.
-Fixed: Several style issues for unregistered users
-Fixed: 'Latest Donations' issues
-Fixed: Import error on some configs
-Fixed: Minor bugs
v7.0.3 - Apr 12. 2010.
-Fixed security bug (user able to set number of results manually)
v7.0.4 - Jan 14. 2012.
-Fixed: Status icons must be GIFs
-Fixed: Status icon overlay problems in Chrome and Safari
-Fixed: Drop-down menu items invisible until highlighted
-Fixed: Last unread post links not compatible with vBSEO
-Fixed: Search Member's posts shows results as threads
-Added: Rich thread prefix support
-Improved: CSS compatibility
-Minor bugs fixed
v7.0.5 - Jan 15. 2012.
-Links in Latest Posts are now fully SEO compatible
-New option: Automatically disable auto-refresh if server load is higher than X
v7.0.6 - Jan 17. 2012.
-Fixed: Prefixes linked in some thread stats
v7.0.7 - Jan 22. 2012.
-New: Show Stats in selected forum only
-Fixed: Some style issues
-Improved: Product menu style
-Improved: Menu disappears on click
-Changed background color variable: 'editor_background' used for better compatibility with custom styles
v7.0.8 - May 27. 2012.
-Fixed: QL Enable Stats link in vB 4.2
v7.0.9 - Jul 07. 2012.
-Fixed: Hide on misc.php requests not related to Stats
v7.1 - Avg 02. 2012.
-New: Top Thanked now works with "Thumbs Up?" system by Scandal
-Note: Above still works with "Post Thanks" system by Abe

Download Now

Only licensed members can download files, Click Here for more information.

Addons

Screenshots

Click image for larger version

Name:	stats1.jpg
Views:	21187
Size:	178.7 KB
ID:	112315   Click image for larger version

Name:	stats2.jpg
Views:	14943
Size:	153.8 KB
ID:	112316   Click image for larger version

Name:	menu.jpg
Views:	9679
Size:	65.4 KB
ID:	112317   Click image for larger version

Name:	more.jpg
Views:	10668
Size:	73.7 KB
ID:	112318  

Click image for larger version

Name:	acp1.jpg
Views:	7327
Size:	109.4 KB
ID:	112319   Click image for larger version

Name:	acp2.jpg
Views:	6052
Size:	117.0 KB
ID:	112320  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Statistics Modifications Cyb - Advanced Forum Statistics Valter vBulletin 3.8 Add-ons 1232 19 Aug 2020 08:32
Statistics Modifications Cyb - Advanced Forum Statistics Valter vBulletin 3.7 Add-ons 651 02 Sep 2013 12:25
Statistics Modifications Cyb - Advanced Forum Statistics Valter vBulletin 3.6 Add-ons 1599 15 Feb 2013 02:33
Cyb - Advanced Forum Statistics Valter vBulletin 3.5 Add-ons 116 16 May 2010 02:57

  #1231  
Old 16 Apr 2014, 17:06
Bob_R Bob_R is offline
 
Join Date: Jun 2009
Anyone?

Again, thanks.
Reply With Quote
  #1232  
Old 18 Apr 2014, 15:46
prezer prezer is offline
 
Join Date: Nov 2011
Originally Posted by [email protected] View Post
Got a bit of a head scratcher with this mod. I have one user almost permanently logged in to my forum with UA Chrome 30.xx which somehow causes the session table to fill up with thousands of rows with queries to this mod, sometimes a mere 2 minute session is enough to bang the table up to its 16mb limit. Curiouser still is that no other members using the same UA causes this problem. Have any of you boffins run into this issue; am I overlooking something obvious?

Running 4.2.2 on PHP 5.4.20 and Mysql 5.5.32
Yes crons are running and yes, my footer table sports the cron image as is required.


_____________________________________

Never mind. The member was running an Auto refresh script in Chrome on top of the mods' own built in auto refresh system; collision city
I had the same problem. I tune settimeout function, problem solved.
Reply With Quote
  #1233  
Old 23 Apr 2014, 03:36
socialteenz's Avatar
socialteenz socialteenz is offline
 
Join Date: May 2011
Originally Posted by SPEEDKILLZ View Post
Note i have already tried


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Try this.


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

__________________
Reply With Quote
  #1234  
Old 28 Apr 2014, 11:08
WxP's Avatar
WxP WxP is offline
 
Join Date: Dec 2005
I cant import this addons how is possible in 88% uploading page go offline but when i refresh it is avrything Ok.
Reply With Quote
  #1235  
Old 06 May 2014, 20:23
Moh4m4d Moh4m4d is offline
 
Join Date: Feb 2010
Real name: Mohamad
H! all
i'm want usign the session or Authentication for obtaining Username in file class_+++++++topx.php
but i'm faced with a blank pasge
in private varibel add
private $taccess
and in construct add
$this->taccess = $vbulletin->userinfo['userid'];
and add line 866
$sessionid = $taccess ;
$get_new_posts[fullthreadtitle] ="$session";
pleas help me
thanks
Reply With Quote
  #1236  
Old 02 Jun 2014, 22:28
boochaka boochaka is offline
 
Join Date: May 2008
To fix the read/unread status of the latest posts change:

< $readtime = $vbulletin->userinfo['lastvisit'];
< if ($vbulletin->userinfo['userid']) {
< $is_new = $vbulletin->db->query_read("SELECT readtime FROM threadread where userid = " .
< $vbulletin->userinfo['userid'] .
< " AND threadid = " .
< $get_new_posts[threadid]);
< while ($times = $vbulletin->db->fetch_array($is_new)) {
< $readtime = $times['readtime'];
< break;
< }
< }
<
< if ($get_new_posts[lastpost] > $readtime)
---
> if ($get_new_posts[lastpost] > $vbulletin->userinfo['lastvisit'])

This changes it from comparing 'last visit' to the actual last time the user read the thread.

beware, I have no idea what kind of performance impact this may cause.
Reply With Quote
  #1237  
Old 21 Jun 2014, 18:00
yukirina yukirina is offline
 
Join Date: Apr 2014
The mod is extraordinary and I really love it, but I still don't know why auto-refresh is not working. It loads every 10 seconds and says auto refreshed but it doesn't refresh anything. PHP is not in safe mode. What am I missing?

Also, is it possible to change timestamp to "X minutes/hours/days/weeks/months ago" instead?

Last edited by yukirina; 21 Jun 2014 at 18:25.
Reply With Quote
  #1238  
Old 22 Jun 2014, 10:58
NewGameX NewGameX is offline
 
Join Date: Jan 2012
Latest Icons are gone in my website. I upgraded addon but it is still not working. Can you please help me?
Reply With Quote
  #1239  
Old 22 Aug 2014, 15:25
badboykila badboykila is offline
 
Join Date: Sep 2011
Hello, I was wondering how to fix this problem I've been having. I've looked into a lot of style vars that are quoted in the vsa_topstats templates but most of the stylevars don't exist in my themes vars.

Here is a picture of what I'm talking about.
'

As you can see the username is overlapping the date.

I've already tried changing the width of my forums but it doesn't change.
Reply With Quote
  #1240  
Old 06 Sep 2014, 00:12
jclf jclf is offline
 
Join Date: Apr 2014
Hello good morning:
I have a problem with this mod and is as follows:
The 7.1 version is installed
At one point go to my forum as a user in the menu options of this mod ahy an option to turn off the statistics, but it turns out after I wanted to activate again and I can not do it, other users if they can see them perfectly but after disabling them I can not see.
Reply With Quote
  #1241  
Old 06 Sep 2014, 22:26
Alan_SP's Avatar
Alan_SP Alan_SP is offline
 
Join Date: Nov 2009
I think you're saying you can't turn mod on again once you turn it off?

If it is so, you have option to do this in quick links, if I'm not mistaken.
Reply With Quote
  #1242  
Old 12 Sep 2014, 07:19
xpwmaster xpwmaster is offline
 
Join Date: Dec 2009
anyone had any exploit problem with this script or can say its 100% safe . i would love to know the some coder here can check and verify if this script after all this years is safe to put .
Reply With Quote
  #1243  
Old 17 Sep 2014, 12:47
rohirrim rohirrim is offline
 
Join Date: Oct 2011
on firefox and ie everything works fine. But on chome the img for new post is too small which is almost invisible. Please look at the attachments...
Attached Images
File Type: jpg firefox.jpg (39.3 KB, 19 views)
File Type: jpg chrome.jpg (36.6 KB, 13 views)
Reply With Quote
  #1244  
Old 22 Sep 2014, 19:33
iraqiboy90 iraqiboy90 is offline
 
Join Date: Sep 2012
What is happening?!
I have noticed this today. Dont know if this has been happening before.

I have two users having crazy hits pr minute.

The first user were using chrome.

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

in a constant loop.
744 request pr minute.

Second user, using nexus 7 phone, same thing, but 393 requests pr minute.

Is this an exploit or what?

Currently disabled until figured out
Reply With Quote
  #1245  
Old 02 Oct 2014, 15:17
rohirrim rohirrim is offline
 
Join Date: Oct 2011
Originally Posted by boochaka View Post
To fix the read/unread status of the latest posts change:

< $readtime = $vbulletin->userinfo['lastvisit'];
< if ($vbulletin->userinfo['userid']) {
< $is_new = $vbulletin->db->query_read("SELECT readtime FROM threadread where userid = " .
< $vbulletin->userinfo['userid'] .
< " AND threadid = " .
< $get_new_posts[threadid]);
< while ($times = $vbulletin->db->fetch_array($is_new)) {
< $readtime = $times['readtime'];
< break;
< }
< }
<
< if ($get_new_posts[lastpost] > $readtime)
---
> if ($get_new_posts[lastpost] > $vbulletin->userinfo['lastvisit'])

This changes it from comparing 'last visit' to the actual last time the user read the thread.

beware, I have no idea what kind of performance impact this may cause.
On my db it's allready if ($get_new_posts[lastpost] > $vbulletin->userinfo['lastvisit'])

but still When I go to a thread it does not mark it as read.. How can I fix this? Please

Although I select Admin CP -> Settings -> Options -> General Settings -> Thread/Forum Read Marking Type: Change it to Database (automatic forum marking). Still have the problem?

Last edited by rohirrim; 02 Oct 2014 at 16:19.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 08:24.

Layout Options | Width: Wide Color: