Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Complete Wordpress/Vbulletin Bridge - Share Users And Postings Details »
Complete Wordpress/Vbulletin Bridge - Share Users And Postings
Mod Version: 4.01.13, by Jafo232 (Coder/Designer) Jafo232 is offline
Developer Last Online: Oct 2017 I like it Show Printable Version Email this Page

vB Version: 3.8.1 Rating: (83 votes - 4.40 average) Installs: 1330
Released: 14 Feb 2009 Last Update: 16 Feb 2011 Downloads: 5467
Not Supported DB Changes Uses Plugins Additional Files  

Identical to this Mod here, but now for the Vbulletin 3.8 line.
DOES NOT WORK FOR Vbulletin 4.x

This version probably no longer works for Wordpress 3.x. I have started developing this product over and have released the NEW version here:

http://www.lampwrights.com/showthread.php?t=41




This mod bridges your Vbulletin users over to Wordpress. You can also use Vbulletin as your comment engine instead of the spammy one built into Wordpress. You can display the comments inline in your post. You need not use the comment feature, if your only interested in sharing users.

You can map your Vbulletin Usergroups to Wordpress Usergroups and those users will then be recognized as registered Wordpress users.

For example, user "Joe" registers at your forum and logs in. Joe then clicks on your Wordpress page. Joe is instantly added to the Wordpress user base with the permissions you set for his usergroup. In otherwords, if a user comes over belonging to the "Registered User" group, you can select that he is placed in the Wordpress "Subscriber" usergroup.

If you change a users group from vbulletin, it will automatically change in Wordpress.

Requirements:
  • DOES NOT and WILL NEVER support Wordpress MU.
  • Wordpress and Vbulletin scripts must reside on the same physical server.
  • Wordpress and Vbulletin must use the same domain name.
  • Stable Wordpress Version greater than or equal to 2.7.
  • DOES work for Vbulletin 3.7.
  • Does work for vBulletin 3.8.
Limitations:
  • Does not work for 4.x. Why? Because VB 4.x does not work for me. If they ever make that product worth a shit, I might support it.
  • Please don't ask if it works for any BETA versions of Vbulletin. I do not know and will not convert this to the latest version of VB (whatever it is at the time you are reading this) until the version is released as non-beta.
  • Does not work with XMLRPC.
  • Chances are, this will not work when VB and Wordpress are located in different sub domains. I.E. forum.yoursite.com - blog.yoursite.com. Cookie issue.
  • I did the best I could in determining your forums file path with the script. There may be certain script setups that cannot find the file path properly, in which case you may get errors that the script cannot find or open /config.php. If this is the case, please HARDCODE your ABSOLUTE path to the forum in vbridge.php.

    To do this find:


    Block Disabled:      (Update License Status)  
    Suspended or Unlicensed Members Cannot View Code.

    And uncomment the last line, and change the path to your forums path:


    Block Disabled:      (Update License Status)  
    Suspended or Unlicensed Members Cannot View Code.

Common Mistakes When Installing:
  • Using two different host names causes problems. If your forum URL contains www.yourdomain.com, then your wordpress blog URL MUST contain the www. part of www.yourdomain.com also. This goes for any other host name. Browsers are finnecky when it comes to cookies (as they should be).
  • Editors generally EDIT, not write. In Wordpress, editors don't show up in the post author drop down. This has nothing to do with this plugin, that is Wordpress code.
  • Make sure you DO NOT create a subdirectory for this plugin in the wp-content/plugins directory. Just upload it directly there..
  • If you do not map users before you turn auto-integrate on, the plugin has no idea whether your allowed into the dashboard.
  • If you all of a sudden can't login to the dashboard, see the above two common mistakes.
  • FOLLOW the directions and make a test post first. Being in a rush and not testing will most likely turn out bad for you.
UPDATES:

Changelog is included in download, here is the most recent changes:

3/09/2009
  • Added code to process scheduled posts
  • Addressed code where links and images would not show up properly in VB
  • Added new table called vb_forumid for scheduled posts
  • Reduced redundant calls when dealing with forum excerpts
Sites Using This Plug-In:(PM me if you want to add your site here)

Special Thanks:

axisoverdrive - Debugging Help, Kyraal - Paypal Donation, Kalina - Paypal Donation, Wildcard27 - Paypal Donation, Shri - Paypal Donation, pspcrazy - Paypal Donation, Tomahoochi - Paypal Donation.

If you use this plug-in, and find it useful, please support us by nominating us for Mod Of The Month (MOTM) in the top right corner of this thread, or feel free to donate.

If you do install:

Download Now

Only licensed members can download files, Click Here for more information.

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Integration with vBulletin Complete Wordpress/Vbulletin Bridge - Share Users And Postings Jafo232 Modification Graveyard 1318 24 Mar 2013 18:45
Integration with vBulletin Complete Wordpress/Vbulletin Bridge - Share Users And Postings Jafo232 vBulletin 3.7 Add-ons 359 07 Mar 2012 15:18
Integration with vBulletin VBulletin-Wordpress Bridge for 3.64 imranbaig vBulletin 3.6 Add-ons 53 22 Mar 2008 17:41

  #151  
Old 22 Feb 2009, 13:35
Jafo232 Jafo232 is offline
 
Join Date: May 2004
Originally Posted by pypons View Post
Hi Jafo!

There is news about the possibility to post in the forum a scheduled post ?
http://www.vbulletin.org/forum/showp...&postcount=123
__________________
Become a Lampwright today at www.lampwrights.com!
Reply With Quote
  #152  
Old 22 Feb 2009, 13:36
Jafo232 Jafo232 is offline
 
Join Date: May 2004
Originally Posted by ckain View Post
thx laztrix,

I fixed it removing all old code from version III in the various templates

Now i can't access the vBridge User Settings:
Fatal error: Call to a member function on a non-object in /www/htdocs/mio/blogs/newz/wp-content/plugins/vbbridge.php on line 408
Not sure what you "fixed" but it seems to have broken something. Looks to me that your path is not right to Vbulletin, but all of that depends on what you "fixed".
__________________
Become a Lampwright today at www.lampwrights.com!
Reply With Quote
  #153  
Old 22 Feb 2009, 13:41
amjadz4's Avatar
amjadz4 amjadz4 is offline
 
Join Date: Aug 2007
Anyone need to wrap their vBulletin inside the wordpress theme? please PM me. I can do it for you for a small service fee.

Reply With Quote
  #154  
Old 22 Feb 2009, 13:47
laztrix laztrix is offline
 
Join Date: Dec 2008
Originally Posted by Jafo232 View Post
I have no idea. I never use any other language than English, so I guess I just do not understand what is happening with your install.
I'm gonna try it with the english version of wordpress.

I'll keep you posted what's going on with it.

Thank you so much for everything.
Reply With Quote
  #155  
Old 22 Feb 2009, 15:06
Reynaldovb Reynaldovb is offline
 
Join Date: Dec 2004
LOL, is it me or Jaffo is ignoring my question?
Reply With Quote
  #156  
Old 22 Feb 2009, 16:08
Mr. Mooney Mr. Mooney is offline
 
Join Date: Apr 2007
Originally Posted by Reynaldovb View Post
LOL, is it me or Jaffo is ignoring my question?
He's not ignoring your question. He probably assumed you would check the features of the new update.

The new update has an option to set if your forum uses UTF-8, which yours does.
Reply With Quote
  #157  
Old 22 Feb 2009, 16:49
Fraik's Avatar
Fraik Fraik is offline
 
Join Date: Mar 2007
Real name: Freek
Originally Posted by Jafo232 View Post
Hmm, unable to reproduce this. Are you sure you uploaded ALL of the new files? Are you using the most recent release of Wordpress?
Yes, I've updated it all. I am using excerpted posts and I have set a custom permalink structure.

However, I will delete the plugin files and re-upload them, just to make sure.

Edit: Works now! Thanks. Something must've gone wrong with overwriting the files last time...
__________________
Middle Earth Center - All about the Lord of the Rings & The Hobbit games, movies and books
Reply With Quote
  #158  
Old 22 Feb 2009, 17:24
pypons pypons is offline
 
Join Date: Nov 2008
Hi Jafo,

i have tested this new version but the future post don't work.

I use wp 2.7.1. Tell me if you need help.

Thanks.
Reply With Quote
  #159  
Old 22 Feb 2009, 18:05
Reynaldovb Reynaldovb is offline
 
Join Date: Dec 2004
Originally Posted by Mr. Mooney View Post
He's not ignoring your question. He probably assumed you would check the features of the new update.

The new update has an option to set if your forum uses UTF-8, which yours does.
Thank you for your reply. I meant the permalink issue which still persists, you know the one where Wordpress doesnt have any value to assign to the %author% variable in the permalink. Right now it is populated with an empty value.
Reply With Quote
  #160  
Old 22 Feb 2009, 19:21
aparatchik aparatchik is offline
 
Join Date: Feb 2009
targeting forum ID's

no idea if this is possible, but it would be cool to be able to assign a forum ID for each individual WP post. I don't necessarily want to drop them all in the same forum...
Reply With Quote
  #161  
Old 22 Feb 2009, 19:24
remotay remotay is offline
 
Join Date: Sep 2007
Another small issue, even though i was told to ignore the 'users' area of wordpress.

All of my post's authors show as random users on the forum! I tried logging into one of my users accounts to see if they can edit MY wordpress posts as it showed them as admin, but thankfully, they can't. It still bothers me that I see THEM as the authors of MY wordpress posts. I disabled the show author portion of my posts, but it would be nice for this small issue to be worked out. I'd be happy to donate to the author of this plugin when it gets tweaked a bit more.

I Do appreciate all the hard work put into this plugin, and I understand this isn't your 'job', so I don't expect immediate results. Vbulletin is such a great piece of software, only because of the coders who put their time, effort and energy into making great plugins. In that regard, Thank you Jafo232 =).
Reply With Quote
  #162  
Old 22 Feb 2009, 20:14
myHybridcar.com myHybridcar.com is offline
 
Join Date: Feb 2009
Originally Posted by dieslcruisrhead View Post
FYI though I am still getting an error. When I save under Settings > vBridge settings it kicks out this error. Otherwise it seems to be working excellently...
Don't worry about that if everything else works fine. The control panel is probably just not able to lay a cookie—it won't break your blog or forum (It's still a bug but nothing to stress over.)
Reply With Quote
  #163  
Old 22 Feb 2009, 21:08
Jafo232 Jafo232 is offline
 
Join Date: May 2004
Originally Posted by Reynaldovb View Post
Thank you for your reply. I meant the permalink issue which still persists, you know the one where Wordpress doesnt have any value to assign to the %author% variable in the permalink. Right now it is populated with an empty value.
That is because technically, the authors name is blank.. I will look into this when I get some time to see what can be done about it.
__________________
Become a Lampwright today at www.lampwrights.com!
Reply With Quote
  #164  
Old 22 Feb 2009, 21:10
Jafo232 Jafo232 is offline
 
Join Date: May 2004
Originally Posted by aparatchik View Post
no idea if this is possible, but it would be cool to be able to assign a forum ID for each individual WP post. I don't necessarily want to drop them all in the same forum...
You should see a drop down list of forums when you make your post in wordpress (scroll down)...
__________________
Become a Lampwright today at www.lampwrights.com!
Reply With Quote
  #165  
Old 22 Feb 2009, 21:12
Jafo232 Jafo232 is offline
 
Join Date: May 2004
Originally Posted by remotay View Post
All of my post's authors show as random users on the forum! I tried logging into one of my users accounts to see if they can edit MY wordpress posts as it showed them as admin, but thankfully, they can't. It still bothers me that I see THEM as the authors of MY wordpress posts. I disabled the show author portion of my posts, but it would be nice for this small issue to be worked out. I'd be happy to donate to the author of this plugin when it gets tweaked a bit more.
Did you see in the readme about how to replace "the_author()"?
__________________
Become a Lampwright today at www.lampwrights.com!
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


New To Site? Need Help?

All times are GMT. The time now is 17:48.

Layout Options | Width: Wide Color: