Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old 17 Feb 2022, 06:50
BillB1 BillB1 is offline
 
Join Date: Jan 2022
I need your help

I am trying to upgrade from vb 3.6 to 5.6.6
Restored old database from backup file to vb 3.8.11
hoping to upgrade to 4.2.5 then 5.6 BUT...

It's not going so well with Arabic Language,
The upgarde went fine on my local machine, Xampp
but not on the host server,

all arabic text turns into gibrish or question marks.

I have tried the following:
1. Xampp with several PHP versions from 5.6 to 7.4,
2. Converted collation and charset from Latin1 swedish to UTF8
3. used the VB script: utf8convert.phar
4. Imported the same exact working database from Xampp, same VB files
then tried with multiple fresh installations, No luck!
5. SQL on xampp is the same as the host server tried both MariaDB 10.1 and 10.2, and
I have read similar threads, and tried solutions presented on this forum, no luck!

This is what I get:
https://dantdubai.org/vb/

What am I missing?
Reply With Quote
  #2  
Old 17 Feb 2022, 22:39
snakes1100 snakes1100 is offline
 
Join Date: Dec 2001
Real name: Anthony
Verify the charsets match for sql when you export it out of xampp server & the charsets match what xampp is when importing it into the host server.

character_set_client latin1
character_set_connection latin1
character_set_database latin1
character_set_results latin1
character_set_server latin1
character_set_system utf8

You could also try settings the charset in vb's config file.
Reply With Quote
  #3  
Old 18 Feb 2022, 08:55
BulliM's Avatar
BulliM BulliM is offline
 
Join Date: Oct 2017
Thereis an error in your header.


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

should be:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

And the content charset is...


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Should be utf-8.

Last edited by BulliM; 18 Feb 2022 at 09:03.
Reply With Quote
  #4  
Old 19 Feb 2022, 01:17
BillB1 BillB1 is offline
 
Join Date: Jan 2022
Originally Posted by snakes1100 View Post
Verify the charsets match for sql when you export it out of xampp server & the charsets match what xampp is when importing it into the host server.

character_set_client latin1
character_set_connection latin1
character_set_database latin1
character_set_results latin1
character_set_server latin1
character_set_system utf8

You could also try settings the charset in vb's config file.
Thank you for the promp reply!
I'll export the DB from Xampp following charset above, upload it to host and then restore.
I've noticed one difference: Xampp has MariaDB 10.1 while the host has MariaDB 10.2
I am not sure if this is what causing issues!

Thanks again
Bill

--------------- Added 19 Feb 2022 at 01:26 ---------------

Originally Posted by BulliM View Post
Thereis an error in your header.


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

should be:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

And the content charset is...


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Should be utf-8.
Thanks for the reply,
To be honest, I don't know where or how to do it, but I assume if I can get out of the gibberish, I'll be able to make these changes from admincp. correct?

Thanks again
Bill

Last edited by BillB1; 19 Feb 2022 at 01:26.
Reply With Quote
  #5  
Old 19 Feb 2022, 12:27
snakes1100 snakes1100 is offline
 
Join Date: Dec 2001
Real name: Anthony
If the host allows it, you can use a local php.ini to set the charset, add it to the public_html dir via ftp.
Reply With Quote
  #6  
Old 19 Feb 2022, 17:52
BillB1 BillB1 is offline
 
Join Date: Jan 2022
Originally Posted by snakes1100 View Post
If the host allows it, you can use a local php.ini to set the charset, add it to the public_html dir via ftp.
Yes, I have root access. it's VPS.
Notice:
1. Following your advise, on the second import, things did change, got better a bit,
Now you can see REAL English and actual words!
https://dantdubai.org/vb/
2. Also I can login into admincp, so deleted the Arabic language, tested several language packs
but still.....In fact you may notice the actual shape/fonts, they look like Vietnamese instead of Arabic? I copied and pasted it in Google translate Auto detect said Vietnamese

I wish to share this image with you:
Same DB on both servers: xampp being on the left side, the other one on hosted VPS.

All the best,
Bill
Attached Images
File Type: jpg myadmin.jpg (86.4 KB, 7 views)
Reply With Quote
  #7  
Old 20 Feb 2022, 17:02
socialteenz's Avatar
socialteenz socialteenz is offline
 
Join Date: May 2011
Real name: Stan
Create a blank index.php file to your root to prevent your files from appearing on the root (https://dantdubai.org)
__________________
Web development done right.
read my Reviews (59) from here.

Pm me - for custom forum work & web development

Last edited by socialteenz; 20 Feb 2022 at 17:13.
Reply With Quote
  #8  
Old 20 Feb 2022, 22:47
BillB1 BillB1 is offline
 
Join Date: Jan 2022
Originally Posted by socialteenz View Post
Create a blank index.php file to your root to prevent your files from appearing on the root (https://dantdubai.org)
Sure thing, and thanks for the heads-up

--------------- Added 20 Feb 2022 at 23:54 ---------------

Updating the topic in case someone faces a similar Charset issue with non english language.
After going through so many suggestions, forums, and stackoverflow
especially this Hell of Latin1 vs. utf8 arguments, I feel silly.

The reason why I had all these ?????? and Gibberish characters was the very Locale
setting on the Centos7 server.

This is how it was solved:
logged in as root> terminal
# yum update
# localectl status
checked the system locale:
# cat /etc/locale.conf
list available locale on server:
# localectl list-locales | grep en_
pick AR support locale:
# localectl set-locale LANG=<<locale_name>>
and confirm
# localectl status.

Then I importing the same OLD Latin1 database charset and collation.
Since Arabic is not my language, I copied several pages worth of global phrases from xampp
and pasted them into global phrases on the host, charset is just fine!
https://dantdubai.org/vb/

Still not out of the woods yet, Next step:
Restore about 90.000 users with 1.3 million posts.
I'll stay with vb3.8 to see if impex is up to the task.
Had anyone tried impex to selectively import some tables and exclude old styles, language pack, outdated mods etc?

Last edited by BillB1; 20 Feb 2022 at 23:56.
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 13:30.

Layout Options | Width: Wide Color: