Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
CND Garage - Timeslips Details »
CND Garage - Timeslips
Mod Version: 2.0.6, by Dylanblitz (Contributor) Dylanblitz is offline
Developer Last Online: Feb 2017 I like it Show Printable Version Email this Page

vB Version: 3.8.x Rating: (7 votes - 5.00 average) Installs: 57
Released: 03 Jul 2009 Last Update: 11 Aug 2010 Downloads: 586
Not Supported DB Changes Uses Plugins Auto-Template Additional Files Translations  

Description
CND Garage Timeslips is a garage/timeslip add on for vbulletin. Although it looks like phpbbgarage this is NOT a port, it is 100% my own code. I just modeled the layout to look like it.
Users can add as many vehicles, timeslips and images that the admin allows. The admin can define the amounts per site or per usergroup. Images are stored in the filesystem and thumbnails are automatically created as the image is uploaded.

Main Features
  • No vb template modification needed (except to add link to navigation/community)
  • Ajax driven menu's to keep load time down for very large lists of makes/models
  • Button images are attached to style so that each style can have their own images
  • 99.9% of the text is phrased so that it can be translated for multinational sites
  • User's vehicles shown in their profile (vb 3.7+)
  • vboption used for type of garage, to help aid in change it from a car to a motorcycle, atv, etc garage system
  • Easily import data from vbgarage

NEW FEATURES IN 2.0!!!!
  • New navbar menu, dropdown vehicle options and dropdown administrator options to clean up the layout
  • On the fly watermarking, text and image
  • Run garage outside of the forum directory
  • Image resizing, 3 sizes of images, link on lytebox to open large image
  • Trim field, vehicle class and purchase date added to the vehicle data
  • Vehicle of the day automatic cron added
  • Vehicle of the month setting with customizable image

Installation
Instructions, tips and more are now in the online documentation as well as an included chm file.
Both are linked in the read me file.

The garage is developed on vb 3.8.3 and tested back to 3.7.0. The garage will run on PHP 4.4.7+ compiled with GD/GD2 and MySQL 4.1.x+

I am currently working on an importer for the old timeslips database.

Additional options for the garage like dyno charts, modifications and lots more are included in the commercial version at CND Systems

Added
The vba_vehicle_display.xml is a vbadvanced module to add a verticle column with vehicles, can be either latest vehicles, random vehicles or the featured vehicle. Once imported you can modify the module to change the number of vehicles displayed. This only works with the 2.x series.
The forum_home_2_0_2.xml file is a vb product which will display garage images on your forum home page. It has options for the location and number of images which is set through the ACP vboptions section. This only works with the 2.x series.
The postbit_user_garage-1_4_1.xml is a vb product which will add a link to the user garage in the postbit. Configure this on the Garage General Settings vboptions tab.


Release Notes
v2.0.6 - 09/8/2009
Fixed vb problem with cleaning numbers formatted with non english decimal and thousand separators
Fixed extra $ in vehicle dropdown menu

v2.0.5 - 09/6/2009
Fixed decimal spacing on timeslips
Added ability to remove VOTM
Added ability to remove Featured Vehicle

v2.0.4 - 09/5/2009
Fixed image links breaking when changing vehicle user
Fixed decimal and thousand separator on viewing items
Fixed removing engine type error

v2.0.3 - 09/1/2009
Fixed editing number fields for decimal and thousand separater in different languages
Fixed problem with timezone skewing dates
Fixed switching Miles/KM in timeslip
Fixed ACP Front Block modification
Fixed dates with year and day problems
Fixed approval header background
Fixed front row blocks number and order

v2.0.2 - 08/27/2009
Fixed problem with vehicle image uploads if set to Basic and Per Item
Fixed problem with 2.0.1 import, permission field does not get created
Fixed unused fields killing vehicle creation

v2.0.1 - 08/25/2009
Fixed bug with vehicle options not being available
Fixed admin editing user vehicle
Fixed header owner name on front page block
Modified templates to clean up navigation
Modified templates to clean up admin vehicle options
Fixed vehicle purchase date showing wrong on view
Fixed not used data showing in user vehicle's view

v2.0.0 - 08/23/2009
Way too many changes to put it here, read the included change log

v1.0.3 - 07/22/2009
Fixed expired session submitting vehicle
Fixed verifying vehicle owner on edit

v1.0.2 - 07/17/2009
Fixed red x on browse vehicles with no image
Fixed missing phrases for ACP options
Fixed deleting and setting primary of images
Add vbgarage import tool

v1.0.1 - 07/15/2009
Fixed variables
Fixed popup to create new makes/models

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	front_page.jpg
Views:	1062
Size:	112.3 KB
ID:	103633   Click image for larger version

Name:	vehicle_add.jpg
Views:	733
Size:	64.4 KB
ID:	103634   Click image for larger version

Name:	vehicle_view.jpg
Views:	1098
Size:	74.3 KB
ID:	103635   Click image for larger version

Name:	timeslip_view.png
Views:	496
Size:	31.8 KB
ID:	103638  

Click image for larger version

Name:	browse.png
Views:	563
Size:	33.9 KB
ID:	103639  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Major Additions DTO Garage - free garage features for all your members (vB 3.8.X) mferguson vBulletin 3.8 Add-ons 493 14 Aug 2012 23:22

  #31  
Old 15 Jul 2009, 23:53
Martyn1983 Martyn1983 is offline
 
Join Date: Nov 2008
Hiya, installed and liking this. Just one problem coming up when I try and upload pictures: Get this at the top of the page


Warning: move_uploaded_file(images/garage/attach/garage_vehicle-1-12477018691.jpg) [function.move-uploaded-file]: failed to open stream: No such file or directory in [path]/garage_func_var.php on line 899

Warning: move_uploaded_file() [function.move-uploaded-file]: Unable to move '/tmp/phpNgwJdh' to 'images/garage/attach/garage_vehicle-1-12477018691.jpg' in [path]/garage_func_var.php on line 899

It's probably something obvious that I'm missing, but any help appreciated.
Reply With Quote
  #32  
Old 15 Jul 2009, 23:58
burntire burntire is offline
 
Join Date: Jun 2006
Very nice mod. I am having some issues. I can not delete images or set them as primary?
Reply With Quote
  #33  
Old 16 Jul 2009, 00:00
Dylanblitz Dylanblitz is offline
 
Join Date: Oct 2005
Originally Posted by Martyn1983 View Post
Hiya, installed and liking this. Just one problem coming up when I try and upload pictures: Get this at the top of the page


Warning: move_uploaded_file(images/garage/attach/garage_vehicle-1-12477018691.jpg) [function.move-uploaded-file]: failed to open stream: No such file or directory in [path]/garage_func_var.php on line 899

Warning: move_uploaded_file() [function.move-uploaded-file]: Unable to move '/tmp/phpNgwJdh' to 'images/garage/attach/garage_vehicle-1-12477018691.jpg' in [path]/garage_func_var.php on line 899

It's probably something obvious that I'm missing, but any help appreciated.
Most likely it's permission issues. The way your server is configured you need to chmod the forum/images/garage/attach directory to 777
Reply With Quote
  #34  
Old 16 Jul 2009, 00:01
Dylanblitz Dylanblitz is offline
 
Join Date: Oct 2005
Originally Posted by burntire View Post
Very nice mod. I am having some issues. I can not delete images or set them as primary?
What happens when you try? Does it give an error or just refresh the page and not do anything?
Reply With Quote
  #35  
Old 16 Jul 2009, 00:12
burntire burntire is offline
 
Join Date: Jun 2006
Originally Posted by Dylanblitz View Post
What happens when you try? Does it give an error or just refresh the page and not do anything?
Just a refresh without applying the change.
Reply With Quote
  #36  
Old 16 Jul 2009, 00:37
Martyn1983 Martyn1983 is offline
 
Join Date: Nov 2008
Originally Posted by Dylanblitz View Post
Most likely it's permission issues. The way your server is configured you need to chmod the forum/images/garage/attach directory to 777
Bingo!

As I said, it'd be something daft and it was exactly that! Oh, and the fact I hadn't uploaded the folder to the correct location!

Many thanks mate! Cracking mod
Reply With Quote
  #37  
Old 16 Jul 2009, 00:37
Dylanblitz Dylanblitz is offline
 
Join Date: Oct 2005
Originally Posted by burntire View Post
Just a refresh without applying the change.
Hmm, think it might be some left over variable issues.

Can you try uploading this file to your forum directory? Overwrite the current one. Should fix the problem.
Attached Files
File Type: php garage_func_var.php (56.6 KB, 8 views)
Reply With Quote
  #38  
Old 16 Jul 2009, 00:49
burntire burntire is offline
 
Join Date: Jun 2006
Originally Posted by Dylanblitz View Post
Hmm, think it might be some left over variable issues.

Can you try uploading this file to your forum directory? Overwrite the current one. Should fix the problem.
That did the trick.

What is the featured vehicle button for?
Reply With Quote
  #39  
Old 16 Jul 2009, 00:50
Dylanblitz Dylanblitz is offline
 
Join Date: Oct 2005
Originally Posted by burntire View Post
That did the trick.

What is the featured vehicle button for?

Good to hear

The featured vehicle will show on the front garage page if you set the vboptions to use the featured. There is only 1 at a time, it will clear the old one when you set a new one.
Reply With Quote
  #40  
Old 16 Jul 2009, 00:52
Dylanblitz Dylanblitz is offline
 
Join Date: Oct 2005
Originally Posted by Martyn1983 View Post
Bingo!

As I said, it'd be something daft and it was exactly that! Oh, and the fact I hadn't uploaded the folder to the correct location!

Many thanks mate! Cracking mod
Ah yeah, having the folder in the right place is important
Good to hear it's working right now though. Let me know if you run into any problems. Might want to download the file in a previous post to fix some image issues.

http://www.vbulletin.org/forum/showp...5&postcount=37
Reply With Quote
  #41  
Old 16 Jul 2009, 20:59
burntire burntire is offline
 
Join Date: Jun 2006
Everyone seems to like the setup on my site.

Are there any know issues upgrading to the commercial version?
Reply With Quote
  #42  
Old 16 Jul 2009, 21:06
Dylanblitz Dylanblitz is offline
 
Join Date: Oct 2005
Originally Posted by burntire View Post
Everyone seems to like the setup on my site.

Are there any know issues upgrading to the commercial version?
Glad they like it

No issues that I can think of. The vehicle and timeslip tables, phrases and plugins are the exact same as the commercial. I just need to finish the upgrade script and test it out. If you are thinking about doing it let me know and I'll put more effort into the script. Right now all my free time is going into enhancements since no one has asked about upgrading
Reply With Quote
  #43  
Old 16 Jul 2009, 21:41
burntire burntire is offline
 
Join Date: Jun 2006
Originally Posted by Dylanblitz View Post
Glad they like it

No issues that I can think of. The vehicle and timeslip tables, phrases and plugins are the exact same as the commercial. I just need to finish the upgrade script and test it out. If you are thinking about doing it let me know and I'll put more effort into the script. Right now all my free time is going into enhancements since no one has asked about upgrading
No rush. I want to see how things progress with my members.

Here is a suggestion

1. Have a way to force all model types to disapproved with one click. I found all the data to be too much. I manually had to deselect all the makes and models that do not apply to my site.

If basic is selected do I need to set anything in the usergroup permissions? I was just curious what basic defaults to?
Reply With Quote
  #44  
Old 16 Jul 2009, 21:49
Martyn1983 Martyn1983 is offline
 
Join Date: Nov 2008
Originally Posted by Dylanblitz View Post
Ah yeah, having the folder in the right place is important
Good to hear it's working right now though. Let me know if you run into any problems. Might want to download the file in a previous post to fix some image issues.

http://www.vbulletin.org/forum/showp...5&postcount=37
Cheers fella,

Updated the file. Just wondering - the 1/8 mile setting, it's not something we really need to list - can that be removed easily? Ironically, theres options to remove 1/4 mile but not 1/8.
Reply With Quote
  #45  
Old 16 Jul 2009, 22:00
Dylanblitz Dylanblitz is offline
 
Join Date: Oct 2005
Originally Posted by burntire View Post
No rush. I want to see how things progress with my members.

Here is a suggestion

1. Have a way to force all model types to disapproved with one click. I found all the data to be too much. I manually had to deselect all the makes and models that do not apply to my site.

If basic is selected do I need to set anything in the usergroup permissions? I was just curious what basic defaults to?
Since your site just deals with mustangs I would of just created the one make of ford and the models under it instead of importing the whole vehicle list. Bit of an after thought, but if you ever need to rebuild it's something to think about

If you are just using the basic permissions then you can leave the advanced groups alone. It will skip those settings when it's figuring out who has permissions to do what.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 23:11.

Layout Options | Width: Wide Color: