Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Product Review Forums Research, Review & Compare Items Details »
Product Review Forums Research, Review & Compare Items
Mod Version: 1.4.0, by Ted S (Coder) Ted S is offline
Developer Last Online: Dec 2016 I like it Show Printable Version Email this Page

vB Version: 4.x.x Rating: (34 votes - 4.50 average) Installs: 214
Released: 07 Sep 2011 Last Update: 06 Apr 2014 Downloads: 1703
Not Supported DB Changes Uses Plugins Auto-Template Additional Files  

Version 1.4.0 has been released to remove the giftery / list it integration of the addon now that service has been discontinued. No upgrade is needed though there have been a few other bug changes since 1.3.5.

Finding Feedback Can be Like a Needle in a Haystack


The more your forum grows, the more of a challenge it becomes to sort through the history and get the full story.


Product Review Forums Brings Structure to the Chaos


As a full-featured product management addon, PRF sits on top of your forum allowing you to create defined products which, unlike individual posts, stay relevant over time. Each comment, review and even product updates filter back into this one spot allowing for a quick and comprehensive overview while the individual discussions rage on as always.


Here's just a few of the many features you'll find in PRF:
  • Bring structure to products with established pages & reviews
  • Reduce the number of repetitive posts from members looking up the same info
  • Increase your traffic with content-rich, seo friendly, product listings
  • Drive revenue by adding your own affiliate links to product listings
  • Increase the activity stream's value with review integration
  • Engage visitors with integrated wishlists from Giftery.me
===========================

Installation is not upload & go... individualized settings are required. Read the install file.


===========================
QUICK TIPS:
===========================

Enabling Product Forums: To show product details and ratings, each product-forum must be enabled in the forum manager.

Adding Products: You may upload products one at a time through the admin [includes an image uploader using GD] or you can bulk import through XML. You can also enable users to add moderated products through a global and usergroup option.

Product Review Index: To access your forum's product overview go to www.yoursite.com/productforums.php - You may want to add a link to this to your navbar or as a tab.

Customization: This addon is made to be customized. To change the color schema see clientscript/vbulletin_css or dive right on in to the templates and phrases.

Powered by Giftery.me: This mod is maintained includes two integrations you should know about. Both can be controlled through the mod options.

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	Untitled-1.jpg
Views:	2467
Size:	45.4 KB
ID:	139758   Click image for larger version

Name:	Untitled-2.jpg
Views:	3592
Size:	79.4 KB
ID:	139759   Click image for larger version

Name:	Untitled-3.jpg
Views:	2488
Size:	70.0 KB
ID:	139760   Click image for larger version

Name:	Untitled-4.jpg
Views:	2073
Size:	76.3 KB
ID:	139761  

Click image for larger version

Name:	Untitled-5.jpg
Views:	1548
Size:	62.0 KB
ID:	139762  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
  #61  
Old 10 Sep 2011, 20:06
Ted S Ted S is offline
 
Join Date: Dec 2003
Originally Posted by Sforums View Post
Absolute disaster on 4.1.0!
Installed modification and allocated subforum for single product for purpose of testing. It changed the title of every single topic in all vendors forums (even though I've chosen single subforum) to test the title. More than thousand of threads have been renamed even I uninstalled the modification. Trying to rename them back to original titles and can't be done!!
I am absolutelly desperate to bring my forum back to original state. Wish I never touched beta product. These things should be properly tested before released to public.
This mod does not update your database on anything that already exists on install. It does not rename thread titles. It does not care about current threads.

So, let's figure out what's happening and get your forum back in order...

Did you have this issue after installing? After adding a product? After adding a review?

Have you checked your database to see if the thread titles were actually changed or merely getting displayed wrong?

To test run: SELECT title FROM [table_prefix]thread WHERE forumid = XXX LIMIT 10.

Did you run this on a LIVE site or a DEV site?

And while I absolutely agree that nothing negative should happen, which is why testing is done before anything is released. However, there are an infinite number of forum options, other modifications and configurations which can introduce problems... that's why this mod is clearly labeled beta. But that's not what counts... right now let's focus on fixing up your forum.
__________________
New features released for Product Review Forums 1.3 (4.0)
Helpful Answers (3.8) (4.0) | Limited Guest Viewing (3.8) (4.0)

Last edited by Ted S; 10 Sep 2011 at 20:21.
Reply With Quote
  #62  
Old 10 Sep 2011, 20:10
Ted S Ted S is offline
 
Join Date: Dec 2003
Originally Posted by rammieone View Post
We have been using it on 4.1.3 and so far its done a 100% job without any problems or errors at all,Superb support on the mod too From Ted and our forum members have been very happy with it.
Thank you!
__________________
New features released for Product Review Forums 1.3 (4.0)
Helpful Answers (3.8) (4.0) | Limited Guest Viewing (3.8) (4.0)
Reply With Quote
  #63  
Old 10 Sep 2011, 20:18
Ted S Ted S is offline
 
Join Date: Dec 2003
Originally Posted by jshallo View Post
Hi, Just installed this on 4.1.3 and I got as far as adding products and it creates a product page (new thread) and one empty post under it. However, When I attempt to add the first review its taking me to a white screen at http://www.yoursite.com/forums/productforums.php
White pages are a pain to diagnose but we'll figure it out...

Is the blank poage showing up when you click write a review or when you go to submit it? Does the url structure look correct to your forum?

I like what you have here but, find myself wanting to customize some things for my type of reviews (cruise ship reviews). So maybe we can work on this together and tailor it to my needs and I'll list it as a live demo. My concern with editing too much now is that it would be too hard to upgrade this later on once its been modified too much now.
The mod is built using the vBulletin plugin system's flexibility so even if you customize the heck out of the templates, you can update the base code. When I release template changes they are documented so you can make any you want easily.

If you want to get really extensive I'd suggest waiting until after the "beta" ends as the release cycle is a little high pace right now.

1. Review submission box was small for a ship review and lacked the full editor that would allow users to include photos, videos, etc like a forum post. So I would like a (advanced editor option (on or off) per product option. The advanced would have the advanced forum editor box.
I'll have to see how the advanced editor works for inline vs attachment images. The attachment system is not flexible and while I realize this doesn't concern you much, I'd like to avoid trying doing anything that requires direct uploads for a bit.

Otherwise I hear you loud & clear and can add in the WYSIWYG editor easily enough.

2. Products one thing about ship reviews is the (product) would have a parent category (the cruise line) and then the ships within the line. (ie Royal Caribbean) and then all the ships (Oasis of the Seas, Allure of the Seas, Navigator of the Seas).. etc.
So you'd need a 3 category tree but more likely an infinite category tree...

Now the big point: Since reviews show up in forums you would either have to create a structure with forums or put them all into one area and then highly promote the search tool to find them by category [i.e. a pretty page with all the sorting options]. Does that sound right?

3. Price - You have price as mandatory and I'm not selling a product, just displaying the review. So this would need to be an option (on or off) in the product settings?
Easy enough.

4. Some added options? Launch Date (Inaugural), Link to Deck Plans, Link to Cruise Line, Discussion Forum Link, Related Videos Link.
I'm looking into ways to let you add your own fields as it's obviously not logical to have a database of hundreds of options for every type of product. Great idea of course!
__________________
New features released for Product Review Forums 1.3 (4.0)
Helpful Answers (3.8) (4.0) | Limited Guest Viewing (3.8) (4.0)
Reply With Quote
  #64  
Old 10 Sep 2011, 20:33
jshallo jshallo is offline
 
Join Date: Aug 2009
Hi Ted, I upgraded the forum to 4.1.5 and tried to submit a review again. It came back with a special error message.

"Oh great, you had to go and press THAT button. There goes the whole site. Just kidding... We had an issue posting your review, please try again or contact support and use code 164250-A"


Url: http://www.cruise-addicts.com/forums/productforums.php
Reply With Quote
  #65  
Old 10 Sep 2011, 20:40
Ted S Ted S is offline
 
Join Date: Dec 2003
Originally Posted by jshallo View Post
Hi Ted, I upgraded the forum to 4.1.5 and tried to submit a review again. It came back with a special error message.

"Oh great, you had to go and press THAT button. There goes the whole site. Just kidding... We had an issue posting your review, please try again or contact support and use code 164250-A"


Url: http://www.cruise-addicts.com/forums/productforums.php
Was actually just working on this code... Nice timing.

Mind giving the attached copy of upload/productforums.php a shot? Also be sure your forumcache is properly set.

To be clear, this error comes when you have enabled the "create review thread" option. If you did not intend that option to run please let me know.
Attached Files
File Type: php productforums.php (20.6 KB, 4 views)
__________________
New features released for Product Review Forums 1.3 (4.0)
Helpful Answers (3.8) (4.0) | Limited Guest Viewing (3.8) (4.0)
Reply With Quote
  #66  
Old 10 Sep 2011, 20:49
jshallo jshallo is offline
 
Join Date: Aug 2009
Is the blank poage showing up when you click write a review or when you go to submit it? Does the url structure look correct to your forum?

When I submit it.

Now shows "vBulletin Message
Oh great, you had to go and press THAT button. There goes the whole site. Just kidding... We had an issue posting your review, please try again or contact support and use code 164250-A"

The url structure appears ok, however the productforums.php is in root.. which is fine if that where it belongs.

WYSIWYG

WYSIWYG is not a priority but, probably would be a nice option.

Categories:

http://www.cruise-addicts.com/reviews/index.php


Here is what I have in place now. So this may answer a many of your questions. Note the lists of ships and how you can select from the drop-down menu a specific ship.

The reviews are displayed by most recent submission. So one Cruise Review forum sorted by newest with each thread being a unique ship review would work.

Note that my setup is not perfect but, I think it can be improved with better software and VBSEO and good integration your mod provides.
Reply With Quote
  #67  
Old 10 Sep 2011, 20:56
Ted S Ted S is offline
 
Join Date: Dec 2003
Originally Posted by jshallo View Post
Now shows "vBulletin Message
Oh great, you had to go and press THAT button. There goes the whole site. Just kidding... We had an issue posting your review, please try again or contact support and use code 164250-A"
Think the updated version I just posted should fix the error... we'll see where that gets things.

WYSIWYG is not a priority but, probably would be a nice option.
It would have to be without HTML but I doubt that's a big deal. Playing with the code now.

Categories:
Here is what I have in place now. So this may answer a many of your questions. Note the lists of ships and how you can select from the drop-down menu a specific ship.

The reviews are displayed by most recent submission. So one Cruise Review forum sorted by newest with each thread being a unique ship review would work.
The dropdowns will be a bit tricky but with some fun code they'd basically progressively expand so if you have 3 layers, you'd get 3 dropdowns building as you select [and updating results along the way with our good friend AJAX].

Users will also be able to search by rating range, when the review was posted, product [or ship] title, and so forth.

As far as the one forum, one thread, we're already good there so it's really much more about getting categories in place and searching than changing any core code.
__________________
New features released for Product Review Forums 1.3 (4.0)
Helpful Answers (3.8) (4.0) | Limited Guest Viewing (3.8) (4.0)
Reply With Quote
  #68  
Old 10 Sep 2011, 20:56
TheLastSuperman's Avatar
TheLastSuperman TheLastSuperman is offline
 
Join Date: Sep 2008
Real name: Michael Miller Jr
Lightbulb

Originally Posted by Sforums View Post
Absolute disaster on 4.1.0!
Installed modification and allocated subforum for single product for purpose of testing. It changed the title of every single topic in all vendors forums (even though I've chosen single subforum) to test the title. More than thousand of threads have been renamed even I uninstalled the modification. Trying to rename them back to original titles and can't be done!!
I am absolutelly desperate to bring my forum back to original state. Wish I never touched beta product. These things should be properly tested before released to public.
Originally Posted by Sforums View Post
As a matter of fact every single thread on the forum has been renamed. This is the worst thing ever happened to me in 6 years on vb forums!
Originally Posted by rammieone View Post
We have been using it on 4.1.3 and so far its done a 100% job without any problems or errors at all,Superb support on the mod too From Ted and our forum members have been very happy with it.
Originally Posted by Ted S View Post
This mod does not update your database on anything that already exists on install. It does not rename thread titles. It does not care about current threads.

So, let's figure out what's happening and get your forum back in order...

Did you have this issue after installing? After adding a product? After adding a review?

Have you checked your database to see if the thread titles were actually changed or merely getting displayed wrong?

To test run: SELECT title FROM [table_prefix]thread WHERE forumid = XXX LIMIT 10.

Did you run this on a LIVE site or a DEV site?

And while I absolutely agree that nothing negative should happen, which is why testing is done before anything is released. However, there are an infinite number of forum options, other modifications and configurations which can introduce problems... that's why this mod is clearly labeled beta. But that's not what counts... right now let's focus on fixing up your forum.
I have not had any issues with this modification, in fact I even noticed a misc issue and contacted Ted about it and he already had it in the next version, furthermore I don't see anything within the code that would do this?

To anyone and everyone reading this from here on out, this goes for EVERY modification on this site - Anything marked as Beta and/or anything that deals with your database should throw up a red flag telling you to either:

1) Install on a test site first.
2) If you install on a Live/Production site make a database backup beforehand then install the modification and test the functionality before turning the forums back on - this way if something is not quite right or goes wrong you can restore the backup promptly then turn the forum back on and return to the modification thread and report the error. *You just avoided much stress and can always be confident that your dealing with a Beta product correctly .
__________________
Daddy Does Dios and Figs!
https://www.linkedin.com/in/thelastsuperman - Custom vBulletin Modifications, Styles, and Services.
Need a Host? I recommend URLJet.

Search - Use the search feature to find similar issues/answers.
Information - Include screenshots, copy/pasted error codes, url etc.
Fixed - Please return to your thread/post and let us know how it was fixed!
Thanks - For participating! Click the "Like" on a post if someone helped you!
Reply With Quote
  #69  
Old 10 Sep 2011, 21:02
jshallo jshallo is offline
 
Join Date: Aug 2009
Hi Ted, Yes the new file fixed the problem. I did have it set to create a new thread for each new review but, now that I see it in action I don't think its what I wanted. So I may have to change this setting. I'll look forward to what you come up with and making it work for my needs. Most review sites don't have very much video, photos so its not a priority but, I think embed options that VB use would be nice possibly.
Reply With Quote
  #70  
Old 10 Sep 2011, 21:03
Ted S Ted S is offline
 
Join Date: Dec 2003
Originally Posted by TheLastSuperman View Post
Furthermore I don't see anything within the code that would do this?
Your remarks on beta installs should be stuck with any thread but of course any serious error gets me worried. However, I'm just not seeing anything that could cause a mass-rewrite either.

Hopefully the poster chimes in with some additional insight so I can track down what happened, if it was this mod, a conflict, whatever.
__________________
New features released for Product Review Forums 1.3 (4.0)
Helpful Answers (3.8) (4.0) | Limited Guest Viewing (3.8) (4.0)
Reply With Quote
  #71  
Old 10 Sep 2011, 21:06
Ted S Ted S is offline
 
Join Date: Dec 2003
Originally Posted by jshallo View Post
Hi Ted, Yes the new file fixed the problem. I did have it set to create a new thread for each new review but, now that I see it in action I don't think its what I wanted. So I may have to change this setting. I'll look forward to what you come up with and making it work for my needs. Most review sites don't have very much video, photos so its not a priority but, I think embed options that VB use would be nice possibly.
Thankfully links and embeding are easy so it's more about just letting you define your own fields than worrying about what's in them.

What i'll probably end up with is:

Text Fields
Yes / No fields
Additional Images [url]
Video [url]

On the other side you have user contributions which are a little more tricky to process since users aren't likely to FTP up an image.
__________________
New features released for Product Review Forums 1.3 (4.0)
Helpful Answers (3.8) (4.0) | Limited Guest Viewing (3.8) (4.0)
Reply With Quote
  #72  
Old 10 Sep 2011, 21:24
jshallo jshallo is offline
 
Join Date: Aug 2009
Ok, I'll wait for your next update.
Reply With Quote
  #73  
Old 11 Sep 2011, 05:03
Ted S Ted S is offline
 
Join Date: Dec 2003
PRF users -

I will be traveling for the next few days and not on to check this thread. Please chime in with any questions or suggestions you have and I will get back to you later next week.
__________________
New features released for Product Review Forums 1.3 (4.0)
Helpful Answers (3.8) (4.0) | Limited Guest Viewing (3.8) (4.0)
Reply With Quote
  #74  
Old 11 Sep 2011, 17:14
PaintballHQ PaintballHQ is offline
 
Join Date: Nov 2003
Real name: Robert
Thanks for putting this together Ted!

I have some suggestions that I was thinking of.

Having the products rating based on the average of the following: (maybe customizable options depending on what your site is geared toward)
  • Appearance
  • Performance
  • Reliability
  • Value
Customizable fields like you said would be great. I need to have fields for Pros & Cons.

Define what user group(s) can add a new product/service for review & what user group(s) can submit a review.
Reply With Quote
  #75  
Old 14 Sep 2011, 04:10
Da-Vinci Da-Vinci is offline
 
Join Date: Mar 2010
Hi Ted, your mod looks really good, but when I install it, the thread the review should show in, just displays the title and below it says.
This is an empty post


Not sure what I could have done wrong, I uploaded everything to the root and installed the product via the product manager.

When I visit http://www.cameraguru.co.uk/productforums.php I just get redirected to the CMS.

Here is how I've got the settings.




Last edited by Da-Vinci; 14 Sep 2011 at 04:26.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


New To Site? Need Help?

All times are GMT. The time now is 06:25.

Layout Options | Width: Wide Color: