Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Thread Thumbnail Details »
Thread Thumbnail
Mod Version: 1.1, by jasonmerchant (Member) jasonmerchant is offline
Developer Last Online: Jun 2009 I like it Show Printable Version Email this Page

This modification is in the archives.
vB Version: 3.6.8 Rating: (21 votes - 4.81 average) Installs: 208
Released: 21 Sep 2007 Last Update: 21 Sep 2007 Downloads: 1391
Not Supported Uses Plugins Template Edits  

This plugin is the newest version of the Thread Thumbnail plugin

This plugin will display the first attachment as a thumbnail on forumdisplay.php

New Features:
  • If there are attachments that are not images, it will skip them and go to the first image attachment.
  • Optional - you can now display thumbnails on search results.



Installation:

In your AdminCP, go to Plugin System, Download/Upload Plugins and import the xml document.

Be sure to change the forum ids in the $thumbsforums array to the forum ids you want to enable thumbnails in.

The plugin comes with the Search Thumbnails enabled. If you do not want to have thumbnails show up in the search results, make sure you deactivate it.

If you would like thumbnails to display in the search results, you will need to replace your search.php page with the one in the zip file. Unfortunately vBulletin forgot to include a hook variable where it is necessary for this to work. I have added 1 line to search.php with the hook variable. There is no way around this until vbulletin adds it themselves.

Next you will need to modify your threadbit template:

Find:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Replace With:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

You will also need to upload an image to display if there are no image attachments here: $stylevar[imgdir_misc]/nothumb.jpg(ex: http://www.mysite.com/forums/images/misc/nothumb.jpg). I've made a simple one you can use or you can make your own. By default thumbnails are confined in a 100x100 px area, I found that it looks good to make the "no image" image about 100x83 px.

_____________________________________________________

Add-ons (Optional)

UserCP option to turn the thumbnails on/off on a per user basis

Go into your admincp and click User Profile Fields->Add New User Profile Field.

Select "single selection radio buttons", click continue.

For title put "Thread Thumbnails", for description put "This will allow you to turn the thumbnails of threads on and off."

For options, enter "On" and "Off".

Skip down to Display Page and choose "Options: Thread Viewing".

In your threadbit template(assuming you already applied the template changes above):

Find:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Replace with:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

You need to replace field5 with the field name of the profile field you created earlier.

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	attachment.jpg
Views:	5492
Size:	36.5 KB
ID:	70123  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Thread Thumbnail jasonmerchant vBulletin 3.5 Add-ons 196 04 Jan 2009 10:26

  #46  
Old 04 Oct 2007, 21:57
rapidphim rapidphim is offline
 
Join Date: Feb 2007
Wondering if this mod works with any other free hosting image such as imageshack?
Reply With Quote
  #47  
Old 05 Oct 2007, 13:35
PlymWS PlymWS is offline
 
Join Date: Mar 2006
Err, no. It parses the attachments in each thread and produces uses the first attachments thumbnail as the thread thumbnail.
Reply With Quote
  #48  
Old 05 Oct 2007, 13:36
PlymWS PlymWS is offline
 
Join Date: Mar 2006
What's the line you've added to search.php ? I have already modified my search.php so I would need to modify the file for this hack myself.
Reply With Quote
  #49  
Old 05 Oct 2007, 21:06
lasto lasto is offline
 
Join Date: Jan 2002
any pics i upload i like to show inside the post but if i do then the thumbnail does not show unless i switch create thumbnail back on = then if i do that then pics are shown in threads/posts as small images which need to be clicked on to get full view.

Is there anyway i can have the thumbnail on forumdisplay while still viewing the full pic inside thread/posts without having to click on the image in the post.
Reply With Quote
  #50  
Old 05 Oct 2007, 21:30
Principe10's Avatar
Principe10 Principe10 is offline
 
Join Date: Sep 2007
Real name: Massimo
Originally Posted by lasto View Post
any pics i upload i like to show inside the post but if i do then the thumbnail does not show unless i switch create thumbnail back on = then if i do that then pics are shown in threads/posts as small images which need to be clicked on to get full view.

Is there anyway i can have the thumbnail on forumdisplay while still viewing the full pic inside thread/posts without having to click on the image in the post.
Try so:
in option vbulletin switch yes (pic 001 rif pic 002 in english the help of pic 1)
then attachment switch yes pic 003.

Sorry but my forum is in italian!!!

P.
Attached Images
File Type: jpg 001.jpg (46.6 KB, 66 views)
File Type: jpg 002.jpg (74.4 KB, 53 views)
File Type: jpg 003.jpg (52.3 KB, 58 views)
Reply With Quote
  #51  
Old 05 Oct 2007, 21:40
lasto lasto is offline
 
Join Date: Jan 2002
it all set same as yours m8 but pics in posts still need to be clicked on.
Thanks for your time is appreciated.

If i turn off the show thumbnail in attachments option it just displays a link instead of the pic
Reply With Quote
  #52  
Old 05 Oct 2007, 21:49
Principe10's Avatar
Principe10 Principe10 is offline
 
Join Date: Sep 2007
Real name: Massimo
Originally Posted by lasto View Post
it all set same as yours m8 but pics in posts still need to be clicked on.
Thanks for your time is appreciated.

If i turn off the show thumbnail in attachments option it just displays a link instead of the pic
Watch here if is like U want: http://www.forumocchisullanatura.it

P.
__________________
My web site

My forum: Forum Occhi sulla Natura
Reply With Quote
  #53  
Old 05 Oct 2007, 22:00
lasto lasto is offline
 
Join Date: Jan 2002
that is weird cause its deffo working on your board.Yet my options in admincp are same as yours yet dont work

will pm u an account so u can take a look m8
Reply With Quote
  #54  
Old 05 Oct 2007, 22:04
Principe10's Avatar
Principe10 Principe10 is offline
 
Join Date: Sep 2007
Real name: Massimo
Originally Posted by lasto View Post
that is weird cause its deffo working on your board.Yet my options in admincp are same as yours yet dont work

will pm u an account so u can take a look m8
send here: info@massimopisettaphotography.com

P.
__________________
My web site

My forum: Forum Occhi sulla Natura
Reply With Quote
  #55  
Old 05 Oct 2007, 22:09
lasto lasto is offline
 
Join Date: Jan 2002
sent m8
Reply With Quote
  #56  
Old 05 Oct 2007, 22:45
WEBclay's Avatar
WEBclay WEBclay is offline
 
Join Date: Aug 2006
Location: Switzerland
Real name: Manuel Merz
Hi there

I did all needed changes twice but no thumb is displaying. My other administrator got the sql error too when clicking on "new posts" but not me :/

edit: never mind. Don't forget: Always do the modifications on the right style, lol

Last edited by WEBclay; 05 Oct 2007 at 23:04.
Reply With Quote
  #57  
Old 06 Oct 2007, 12:46
lasto lasto is offline
 
Join Date: Jan 2002
@Principe10

big thanks for sorting out my problem.
Reply With Quote
  #58  
Old 06 Oct 2007, 13:51
Principe10's Avatar
Principe10 Principe10 is offline
 
Join Date: Sep 2007
Real name: Massimo
Originally Posted by lasto View Post
@Principe10

big thanks for sorting out my problem.
You'r welcome!

M.
__________________
My web site

My forum: Forum Occhi sulla Natura
Reply With Quote
  #59  
Old 08 Oct 2007, 23:10
Defkalion Defkalion is offline
 
Join Date: Jan 2007
@lasto and @principe10: Can you guys please share how you accomplished this? I've been trying to do it myself, following principe10's instructions and screenshots but I haven't been able to get it to work.

Can you please assist?
Reply With Quote
  #60  
Old 08 Oct 2007, 23:49
Spank Spank is offline
 
Join Date: Jan 2007
Real name: Mark
Is it possible to take a thumbnail from the first youtube video posted in a thread?
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 00:58.

Layout Options | Width: Wide Color: