Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
  #61  
Old 22 Mar 2008, 00:26
Hornstar's Avatar
Hornstar Hornstar is offline
 
Join Date: Jun 2005
Real name: Matt
Okay few things.

1st, as vb.com would say

To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions


[Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

Next, disable all plugins.

Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

define('DISABLE_HOOKS', true);

Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it. Do you have the same problem?

--------------------------------------

obviously some of the above will not apply to you, but that is the general first thing you do. Check your plugins and hacks you have done to your board!

--------------------------------------

2nd, you said your database was compromised a few months ago or something. Well that rings alarm bells straight away.
Provide more info on this aspect and it may shed some light.

--------------------------------------

3rd, are you the only admin?

--------------------------------------

4th, are you on shared hosting or a dedicated server?

--------------------------------------

5th, What vbulletin version are you running?

-------------------------------------

6th, what version of php and mysql are you on?

----------------------------------------


Once I know the above info, we can go from there.
Reply With Quote
  #62  
Old 22 Mar 2008, 00:59
flavoflav2000 flavoflav2000 is offline
 
Join Date: Dec 2005
two words - mod security - on you web server - http://www.modsecurity.org/

This will help with the script kiddies - and XSS and system injection attacks - if your server or site was compromised it was because the security sucked.

Also I would make sure you have cpanel server locked down - go to the cpanel forums to find out how.

Do you have shell access to the server?

You may want to run rkhunter and see whats up.

If you have been comprimised for a month - well best advice to you is - redo the server - i.e. wipe it clean and reinstall the OS lock it down, install mod security and trip wire - rebuild your forum etc and go from there.

A system that has been hacked for a month is screwed no matter what you do.
__________________

___________________
www.westcoastbikers.com
Reply With Quote
  #63  
Old 24 Mar 2008, 11:55
t3nt3tion's Avatar
t3nt3tion t3nt3tion is offline
 
Join Date: Aug 2005
Real name: Adrian A.
If you need more in depth help, I`d offer my help : server & forum. Drop a pm if you want to.
Reply With Quote
  #64  
Old 28 Mar 2008, 20:21
FlyBoy73 FlyBoy73 is offline
 
Join Date: Feb 2002
Why is this in the big board forums?
Reply With Quote
  #65  
Old 02 Apr 2008, 10:44
Brian30fl Brian30fl is offline
 
Join Date: Jun 2005
well doh cause its a big board being screwed with
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


New To Site? Need Help?

All times are GMT. The time now is 09:55.

Layout Options | Width: Wide Color: