Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Subforums on Forumhome (no extra queries Version) Details »
Subforums on Forumhome (no extra queries Version)
Mod Version: 1.00, by Xenon (Member) Xenon is offline
Developer Last Online: Jul 2018 I like it Show Printable Version Email this Page

This modification is in the archives.
vB Version: 2.2.x Rating: (1 vote - 4.00 average) Installs: 53
Released: 17 Feb 2003 Last Update: Never Downloads: 10
Not Supported  

Well, i think most of you know the hack already but with a great ammount of additional queries.

This hack shows on every forum on forumhome (also on categories if you want it so) all it's Subforums.
It works dynamically so whenever you add a forum, it will be added to the list

One disadvantage on having it queryless is, that if you have private subforums below nonprivate mainforums that these will be seen so (not accesable but seen)

Hope it fits in what some of you need

Download Now

Only licensed members can download files, Click Here for more information.

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
  #61  
Old 13 May 2003, 15:16
lifesourcerec's Avatar
lifesourcerec lifesourcerec is offline
 
Join Date: Jan 2002
Today at 10:00 AM Nietzsche said this in Post #60
@WE and life:
To get the subforums bold you have to edit the part in forum.php and after that, you have to edit a forum to update the cache like you have to do when you first install the hack.
Thanks. Worked like a charm.
Reply With Quote
  #62  
Old 17 Jun 2003, 06:55
csidlernet csidlernet is offline
 
Join Date: Apr 2003
Real name: chad
Thankyou!

/me hits install button
Reply With Quote
  #63  
Old 19 Jul 2003, 07:20
kaotic's Avatar
kaotic kaotic is offline
 
Join Date: Mar 2003
I would really like to install this nice little hack, but sadly, I'm getting an error:

Database error in vBulletin Control Panel 2.3.0:

Invalid SQL: UPDATE forum SET subforums=''
mysql error: Unknown column 'subforums' in 'field list'

mysql error number: 1054
I triple checked the query that I was suppose to run. It worked perfectly. Can someone point me in the right direction?
Reply With Quote
  #64  
Old 19 Jul 2003, 12:05
Xenon's Avatar
Xenon Xenon is offline
 
Join Date: Oct 2001
Real name: Stefan Kaeser
you must have made an error while runing the alter table query.
do it again, i can't help any further....
Reply With Quote
  #65  
Old 20 Jul 2003, 05:14
kaotic's Avatar
kaotic kaotic is offline
 
Join Date: Mar 2003
Is there another method that I could use to update the cache? Like a query that I could run myself.
Reply With Quote
  #66  
Old 20 Jul 2003, 13:57
Xenon's Avatar
Xenon Xenon is offline
 
Join Date: Oct 2001
Real name: Stefan Kaeser
to update the cache yourself you have to run a lot of queries yourself, so i don't suggest you'd do that ^^

also the problem you reported above is not because of the caching, but because you haven't installed the hack correctly
Reply With Quote
  #67  
Old 28 Jul 2003, 03:16
kaotic's Avatar
kaotic kaotic is offline
 
Join Date: Mar 2003
I knew I followed instructions correctly. After running repair.php, it finally started working. Thanks for the hack.
Reply With Quote
  #68  
Old 28 Jul 2003, 11:51
Xenon's Avatar
Xenon Xenon is offline
 
Join Date: Oct 2001
Real name: Stefan Kaeser
ah, ok a db problem could always produce unknown bugs ^^

Reply With Quote
  #69  
Old 30 Jul 2003, 05:03
Oblivion Knight's Avatar
Oblivion Knight Oblivion Knight is offline
 
Join Date: May 2002
Real name: Andy
Working like a charm, as always Xenon
Reply With Quote
  #70  
Old 08 Aug 2003, 01:10
lifesourcerec's Avatar
lifesourcerec lifesourcerec is offline
 
Join Date: Jan 2002
Can't get it to work on v2.3.0
Reply With Quote
  #71  
Old 10 Aug 2003, 17:26
Xenon's Avatar
Xenon Xenon is offline
 
Join Date: Oct 2001
Real name: Stefan Kaeser
i don't know of any problems with 2.3.0 as i've written it with 2.3.0.

follow the instructions carefully and it'll work
Reply With Quote
  #72  
Old 11 Aug 2003, 01:05
lifesourcerec's Avatar
lifesourcerec lifesourcerec is offline
 
Join Date: Jan 2002
I re-did it step by step twice and no go. Added
$forum[subforums]
to level2_post and level2_nopost and it still doesn't work. I did edit forum and save. Nothing happening.
Reply With Quote
  #73  
Old 19 Aug 2003, 22:30
Xenon's Avatar
Xenon Xenon is offline
 
Join Date: Oct 2001
Real name: Stefan Kaeser
then i can't help, as it's not reproducable on my testboards...
are you sure you've uploaded the files correctly?
Reply With Quote
  #74  
Old 21 Aug 2003, 17:33
The Realist's Avatar
The Realist The Realist is offline
 
Join Date: Oct 2001
Real name: Brian
Its level1_nopost and level2_nopost templates not level2_post. Could that be your problem?

08-11-03 at 01:05 AM lifesourcerec said this in Post #72
I re-did it step by step twice and no go. Added to level2_post and level2_nopost and it still doesn't work. I did edit forum and save. Nothing happening.
Reply With Quote
  #75  
Old 21 Aug 2003, 17:34
The Realist's Avatar
The Realist The Realist is offline
 
Join Date: Oct 2001
Real name: Brian
Now I have a problem. Did the hack 100% working fine but every sub forum I have is showing up as a link under the main section header?

How can I only show the sub forums I need?
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 00:25.

Layout Options | Width: Wide Color: