Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Email Integration (New threads/replies by email) Details »
Email Integration (New threads/replies by email)
Mod Version: 2.6, by Cyricx (Member) Cyricx is offline
Developer Last Online: Dec 2011 I like it Show Printable Version Email this Page

This modification is in the archives.
vB Version: 3.6.8 Rating: (36 votes - 4.72 average) Installs: 191
Released: 02 Jul 2007 Last Update: 29 Feb 2008 Downloads: 2009
Not Supported DB Changes Uses Plugins Template Edits Auto-Template Code Changes Additional Files  

This mod is based off of the Mail Reply modification by Colin F to which I have obtained permission to rewrite and release.

This modification allows you to mimic email lists such as yahoo groups through your forums!

After installing this modification you will have new settings in your forum manager where for each forum you can enable this modification and setup a separate email address to use for each forum that you have this enabled for.

Just like how there is a separate email address for each yahoo group.

After doing so, members can subscribe to each forum that this mod is enabled for to receive notifications for new threads and replies.

Any posts in that forum, will be sent to them via email. (Example email attached below). The users can then reply to that email (which will then be processed and posted to the forums through the cron job that runs every 10 minutes), or they can send a new email to the email address and a brand new thread will be created!

Essentially mimicing an email list! Suddenly those users that hate forums, can still be dragged into the conversations and help keep the forum's activity level up!


BUGS!
These are the known bugs to date:
  • Confirmed bug that email processing does not handle Japanese characters.
Unsupported Items
These are the items that are not currently supported:
  • Some custom bbcode modifications will not display like they do on the forums in the html emails. Like glow, and the table mod.
TO UPGRADE
  • Please see the file in the zip for upgrading!! If your upgrading from version 2.3.X you will need to reverse some file edits that are no longer nessecary!
NEW INSTALL
  • See instructions in the zip file.
VERSION HISTORY!
(See the file in the zip for a complete history!)
  • 2.6 Release
    • Bug Fixes
      • Joining an unmoderated public group will now auto subscribe you per the usergroup settings.
      • NO CONFLICTS with Instant Thread Subscription! See details in below post.
    • New Stuff
      • User Option Allow Auto Subscribe - This is an admin allowable, user option that let's the user choose to not be auto subscribed.
      • User Option not receive own posts - A new user option that lets them select to NOT receive their own posts via email.
      • Editted the phrase for the Auto Subscription script to tell people what to do if there are no listings.
      • Added error checks when saving a usergroup for if auto subscriptioin is entered with a forumid for a forum that does not have email integration enabled and also checks that the usergroup you are saing is entered in the forum manager as allowed to use email integration.
  • 2.6.1 Release (BETA VERSION)
    • Hot Fix
      • It appears I was unseting a variable too soon. I've corrected this and it has resolved the issue with multiple posted replies on my test server.
Most of these will be slow to make it in til I know I've got the code to handle just about every type of email we could receive But in anycase, here are the ideas for future versions!
  • End User Option to subscribe to just receive new thread emails, or receive all new thread & reply emails (current version does all new threads & replies).
Thanks to RedTyger, Bob Denny, Ed Kohwley and Chris McKeever for their additions and assistance with portions of this code.

Huge thanks also goes to the many individuals that have helped test various incarnations of this mod.

MAD PROPS TO: cgmckeever for a great quoting regex for the old format, and all the mods at www.4winmobile.com for helping test version 2.4 prior to release!!

You guys rock!

Please feel free to donate to my continued work on this modification!! It let's me spend more time on it!
Make a Donation!


Version 2.6 will work with both 3.6.8 and 3.7!


The #.X versions are the solid tested versions.

The #.X.X versions are the beta versions. New features and bug fixes will be worked in there and then when I have a solid version it'll be released as the next #.X

Thank you!!

~ Cyricx

Download Now

Only licensed members can download files, Click Here for more information.

Supporters / CoAuthors

Screenshots

Click image for larger version

Name:	exampleemailnewformat.jpg
Views:	1987
Size:	90.0 KB
ID:	74777   Click image for larger version

Name:	exampleemailoldformat.jpg
Views:	2154
Size:	42.7 KB
ID:	74778   Click image for larger version

Name:	examplesubforum.jpg
Views:	1484
Size:	26.2 KB
ID:	75917  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Major Additions Email Integration (New Threads/Replies by and through email!) Cyricx vBulletin 3.7 Add-ons 357 24 Jun 2014 20:05

  #841  
Old 21 May 2008, 20:20
capsize capsize is offline
 
Join Date: May 2007
Cyricx has been good about incorporating all the bug fixes reported in this thread into his next releases. I don't have a clue when he might make another release of this mod, though his last post said that he was going to replace the mimedecode.php message parsing with something more robust; i.e., a major change. I'm relying on this mod on my board and have so far not had any problems. I'd definitely like to help make this mod as solid and stable as possible. A major failure of this mod would be devastating to my board. It would be useful to put together a list of open bugs unrelated to the mimedecode attachment parsing for Cyricx to fix in his next release. I'll start it here. Please post any issues you're having with this mod so that they can be addressed. Note that "fixed" below only means that a workaround is known that seems to resolve the problem. There may be a better fix to the problem but this workaround is sufficient for now.

2.6.1beta issue #1:
Email notification for a new thread contains a blank name for the poster
status: fixed
see post #760 in this thread from Ron Wilhelm

2.6.1beta issue #2:
Fatal error: Call to a member function on a non-object in [forumdir]/includes/cron/emailintegration.php on line 1093
status: unknown
When this error occurs, incoming email posts are emailed out multiple times and are not deleted from the mailbox. May be caused by certain incoming email messages containing text or headers that are not handled properly.

2.6.1beta issue #3:
Fatal error: require_once() [function.require]: Failed opening required '[forumdir]/includes/functions_threadprefix.php' (include_path='.:/usr/local/lib/php') in [forumdir]/includes/cron/emailintegration.php on line 41
status: unknown
May be caused by an incorrect configuration or installation of the EI mod.

2.6.1beta issue #4:
PHP Fatal error: Call to a member function set_parsing_language() on a non-object in [forumdir]/includes/cron/emailintegration.php on line 1615
status: fixed
see post #809 in this thread from toivo

2.6.1beta issue #5:
Dismiss attachments mode doesn't work properly
status: fixed
see post #839 in this thread from capsize
Reply With Quote
  #842  
Old 21 May 2008, 20:37
ThePiston ThePiston is offline
 
Join Date: Jun 2006
can we also start a thread for requested changes?

For example: if you really want this to work like an email list, you need to have the ability to either the "list" or just the person that sent the last post. It's like having "reply" vs "reply all". That's a huge piece of the puzzle missing for me and I sadly I can't use it until that's addressed. Shouldn't be too hard - make the "reply all" go back to the forum like usual, but the "reply" be directed as a PM to that one user.
Reply With Quote
  #843  
Old 31 May 2008, 23:37
capsize capsize is offline
 
Join Date: May 2007
I have a tentative fix for issue #2. I believe this fix also resolves another aspect of issue #4. If you have experienced either issue #2 or #4, can you please try making the following changes plus toivo's change for #4 and report back as to whether the issues are fixed?

I believe the cause of #2 and #4 is that a variable is redefined and then unset within a block inside a loop. This causes the remaining code in the loop to now reference the unset variable. The workaround is to use a different name for the variable in the block so that it doesn't conflict with the other usage. The name collision appears to be a case where code was copied and pasted carelessly.

I have made the changes to my installation and have seen no problems with this fix so far.

Here's the fix to 2.6.1beta:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Reply With Quote
  #844  
Old 01 Jun 2008, 09:42
tekguru tekguru is offline
 
Join Date: May 2007
Okay change now in place on my site, we'll see how it goes!
Reply With Quote
  #845  
Old 01 Jun 2008, 21:35
goldendox goldendox is offline
 
Join Date: Mar 2008
I have the beta installed. Did a test by running it in task manager. Seems okay, yet nobody is getting emails (that I know of).

in hostname, is localhost ok, or should it be 'localhost'
it seems that all users are set by default to receive emails from all forums. I have a junior member acct (who i have as an allowed usergroup), and am not receiving any emails other than the admin ones. i set each forum up with different addresses. still have the admin one. that is the one i'm still getting standard email notifications of.

also, how or where can i check to see if those emails are going through?

thanks.

Last edited by goldendox; 01 Jun 2008 at 21:49.
Reply With Quote
  #846  
Old 01 Jun 2008, 22:26
Cyricx Cyricx is offline
 
Join Date: Sep 2002
I'm still bouncing around, but have zero time to look into all the posts yet..

Wife lost her job, so having to take on alot of extra freelance work to keep the bills paid.

No eta on when I'll be able to bust some more arse on this. There are a few new email parsers out I want to try.

Just wanted to give ya all a headsup so you didn't think I was dead LOL.

Just paying bills
__________________
Cyricx (Chris)
Reply With Quote
  #847  
Old 03 Jun 2008, 01:09
Tralala's Avatar
Tralala Tralala is offline
 
Join Date: Jan 2006
Hiya Cyricx, long time no chat, thanks for your help with getting this guy installed on my small forum.

I only have one sub-forum set up for important announcements, that's the one that has email integration turned on.

My question is, is it possible to set it so that only one usergroup can post to particular forum, but that those posts are emailed to everyone on the forum (assuming everyone is subscribed?)

If so, would I just set this up in that forum's usergroup permissions?
Reply With Quote
  #848  
Old 03 Jun 2008, 01:44
Cyricx Cyricx is offline
 
Join Date: Sep 2002
I believe right now, those two permissions are tied together in the "Please enter the usergroup IDs that can use this feature." setting in the Forum Manager. That controls who can choose to receive the emails as well as who is enabled to receive them.

I'll add this to my list to separate those permissions though.
__________________
Cyricx (Chris)
Reply With Quote
  #849  
Old 03 Jun 2008, 03:08
toivo toivo is offline
 
Join Date: Jul 2007
Real name: Toivo Talikka
I have just re-installed the EI mod to a test forum with the suggested modifications. Messages are read and posted all right to the forum, and they magically started arriving by email, too.

Regards,
toivo

Last edited by toivo; 03 Jun 2008 at 03:24.
Reply With Quote
  #850  
Old 03 Jun 2008, 17:19
Tralala's Avatar
Tralala Tralala is offline
 
Join Date: Jan 2006
Originally Posted by Cyricx View Post
I believe right now, those two permissions are tied together in the "Please enter the usergroup IDs that can use this feature." setting in the Forum Manager. That controls who can choose to receive the emails as well as who is enabled to receive them.

I'll add this to my list to separate those permissions though.
Ah, okay, I was thinking I could set this up with the standard forum permissions (ie: restricting postability via the standard admin tools.)

I anxiously await any future updates. This mod makes vBulletin so much better for our needs and I really appreciate your work on it. Thank you!
Reply With Quote
  #851  
Old 04 Jun 2008, 22:02
rcwild rcwild is offline
 
Join Date: Mar 2004
I'm having a problem similar to a previous poster. Scheduled Task Manager error message reads:

Email Integration

Warning: imap_open(): Couldn't open stream {localhost:110/pop3/notls}INBOX in [path]/includes/cron/emailintegration.php on line 98

Failed to connect to the mailbox for forum - News, Videos, Free for All

Warning: imap_open(): Couldn't open stream {localhost:110/pop3/notls}INBOX in [path]/includes/cron/emailintegration.php on line 98

Failed to connect to the mailbox for forum - Technical Canyoneering

Warning: imap_open(): Couldn't open stream {localhost:110/pop3/notls}INBOX in [path]/includes/cron/emailintegration.php on line 98

Failed to connect to the mailbox for forum - Canyon Beta & Partners
Done
It seems to suggest that there is a discrepancy with usernames and/or passwords, but I've checked, double-checked and triple-checked to make sure they match.

I'm stumped.
Reply With Quote
  #852  
Old 04 Jun 2008, 22:56
goldendox goldendox is offline
 
Join Date: Mar 2008
Thanks. Sorry to hear about your wife losing her job. Hang in there. I've disabled this beta till able to get support regarding why it's not working. Thanks.

{QUOTE=Cyricx;1538174]I'm still bouncing around, but have zero time to look into all the posts yet..

Wife lost her job, so having to take on alot of extra freelance work to keep the bills paid.

No eta on when I'll be able to bust some more arse on this. There are a few new email parsers out I want to try.

Just wanted to give ya all a headsup so you didn't think I was dead LOL.

Just paying bills [/QUOTE]
Reply With Quote
  #853  
Old 04 Jun 2008, 22:57
rcwild rcwild is offline
 
Join Date: Mar 2004
With some help from my host, I moved beyond the mail connection problem above and onto a new problem.

Email Integration

Fatal error:
This forum requires that you wait 30 seconds between posts. Please try again in 30 seconds.
Unable to proceed with save while $errors array is not empty in class vb_datamanager_post in [path]/includes/class_dm.php on line 810
Reply With Quote
  #854  
Old 04 Jun 2008, 23:10
toivo toivo is offline
 
Join Date: Jul 2007
Real name: Toivo Talikka
Originally Posted by goldendox View Post
I have the beta installed. Did a test by running it in task manager. Seems okay, yet nobody is getting emails (that I know of).

in hostname, is localhost ok, or should it be 'localhost'
it seems that all users are set by default to receive emails from all forums. I have a junior member acct (who i have as an allowed usergroup), and am not receiving any emails other than the admin ones. i set each forum up with different addresses. still have the admin one. that is the one i'm still getting standard email notifications of.

also, how or where can i check to see if those emails are going through?

thanks.
If the email messages you send to the mailbox are read all right by EI mod, then obviously the hostname of your SMTP server is correct. If the mailbox is on a mail server running in the same box as your vBulletin, the hostname should be just localhost, without quotes.
Reply With Quote
  #855  
Old 04 Jun 2008, 23:22
toivo toivo is offline
 
Join Date: Jul 2007
Real name: Toivo Talikka
Originally Posted by rcwild View Post
With some help from my host, I moved beyond the mail connection problem above and onto a new problem.
The script /includes/class_dm.php is not part of the EI mod but obviously its methods are being used when posting the email messages.

The 30 second restriction comes from the flood check setting in AdminCP - vBulletin Options - Email Options: "This is the number of seconds that must elapse between emails that a user can send to other members. This is primarily to prevent a user from easily spamming members. Set it to 0 to disable this option."

It would be useful to see what actual error causes the $errors array to have a message. Have you tried to change the 30 second limit to 0?
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 16:57.

Layout Options | Width: Wide Color: