Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Mobile/Cell Phone Style Details »
Mobile/Cell Phone Style
Mod Version: 2.10a, by dartho (Coder/Designer) dartho is offline
Developer Last Online: Mar 2022 I like it Show Printable Version Email this Page

This modification is in the archives.
vB Version: 3.6.10 Rating: (15 votes - 4.80 average) Installs: 263
Released: 02 Jul 2007 Last Update: 12 Jun 2008 Downloads: 2828
Supported Template Edits Additional Files  

A version for 3.7 can be found HERE

A super light style designed for Mobile Phones - use in conjunction with THIS or THIS modification to redirect mobile phone users to this theme.

This is a work in progress, and any and all feedback is greatly appreciated - I will do my best to act on bugs and suggestions.

Check http://mobility.mobi (not my site) from a mobile device to see how it looks or you can visit via an emulator HERE

Whilst this doesn't have ALL functionality of vBulletin default, it does allow browsing forums, replying to posts, creating new topics and sending/receiving PMs.

I'm new at this, be kind.

Version History
1.00 - Initial Release
2.00 - Validates Strict XHTML 1.0 on http://validator.w3.org/
Added PM notification, fixed new reply, new thread, new PM to look better. Can edit posts. Added Logout and also an "Up" menu which will take you to the parent forum of where ever you currently are. Images in posts are replaced with a link to the image - unfortunately this meant I had to do teh same to smilies which all now show up as :-) (which is a link to teh smilie itself). It is now approaching a fully functioning skin - not sure what else you would want to do from a mobile phone/PDA. A few small bugs fixed too.
2.01 - Added viewing thread subscriptions, who's online (both only for logged on members) and quick reply
2.02 - Quick reply for logged on members only
2.03 - fix a w3.org validation issue, added "mark forums read" to forum home
2.04 - Internal release
2.05 - added mark as read to 'new posts' added 'sub' (Subscribed threads) and 'online' (who's online) footer navbar forum name in post title (as link) fixed a few things.
2.06 - Page numbers appear in thread bits
- UserCP page, with access to PMs, Subscribed Threads, Edit Signature, Edit Options (which includes changing view from oldest first to newest first
- Basic MOD options added - can delete posts and threads (and undelete also)
- Remember me added to login in footer (duplicate login screens removed
- I should probably test this latest version more extensively and re validate it, but thought you wouldn;t mind a pre-release

2.07 - Added requests, revalidated STRICT XHTML on w3.org. If you have modified your existing install of this, I suggest you backup the style first before upgrading with this new version just in case you want to roll back.
2.08 - Remove backlink from FORUMHOME
2.09 - updated version numbers on templates to 3.6.9
2.10 - added securitytoken field to all forms

A Spanish translation can be found in post # 200 HERE

Install Instructions
Unzip and upload the wireless.css to your forum root.
Import the XML as a new style WITH NO PARENT.

Upgrade Instructions
Unzip and upload the wireless.css to your forum root (overwriet existing).
Import the XML and merge with existing. Alternatively you could delete the existing mobi style and re-upload fresh.

Keywords: Mobile, Cell, Portal, Mobi, Light, PDA, Phone

Screen Shots - Don;t be put off by the colours, these are all very easily changed by editing the CSS file. If you need help, just ask. I did these from a desktop browser with the window resized to 240px wide - to get a proper idea of the look, use the emulator link mentioned above. It looks MUCH better from an actualy small screen device!



How to hide a style from style chooser
This template edit will allow you to 'hide' a style from the Style Chooser so users can't select a specified style.

Download Now

Only licensed members can download files, Click Here for more information.

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Forum Display Enhancements Mobile Phone / iPhone / PDA Detection and Style Assignment dartho vBulletin 3.7 Add-ons 407 19 Mar 2015 14:53
Mobile, Cell, Phone, PDA, iPhone Style dartho vBulletin 3.7 Styles 795 16 Aug 2012 13:39

  #271  
Old 12 Jun 2008, 07:57
SwissGuy SwissGuy is offline
 
Join Date: Jul 2004
Maybe I missed it (happens ), new threads/threads with new posts are not highlighted (green, I read in the thread) on our forum. Any thoughts?

Edit: Stickies show up fine (yellow) by the way. So I guess the CSS is in the right place.
Reply With Quote
  #272  
Old 12 Jun 2008, 09:31
dartho dartho is offline
 
Join Date: Sep 2005
Green for new threads was from the original CSS. I think now new threads are only bolded..

You can change the colours around by editing the wireless.css file - look at all the classes with "new" or "unread" in the name...
Reply With Quote
  #273  
Old 12 Jun 2008, 09:39
dartho dartho is offline
 
Join Date: Sep 2005
New version release - only change is securitytoken added in for all forms..

Originally Posted by Tim. View Post
This is a great mod, perfect for my Blackberry Curve!

However after applying it, I notice one problem:
The top forums are not displayed in the Mobile Version, however are displayed in the Full Version. Screen shot attached.

Webpage: http://www.wc3campaigns.net/forums.php

As you can see on the Full Version there are forums titled 'Developers Corner', 'Artists Corner,' 'Project Discussion,' 'Hosted Projects,' then 'Town Hall' and the rest. The Mobile Version skips straight to the 'Town Hall.'


Any ideas?
Hi Tim - I've just had a look at your forums, and the "missing" forums are somehow different to the rest... Your "Modding" Forums and sub forums are the ones not showing up. I notice the link to "Warcraft III Modding Forums" is /forums.php?ex=1 which is not standard vBulletin. There must be an addon installed messing with things....
Reply With Quote
  #274  
Old 12 Jun 2008, 10:00
SwissGuy SwissGuy is offline
 
Join Date: Jul 2004
Great. Found the right places and made the changes .... and there we are. Many thanks!
Originally Posted by dartho View Post
Green for new threads was from the original CSS. I think now new threads are only bolded..

You can change the colours around by editing the wireless.css file - look at all the classes with "new" or "unread" in the name...
Reply With Quote
  #275  
Old 12 Jun 2008, 10:01
SwissGuy SwissGuy is offline
 
Join Date: Jul 2004
Originally Posted by dartho View Post
New version release - only change is securitytoken added in for all forms.
Just tried it. Sadly, this hasn't completely fixed the issue.

I found out that I can post using the reply button and "normal editor". The quick reply returns the same error as before, though.
Reply With Quote
  #276  
Old 12 Jun 2008, 10:41
dartho dartho is offline
 
Join Date: Sep 2005
You're right! Should be fixed now (version 2.10a) Thanks!
Reply With Quote
  #277  
Old 12 Jun 2008, 11:03
SwissGuy SwissGuy is offline
 
Join Date: Jul 2004
Works like a dream now. Many thanks for your efforts, Dartho. Much appreciated.
Reply With Quote
  #278  
Old 12 Jun 2008, 17:04
mariocaz mariocaz is offline
 
Join Date: Feb 2008
I have a problem I want to do the update but in the ACP panel said me that the specified file is invalid when I want to overwrite the other version.
Reply With Quote
  #279  
Old 12 Jun 2008, 22:51
dartho dartho is offline
 
Join Date: Sep 2005
Mario - this is the 3.6 version - you need the 3.7 version
Reply With Quote
  #280  
Old 13 Jun 2008, 02:29
mariocaz mariocaz is offline
 
Join Date: Feb 2008
Yes so sorry I was confused because I received a mail of updated advice for this mod, sorry also I have that one for 3.7 and updated.
Reply With Quote
  #281  
Old 18 Jun 2008, 12:16
incisor incisor is offline
 
Join Date: May 2006
Originally Posted by dartho View Post
You're right! Should be fixed now (version 2.10a) Thanks!
nope, not for me i get a Invalid File Specified error when i try to update with 10a
Reply With Quote
  #282  
Old 18 Jun 2008, 23:40
dartho dartho is offline
 
Join Date: Sep 2005
Are you installing via product manager or style manager?
Reply With Quote
  #283  
Old 20 Jun 2008, 12:02
incisor incisor is offline
 
Join Date: May 2006
as a style...

tried again tonite and it went fine, so it is clear it was something at my end..

not sure what but it worked fine....
Reply With Quote
  #284  
Old 18 Jul 2008, 20:24
Tralala's Avatar
Tralala Tralala is offline
 
Join Date: Jan 2006
I'd love this skin, and am still on 3.6.x so can't (yet) use the 3.7 upgrade.

Any chance this version can get the update: "Added auto quoting when replying to a post"
(Cuz that's really the only thing my users are clamoring for.)

And I can't justify going through the hassle of upgrading my whole forum to 3.7 just yet, just to use that skin, just to get that feature.

Thanks for the consideration.
Reply With Quote
  #285  
Old 18 Jul 2008, 22:56
dartho dartho is offline
 
Join Date: Sep 2005
Changing your newreply template to the following should do the trick

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 08:16.

Layout Options | Width: Wide Color: