Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
  #1  
Old 22 Jan 2008, 18:00
crucialjames crucialjames is offline
 
Join Date: Jan 2008
Location: BOSTON
Real name: James
Moving from 3.0 to 3.6 and new HOST

I'm currently hosting 3.0.7 on provider A and 3.6.8 on provider B (My New Host).

When backing up the mySQL database on 3.0.7 and uploading to the new hosting provider I get this error when executing the backup into the new mySQL

$ mysql -uUSER -pPASS vbulletin < vbulletin.sql

ERROR 1064 at line 182439: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near '<br />
<b>Fatal error</b>: Maximum execution time of 30 second

Current Host: mySQL 3.x
New Host: mySQL 4.x

If I'm jumping to 3.6.8 too fast please let me know what version I should be going to that might work with this transistions as I don't have much time before old hosting provider shuts me off. The database size is 205M

James
Reply With Quote
Comments
  #2  
Old 22 Jan 2008, 18:36
snakes1100 snakes1100 is offline
 
Join Date: Dec 2001
Real name: Anthony
What did you use to dump the database on the old server?

What version of 4.x is it exactly?
Reply With Quote
  #3  
Old 22 Jan 2008, 18:54
crucialjames crucialjames is offline
 
Join Date: Jan 2008
Location: BOSTON
Real name: James
Thanks for a quick response...

I logged into the admin cp disabled the board for a few minutes and backed it up to my PC then transfered it via binary mode on my ftp client to the new server.

New Server mySQL = version: 4.0.17

I have full access on the new server, just plesk on the old server and their crontab wont do a mysqldump thats why I resorted to admincp for dump.
Reply With Quote
  #4  
Old 22 Jan 2008, 22:40
slappy slappy is offline
 
Join Date: Apr 2003
You did not say if you created the backup with phpMyAdmin, the AdminCP or MySQL.

In posts on vBulletin.com I find:

This is a server time limit. To temporarily up your limits edit your includes/config.php file and add this line right under the <?php line:

ini_set("max_execution_time", "240");

This, and other post on vBulletin.com also said:

This is a server issue where the process is taking longer than the maximum allowed on the server.

The only consistently reliable method of backing up and restoring a database is with shell access via telnet or ssh. This is because backing up with a PHP script like that in the Admin CP or phpMyAdmin can result in PHP timeout errors and an incomplete backup file.

Please see the instructions here:

Backup:
http://www.vbulletin.com/docs/html/m...nce_ssh_backup

Restore:
http://www.vbulletin.com/docs/html/m...ce_ssh_restore

If you don't have telnet or SSH access, some people have reported success with these scripts:

MySQLDumper:
http://www.mysqldumper.de/en/index.php

MySQLHotxcopy:
http://www.vbulletin.com/forum/showt...t=mysqlhotcopy

Bigdump (restore only):
http://www.ozerov.de/bigdump.php

Hope that helps.

Regards,

Last edited by slappy; 22 Jan 2008 at 22:53.
Reply With Quote
  #5  
Old 22 Jan 2008, 22:41
crucialjames crucialjames is offline
 
Join Date: Jan 2008
Location: BOSTON
Real name: James
I just actually moved it 100%. I manually got the webhost to do a backup of the DB for me.

thanks everyone
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 03:12.

Layout Options | Width: Wide Color: