Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old 19 Feb 2017, 18:25
ka99 ka99 is offline
 
Join Date: Aug 2005
Lightbulb Help: db error installing helpcenter

Hi

I'm trying to install the product help center http://www.vbulletin.org/forum/showthread.php?t=176367

but after uploading the product the tables arent created in the db, I get the error:

=====================
Database error in vBulletin 3.8.9:

Invalid SQL:
SELECT * FROM helpcenter_department ORDER BY displayorder;

MySQL Error : Table 'db_vb3.helpcenter_department' doesn't exist
Error Number : 1146
Request Date : Sunday, February 19th 2017 @ 10:21:27 PM
Error Date : Sunday, February 19th 2017 @ 10:21:27 PM
Script : http://xxx/vb/admincp/helpcenter_adm...do=departments
Referrer : http://xxx/vb/admincp/index.php?do=nav
IP Address : 188.153.230.15
Username : admin
Classname : vB_Database_MySQLi
MySQL Version : 5.6.35-log
=====================

I looked at the db using phpmyadmin and didnt find the tables

how can I create the required tables ?

Thanks for the help
Attached Files
File Type: xml product-helpcenter.xml (45.4 KB, 0 views)
Reply With Quote
  #2  
Old 19 Feb 2017, 18:30
Dave Dave is offline
 
Join Date: Jun 2010
Real name: Dave
Well the plugin was made 9 years ago for vBulletin 3.7.*, you're trying to install it on the most recent vBulletin 3 version, no wonder it doesn't work.

You can check the installation XML files for the table structures.
__________________
https://technidev.com - security, development, exploits, vBulletin
dave[at]technidev[dot]com

Contact me for custom vBulletin 3/4 work & server/website management.
Reply With Quote
  #3  
Old 19 Feb 2017, 18:35
ka99 ka99 is offline
 
Join Date: Aug 2005
Originally Posted by Dave View Post
Well the plugin was made 9 years ago for vBulletin 3.7.*, you're trying to install it on the most recent vBulletin 3 version, no wonder it doesn't work.

You can check the installation XML files for the table structures.
I tried, compared it with other products installed successfully but couldnt find a way to fix it

hope someone can help checking the xml and tell me how to create the tables

Thanks.
Reply With Quote
  #4  
Old 19 Feb 2017, 23:04
Dr.CustUmz's Avatar
Dr.CustUmz Dr.CustUmz is offline
 
Join Date: Aug 2013
Real name: Ryan
Should work a ok for ya now =)

Uninstall the old one first and re upload all files
Attached Files
File Type: zip HelpCenterVB.zip (20.0 KB, 5 views)
__________________
Sorry been away so long, new baby, got married, got into GM, just got to the point I can resume developing.
I'm working on a bunch of products, some free, some paid, and will release them all at once.
Dirt RIF CustUmz
Reply With Quote
  #5  
Old 20 Feb 2017, 00:18
ka99 ka99 is offline
 
Join Date: Aug 2005
Originally Posted by Dr.CustUmz View Post
Should work a ok for ya now =)

Uninstall the old one first and re upload all files
THANKS a million!!

have been fighting with different versions since yesterday with no luck

appreciate your help
Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Add-On Releases PS - HelpCenter PaulSonny vBulletin 3.6 Add-ons 86 16 Oct 2013 17:32
Add-On Releases PS - HelpCenter PaulSonny vBulletin 3.7 Add-ons 813 02 Jul 2012 00:18



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 13:48.

Layout Options | Width: Wide Color: