Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Mark Threads As "Solved" Details »
Mark Threads As "Solved"
Mod Version: 2.0.1, by Eric (Coder/Designer) Eric is offline
Developer Last Online: Oct 2018 I like it Show Printable Version Email this Page

vB Version: 4.0.x Rating: (34 votes - 4.56 average) Installs: 303
Released: 04 Feb 2010 Last Update: 30 Jul 2010 Downloads: 1348
Not Supported DB Changes Uses Plugins Template Edits Additional Files Re-usable Code  

My time is very limited these days, with my full time job. I have marked this mod as re-usable code, if any other coder wishes to continue work on it. I may still try to support this mod as time permits.



If you use this modification, please >> Mark As Installed, and consider Nominate for MOTM and Support Developer <<


What is this!?
This modification will allow you & your members (based on usergroup permissions) to mark a thread as "Solved". It will add the prefix "[SOLVED]" to the thread title, and if set in the admincp - it will also close the thread.

Current Version
2.0.1.

Features flagged for future version(s):
  • Thread starter can choose to solve a thread, and input the username of who solved it - that user would receive rep. points. (admin-configurable amount of rep. points)
  • Given the above - include count of threads a user has solved in postbit & profile
  • Option to move the thread to a specific forum when a thread is "Solved"
  • Possibly figure out a way to automate everything on install - so there are no template edits.
And anything else that is suggested

Will this work on x.x.x ??
Unless otherwise stated, this will work on all 4.0.x versions. This will not work on 3.x.

Sounds cool. How do I install?
  1. Extract the zip, you should have the following directories/files:


    Block Disabled:      (Update License Status)  
    Suspended or Unlicensed Members Cannot View Code.

  2. Upload: (in the below instructions 'yourforum' would be where you have vBulletin installed)
    • /upload/solved.php to /yourforum/solved.php
    • /upload/images/buttons/marksolved.gif to /yourforum/images/buttons/marksolved.gif (upload to each style folder, if you have more than one style)
    • /upload/includes/xml/bitfield_solvedthread.xml to /yourforum/includes/xml/bitfield_solvedthread.xml
  3. Import the product, product-solvedthreads.xml by going to: AdminCP -> Plugins & Products -> Manage Products -> [Add/Import Product]
  4. Make the following template edits to all of your installed styles:

    SHOWTHREAD

    Find:

    Block Disabled:      (Update License Status)  
    Suspended or Unlicensed Members Cannot View Code.

    Add after:

    Block Disabled:      (Update License Status)  
    Suspended or Unlicensed Members Cannot View Code.

  5. Set options in AdminCP > Settings > Options > Solved Threads
  6. Edit Solved Threads Permissions > Can Mark Threads as Solved for each usergroup.
  7. To setup the forums it can be used in, follow the instructions in this post.

Upgrade
  1. Re-import the product, product-solvedthreads.xml, with "Allow Overwrite" set to yes
  2. Upload the files/folders in the "upload" folder, allowing it to overwrite the old files.

That's it! Enjoy!

Changelog
2.0.1 - July 30, 2010
- Changes to solved.php, to check for errors while saving thread, changed how threadinfo is pulled.
- Changes to bitfield_solvedthread.xml, removed the "install" attribute, doesn't seem to work anyway.
- Changes to product-solvedthread.xml, install process. Gave the install a small delay between rebuilding prefix datastore (after adding prefixset), and creating prefix.
- Changes to product-solvedthread.xml, plugin. Removed check for can_use_prefix function, as vB 3.8 + includes it, and this mod is for 4.0

2.0.0 - February 3, 2010
- Updated to vBulletin 4

1.1.2 - January 15, 2010
- Updated the product file, permissions, and phrases. This should, hopefully, resolve the blank page problems, along with the permission not showing up for usergroups.

1.1.1 - July 21, 2009
- Updated the product plugins and phrases, this should solve the blank page problem, and the problem of the option not showing in Admincp for ug permissions.

1.1.0 - April 14, 2009
- Small updates to xml file, no version # change. If it works for you, no need to do anything.
- If you have problems uninstalling, please see this post.

1.1.0 - April 12, 2009
- Updated for 3.7 & 3.8
- Now uses the built-in Thread Prefix system
- Instead of 'excluding' forums, since using the Thread Prefix system, you can choose which forums this will be shown in.

1.0.1 - July 12, 2007
- Added the ability to unsolve a thread.
- Added the ability to exclude this in certain forums
- Added the ability to change the prefix in that acp

1.0.0 - June 8, 2007
- Initial release.



If you use this modification, please >> Mark As Installed, and consider Nominate for MOTM and Support Developer <<



NOTE: This mod is marked "unsupported", but I'll try my best (as time permits) to help those who have marked as installed.

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	admincp_edit_prefix_forums.jpg
Views:	1655
Size:	45.7 KB
ID:	111606   Click image for larger version

Name:	admincp_options.jpg
Views:	1226
Size:	66.9 KB
ID:	111607   Click image for larger version

Name:	admincp_thread_prefixes.jpg
Views:	1044
Size:	41.2 KB
ID:	111608   Click image for larger version

Name:	admincp_ug_perms.jpg
Views:	1336
Size:	136.2 KB
ID:	111609  

Click image for larger version

Name:	showforum_solvedthread.jpg
Views:	3158
Size:	87.5 KB
ID:	111610   Click image for larger version

Name:	showthread_marksolved.jpg
Views:	2890
Size:	74.5 KB
ID:	111611   Click image for larger version

Name:	showthread_markunsolved.jpg
Views:	2529
Size:	74.6 KB
ID:	111612  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
  #46  
Old 16 Mar 2010, 01:15
Eric's Avatar
Eric Eric is offline
 
Join Date: May 2006
Real name: Eric
Originally Posted by CCV_Pinto View Post
I think Ive found a little "cache" problem:

if my user creates an thread with a prefix "Problem", for example

then, I go there, and I mark the thread as solved

the prefix change fine, but, if I go back to the forum home, in the "last post" column, the name of the thread is still with the prefix "Problem"

I think thats because you cant only update the thread itself, but, if the thread is also the last thread of the forum, you have to update the forum too (because, if I am not wrong, the table "forum" of vbulletin stores some last thread infos, like title and prefix, probably)

anyway, great mod

thanks!
This is a vBulletin thing, not necessarily this mod. I may be able to add in a way to rebuild forum info though if it's really needed ...
Originally Posted by Terminator1138 View Post
so let me get this right as a few have pointed me here...

You can only create one usable prefix like solved and unsolved?

How can one create a multiple list like I mentioned above...I've added another prefix but it does not show up..

also is it possible when you create a thread for users to select thread prefixes? What I'm looking for is similar to what vbulletin.com has....any thoughts?


Update: I got this to work, what does the prefix add do , I see the solved one, but there is a setting to create another category like ?
This is simply for marking threads as "Solved", it doesn't support multiple prefixes. For what you're wanting to do, that's already a vBulletin feature.
__________________
My modifications

Please do not contact me for support via PM or E-Mail unless I've asked you to do so. Otherwise, your message will be ignored/deleted.
Reply With Quote
  #47  
Old 16 Mar 2010, 20:37
karel1985 karel1985 is offline
 
Join Date: Mar 2007
Real name: Karel B.
SecondV,

You made my day, we were waiting for your release for vb4 and i was a disapounted to hear if you would drop it, but i hope you will still continuiing this mod, special the future version would be soooooo nice to have.

I'll send you some support ;-)

Best regards,
Karel
__________________
Dutch Pc Helpforum - www.pc-helpforum.be
Reply With Quote
  #48  
Old 16 Mar 2010, 21:33
Eric's Avatar
Eric Eric is offline
 
Join Date: May 2006
Real name: Eric
Originally Posted by karel1985 View Post
SecondV,

You made my day, we were waiting for your release for vb4 and i was a disapounted to hear if you would drop it, but i hope you will still continuiing this mod, special the future version would be soooooo nice to have.

I'll send you some support ;-)

Best regards,
Karel
I'm working on a new release atm - not sure when it'll be ready, though.


Thank you for your generous donation Karel I appreciate it.
__________________
My modifications

Please do not contact me for support via PM or E-Mail unless I've asked you to do so. Otherwise, your message will be ignored/deleted.
Reply With Quote
  #49  
Old 23 Mar 2010, 23:35
wolfyman's Avatar
wolfyman wolfyman is offline
 
Join Date: Apr 2005
Real name: James
I can't change the forums this applies to since I updated to 4.0.2.. it was working in 4.0.1

This is what I get when I try to edit the prefix:
Attached Images
File Type: gif Untitled-1.gif (15.5 KB, 55 views)
__________________
see sig.
Reply With Quote
  #50  
Old 05 Apr 2010, 04:53
badawidollah badawidollah is offline
 
Join Date: Nov 2008
not work for vb402
Reply With Quote
  #51  
Old 05 Apr 2010, 23:27
Verionia Verionia is offline
 
Join Date: Jul 2009
I would like images instead of [solved]
Reply With Quote
  #52  
Old 19 Apr 2010, 15:12
7thSENSE 7thSENSE is offline
 
Join Date: Mar 2010
Nice mod! Which file and which line is to be edited to change the language of the output "mark thread as solved"?

Thanks!
Reply With Quote
  #53  
Old 19 Apr 2010, 16:50
Boosted Panda Boosted Panda is offline
 
Join Date: Mar 2008
Real name: Matt
Lightbulb

Originally Posted by SecondV View Post
Rebuild bitfields: yourforum.com/admincp/index.php?do=buildbitfields

And click on "Edit" in the prefix manager of the blank prefix, don't change anything, just hit Save.

I've never had this problem, but the above should fix it.
Great mod. I suggest you add this though to the install instructions, as I had the same issue.
Reply With Quote
  #54  
Old 11 Jun 2010, 23:05
CFodder CFodder is offline
 
Join Date: Mar 2008
Great mod, used this on 3.8 too.

How can I change the colour of the solved text, or at least make it bold?

Last edited by CFodder; 11 Jun 2010 at 23:19.
Reply With Quote
  #55  
Old 12 Jun 2010, 03:59
CFodder CFodder is offline
 
Join Date: Mar 2008
Never mind, undumbed myself and figured it out
Reply With Quote
  #56  
Old 22 Jun 2010, 00:43
LightFatality LightFatality is offline
 
Join Date: Sep 2009
I am running 4.0.3 and it is not working. Can anyone confirm if they have it working on theirs?

Last edited by LightFatality; 26 Jun 2010 at 20:39.
Reply With Quote
  #57  
Old 22 Jun 2010, 00:58
Bouncer222 Bouncer222 is offline
 
Join Date: Oct 2009
Hey SecondV, I love the mod idea, just that I was wondering if you could tweak it a bit or possibly create a new mod that...

When a thread is marked an [APPROVED] prefix, the thread starter gets moved to a different usergroup.

This feature is needed for our community because, we tell people to post applications on our forums, then someone [APPROVED]'s it and after our staff approves it, they have to contact us to tell us to change their usergroup. I don't want to give our staff access to change people's usergroups, because then they could do other stuff as well.

Could you possibly create this nice feature?
I would be very grateful, thanks.
__________________

FRAG TOSS! Gaming Community Discussion Board!


Biggest Multi-Gaming Community in the World! www.brotherhoodofgamers.com
Reply With Quote
  #58  
Old 22 Jun 2010, 11:15
emath emath is offline
 
Join Date: Sep 2008
what about the other prefixes that belongs to the vbulletin it self, will it overwrite it ?
Reply With Quote
  #59  
Old 26 Jun 2010, 20:31
LightFatality LightFatality is offline
 
Join Date: Sep 2009
OK, randomly after looking through the thread options again it "mark as solved" showed up.

However, it isn't putting the tag/prefix in front after I mark it solved; although it does close it.

4.0.3

EDIT: And now it's gone again after doing nothing...

I give up xD Going to uninstall. Might look into it more later =)

Last edited by LightFatality; 26 Jun 2010 at 20:45.
Reply With Quote
  #60  
Old 07 Jul 2010, 19:09
karel1985 karel1985 is offline
 
Join Date: Mar 2007
Real name: Karel B.
Just upgraded from vb3.8 on 4.0.4 and is working as it should !

Thanks SecondV, my donation was worth it...
__________________
Dutch Pc Helpforum - www.pc-helpforum.be
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 13:11.

Layout Options | Width: Wide Color: