Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Embedded Windows Streaming Medea Player, with download link. Details »
Embedded Windows Streaming Medea Player, with download link.
Mod Version: 1.00, by camoit (Member) camoit is offline
Developer Last Online: May 2014 I like it Show Printable Version Email this Page

vB Version: 4.1.2 Rating: (4 votes - 5.00 average) Installs: 27
Released: 25 Mar 2011 Last Update: 30 Mar 2011 Downloads: 137
Not Supported Re-usable Code  

Embedded Windows Streaming Medea Player with download link. Works in vB 4.1.11 and below

Here is a nice clean embedded WMP with a download link you can put in your forum.
Using the custom BB Codes.
Feel free to change things as needed to customize for your site. Please add in what you did in the post section.
Please read the hole mod before making changes to your board.
Thank You.


<<<<NOTE>>>>
FIRE FOX USERS: see bug fix and work around section below. It's not hard to make changes in the code for the fixes or behaviors that you may want to change.


For a live demo, see the first post, on the first page. GO HERE.

It should work in earlier versions also. OH to download with the link below the player just right click then save target as. --- And BAM--- You got the song... Cool hu???

To Install First download the zip file.
Install Time 5 minutes.

Go to your AdminCP> Custom BB Codes> BB Code Manager. Click on Add New Code.

Title: WMP
BB Code Tag Name: WMP
Replacement code:
(just copy and paste from the download and place in the replacement box.)


Example: [wmp]http://www.yoursite.com/source.mp3[/wmp]

Description:
Embed a video link from another website...
You can use *.wmv, *.mpeg, *.mpg, *.avi. *mp3. and more.
For streaming content use the URL to the stream.


Use {option}: NO

Button Image: Can be used
(See Attach File for Icon.)

Remove Tag If Empty: YES

Disable BB Code Within This BB Code: YES

Disable Smilies Within This BB Code: YES

Disable Word Wrapping Within This BB Code: YES

Disable Automatic Link Parsing Within This BB Code: YES




This must be done when installing or to change the auto start feature. Date added 10-15-2011

Factory default is set this way. Please look when installing.
AUTO START
Internet Explorer----------------- OFF
Fire Fox --------------------------ON


To turn the "Auto Start" function ON or OFF
IE USERS: Look in the top section of code for this line:

To turn ON
Find:
<param name="AutoStart" value="False">

Change to:
<param name="AutoStart" value="True">


Now in the Fire Fox section near the bottom.
To turn the "Auto Start" function ON or OFF


To turn OFF auto start:

Find and change this:
autostart" value="False">

To This:
autostart="0"


For some reason Fire Fox want's it this way.



Date added 10-15-2011
Fire Fox BUG FIX and work around.


<<<<NOTE>>>> Date added 10-15-2011
In the bottom section, for Firefox users.

To STOP the auto start function

Change from this:
autostart" value="False"

To this:
autostart="0"

This will disable the auto start function.

Credit to hotrod122, for the bug fix.
Thanks.


<<<<NOTE>>>> Date added 10-15-2011
Fire Fox users. With a "LIVE" streaming feed the control buttons may not be visible.

You might want to add the fallowing line of text at the very top of the mod text.
Add this line, or your own line of text.

Find this line:
<object id="MediaPlayer1" width=640height=480 classid="CLSID:22D6F312-B0F6-11D0-94AB-0080C74C7E95"

On a new line just above the find line,
Add this line:
<b>Fire Fox Users may need to right click the screen for Start / Stop controls.</b>








If you are having problems. There are two things to check. First right click on the player screen area then select "Properties". If it shows your URL/directory/ href= or somthing like that then fallow the directions below.
Click on "View" then source at the top of your Browser. Find the code in the source and look for this line of code:
<param name="FileName" value= {param} ref>
See if your vBulletin is adding extra lines of code. If so it will have somthing like this:

target="_blank

If you see this code then look through the MOD section for the little fix I found:
Stop opening links in a new window.
Install this and you should be up and running.
The 3 lines of code below is what you will need to play around with in order to make it play right.

I am NOT a coder. But I have used this code for other PHP boards and have always managed to make it work.


NOTETo use with phpbb find and change the fallowing lines.

Find and change this:
<param name="FileName" value= {param} ref>
To this:
<param name="FileName" value="{URL}">
Find and change this:
src= {param} align="middle"
To this:
src="{URL}" align="middle"
Find and change this:
<a href= {param} >Download</a>
To this.
<a href="{URL}">Download</a>

Good Luck.

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	wmp_mod.jpg
Views:	541
Size:	295.4 KB
ID:	127665  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Comments
  #2  
Old 26 Mar 2011, 17:03
Flyte Flyte is offline
 
Join Date: Oct 2009
Hello..and thanks for developing this mod. I've been looking for one that works for a long time. Is it stable on 4.1.2?
Thanks
Reply With Quote
  #3  
Old 26 Mar 2011, 23:35
Danasy Danasy is offline
 
Join Date: Jun 2008
Installed.
Works great in Vb 4.1.0. Thanks
Reply With Quote
  #4  
Old 27 Mar 2011, 01:14
camoit camoit is offline
 
Join Date: Feb 2011
Thank You.
I think it will work in earlier versions also. OH to download with the link below the player just right click then save target as. And BAM.... You got the song... Cool hu???
Reply With Quote
  #5  
Old 30 Mar 2011, 09:25
camoit camoit is offline
 
Join Date: Feb 2011
Originally Posted by Flyte View Post
Hello..and thanks for developing this mod. I've been looking for one that works for a long time. Is it stable on 4.1.2?
Thanks
Yes it works with 4.1.2 Thats what I have.
You will need to go into your Attachment Manager and add the extensions you want to allow for uploading.

There is two ways to play video or music using the Embedded Windows Media Player. First is to know the URL. In the Advanced Editor put in your URL then Highlight the hole URL then click the WMP Icon. Be careful not to allow extra spaces between the tags and the URL. How to load play an .MP3, as an attachment. From the Advanced Editor. First click the attachment button. Browse for the file and upload it. Then in the Attachment Manager dialog box click the Insert "In-Line" button. Now click done. Next click Save or Submit Reply. When looking at the post you will see the file you just uploaded as a link. Right Click the link, and choose "Copy Short Cut". Next you need to Edit the post you just made Post. In the Edit Dialog box right click, then choose paste. [code]Now add these tags in ALL CAPS: [WMP] in front of the URL, [/WMP] at the end of the URL. Now it should look somthing like this.
Reply With Quote
  #6  
Old 09 Apr 2011, 08:00
camoit camoit is offline
 
Join Date: Feb 2011
Just upgraded to V4.1.3 and it' works just fine for me.
Reply With Quote
  #7  
Old 04 Jun 2011, 22:08
Stefan118 Stefan118 is offline
 
Join Date: Dec 2010
Have done all the changes above, screen is appearing, but no video.

When I try to edit the "message" i see the folowing:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Note...
Had to put some spaces between the URL tags to let all the code show here.
In the original message are the tags correct.

Right click on the video --> Properties
doesn't even show the entire link.

When i click to download, i get the folowing error:
The requested URL /{URL} was not found on this server

Please help?

URL to the problem:
http://www.testforum.papegaaienforum...test-met-video

Last edited by Stefan118; 04 Jun 2011 at 22:32.
Reply With Quote
  #8  
Old 04 Jun 2011, 22:59
Stefan118 Stefan118 is offline
 
Join Date: Dec 2010
I have all things changed back to original, but now i get the folowing message at entering the topic:

The file you are trying to play has an extension (.) that does not match the file format. Playing the file may result in unexpected behavior.

Do you want to stream content from media player?

How to get this message gone?

P.S.
In FireFox the video's start to play automaticly. How to change that?
And in Internet explorer, when you klick the button to embed the videolink, there is a space and a "break" between the tag and the link.

Last edited by Stefan118; 04 Jun 2011 at 23:28.
Reply With Quote
  #9  
Old 05 Jun 2011, 20:52
camoit camoit is offline
 
Join Date: Feb 2011
I went to your site. They look to be working, BUT it's not streaming. It is downloading the hole video then playing. (no buffering) Why that is happening I don't know, . When I go there, as soon as the page is up it's down loading #2 video on the page. It's set to auto start. Clear the cash in the ACP.
I would guess by now you have started to see how the code works with the values in it. If you play with the values and how things have or where the "spaces" are, or <> tags it will change things. It took me about 4 days to convert it from PhPbb3 to the VBulletin format. I wish I could be of more help but you will get it working the way you want. Just make one change at a time to the code.

To control the auto start look in the code for autostart = make sure they are set to False. Fire Fox is a problem. Ever since they sued Microsoft over the video player they have had problems. MS stopped all support to them.
You also said there is a space when you click the button on the vid. Yes it is a problem. VBulletin is causing that. I have not found a work around for it.
It has somthing to do with this line. <param name="FileName" value= {param} ref> But this was the olnly way I could get it to work on my board.
You will also need to allow for the attachment extensions in your ACP. In the Attachment manager.

Here is my code the way it is in my board.


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


Last edited by camoit; 05 Jun 2011 at 21:07.
Reply With Quote
  #10  
Old 28 Aug 2011, 20:23
dallibose dallibose is offline
 
Join Date: May 2009
working perfectly but how can i disable autoplay and right click??
Reply With Quote
  #11  
Old 30 Aug 2011, 03:01
camoit camoit is offline
 
Join Date: Feb 2011
If you look in the code you should see autoplay = make sure its like the code above with "false". It's in 2 places. But fire fox will auto play. It's just a fire fox thing. I have no idea why it does this with FX. as for the down load you can remove the last line. a href= {param} >Download? Right Clk, Then Save Target As. That should get rid of it. If you figure out how to stop the Fire fox thing please let us know.
Reply With Quote
  #12  
Old 30 Aug 2011, 03:20
dallibose dallibose is offline
 
Join Date: May 2009
I deleted the a href= {param} >Download? Right Clk, Then Save Target As

but i can still right click ... any other option ?
Reply With Quote
  #13  
Old 30 Aug 2011, 21:26
camoit camoit is offline
 
Join Date: Feb 2011
I think that is a windows operating system thing. Just like the save picture as option.
Reply With Quote
  #14  
Old 01 Sep 2011, 04:52
webgroup webgroup is offline
 
Join Date: May 2006
Could this be done with youtube?
Reply With Quote
  #15  
Old 02 Sep 2011, 02:04
Reycer Reycer is offline
 
Join Date: Jul 2008
Real name: Mike
Originally Posted by webgroup View Post
Could this be done with youtube?
You do realize that VB4 has that feature built in...right?
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


New To Site? Need Help?

All times are GMT. The time now is 16:40.

Layout Options | Width: Wide Color: