Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
  #1  
Old 24 Apr 2005, 19:18
hitokiri battou hitokiri battou is offline
 
Join Date: Feb 2005
A bug?

Forgive me if this is answered somewhere else but I searched and did not see it. I think my problem involves a persosns stats. I created a person that has a level of 88 to test this. I equipped him with the masamune and he can NEVER hit a person. Also, it seems thats stats dont really influence how much damage you do. A level 10 person can do aprxo 30-50 pts of damage with fists while level 88 person does 45-60 pts of damage with fists. Is this normal, how can I get it so people can actually hit others with weapons? :ermm:

Last edited by hitokiri battou; 24 Apr 2005 at 19:20.
Reply With Quote
Comments
  #2  
Old 25 Apr 2005, 11:09
Revan's Avatar
Revan Revan is offline
 
Join Date: Jan 2004
Real name: Fillip
Well.
Stats influence how much damage you do, however fist damage is based on levels (plus the +/- 10% damage range).
Secondly, exactly what is the message you get when attacking? Miss or no damage?
Reply With Quote
  #3  
Old 25 Apr 2005, 18:59
hitokiri battou hitokiri battou is offline
 
Join Date: Feb 2005
Originally Posted by Revan
Well.
Stats influence how much damage you do, however fist damage is based on levels (plus the +/- 10% damage range).
Secondly, exactly what is the message you get when attacking? Miss or no damage?

I forgot exactly what the message said but in short it pretty much says that you attack but miss. No matter how skilled the person is they always miss with the exception of one member. One of my members around level 12 actually hit someone once but he is the only one and I have battled many people and never hit one of them with a weapon. Could it be something wrong with the code I had to edit or just an option Im overlooking? :ermm:
Reply With Quote
  #4  
Old 25 Apr 2005, 19:16
Revan's Avatar
Revan Revan is offline
 
Join Date: Jan 2004
Real name: Fillip
Umm I doubt this is an edit problem, as the battle files are quite independant of the file edits.
Tell you what: Open battleupdate.php and set $battledebug to 1, then fight a couple of rounds trying to hit with Weapons, then post the Debug Variables, and I can see if I find something shady
Reply With Quote
  #5  
Old 26 Apr 2005, 19:10
hitokiri battou hitokiri battou is offline
 
Join Date: Feb 2005
Originally Posted by Revan
Umm I doubt this is an edit problem, as the battle files are quite independant of the file edits.
Tell you what: Open battleupdate.php and set $battledebug to 1, then fight a couple of rounds trying to hit with Weapons, then post the Debug Variables, and I can see if I find something shady

OO ok I think I have solved the problem. It appears that only classes that i make up miss for some reason. The defoault classes such as assassin have no problem hitting others.
Reply With Quote
  #6  
Old 27 Apr 2005, 10:04
Revan's Avatar
Revan Revan is offline
 
Join Date: Jan 2004
Real name: Fillip
That's odd, but it doesnt actually SOLVE the problem, as theres no reason to be able to make up classes if they are utterly useless.
Reply With Quote
  #7  
Old 27 Apr 2005, 18:36
hitokiri battou hitokiri battou is offline
 
Join Date: Feb 2005
Originally Posted by Revan
That's odd, but it doesnt actually SOLVE the problem, as theres no reason to be able to make up classes if they are utterly useless.

Thats what I think as well. But i also have anotehr problem. I installe dthis hack and the ushop hack at the same time. After i did my rep point settings started going haywire. No matter how many times I save the rep pt settings in the adminCP for a usergroup it always randomly changes them again. If this problem isnt due to these hacks does anyone else have any idea what may be causing this? :ermm:
Reply With Quote
  #8  
Old 27 Apr 2005, 21:21
Revan's Avatar
Revan Revan is offline
 
Join Date: Jan 2004
Real name: Fillip
This is cause of a bug in the uCS, I have reported it to the devs, they said they would incorporate the fix in 1.0

My bugreport (includes a fix): http://www.geekydesigns.com/board/sh...=1052#post1052
Reply With Quote
  #9  
Old 01 May 2005, 21:26
hitokiri battou hitokiri battou is offline
 
Join Date: Feb 2005
Ok, thanks alot for your help.
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 14:25.

Layout Options | Width: Wide Color: