Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old 26 Oct 2019, 09:30
khalled khalled is offline
 
Join Date: Apr 2007
problem in language symbols

in stall vb 4.x and after i change website hosting and transfer website and database to new hosting the web site language (Arabic) and forum control panel was change to strange characteristics as attached


how I can solve that
Attached Images
File Type: jpg vb problems.jpg (66.5 KB, 37 views)
Reply With Quote
  #2  
Old 26 Oct 2019, 12:07
snakes1100 snakes1100 is offline
 
Join Date: Dec 2001
Real name: Anthony
Different charsets being used on each server, so you;; need to change mysql charsets to match what you was using on the old server
Reply With Quote
  #3  
Old 05 Nov 2019, 21:01
khalled khalled is offline
 
Join Date: Apr 2007
I change it to latin1_swedish which I use on old self but unfortunately, not solve the problems
also I change it to utf8mb4_unicode_ci and not solve the problem as well
any other charsets can I use which compatible for the Arabic language
Reply With Quote
  #4  
Old 05 Nov 2019, 21:53
Dave Dave is offline
 
Join Date: Jun 2010
Real name: Dave
Did you modify the "HTML Character Set" setting at Languages & Phrases > Language Manager > Edit Settings of the language?
__________________
https://technidev.com - security, development, exploits, vBulletin
dave[at]technidev[dot]com

Contact me for custom vBulletin 3/4 work & server/website management.
Reply With Quote
  #5  
Old 06 Nov 2019, 09:48
snakes1100 snakes1100 is offline
 
Join Date: Dec 2001
Real name: Anthony
I meant the server, not in your db via phpmyadmin

Check the mysql server charsets, via diagnostics -> mysql variables

character_set_client latin1
character_set_connection latin1
character_set_database latin1
character_set_filesystem binary
character_set_results latin1
character_set_server latin1
character_set_system utf8

If those match on each server, then rule it out.

If its a plesk server, plesk likes to set a local php.ini with a charset in it, which is most likely wrong.
Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Forbid the use of some symbols in USERNAME ghroob vBulletin 3.5 Add-ons 20 12 Apr 2007 22:55
Over 50 custom smilies, symbols and over 250 flags Deathstar vBulletin Smilie Sets 17 28 Nov 2005 16:31



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 06:55.

Layout Options | Width: Wide Color: