Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
vB Nexus, Facebook & Google multiple login integration Details »
vB Nexus, Facebook & Google multiple login integration
Mod Version: 1.00, by ibautocommunity (Coder) ibautocommunity is offline
Developer Last Online: Feb 2020 I like it Show Printable Version Email this Page

vB Version: 3.8.3 Rating: (17 votes - 4.47 average) Installs: 154
Released: 13 Aug 2009 Last Update: 13 Aug 2009 Downloads: 1929
Not Supported DB Changes Uses Plugins Auto-Template Additional Files Re-usable Code Translations External Content Is in Beta Stage  

vBulletin Nexus
Current project release: BETA
This works on vBulletin 3.7.X - 3.8.4

This product will allow visitors to join your community using their Facebook, Google, Yahoo or AIM account; and will allow your existing members to associate an existing forum account with one of the services - such as Facebook.

Please read the documentation and follow it exactly before requesting installation help. Please note, if you have heavily modified styles that are missing hooks - this product will not work and require additional installation steps.

DEMO: http://www.carblog.com/vbnexus

Basic Instructions for your forum's users: http://carblog.com/vbnexus/user-guide/

Download Now

Only licensed members can download files, Click Here for more information.

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
  #121  
Old 18 Aug 2009, 02:55
Chief Corn Chief Corn is offline
 
Join Date: Nov 2002
Can it refresh the page on login? It's kind of awkward for it to take you to the main forum if a user logs in wanting to reply to a thread.
__________________
South Bay Bodywork
Reply With Quote
  #122  
Old 18 Aug 2009, 05:49
wolfstream wolfstream is offline
 
Join Date: Jan 2003
Real name: Tom Whiting
Problem #1: no facebook login button at all. The script is there, but there is no login button, and yeah, I've verified that the application id is correct.

Problem #2: when the user logs out, this is not shown on the logout page itself. Yeah, a bit picky there, but let's say they want to switch accounts (for forums that allow that kind of thing), or log right back in? Not the biggest problem in the world, but still an issue.

Last edited by wolfstream; 18 Aug 2009 at 18:58. Reason: corrected one of the problems myself?
Reply With Quote
  #123  
Old 18 Aug 2009, 10:14
J105C J105C is offline
 
Join Date: Mar 2008
WOW amazing, nominated and will tag this for further updates! Once this completes beta I am all in!
Reply With Quote
  #124  
Old 18 Aug 2009, 18:45
woffie's Avatar
woffie woffie is offline
 
Join Date: Jan 2009
Real name: Jim
Originally Posted by ct2k7 View Post
Ok, found a warning, when I log out, and login using fbconnect to match my normal login, on the login redirection page, I recieve:

Warning: array_merge() [function.array-merge]: Argument #1 is not an array in [path]/includes/functions_login.php on line 332




When I click on the nexus.gif image, "google" is undefined, hence we don't get a pop-up. That's in IE only.

I've got my main vB account set up, and I've added a FB login to it. So next I wanted to add in the rest of my ID's so I try OpenID via Google; I recieve a database error:

Database error in vBulletin 3.8.3:
Invalid SQL:
REPLACE INTO vbnexus_nonvbuser (nonvbid, userid, type, associated, emailonfile) VALUES (, 1, 2, 1, 1);
MySQL Error : You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ' 1, 2, 1, 1)' at line 1
Error Number : 1064
Request Date : Thursday, August 13th 2009 @ 11:09:55 PM
Error Date : Thursday, August 13th 2009 @ 11:09:55 PM
Script : index.php?product=vbnexus
Referrer : /index.php?product=vbnexus&product-mod=gfconnect&do=login&loc=Lw==
IP Address :
Username : ct2k7
Classname : vB_Database_MySQLi
MySQL Version : 5.0.81-community


nonvbid is missing.

Thanks Anders, + nominated for MOTM.
Getting this same problem. Had to uninstall. Works perfectly on my test forum. There must be some kind of conflict with another mod. I really want this mod, this is one of the best mods I have seen!
Reply With Quote
  #125  
Old 18 Aug 2009, 21:24
Chief Corn Chief Corn is offline
 
Join Date: Nov 2002
Template problem? When viewing a page in Safari with Google ID enabled it adds like 200 pixels of blank space under the footer.
__________________
South Bay Bodywork
Reply With Quote
  #126  
Old 18 Aug 2009, 22:07
dvsDave's Avatar
dvsDave dvsDave is offline
 
Join Date: Nov 2005
Real name: David
I was testing this on your site and I noticed that it won't work in Google Chrome. I tried logging in with my Google account, and it got to the login screen where it shows your avatar, then I click login, but nothing happens. I went over to IE, and it worked great. I'm using Chrome dev build 4.0.201.1 (the latest build)
__________________
About dvsDave
dvsDave is the webmaster of the technical theatre forum, ControlBooth.com, a site that is dedicated to teaching high-school and college level techies practical and useful skills for the stage and provides an online community that allows techies from all over the world to discuss the art and science of technical theater.
Reply With Quote
  #127  
Old 18 Aug 2009, 23:58
Ohiosweetheart Ohiosweetheart is offline
 
Join Date: Dec 2005
Real name: Peggy
This mod just may not work correctly with all browsers. Many mods don't.
Reply With Quote
  #128  
Old 19 Aug 2009, 00:01
Ohiosweetheart Ohiosweetheart is offline
 
Join Date: Dec 2005
Real name: Peggy
I'm really wanting to let people know that they can join our site through their FB/Google Friends/Yahoo etc accounts. But I can't as long as I'm having these issues.

On a side note tho - The Kawfee Klub HAS gotten 4 new members - all 4 joined using this mod
Reply With Quote
  #129  
Old 19 Aug 2009, 01:28
wmlvb's Avatar
wmlvb wmlvb is offline
 
Join Date: May 2008
Wink

Originally Posted by wmlvb View Post
Is there a way to set it up so that new members are forced to register before they can post? I have an elaborate screening process due to all my private forums and I have to have them register to go through it.

IF cannot do this then can I set so only available to registered members?
can someone who knows answer this question.! Thank you.
Reply With Quote
  #130  
Old 19 Aug 2009, 02:04
wolfstream wolfstream is offline
 
Join Date: Jan 2003
Real name: Tom Whiting
You can do anything you want, you just have to know how to manipulate code and xml.
In this case, I'd say the odds are pretty damn good that you can, it'll just take some exploring.
Reply With Quote
  #131  
Old 19 Aug 2009, 10:58
MikeF MikeF is offline
 
Join Date: Jan 2006
This mod is being used at http://windows7forums.com and for the most part appears to be working well. However, it is creating some scripting errors on the page, and occasionally when the Facebook prompt "to post your reply or new thread to Facebook" comes up, there it results in a grey page and nothing more. I am assuming it could be a conflict with VBSEO. There is also a scripting error on pages


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

In this case line 127 is....


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

The ending brackets };

If this in any way helps you fix or develop the product I hope you can take a look and see what is being dealt with. It is a rather big board (not massive but of medium size and high activity).

Update: It must be related to the navbar login because it doesn't appear for guests at all, only logged in users who do not see that navbar login... the navbar works great with no custom re-write rules. The styles I am using have almost no custom changes and this only affects postbit/showthread pages.

It may only appear if you are Facebook-integrated but this is not confirmed...


Warm Regards,
Mike

Last edited by MikeF; 19 Aug 2009 at 11:26.
Reply With Quote
  #132  
Old 19 Aug 2009, 16:22
macbooking's Avatar
macbooking macbooking is offline
 
Join Date: Jan 2009
Great Job - Big ups

myspace would also be usefull (we have musicians/djs @ audiosuite.at)

Switch to Connect tab and set Base Domain to your Domain (mysite.com), no www or http.
audiosuite.at <- not valid (but it works ...after some tries)


thx

Last edited by macbooking; 19 Aug 2009 at 16:47.
Reply With Quote
  #133  
Old 19 Aug 2009, 16:34
Ohiosweetheart Ohiosweetheart is offline
 
Join Date: Dec 2005
Real name: Peggy
This mod is being used at The Kawfee Klub as well.

We're having issues with Facebook that we're still waiting on Anders to help us with, but all of the other logins - yahoo, google friends, etc, work perfectly.

I'm very happy with this mod. And will be happier when the facebook issues are ironed out.
Reply With Quote
  #134  
Old 19 Aug 2009, 17:21
tpearl5's Avatar
tpearl5 tpearl5 is offline
 
Join Date: Nov 2001
Real name: John
How can I convert from sllik's fb connect hack? (I'm sure others using the hack would love to know this as well)
__________________
John
Reply With Quote
  #135  
Old 19 Aug 2009, 17:34
jarosciak jarosciak is offline
 
Join Date: Apr 2005
Installed it, loved it, uninstalled it.
Doesn't work with vbulletin Photopost Gallery.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 17:08.

Layout Options | Width: Wide Color: