Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Talker Bot v2.0.2 Details »
Talker Bot v2.0.2
Mod Version: 2.0.2, by eXtremeTim (Member) eXtremeTim is offline
Developer Last Online: Feb 2008 I like it Show Printable Version Email this Page

This thread is in the Modification Graveyard.
vB Version: 3.0.0 Rating: (3 votes - 4.33 average) Installs: 144
Released: 17 Jan 2004 Last Update: 21 Jan 2004 Downloads: 23
Not Supported DB Changes  

I will try and support this hack here. For better support use the link I have provided below:
http://www.extremescripts.com/forums/index.php


Version 3.0 is finaly being made. Please go to the link above and put in your feedback on what you would like to see added.

Talker Bot Hack v2.0.2
Hack By: Tim (eXtremeTim) Yarbrough
Website: www.extremechatforums.com
Original: by: C-birch
Credits: Rapid Gaming (for porting it to vb3)

What This Hack Does.

This hack add a userlike bot to your forums. You can set which forum he will post in and how often he will reply to poeples posts. He will try and build his replies off the text that they posted. This bot will learn overtime slowly from your users posts. I will also be seeing about porting over the teachbot soon.

Some New Features
acp controlled Rate Of Post
ability to post as bot and he will not reply
post count will not go up in forums where post counts are turned off
a few options to turn off and on a few things including the script itself.
Some other stuff i just cant remember

Fixed in 2.0.2:
Go advanced feature works for quick reply.
Bot will no longer reply when post is stopped becuase of an error. (aka floodlimit, to many images, ect)

Fixed in 2.0.1:
Fixed a few minor problems including using the wrong variable in the if statement for the random smilie check.
fixed the install.txt problem used a find code that was from one of my modifications sorry about that.

Upgrading From v2.0.1 Instructions:
These are in the v202 upgrade file

Upgrading From v2.0.0 Instructions:
To upgrade from v2.0 just make your changes to the new _talkerbot.php file and replace the old v2.0 one.


Upgrading From v1 Instructions:
Just use the install.txt and do the forum.php in the acp directory edits.
Add the new phrase and run the query.


Todo List:
Move all settings to acp settings page
fix the floodcheck problem of bot still replying when users post is not made.
Clean up the code more
Figure out more stuff todo.

-=~=-=~=-=~=-=~=-=~=-=~=-=~=-=~=-
-=If You Like This Hack Please Click Install=-
-=~=-=~=-=~=-=~=-=~=-=~=-=~=-=~=-

IMPORTANT INFORMATION

Support for this hack has returned. I will try to give support in this thread. Priority support will be given Here

Just a note I will be starting work on a new version possible as soon as tonight.

If you like this modification please donate to help support the developement process on it.

Download Now

Only licensed members can download files, Click Here for more information.

Show Your Support

  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
  #421  
Old 11 Sep 2005, 13:55
Thug's Avatar
Thug Thug is offline
 
Join Date: Feb 2004
hi i get this error
on this
http://www.oh-twadi.com/forum/alice/.../botloader.php
i get this error

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Reply With Quote
  #422  
Old 11 Sep 2005, 17:00
martinc126 martinc126 is offline
 
Join Date: Dec 2004
Originally Posted by martinc126
Hello,

I keep getting this error, The file is there i have checked more than once.

Loading startup.xml

Warning: fopen(/public_html/community/alice/aiml/startup.xml): failed to open stream: No such file or directory in /home/steve/public_html/community/alice/src/admin/botloaderfuncs.php on line 508
could not open XML input

Anyone know what i am doing wrong.

Thanks

Martin

Hi,

The error i was getting has been fixed now.

I need to make sure i put a / in front

Anyway it ended up been

/home/steve/public_html/community/alice/aiml/

However now i have another little problem. When users post in the bots forum it sends it to the database fine, and the bot replies to it in the database but it doesn't make a new post with the bots reply.

Any ideas why.

Thanks

Martin
Reply With Quote
  #423  
Old 11 Sep 2005, 23:35
Thug's Avatar
Thug Thug is offline
 
Join Date: Feb 2004
How do i make him more clever

Last edited by Thug; 11 Sep 2005 at 23:57.
Reply With Quote
  #424  
Old 12 Sep 2005, 18:42
Thug's Avatar
Thug Thug is offline
 
Join Date: Feb 2004
how do i get it so the post count goes up when the bot posts?
Reply With Quote
  #425  
Old 16 Sep 2005, 08:14
b00k b00k is offline
 
Join Date: Feb 2005
Originally Posted by TSR
Went to install this and had my account suspended for a weee bit.. LOL

apparently they did not appreciate the 300,000 queries, is there another way around this?

I asked if they could run the script for me, they said no, find another way.


So any advice would be appreciated.
anyone have a solution for this?
Reply With Quote
  #426  
Old 28 Sep 2005, 11:57
Chief Corn Chief Corn is offline
 
Join Date: Nov 2002
Originally Posted by TSR
anyone have a solution for this?
switch hosts? :ermm: there's plenty of hosts out there who would already allow you to do it. that'll learn 'em to say no.
Reply With Quote
  #427  
Old 05 Oct 2005, 21:11
Mijae's Avatar
Mijae Mijae is offline
 
Join Date: Nov 2001
Any news on the port for vB3.5?
Reply With Quote
  #428  
Old 12 Oct 2005, 21:07
FightRice.com FightRice.com is offline
 
Join Date: Mar 2005
Originally Posted by Mijae
Any news on the port for vB3.5?
Thats what i just checked this thread for :lol:
Reply With Quote
  #429  
Old 12 Oct 2005, 22:27
n1ckn4me n1ckn4me is offline
 
Join Date: Jan 2005
wow! ...this is A freaking I! I like it ...please tell me this is going to be ported! ^^
Reply With Quote
  #430  
Old 17 Oct 2005, 00:58
xproductionz xproductionz is offline
 
Join Date: Jul 2005
i get this error

Loading startup.xml
could not open XML input
Reply With Quote
  #431  
Old 17 Oct 2005, 05:13
xproductionz xproductionz is offline
 
Join Date: Jul 2005
i give up.. i been working on this thing for countless hours and days now and cant figure it out.. think i need someone to do this for me
Reply With Quote
  #432  
Old 17 Oct 2005, 05:17
b00k b00k is offline
 
Join Date: Feb 2005
Thumbs down

little to no support, real shame. :ermm:
Reply With Quote
  #433  
Old 22 Oct 2005, 02:22
xproductionz xproductionz is offline
 
Join Date: Jul 2005
real shame
Reply With Quote
  #434  
Old 28 Oct 2005, 06:30
unixdotcom unixdotcom is offline
 
Join Date: Nov 2001
Dear Tim,

What is the status of TalkerBot, the next generation AI bot for vB?

Neo

Gollum the UNIX forum bot....
Reply With Quote
  #435  
Old 30 Oct 2005, 01:29
Ski-Whiz's Avatar
Ski-Whiz Ski-Whiz is offline
 
Join Date: May 2003
I was able to get my talker bot to show online.

Only thing, they ALWAYS show online.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 09:42.

Layout Options | Width: Wide Color: