Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old 27 Apr 2015, 20:22
Steelerfan81 Steelerfan81 is offline
 
Join Date: Apr 2015
Subscription problems

So whenever anyone pays for a subscription it doesn't automatically update. I have to go in and manually switch them to a subscriber and put in the amount of time. I've checked all the options in the Admin Control panel but I don't see anything. I assume it is somewhere in the code.

I'm new to all this and I have a general idea but try to explain in simple terms lol
Reply With Quote
  #2  
Old 27 Apr 2015, 21:34
ForceHSS's Avatar
ForceHSS ForceHSS is offline
 
Join Date: Apr 2008
You need to give time for the cron to run
Reply With Quote
  #3  
Old 27 Apr 2015, 22:36
Steelerfan81 Steelerfan81 is offline
 
Join Date: Apr 2015
Well it doesn't do it even after a full day.
Reply With Quote
  #4  
Old 27 Apr 2015, 23:09
ForceHSS's Avatar
ForceHSS ForceHSS is offline
 
Join Date: Apr 2008
give it more than 24hrs if it still does not work then get someone to have a look it might be a custom plugin or something stopping it from running
Reply With Quote
  #5  
Old 27 Apr 2015, 23:30
kh99 kh99 is offline
 
Join Date: Aug 2009
Real name: Kevin
Originally Posted by Steelerfan81 View Post
So whenever anyone pays for a subscription it doesn't automatically update. I have to go in and manually switch them to a subscriber and put in the amount of time. I've checked all the options in the Admin Control panel but I don't see anything. I assume it is somewhere in the code.

I'm new to all this and I have a general idea but try to explain in simple terms lol
What are you using for the payment type? Paypal, for example, has to get a return "call" from the paypal server before the user will get the subscription.
Reply With Quote
  #6  
Old 27 Apr 2015, 23:41
Lynne's Avatar
Lynne Lynne is offline
 
Join Date: Sep 2004
Real name: Lynne
As Kevin says, have you verified it is all working? Have you checked the Subscription Transaction Logs for errors? Did you try the Test Communication Link and not get an error?
__________________
Former vBulletin.org Staff Member

Try a search before posting for help. Many users won't, and don't, help if the question has been answered several times before.
W3Schools -
Online vBulletin Manual
If I post some CSS and don't say where it goes, put it in the additional.css template.
I will NOT help via PM (you will be directed to post in the forums for help.)
Reply With Quote
  #7  
Old 28 Apr 2015, 02:59
Steelerfan81 Steelerfan81 is offline
 
Join Date: Apr 2015
Yeah, its PayPal. I've tried the test options and it says it works. It just used to be automatic and after an update it never would do it automatically.
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 19:19.

Layout Options | Width: Wide Color: