Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Who Quoted Me Details »
Who Quoted Me
Mod Version: 1.2.0, by renlok (Member) renlok is offline
Developer Last Online: Apr 2015 I like it Show Printable Version Email this Page

vB Version: 3.8.7 Rating: (6 votes - 4.33 average) Installs: 51
Released: 29 Jan 2011 Last Update: 29 Jan 2011 Downloads: 626
Not Supported DB Changes Uses Plugins  

In the user control panel, users can now see a list of the last few people who have quoted them.
This is a great way to encourage users to interact with each other as they can easily keep track of conversations within threads.


If you use this i would really appreciate any small donation

EDIT:
Looks like there a few bugs in this I dont have a computer at the moment but Freshfoot has made an updated release with some new features: http://www.vbulletin.org/forum/showp...1&postcount=30

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	Screen shot 2011-01-29 at 12.13.15.png
Views:	1549
Size:	23.9 KB
ID:	126218  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
  #46  
Old 30 Jan 2011, 16:10
Alfa1's Avatar
Alfa1 Alfa1 is offline
 
Join Date: Dec 2005
I have installed the new version and it works!

bug: setting usergroups to 0 does not work. That turns it off.
sort of a bug: quoting yourself gives an alert.

The overview in usercp would look nicer if:
- the font would be smaller. (smallfont)
- display it like this:
Member_X quoted your post in the thread_title on [date;time]
Please make that all one line.

It would be nice if there were 2 different phrases for the notification:
1 member quoted you.
x members quoted you.

The latter being plural.

Below the 'Who Quoted Me' block, there should be some empty space. I have Paul M's modification installed to show a 'latest reputation given' block there and both blocks touch each other. There should be some distance. Adding a <br/> at the end of the usercp_who_quoted_me template resolves that.

I think that the link should really lead to the post where the quote is. The way to handle the target location that you have posted earlier in the thread should be in the xml.

Thank you!

Last edited by Alfa1; 30 Jan 2011 at 16:42.
Reply With Quote
  #47  
Old 30 Jan 2011, 17:09
Alfa1's Avatar
Alfa1 Alfa1 is offline
 
Join Date: Dec 2005
I have reworked the usercp listing to the following:
display_who_quoted_me

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Looks better now IMHO.
Reply With Quote
  #48  
Old 30 Jan 2011, 23:42
Wonksta Wonksta is offline
 
Join Date: Apr 2009
Originally Posted by Alfa1 View Post
I have reworked the usercp listing to the following:
display_who_quoted_me

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Looks better now IMHO.
Screenshot?
Reply With Quote
  #49  
Old 31 Jan 2011, 01:59
Wonksta Wonksta is offline
 
Join Date: Apr 2009
Doesn't seem to notify me if someone quotes my post that contains links, it's a bit of a hit and miss when a URL is pasted. Can anyone check?
Reply With Quote
  #50  
Old 31 Jan 2011, 04:06
FreshFroot's Avatar
FreshFroot FreshFroot is offline
 
Join Date: Aug 2005
I'll work on some of the suggestions later on.

As for the url thing.. it could be due to checks for if a post was replied too or not. I'm just guessing right now.

when you mean url does www.name.com work fine or is it a problem when you add http://
Reply With Quote
  #51  
Old 31 Jan 2011, 08:16
Wonksta Wonksta is offline
 
Join Date: Apr 2009
Originally Posted by FreshFroot View Post
I'll work on some of the suggestions later on.

As for the url thing.. it could be due to checks for if a post was replied too or not. I'm just guessing right now.

when you mean url does www.name.com work fine or is it a problem when you add http://
Hmmmmm!

Tried it with both http and www and got both notifications how, odd. I'll keep an eye on it though.

Mod is great, users love it btw.
Reply With Quote
  #52  
Old 31 Jan 2011, 11:17
Alfa1's Avatar
Alfa1 Alfa1 is offline
 
Join Date: Dec 2005
Im not sure what the culprit is, but not all quotes cause a notification. We are testing in order to find out. Maybe it differs per subforum?

I am worried that reported posts will cause members to find out, who reported their post. That could spark some riots. So its definitely needed to exclude report forums and infraction forums from causing notifications. Or does this mod already do that?

Here's a screenshot of the usercp after the modifications I applied:

Attached Images
File Type: jpg User Control Panel.jpg (28.5 KB, 262 views)
Reply With Quote
  #53  
Old 31 Jan 2011, 12:15
Wonksta Wonksta is offline
 
Join Date: Apr 2009
OK Just reported one of my own posts and it created a reported post in the Reports sub forum but the good news is it did not notify me that I reported my post. I tried twice. Take note you can notify yourself when you quote yourself anyway so hence I think it wont notify people but maybe FreshFoot could confirm by looking at the code for us?

Alfa that looks great!

EDIT: Alfa the template tweak is mint, thanks for sharing!

Last edited by Wonksta; 31 Jan 2011 at 13:09.
Reply With Quote
  #54  
Old 31 Jan 2011, 13:32
Alfa1's Avatar
Alfa1 Alfa1 is offline
 
Join Date: Dec 2005
I would appreciate it if someone could check the code below to see if proper syntax has been used:

Originally Posted by Alfa1 View Post
I have reworked the usercp listing to the following:
display_who_quoted_me

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Reply With Quote
  #55  
Old 01 Feb 2011, 01:57
FreshFroot's Avatar
FreshFroot FreshFroot is offline
 
Join Date: Aug 2005
I will check the reporting issue and will add in Alfa1's layout, as it looks pretty good.

As for all quote's not being notified. I will try to run a few tests with subforums to see if that could be a problem.

Will keep ya updated.

Thanks.
Reply With Quote
  #56  
Old 02 Feb 2011, 01:25
Wonksta Wonksta is offline
 
Join Date: Apr 2009
FreshFroot here is a post which did not notify me:

This is what it contained:
-----------
Originally Posted by Me View Post
Quote notification not working @Admin ??

------

Two things present in this post A URL DBTECH's Advanced User Tagging Mod which parsed @Admin.

Thoughts?
Reply With Quote
  #57  
Old 02 Feb 2011, 05:17
FreshFroot's Avatar
FreshFroot FreshFroot is offline
 
Join Date: Aug 2005
Originally Posted by Wonksta View Post
FreshFroot here is a post which did not notify me:

This is what it contained:
-----------


Quote notification not working @Admin ??

------

Two things present in this post A URL DBTECH's Advanced User Tagging Mod which parsed @Admin.

Thoughts?
Sorry I don't get what you mean? Are you saying urls don't get a notification or when using @name (DBTech's mod) causes no notification?
Reply With Quote
  #58  
Old 02 Feb 2011, 06:27
Wonksta Wonksta is offline
 
Join Date: Apr 2009
After testing it sometimes it randomly doesn't notify of quotes.

Just to confirm if a member from a usergroup who isn't given permission to use the mod quotes a member from a usergroup which is given permission to use the mod, will it cause a notification?
Reply With Quote
  #59  
Old 02 Feb 2011, 06:29
FreshFroot's Avatar
FreshFroot FreshFroot is offline
 
Join Date: Aug 2005
Originally Posted by Wonksta View Post
After testing it sometimes it randomly doesn't notify of quotes.

Just to confirm if a member from a usergroup who isn't given permission to use the mod quotes a member from a usergroup which is given permission to use the mod, will it cause a notification?
I'll re-check the usergroups. I know there was a bug with adding a 0.

But if the usergroup has no permission to use it, then it will not create a notification at all.
Reply With Quote
  #60  
Old 02 Feb 2011, 06:42
Wonksta Wonksta is offline
 
Join Date: Apr 2009
Originally Posted by FreshFroot View Post
I'll re-check the usergroups. I know there was a bug with adding a 0.

But if the usergroup has no permission to use it, then it will not create a notification at all.
Ahhhhhhhhhhhhh bummer is there anyway to make it so that if you don't have permission to use it and you get quoted you simply don't get notified but when you quote someone who has permission and you don't have permission to use it, it notifies the person with the permission.

If that makes sense? That would be amazing.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 11:14.

Layout Options | Width: Wide Color: