Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old 08 Aug 2012, 12:06
Liff Liff is offline
 
Join Date: Aug 2011
Merging Template Hook Ins?

Hey Guys,

Can one of you guys please take a look at this problem for me?

Lynne, or any other admin - Excuse me if this is an inappropriate place to post this but I have asked on the relevant Template thread and the OP has told me he is not a programmer and cannot help me so I'm looking for information on the most relevant place I can think of )

I have Chiploves thumbnails installed which is great and I want to keep it. I also want to install the Novo Slider for Logo rotation and I've linked to both mods below. The problem is that they both hook in to 'parse_templates' and these modifications are not compatible. The thumbnails always work fine which is great however the banner slider only works on the forum home page (ie listing the forums) but fails to work when in forumdisplay presumably because the Thumbnails are there already. When I disable the thumbnails it works fine again.

I'm on the very edge of my skill set even figuring that out, so I'm pretty unsure of where to go next to integrate the two hook ins. Would anyone be kind enough to advise me where to go next? I have included the coding on my last posts on the relevant threads below as well as a link to my forum with the details of the trial style I am using.

I sincerely thank anyone for taking the time to look, even if you cannot offer a solution of advice.

Installed: Chiplove.9xpro - Thread Thumbnails 2.2.9 ( 1 2 3 4 5 ... Last Page)

Logo Rotation

http://twistsnturns.net

Style: Slider TNT67
Reply With Quote
  #2  
Old 08 Aug 2012, 17:27
Lynne's Avatar
Lynne Lynne is offline
 
Join Date: Sep 2004
Real name: Lynne
Have you tried changing the execution order of the two plugins that use the same hook location?
__________________
Former vBulletin.org Staff Member

Try a search before posting for help. Many users won't, and don't, help if the question has been answered several times before.
W3Schools -
Online vBulletin Manual
If I post some CSS and don't say where it goes, put it in the additional.css template.
I will NOT help via PM (you will be directed to post in the forums for help.)
Reply With Quote
  #3  
Old 08 Aug 2012, 17:43
Liff Liff is offline
 
Join Date: Aug 2011
Hey Lynne,

Thanks very much for the suggestion.. It's a great idea but I've tried moving them and to no effect.. I've tried moving them both up and down the pecking order and it still does the exact same thing.
Reply With Quote
  #4  
Old 08 Aug 2012, 18:34
Lynne's Avatar
Lynne Lynne is offline
 
Join Date: Sep 2004
Real name: Lynne
I don't even see a plugin in the Logo Rotation code that uses the parse_templates hook location - it uses the template_register_var hook location.
__________________
Former vBulletin.org Staff Member

Try a search before posting for help. Many users won't, and don't, help if the question has been answered several times before.
W3Schools -
Online vBulletin Manual
If I post some CSS and don't say where it goes, put it in the additional.css template.
I will NOT help via PM (you will be directed to post in the forums for help.)
Reply With Quote
  #5  
Old 08 Aug 2012, 18:42
Liff Liff is offline
 
Join Date: Aug 2011
Originally Posted by Lynne View Post
I don't even see a plugin in the Logo Rotation code that uses the parse_templates hook location - it uses the template_register_var hook location.
Yeah, when I use that it generates a 503 error - When I pointed this out Thundercat (the OP) told me he had similar and used the Parse_Template hook in instead.

I had figured that if that one worked with the forum listings I could duplicate it and try another location for that would work in forumdisplay but sadly that didn't work either.

I take it that you run the w3schools site in your sig? I might need to spend a few weeks studying to catch up with what's going on, tbh
Reply With Quote
  #6  
Old 08 Aug 2012, 23:35
Lynne's Avatar
Lynne Lynne is offline
 
Join Date: Sep 2004
Real name: Lynne
No, I don't run the w3schools site - it's just a site that I find very, very helpful!

Have you tried just combining the two plugins? Either put the thumbnail code at the beginning or end of the other plugin.
__________________
Former vBulletin.org Staff Member

Try a search before posting for help. Many users won't, and don't, help if the question has been answered several times before.
W3Schools -
Online vBulletin Manual
If I post some CSS and don't say where it goes, put it in the additional.css template.
I will NOT help via PM (you will be directed to post in the forums for help.)
Reply With Quote
  #7  
Old 09 Aug 2012, 13:12
Liff Liff is offline
 
Join Date: Aug 2011
Thanks again, Lynne - Still the same though.. The Thumbnails seem bulletrpoof, they always seem to work but the banner only works outside forumdisplay.

The slider works fine inside threads too..

Is there any way around using a plugin by putting this code anywhere else, or even creating a php file at server level or is that just being silly?


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Reply With Quote
  #8  
Old 09 Aug 2012, 15:51
Lynne's Avatar
Lynne Lynne is offline
 
Join Date: Sep 2004
Real name: Lynne
I honestly don't see why that code would cause issues, but you can certainly try using different hooks. Here's a list of the hooks used in order around where parse_templates is used (you could get this in debug mode on your test site). Try some other and see what happens.


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

__________________
Former vBulletin.org Staff Member

Try a search before posting for help. Many users won't, and don't, help if the question has been answered several times before.
W3Schools -
Online vBulletin Manual
If I post some CSS and don't say where it goes, put it in the additional.css template.
I will NOT help via PM (you will be directed to post in the forums for help.)
Reply With Quote
  #9  
Old 11 Aug 2012, 16:02
Liff Liff is offline
 
Join Date: Aug 2011
Hey Lynne, sorry for taking so long to thank you for giving me those options to try - Work commitments get in the way too often lol!

I've tried each of those in order with no different results.

I guess the two plugins must be incompatible, but I'll see if I can fluke it by playing about with it.

Or some other thumbnail user may decide they fancy both mods and beat me to it *crosses fingers*
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 22:51.

Layout Options | Width: Wide Color: